Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Mostrando resultados del 1 al 6 de 6

Tema: libxslt

  1. #1
    Fox Invitado

    libxslt

    Buenas iba a hacer un dist-upgrade con apt pero dice que ese paquete no se actualizara y mirad :

    linux:/home/fox # apt-get install libxslt
    Leyendo listas de paquetes... Done
    Construyendo árbol de dependencias... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.

    Since you only requested a single operation it is extremely likely that
    the package is simply not installable and a bug report against
    that package should be filed.
    La siguiente información puede ayudar a resolver la situación:

    The following packages have unmet dependencies:
    libxslt: Depends: libgcrypt.so.7
    E: Broken packages
    linux:/home/fox #

    yo tengo

    fox@linux:~> rpm -qa | grep libxslt
    libxslt-1.1.8-0.1
    fox@linux:~>

    y

    fox@linux:~> rpm -qa | grep libgcrypt
    libgcrypt-1.2.0-2.1
    fox@linux:~>


    que versiones de estos paquetes teneis? y porque el apt no lo actualiza? esque no me gusta dejar cosas sin actualizar jajaja :P

    Saludos.

  2. #2
    Fecha de Ingreso
    27-julio-2004
    Ubicación
    En un lugar de la mancha ...
    Mensajes
    2.348
    Post Thanks / Like
    Poder de Credibilidad
    18
    Hola Fox

    Pues yo tengo las siguientes versiones:

    carlos:~ # rpm -q libxslt libgcrypt
    libxslt-1.1.10-2suse91
    libgcrypt-1.2.0-2.1


    El que no te lo actualice imagino es porque la nueva versión del libxslt necesitaría una nueva versión del libgcrypt, pero esa no está disponible en los repositorios, por lo que no te puede actualizar el paquete ...

    Un saludo
    La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
    "No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"

  3. #3
    Fox Invitado
    vale, pero tu version es mas moderna...... quizas la version del apt sea aun mas nueva.

    Puedo mirar q version es la del apt de alguna forma y comparar con la tuya?


    Saludos chuzo .

  4. #4
    Fecha de Ingreso
    27-julio-2004
    Ubicación
    En un lugar de la mancha ...
    Mensajes
    2.348
    Post Thanks / Like
    Poder de Credibilidad
    18
    Cita Iniciado por Fox
    quizas la version del apt sea aun mas nueva.
    No creo ... en ese caso también te saldría para actualizarla desde el propio apt

    Mi versión:

    carlos:~ # rpm -q apt
    apt-0.5.15cnc6-0.suse091.rb.5
    La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
    "No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"

  5. #5
    Fox Invitado
    Chuzo, quise decir mirar la version del libxslt del apt, es decir algun comando del apt para mirar las versiones de los archivos q puedes decargar para ver si la version de libxslt es mas nueva q la tuya o no.

  6. #6
    Fecha de Ingreso
    27-julio-2004
    Ubicación
    En un lugar de la mancha ...
    Mensajes
    2.348
    Post Thanks / Like
    Poder de Credibilidad
    18
    Pues prueba con el siguiente comando:

    carlos:/home/carlos # apt showpkg libxslt

    Eso te saca bastante información, pero justo lo primero del todo te dice las versiones que hay disponibles de ese paquete en las diferentes fuentes que tengas, la primera del todo sería la versión más nueva disponible

    Package: libxslt
    Versions:
    1.1.10-2suse91(/var/state/apt/lists/ftp.gwdg.de_pub_linux_suse_apt_SuSE_9.1-i386_base_pkglist.suser-guru)(/var/lib/rpm/Packages)
    1.1.8-100.SuSE.ulb.1(/var/state/apt/lists/ftp.gwdg.de_pub_linux_suse_apt_SuSE_9.1-i386_base_pkglist.usr-local-bin)
    1.1.8-0.1(/var/state/apt/lists/ftp.gwdg.de_pub_linux_suse_apt_SuSE_9.1-i386_base_pkglist.suse-people)
    1.1.7-0.1(/var/state/apt/lists/ftp.gwdg.de_pub_linux_suse_apt_SuSE_9.1-i386_base_pkglist.suse-people)
    1.1.6-0.1(/var/state/apt/lists/ftp.gwdg.de_pub_linux_suse_apt_SuSE_9.1-i386_base_pkglist.suse-people)
    1.1.5-0(/var/state/apt/lists/ftp.gwdg.de_pub_linux_suse_apt_SuSE_9.1-i386_base_pkglist.suse-people)
    1.1.2-58(/var/state/apt/lists/ftp.gwdg.de_pub_linux_suse_apt_SuSE_9.1-i386_base_pkglist.base)


    Un saludo
    La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
    "No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •