Mostrando resultados del 1 al 2 de 2

Tema: Arranque perdido al actualizar Open Suse 12.2

  1. #1
    Fecha de Ingreso
    03-mayo-2008
    Ubicación
    Mexico
    Mensajes
    31
    Poder de Credibilidad
    0

    Exclamation Arranque perdido al actualizar Open Suse 12.2

    Buen Día.

    Quisiera saber si a alguien le ha pasado el siguiente escenario:

    1. Se realiza la actualización de updates de seguridad en open Suse 12.2 x64
    2. Al reiniciar ya no inicia el sistema operativo y manda error "Operating System not found.
    3. Al iniciar con algun disco de Live o recovery, tampoco inicia manda error de file `/UEFI/BOOT/grubx64.efi` not found
    4. Al iniciar el recovery tampoco puedo usar las opciones de grub.

    He buscado unos viejos post para el uso y recuperación de grub a través de la consola de grub, pero no los encuentro el formato iba mas o menos asi.

    Código:
        grub> find /boot/grub
                 step1 ...
                 root (hdX,X)
                 step1.5
                 chainloader...
    Veo que actualmente todos usan ambiente grafico y los mas acercados al uso de grub por consola fueron los siguientes post.
    http://threep.tumblr.com/post/764599...ma-de-arranque
    http://karuppuswamy.com/wordpress/20...-cd-for-grub2/

    Los mas cercanos fueron
    http://danleff.net/myarticles/fedora...rddrives5.html
    http://en.opensuse.org/openSUSE:UEFI

    pero estan incompletos, usando la informacion de ambos (y los anteriores) pude al menos llegar hasta el intento de booteo, pero llego al mismo error que los liveCD. (los live CD aclaro en modo de recovery, si inicio un Live CD de forma normal si inicia ej. LiveCD OpenSuse KDE, sin embargo al hacer una chroot no puedo usar nada)

    Mis pasos fueron

    Código:
    grub> ls
    (hd0,gtp1)...(hdX,gptX)...
    grub> set
    grub> set prefix=(hd0,gpt1)
    grub> set root=(hd0,gpt1)/efi/opensuse
    grub> chainloader (hd0,1)/efi/opensuse/grubx64.efi
    grub> boot
    y al iniciar manda el error mismo de file "`/efi/opensuse/grubx64.efi` not found"
    Puedo estar haciendo algo mal, sin embargo llego al mismo resultado que los liveCD gráficos.

    EL problema fue que al actualizar los parches de seguridad de mi Open Suse ya no inicio.

    Caracteristicas del equipo: TinkPad X121e procesador AMD Fusion E-350, 6GB de RAM, 250GB de disco duro.
    Caracteristicas del Sistema Operativo: Open Suse 12.2 x64 sin actualizaciones (hasta ayer) kernel 3.4
    Particion /home encriptada, particiones GPT boot UEFI.

    El BIOS tiene la opcion para reconocer los 2 tipos de booteo.
    UEFI BOOT [both] -- (UEFI Only/Legacy Only/both)


    Mi intencion es unicamente recuperar mi inicio, no tengo windows instalado por lo que realmente no me interesa el tipo de bootloader sea por Lilo o grub.

    En caso de que no sea posible realmente no tengo intencion de reinstalar todo, por tanto solo quisiera saber como eliminar la encriptacion de mi particion /home, que hasta ahora solo un vil ubuntu ha accesado, y ni siquiera con el liveDVD de OpenSuse 12.3 he podido acceder. Siempre encripto mis particiones por seguridad, sin embargo es la primera vez que tengo un problema asi.



    agradezco su apoyo.
    La mia vita un 'illusione dei miei sogni
    OpenSuse 10.3 x86_64 AMD athlon 64 X2 Dual 4200+ 2 Gb RAM ATI Technologies Inc RS690 [Radeon X1200 Series

  2. #2
    Fecha de Ingreso
    13-marzo-2007
    Ubicación
    A 8 minutos del Sol
    Mensajes
    211
    Poder de Credibilidad
    13
    No estoy seguro pero creo que antes de chroot tienes que montar las particiones.
    Yo personalmente prefiero la version DVD...
    Si quieres mira este link, este o este, te darán algunas pistas! Buena suerte...

    - "Dios no juega a los dados."
    - A.Einstein.
    - “Señor Einstein, deje de decirle a Dios lo que debe hacer... usted no está pensando, sólo está siendo lógico
    - Bohr.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. Problemas con Mapa de teclado en Open Suse 12.2 al regresar de suspension
    By morfeokmg in forum Instalación y Actualizaciones
    Respuestas: 2
    Último mensaje: 19-oct-2012, 05:55
  2. gDesklets en OpenSUSE 10.3 [SOLUCIONADO]
    By Krakatoa in forum Software
    Respuestas: 9
    Último mensaje: 21-ene-2008, 20:19
  3. Actualizar suse 10.3 64 bit
    By arcaraz in forum Instalación y Actualizaciones
    Respuestas: 4
    Último mensaje: 13-oct-2007, 20:09
  4. XGL error al activarlo
    By Fabricio Guzzo in forum Escritorios: KDE, Gnome, otros...
    Respuestas: 5
    Último mensaje: 21-sep-2007, 10:08
  5. Aviso de seguridad
    By Kunael in forum Internet, Redes y Wireless
    Respuestas: 1
    Último mensaje: 05-ago-2004, 22:35

Tags for this Thread

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •