Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Página 1 de 2 12 ÚltimoÚltimo
Mostrando resultados del 1 al 10 de 11

Tema: Apache2 Virtualhost Problemas Opensuse 12.3

  1. #1
    Fecha de Ingreso
    21-enero-2011
    Mensajes
    16
    Post Thanks / Like
    Poder de Credibilidad
    0

    Unhappy Apache2 Virtualhost Problemas Opensuse 12.3

    Buenas me pongo en contacto con ustedes masters porque ya no logro llegar a una solución me he paseado por google pero no sé que buscar o como buscar así que les doy información anteriormente utilizaba opensuse 12.1 y tenía apache2 configurado con virtualhost para tener diferentes "dominios" locales
    vgr.
    • webhost.info
    • revision.info
    • home.info
    • phpmyadmin.info


    y me facilitaba mucho las cosas pues no tenía que estar peleando para crear nuevos proyectos, pero ahora que me he pasado a opensuse 12.3
    he hecho las mismas configuraciones que hice alguna vez en mi suse 12.1 y voila!

    hice:
    Código:
    $sudo /etc/init.d/apache2 start
    y me ha arrojado
    Código:
    redirecting to systemctl  start apache2
    Job for apache2.service failed. See 'systemctl status apache2.service' and 'journalctl -n' for details.
    he hecho un sysstemctl
    Código:
    apache2.service - apache
              Loaded: loaded (/lib/systemd/system/apache2.service; disabled)
              Active: failed (Result: signal) since Sat, 2013-04-27 10:35:39 CDT; 8s ago
             Process: 3097 ExecStop=/usr/sbin/httpd2 -D SYSTEMD -k stop (code=killed, signal=SEGV)
             Process: 3133 ExecStart=/usr/sbin/start_apache2 -D SYSTEMD -k start (code=killed, signal=SEGV)
            Main PID: 3082 (code=exited, status=0/SUCCESS)
              CGroup: name=systemd:/system/apache2.service
    
    Apr 27 10:35:34 worpisite.site systemd[1]: Starting apache...
    Apr 27 10:35:39 worpisite.site systemd[1]: Failed to start apache.
    Apr 27 10:35:39 worpisite.site systemd[1]: Unit apache2.service entered fail...e
    y tambien hice un journalctl -n

    Código:
    Apr 27 10:53:00 worpisite.site systemd[1]: Starting apache...
    Apr 27 10:53:01 worpisite.site start_apache2[3476]: httpd2-prefork: apr_sockaddr_info_get() failed for worpisite.site
    Apr 27 10:53:01 worpisite.site start_apache2[3476]: httpd2-prefork: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
    Apr 27 10:53:01 worpisite.site start_apache2[3476]: [Sat Apr 27 10:53:01 2013] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
    Apr 27 10:53:01 worpisite.site start_apache2[3476]: [Sat Apr 27 10:53:01 2013] [warn] NameVirtualHost *:80 has no VirtualHosts
    Apr 27 10:53:01 worpisite.site systemd[1]: PID file /var/run/httpd2.pid not readable (yet?) after start.
    Apr 27 10:53:07 worpisite.site kernel: httpd2-prefork[3498]: segfault at 1c ip 00007f833da4a106 sp 00007fff18ac96a0 error 4 in libapr-1.so.0.4.6[7f833da2b000+30000]
    Apr 27 10:53:07 worpisite.site systemd[1]: apache2.service never wrote its PID file. Failing.
    Apr 27 10:53:07 worpisite.site systemd[1]: Failed to start apache.
    Apr 27 10:53:07 worpisite.site systemd[1]: Unit apache2.service entered failed state
    el archivo http.conf no lo he tocado
    lo unico que edite fue mi listen.conf donde desmarque o descomente lo que era la lineas siguientes:

    NameVirtualHost *:80
    #
    # - on all addresses and ports. This is your best bet when you are on
    # dynamically assigned IP addresses:
    #
    NameVirtualHost *
    cree mi archivo en vhosts.d/ con su nombre respectivo terminacion .conf
    y luego edite /etc/hosts
    e hice 2 pasos acá
    1. Comente y agregue mi nombre de host a mi ip 127.0.0.1
    2. Descomente localhost y deje mi nombre de host a mi ip 127.0.0.1


    y con ambos me bota el error respectivo, la carpeta virtual esta creada
    en /srv/www/vhosts/

    no sé que hacer he borrado todo y he pasado mis archivos desde otra computadora donde funciona con 12.1 y nada me estoy volviendo loco gracias por la ayuda de igual modo

    Saludos

  2. #2
    Fecha de Ingreso
    26-abril-2011
    Ubicación
    Mdeo, Uy
    Mensajes
    1.235
    Post Thanks / Like
    Poder de Credibilidad
    10
    debes editar el archivo default-server.conf

    Código:
    DocumentRoot "/srv/www/tuweb"
    
    <directory "/srv/www/tuweb">
    Options None
    AllowOverride None
    Order allow,deny
    Allow from all
    </directory>
    para darle permisos

    debes tocar el archivo "httpd.conf"

    Código:
    < virtualhost *:80="" >
    ServerName tuweb.tudominio
    ServerAlias tuweb
    DocumentRoot /srv/www/tuweb/
    
    DirectoryIndex index.php
    
    </virtualhost>
    date una vuelta por acá http://httpd.apache.org/docs/2.2/vhosts

    espero te sea útil!
    Saludos

  3. #3
    Fecha de Ingreso
    21-enero-2011
    Mensajes
    16
    Post Thanks / Like
    Poder de Credibilidad
    0

    Re

    Yo no toco el http.conf porque no me sirve tocarlo para nada y tampoco había tocado nunca el archivo default-server.conf
    eso que defines lo hago en la carpeta vhosts.d ya antes mencionada donde se crea el archivo de configuración de cada virtual host que se va a tener, puesto que el http.conf hace lo siguiente:

    Código:
    Include /etc/apache2/vhosts.d/*.conf
    como tambien he mencionado siempre he hecho esto de usarlos virtualizados pero nunca había tenido problemas y siempre he hecho lo antes comentado:

    1. editar listen.conf
    2. crear carpeta de vhosts del nameserver virtual
    3. crear archivo de .conf en vhost.d
    4. editar /etc/hosts
    5. reiniciar apache2


    Otro dato adicional...
    He limpiado la configuración de apache2 lo he borrado completo
    reiniciado el equipo y vuelto a instalar y voila! funciona tal como se instala del
    Código:
    yast -i apache2

    el problema me ha venido cuando he hecho
    Código:
    yast -i php5 php5-mysql apache2-mod_php5
    ahora si... estoy totalmente perdido ni si quiera instalando php5 me funciona apache, ya con eso comienza a darme lata
    Última edición por omarin1; 28-abr-2013 a las 00:02

  4. #4
    Fecha de Ingreso
    26-julio-2005
    Ubicación
    Atlántida
    Mensajes
    951
    Post Thanks / Like
    Poder de Credibilidad
    15
    Apr 27 10:53:00 worpisite.site systemd[1]: Starting apache...
    Apr 27 10:53:01 worpisite.site start_apache2[3476]: httpd2-prefork: apr_sockaddr_info_get() failed for worpisite.site
    Apr 27 10:53:01 worpisite.site start_apache2[3476]: httpd2-prefork: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
    Apr 27 10:53:01 worpisite.site start_apache2[3476]: [Sat Apr 27 10:53:01 2013] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
    Apr 27 10:53:01 worpisite.site start_apache2[3476]: [Sat Apr 27 10:53:01 2013] [warn] NameVirtualHost *:80 has no VirtualHosts
    Podrías poner tu vhost? entiendo que te dice que tienes un error en los puertos del vhost, puede ser listen.conf o el propio vhost

    Apr 27 10:53:01 worpisite.site systemd[1]: PID file /var/run/httpd2.pid not readable (yet?) after start.
    Apr 27 10:53:07 worpisite.site kernel: httpd2-prefork[3498]: segfault at 1c ip 00007f833da4a106 sp 00007fff18ac96a0 error 4 in libapr-1.so.0.4.6[7f833da2b000+30000]
    Apr 27 10:53:07 worpisite.site systemd[1]: apache2.service never wrote its PID file. Failing.
    Apr 27 10:53:07 worpisite.site systemd[1]: Failed to start apache.
    has probado a borrar manualmente /var/run/httpd2.pid
    Última edición por soyasi; 28-abr-2013 a las 02:34
    --
    hkp://subkeys.pgp.net
    GNU/Linux Opensuse Tumbleweed x86_64

    Linux Registered User #391410


  5. #5
    Fecha de Ingreso
    21-enero-2011
    Mensajes
    16
    Post Thanks / Like
    Poder de Credibilidad
    0

    Re:

    Aquí esta uno de los n archivos de configuración de vhost que tengo
    son creados apartir del vhost.template lo unico que hago es editar su nombre de dummy-...-.com por el que requiero y todos esos archivos los meto en la carpeta vhosts.d

    http://pastebin.com/fZD2c31S Archivo configuracion vhost

    Y acá esta mi archivo listen.conf

    http://pastebin.com/XJMFkKX2 listen.conf

    pero ahora el sistema me marca otros errores ya no sé que show :/ no he movido nada

    simplemente hice un

    Código:
    # /etc/init.d/apache2 start
    systemctl status apache2.service

    Código:
    apache2.service - apache
                                                                                                                                                                     
              Loaded: loaded (/lib/systemd/system/apache2.service; disabled)                                                                                                                        
              Active: failed (Result: signal) since Sun, 2013-04-28 15:54:27 CDT; 26min ago                                                                                                         
             Process: 10558 ExecStart=/usr/sbin/start_apache2 -D SYSTEMD -k start (code=killed, signal=SEGV)                                                                                        
              CGroup: name=systemd:/system/apache2.service                                                                                                                                          
                                                                                                                                                                                                    
    Apr 28 15:54:27 worpisite.site systemd[1]: Failed to start apache.                                                                                                                             
    Apr 28 15:54:27 worpisite.site systemd[1]: Unit apache2.service entered failed state
    journalctl -n

    Código:
    Apr 28 16:22:54 worpisite.site systemd[1]: Starting apache...
    Apr 28 16:22:59 worpisite.site kernel: httpd2-prefork[10830]: segfault at 1c ip 00007f5cfb307106 sp 00007fff0853bc50 error 4 in libapr-1.so.0.4.6[7f5cfb2e8000+30000]
    Apr 28 16:22:59 worpisite.site systemd[1]: apache2.service: control process exited, code=killed status=11
    Apr 28 16:22:59 worpisite.site systemd[1]: Failed to start apache.
    Apr 28 16:22:59 worpisite.site systemd[1]: Unit apache2.service entered failed state

  6. #6
    Fecha de Ingreso
    26-julio-2005
    Ubicación
    Atlántida
    Mensajes
    951
    Post Thanks / Like
    Poder de Credibilidad
    15
    puedes forzar la actualización de la librería, comprobar dependencias y reintentarlo después?

    libapr1 -1.4.6-5.1.1-x86_64 Biblioteca APR (Apache Portable Runtime)


    Después comenta con # en listen.conf
    #NameVirtualHost *:80
    #NameVirtualHost *

    y quita los vhost simplemente renombralos añadiendo a .conf un número por ejemplo.

    y haz un service apache2 stop
    service apache 2 start
    service apache2 status

    Debería de arrancar apache
    Última edición por soyasi; 29-abr-2013 a las 03:24
    --
    hkp://subkeys.pgp.net
    GNU/Linux Opensuse Tumbleweed x86_64

    Linux Registered User #391410


  7. #7
    Fecha de Ingreso
    21-enero-2011
    Mensajes
    16
    Post Thanks / Like
    Poder de Credibilidad
    0
    Cita Iniciado por soyasi Ver Mensaje

    puedes forzar la actualización de la librería, comprobar dependencias y reintentarlo después?

    libapr1 -1.4.6-5.1.1-x86_64 Biblioteca APR (Apache Portable Runtime)


    Después comenta con # en listen.conf
    #NameVirtualHost *:80
    #NameVirtualHost *

    y quita los vhost simplemente renombralos añadiendo a .conf un número por ejemplo.

    y haz un service apache2 stop
    service apache 2 start
    service apache2 status

    Debería de arrancar apache

    Como se hace eso? o_O

  8. #8
    Fecha de Ingreso
    26-julio-2005
    Ubicación
    Atlántida
    Mensajes
    951
    Post Thanks / Like
    Poder de Credibilidad
    15
    Te explico: he visto que tienes un problema en apache de inicio

    Apr 28 16:22:59 worpisite.site kernel: httpd2-prefork[10830]: segfault at 1c ip 00007f5cfb307106 sp 00007fff0853bc50 error 4 in libapr-1.so.0.4.6[7f5cfb2e8000+30000]
    Esto lo tienes que solucionar, antes de configurar los vhost o tocar las configuraciones.

    Asegúrate siempre antes de tocar configuraciones que apache funciona sin problemas!!

    Cómo? Usa el método gráfico, si te lías todavía con los comandos y la consola.

    Lo mas sencillo es ir a yast--> instalar/desinstalar programas
    en la casilla buscar pones libapr1 y actualizas. Creo que es esta librería la que da fallos. si no es así mira los logs de apache.

    Abre dolphin o konqueror en modo superusuario, navegas hasta el archivo que quieres modificar, seleccionas con el ratón, botón derecho propiedades y cambias el nombre.

    Si pinchas en el archivo abrirás el archivo, normalmente con kwrite modificas y guardas.

    Si buscas en Google "error 4 in libapr" verás que hay varios bugs en diferentes distribuciones.

    Última edición por soyasi; 03-may-2013 a las 17:01
    --
    hkp://subkeys.pgp.net
    GNU/Linux Opensuse Tumbleweed x86_64

    Linux Registered User #391410


  9. #9
    Fecha de Ingreso
    01-agosto-2013
    Mensajes
    1
    Post Thanks / Like
    Poder de Credibilidad
    0

  10. #10
    Fecha de Ingreso
    28-diciembre-2010
    Ubicación
    Frente al teclado
    Mensajes
    829
    Post Thanks / Like
    Poder de Credibilidad
    10
    Cita Iniciado por jessicasmith Ver Mensaje
    can any one tell me the topic in English please??
    No, for english you must ask on forums.opensuse.org
    VampirD

    Microsoft Windows is like air conditioning
    Stops working when you open a window.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. Tumbleweed repos...
    By goro in forum Instalación y Actualizaciones
    Respuestas: 11
    Último mensaje: 03-ene-2014, 16:55
  2. Problemas para subir una web a apache2
    By nachete84 in forum Seguridad y Servidores
    Respuestas: 3
    Último mensaje: 24-abr-2013, 18:18
  3. Intalando agente NRPE en suseserver 10 64bits
    By prubilar in forum Seguridad y Servidores
    Respuestas: 4
    Último mensaje: 27-abr-2012, 18:40
  4. Problemas con la actualización a OpenSuse 11.0
    By gery in forum General OpenSUSE
    Respuestas: 0
    Último mensaje: 23-jun-2008, 17:03
  5. config de apache2
    By dennyszzz in forum Internet, Redes y Wireless
    Respuestas: 0
    Último mensaje: 28-ago-2007, 00:27

Tags for this Thread

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •