Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Mostrando resultados del 1 al 5 de 5

Tema: SOLUCIÓN ~ Sin sonido en OpenSUSE 12.2 y Asus Xonar DG

  1. #1
    Fecha de Ingreso
    06-noviembre-2007
    Ubicación
    Chiclayo - Perú
    Mensajes
    826
    Post Thanks / Like
    Poder de Credibilidad
    12

    SOLUCIÓN ~ Sin sonido en OpenSUSE 12.2 y Asus Xonar DG

    Pongo ésta información esperando que les sea de alguna utilidad.


    Justo hace unos días decidí hacer una instalación limpia de OpenSUSE 12.2 (no había actualizado hace tiempo y aún tenía la RC). Al finalizar la instalación y su correspondiente actualización, resulta que NO TENÍA SONIDO.

    Al momento de revisar el hardware aparecieron dos dispositivos, el que viene con la tarjeta Nvidia y el de mi tarjeta Asus Xonar DG (CMI8786). (cabe mencionar que aún no había instalado el driver de video, sólo estaba el nouveau que viene por default)


    Código:
    0   Nvidia
    1   CMI8786
    A continuación, explicaré los pasos que seguí para dar con la solución:


    1. Eliminar el de Nvidia para dejar solamente el de Asus


    Quedando de la siguiente manera:


    Código:
    0   CMI8786
    1   Nvidia (sin configurar)
    2. Cerrar la sesión y el servidor gráfico y borrar los archivos de configuración de usuario.


    Después de cerrar la sesión:


    Código:
    # CTRL + ALT + F1
    # init 3
     
    
    # cd /home/zchronos/
    # rm -R .kde4/
    # rm -R .config/
    # rm -R .local/
    Con ésto los archivos de configuración de nuestro usuario se habrán eliminado y en el siguiente inicio de sesión se volverán a crear de forma automática.


    NOTA: Es muy importante cerrar la sesión y el servidor gráfico antes de eliminar éstos archivos, de lo contrario habrán errores.


    3. Configurar sonido


    Una vez vuelto a iniciar la sesión, en la barra de abajo hay que buscar el ícono del sonido (kmix) dar clic derecho > Seleccionar Canal Maestro > CMI8786


    Luego dar clic al Gecko > Preferencias del Sistema > Multimedia > Phonon >


    Configurar la salida de los altavoces (en mi caso son 5.1), además configurar todo para que utilice la tarjeta Asus Xonar (CMI8786) como la preferida.


    Una vez hecho ésto el sonido ya funcionará, sólo que me topé con otro inconveniente. Cada vez que inicio sesión, a pesar de haberle eliminado el dispositivo de sonido Nvidia, de todas maneras el kmix me lo marca como predeterminado. Así que la solución a ésto fue simplemente configurar nuevamente el “canal maestro” como CMI8786 y luego “bloquear el archivo de configuración del kmix”.


    Código:
    # chmod 550 /home/zchronos/.kde4/share/config/kmixrc
    Con eso habremos dado permisos solamente de lectura, así la configuración no se volverá a alterar.

    Bueno, espero les haya servido.

    PD. Olvidé mencionar que ésto no me había pasado nunca, tampoco en la RC de la 12.2 que estaba probando, así que imagino que una actualización ha de estar ocasionando conflictos. Por lo que posiblemente se corrija en un futuro cercano y no será necesario pasar por éste lío.
    Última edición por zchronos; 23-oct-2012 a las 17:38

    "No existen los problemas, tan solo soluciones"
    Linux user #460594

  2. #2
    Fecha de Ingreso
    31-diciembre-2013
    Mensajes
    24
    Post Thanks / Like
    Poder de Credibilidad
    0
    Tengo el mismo problema en la 13.1.

    Sigo tus pasos y todo correcto. Pero al reiniciar me da error de que no puede modificar el archivo y tengo que volver a configurarlo a mano.

    Estoy histerico . como algo tan sencillo se me esta atragantando tanto.


    Enviado desde mi GT-I9505G mediante Tapatalk

  3. #3
    Fecha de Ingreso
    02-marzo-2013
    Ubicación
    Lat. 27.994547-Lon -15.405127-160m nivel del mar
    Mensajes
    4.878
    Post Thanks / Like
    Poder de Credibilidad
    11
    Si vas a Yast sonido , veras que aparecen 2 tarjetas , una es la tarjeta de tu placa base y la otra es una hdmi de la tarjeta gráfica .

    Si te sitúas sobre la tarjeta de la placa base y te vas a donde pone otros , hay una opción que dice mas o menos definir como tarjeta principal y después le das aceptar .

    En el ejemplo de ese tema es situarte sobre la CMI 8786 , irse a otros y configurar como principal (ya eso modifica el archivo de configuración dejando la como la tarjeta por defecto ) .

    Los otros ajustes ya tienes que hacerlos sobre kde en preferencias del sistema --multimedia phonon y en el kmixer (mezclador de kde ) .

    Saludos

  4. #4
    Fecha de Ingreso
    18-octubre-2008
    Ubicación
    Vila-Real
    Mensajes
    227
    Post Thanks / Like
    Poder de Credibilidad
    11
    Justo este problema tuvimos con un amigo que se acaba de iniciar en Linux, en openSUSE para ser exactos y la solución fue muy similar, lastima no haber pillado esto antes, gracias por compartirlo.

  5. #5
    Fecha de Ingreso
    31-diciembre-2013
    Mensajes
    24
    Post Thanks / Like
    Poder de Credibilidad
    0
    No me sirve de nada dar permisos de solo lectura. Haga lo que haga siempre vuelve a seleccionarse audio HDMI.

    Lo único que me has servido ( y es para salir del paso porque falla de vez en cuando) es desactivar pulseaudio en el botón de otros de dispositivos de audio en yast2.

    Enviado desde mi GT-I9505G mediante Tapatalk

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. Review de openSUSE 11.0 y comparativa con Ubuntu.
    By Dux in forum El Contubernio
    Respuestas: 54
    Último mensaje: 20-feb-2010, 14:30
  2. Después de instalar suse 11.2 no funciona red local
    By amungar in forum Internet, Redes y Wireless
    Respuestas: 15
    Último mensaje: 21-nov-2009, 09:52
  3. Convocatoria para la comunidad Opensuse
    By obelich in forum General OpenSUSE
    Respuestas: 8
    Último mensaje: 24-oct-2008, 23:47
  4. Respuestas: 4
    Último mensaje: 28-mar-2008, 00:34
  5. Guía de Instalación de OpenSuSE 10.3
    By DiabloRojo in forum Instalación y Actualizaciones
    Respuestas: 5
    Último mensaje: 11-feb-2008, 11:41

Tags for this Thread

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •