Página 1 de 2 12 ÚltimoÚltimo
Mostrando resultados del 1 al 10 de 18

Tema: wifi usb si conecta pero por momentos. opensuse 12.2

  1. #1
    Fecha de Ingreso
    13-agosto-2012
    Mensajes
    10
    Poder de Credibilidad
    0

    Question wifi usb si conecta pero por momentos. opensuse 12.2

    Saludos a todos.

    Tengo una pc y acabo de actualizar a opensuse 12.2, hasta el momento me he enamorado y des enamorado.

    Tenía un opensuse 12.1 y todo funcionaba a la perfección. Sin embargo a la hora de instalar 12.2 me surgieron errores con mi tarjeta gráfica nvidia, los cuales resolví instalando los drivers de nvidia, sin embargo he aquí mi problema y frustración:

    Mi pc solo se conecta a internet por ratitos, y solo por networkmanager explico un poco mas los síntomas:

    -Si intento conectar por ifup me no me conecta definitivamente, al dar "inspeccionar la red" si la reconoce pero no conecta.
    -Luego si vuelvo a intentar "inspeccionar la red" ya no la encuentra.
    -Si cambio a networkmanager y escaneo la red no me la muestra en el mapa y tengo que reiniciar.
    -ya reiniciado y vuelvo a networkmanager ya la ve pero no se conecta, incluso me marca algo como "no agents were defined..." y tengo que ingresar nuevamente la clave de red. Así puedo estar varias horas: reiniciando y tratando de conectarme.
    -Si tengo suerte me conecta un rato a internet (así puede instalar los drivers nvidia).

    alguna ayuda?

    anteriormente en 12.1 me conectaba con ifup y me iba de maravilla.

  2. #2
    Fecha de Ingreso
    05-noviembre-2006
    Ubicación
    Salta (Argentina)
    Mensajes
    174
    Poder de Credibilidad
    13
    Hola: ¿estas usando "systemd" o "sysvinit"? Si usa el 1ro. yo, probaría usar el viejo "sysvinit" ya que el nuevo (y que viene por defecto) "systemd" a mí, me produce cosas raras. Para activar o desactivar ver las Realease Notes.-

  3. #3
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.173
    Poder de Credibilidad
    10
    Bienvenido al foro, por favor, lee las normas del foro donde aprenderás cosas útiles como aportar datos, hacer preguntas, como buscar.... es como una guía para los novatos. Fíjate lo que dice en negrita la norma 5.

    No aportas informacion de la tarjeta, no somos adivinos. Te aconsejo que veas dos guías mías adheridas en esta sección.

    Como eres nuevo, preséntate en la sección de Presentaciones y, por favor, lee las normas.

    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  4. #4
    Fecha de Ingreso
    13-agosto-2012
    Mensajes
    10
    Poder de Credibilidad
    0

    información de tarjeta

    Ok. Una disculpa al nuestro admón, por no aportar nada de información.

    Mi tarjeta es una wifi usb encore enui-sn4 y siguiendo los pasos del tuto de nuestro admon, aquí estan las salidas hasta donde llegue:

    Código:
    xxx@xxx:~> /usr/bin/lsusb
    Bus 001 Device 002: ID 0bda:8171 Realtek Semiconductor Corp. RTL8188SU 802.11n WLAN Adapter
    xxx@xxx:~> dmesg | grep firmware
    [   13.358589] r8712u: Loading firmware from "rtlwifi/rtl8712u.bin"
    xxx@xxx:~> /sbin/modprobe -v rtl8188su
    FATAL: Module rtl8188su not found.
    xxx@xxx:~> dmesg | grep -i RTL8188SU
    xxx@xxx:~>
    No se si hice algún paso mal.

    Sin embargo, he googleado un poco y me dice que el driver realtek rtl8188su solo es soportado por el Linux Kernel 2.6.18~2.6.38 and Kernel 3.0.2 aquí para ver la página oficial:

    Alguna idea?

  5. #5
    Fecha de Ingreso
    03-agosto-2007
    Ubicación
    Sevilla (España)
    Mensajes
    461
    Poder de Credibilidad
    12
    Por lo que he encontrado googleando tienes que eliminar este parámetro:

    CONFIG_R8712_AP

    Mira a ver si esta aquí:
    /etc/modprobe.d/rtl8188su.conf

    Elimina el parámetro, reinicias y a ver si funciona.

    Advertencia: Yo no he probado eso, solo he unido cosas leídas en varios sitios, te recomiendo que hagas una copia de seguridad de ese archivo por si tienes que restaurarlo.
    En ocasiones, se pueden ajustar los tipos para permitir la operación.

  6. #6
    Fecha de Ingreso
    13-agosto-2012
    Mensajes
    10
    Poder de Credibilidad
    0

    continuando

    ok... ya lo intenté y pues ni el archivo existe...

    Código:
    xxx:/etc/modprobe.d # ls
    00-system.conf               50-ipw2200.conf  50-sound.conf            50-yast.conf.YaST2save
    10-unsupported-modules.conf  50-iwl3945.conf  50-sound.conf.YaST2save  99-local.conf
    50-alsa.conf                 50-iwlagn.conf   50-thinkpad_acpi.conf    nvidia-desktop.conf
    50-blacklist.conf            50-nvidia.conf   50-tv.conf               xen_loop.conf
    50-bluetooth.conf            50-prism54.conf  50-yast.conf

  7. #7
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.173
    Poder de Credibilidad
    10
    Esa tarjeta utiliza el driver r8712u, comprueba que este cargado con estos comandos:
    sudo /usr/sbin/hwinfo --netcard
    lsmod | grep -i 8712u
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  8. #8
    Fecha de Ingreso
    13-agosto-2012
    Mensajes
    10
    Poder de Credibilidad
    0

    continuando

    Ya he realizado los pasos que me aconsejaron, y pues creo que he avanzado un poco (y se los agradezco), sin embargo sigo sin tener internet. Pongo los pasos que he seguido y ustedes ya me dirán si he hecho algo mal o que sucede:

    Los primeros pasos, quiero pensar que estan bien, lo interesante es hasta llegar cuando quiero comprobar que tengo internet y hago un dmesg | tail, ahí creo que me marca un error.

    Código:
    xxx@xxx:~> sudo /usr/sbin/hwinfo --netcard
    31: USB 00.0: 0282 WLAN controller
      [Created at usb.122]
      Unique ID: fHJ1.USeKJTMSyaA
      Parent ID: k4bc.OqydEZZ981A
      SysFS ID: /devices/pci0000:00/0000:00:02.1/usb1/1-10/1-10:1.0
      SysFS BusID: 1-10:1.0
      Hardware Class: network
      Model: "Realtek 11n USB Adapter"
      Hotplug: USB
      Vendor: usb 0x0bda "Realtek Semiconductor Corp."
      Device: usb 0x8171 "11n USB Adapter"
      Revision: "2.00"
      Serial ID: "00e04c000001"
      Driver: "r8712u"
      Driver Modules: "r8712u"
      Device File: wlan0
      Features: WLAN
      Speed: 480 Mbps
      HW Address: 00:18:e7:92:a2:3a
      Link detected: yes
      WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13 14
      WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472 2.484
      WLAN bitrates: 1 2 5.5 11
      WLAN encryption modes: TKIP CCMP
      WLAN authentication modes: open wpa-psk wpa-eap
      Module Alias: "usb:v0BDAp8171d0200dc00dsc00dp00icFFiscFFipFF"
      Driver Info #0:
        Driver Status: r8712u is active
        Driver Activation Cmd: "modprobe r8712u"
      Config Status: cfg=no, avail=yes, need=no, active=unknown
      Attached to: #30 (Hub)
    Código:
    xxx@xxx:~> lsmod | grep -i r8712u
    r8712u                196087  0 
    xxx:/home/said # dmesg | grep firmware
    [   74.821750] r8712u: Loading firmware from "rtlwifi/rtl8712u.bin"
    xxx:/home/said # /sbin/modprobe -v r8712u
    xxx:/home/said # lsmod | grep r8712u
    r8712u                196087  0
    Código:
    xxx:/home/said # /usr/sbin/iwlist scan
    eth0      Interface doesn't support scanning.
    
    lo        Interface doesn't support scanning.
    
    wlan0     Scan completed :
              Cell 01 - Address: B0:48:7A:CE:C7:7E
                        ESSID:"TP-LINK_CEC77E"
                        Protocol:IEEE 802.11bg
                        Mode:Master
                        Frequency:2.437 GHz (Channel 6)
                        Encryption key:on
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                                  9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                                  48 Mb/s; 54 Mb/s
                        Extra:wpa_ie=dd160050f20101000050f20401000050f20401000050f202
                        IE: WPA Version 1
                            Group Cipher : CCMP
                            Pairwise Ciphers (1) : CCMP
                            Authentication Suites (1) : PSK
                        Extra:rsn_ie=30140100000fac040100000fac040100000fac020000
                        IE: IEEE 802.11i/WPA2 Version 1
                            Group Cipher : CCMP
                            Pairwise Ciphers (1) : CCMP
                            Authentication Suites (1) : PSK
                        Signal level=94/100
    Código:
    xxx:/home/said # /usr/sbin/iwconfig
    eth0      no wireless extensions.
    
    lo        no wireless extensions.
    
    wlan0     IEEE 802.11bg  ESSID:"TP-LINK_CEC77E"  Nickname:"rtl_wifi"
              Mode:Managed  Frequency:2.437 GHz  Access Point: B0:48:7A:CE:C7:7E   
              Bit Rate:54 Mb/s   Sensitivity:0/0  
              Retry:off   RTS thr:off   Fragment thr:off
              Encryption key:****-****-****-****-****-****-****-****   Security mode:open
              Power Management:off
              Link Quality=62/100  Signal level=100/100  Noise level=0/100
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    Creo que aquí me marca un error,
    Código:
    xxx:/home/said # dmesg | tail
    [   74.821736] r8712u: CustomerID = 0x0000
    [   74.821744] r8712u: MAC Address from efuse = 00:18:e7:92:a2:3a
    [   74.821750] r8712u: Loading firmware from "rtlwifi/rtl8712u.bin"
    [   74.821882] usbcore: registered new interface driver r8712u
    [   75.728061] r8712u: 1 RCR=0x153f00e
    [   75.728807] r8712u: 2 RCR=0x553f00e
    [   75.835220] ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [   86.374623] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    [   96.514920] wlan0: no IPv6 routers present
    [  417.306360] PK-Backend[6603]: segfault at 3fbc ip 00007f0b3b0a76e4 sp 00007f0b2e2a4370 error 4 in libzypp.so.1106.0.2[7f0b3ad2e000+444000]
    Alguna idea?

  9. #9
    Fecha de Ingreso
    13-agosto-2012
    Mensajes
    10
    Poder de Credibilidad
    0

    Otro dato

    Después del mensaje anterior realicé lo siguiente:

    entre a la configuración de mi router inalambrico y le quite la seguridad, e intenté conectarme y me dio internet por escasos 30 segundos, y después se volvió a caer.

    También, a la hora de "inspeccionar la red" en YAST, no la detecta, tengo que reiniciar la pc para poder detectarla.

    Alguna idea?

  10. #10
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.173
    Poder de Credibilidad
    10
    Cita Iniciado por cannon_dm Ver Mensaje
    Alguna idea?
    Si tienes conexion a Internet, por alguna causa se cae o no conectas bien al router. Hay un tema mio cuya segunda parte habla de ello.
    Danos la salida de los comandos ejecutados como superusuario root
    ifconfig
    iwconfig
    route -n
    cat /etc/resolv.conf
    dig www.google.es
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. ¿porque ubuntu es mas popular q suse?
    By goundzchecky in forum El Contubernio
    Respuestas: 161
    Último mensaje: 16-ago-2012, 15:01
  2. reinstalar driver radeon en opensuse 12.2
    By annubis in forum Instalación y Actualizaciones
    Respuestas: 4
    Último mensaje: 19-jun-2012, 02:30
  3. Después de instalar suse 11.2 no funciona red local
    By amungar in forum Internet, Redes y Wireless
    Respuestas: 15
    Último mensaje: 21-nov-2009, 09:52
  4. Opinion de OpenSuse 11.1
    By mukenio in forum Encuestas
    Respuestas: 48
    Último mensaje: 22-oct-2009, 12:59
  5. La wifi conecta pero no se ven...
    By djfran28 in forum Internet, Redes y Wireless
    Respuestas: 0
    Último mensaje: 26-may-2006, 20:57

Tags for this Thread

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •