Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Mostrando resultados del 1 al 5 de 5

Tema: Actualizar Kernel en Tumbleweed

  1. #1
    Fecha de Ingreso
    13-febrero-2010
    Ubicación
    Barcelona, Catalunya
    Mensajes
    94
    Post Thanks / Like
    Poder de Credibilidad
    10

    Actualizar Kernel en Tumbleweed

    Al actualizar al nuevo Kernel-desktop con Zypper este entra en un bucle de dependencias que no se como solucionar:

    Si hago un zypper dup después de actualizar al nuevo kernel me propone hacer downgrade de kernel-desktop y con zypper up me dice que hay dos actualizacione que no puede instalar: kernel-default y kernel-desktop-base.

    ¿Alguien sabe como puedo dejar esto limpio?

    Gracias

  2. #2
    Fecha de Ingreso
    08-septiembre-2005
    Ubicación
    ±43º21'N8º22'W
    Mensajes
    1.232
    Post Thanks / Like
    Poder de Credibilidad
    15
    No he actualizado el kernel (no aún )

    Yast me "incordia" por la versión virtualbox-guest-kmp que me fuerza a instalar el kernel-desktop-base 3.1
    # zypper up
    Las siguientes actualizaciones NO serán instaladas:
    gstreamer-0_10-plugin-esd k3b k3b-lang kernel-default-devel kernel-desktop kernel-desktop-devel kernel-devel kernel-firmware kernel-source kernel-syms
    kernel-xen-devel libreoffice-branding-openSUSE ......

    No hay nada que hacer.
    # zypper dup
    Los siguientes paquetes NUEVOS van a ser instalados:
    freefont gmplayer libxine2-codecs projectM

    Los siguientes paquetes van a ser actualizados:
    gstreamer-0_10-plugin-esd kernel-default-devel kernel-desktop-devel kernel-devel kernel-firmware kernel-source kernel-syms kernel-xen-devel

    Los siguientes paquetes van a ser desactualizados:
    libopencv2_3 pdftk

    Los siguientes paquetes van a cambiar de proveedor:
    gstreamer-0_10-plugin-esd openSUSE -> http://packman.links2linux.de
    kernel-default-devel openSUSE -> obs://build.opensuse.org/openSUSE:Tumbleweed
    kernel-desktop-devel openSUSE -> obs://build.opensuse.org/openSUSE:Tumbleweed
    kernel-devel openSUSE -> obs://build.opensuse.org/openSUSE:Tumbleweed
    kernel-firmware openSUSE -> obs://build.opensuse.org/openSUSE:Tumbleweed
    kernel-source openSUSE -> obs://build.opensuse.org/openSUSE:Tumbleweed
    kernel-syms openSUSE -> obs://build.opensuse.org/openSUSE:Tumbleweed
    kernel-xen-devel openSUSE -> obs://build.opensuse.org/openSUSE:Tumbleweed
    libopencv2_3 http://packman.links2linux.de -> openSUSE
    pdftk obs://build.opensuse.org/Publishing -> openSUSE


    8 paquetes a actualizar, 2 a desactualizar, 4 nuevos, 10 a cambiar de proveedor.
    Tamaño total a descargar: 93,8 MiB. Después de la operación, se liberarán 1,0 MiB.
    ¿Desea continuar? [s/n/?] (s): n
    Por si ayuda, así tengo los repositorios
    | Activado | Actualizar | Prioridad | --------------------
    | Si | Si | 75 | Packman_Tumbleweed
    | Si | Si | 77 | KDEExtra_Tumbleweed
    | Si | Si | 85 | LibreOffice_Tumbleweed
    | Si | Si | 90 | openSUSE_Tumbleweed
    | Si | Si | 99 | openSUSE-Current_oss
    | Si | Si | 99 | openSUSE-current_actualizacions
    | Si | Si | 99 | openSUSE-current_non-ss
    | Si | Si | 99 | Ati-Non-oficiais-
    | No | Si | 99 | Publishing-pdfjam_12.1
    Todo es mejorable, estamos dispuestos a mejorar. ¿Yo? ... poco a poco.
    Nunca hay acritud en mis comentarios, si lo pareciera, seguro que me he expresado mal.

  3. #3
    Fecha de Ingreso
    13-febrero-2010
    Ubicación
    Barcelona, Catalunya
    Mensajes
    94
    Post Thanks / Like
    Poder de Credibilidad
    10
    Cita Iniciado por XisEme Ver Mensaje
    Yast me "incordia" por la versión virtualbox-guest-kmp que me fuerza a instalar el kernel-desktop-base 3.1
    Yo lo resolví así, instalando el kernel-desktop-base 3.1 y ahora es cuando me encuentro con el "bucle" este.

  4. #4
    Fecha de Ingreso
    08-septiembre-2005
    Ubicación
    ±43º21'N8º22'W
    Mensajes
    1.232
    Post Thanks / Like
    Poder de Credibilidad
    15
    Ya he probado (vuelta a pecar de versionitis)

    Como la cosa viene por el VBox ...
    -Lo he desinstalado
    -zypper dup
    -comprobado que todos los "kernel" son 3.2
    -añadido este repositorio
    http://download.opensuse.org/reposit...SE_Tumbleweed/
    y reinstalado VBox desde el.

    Después de reiniciar mis máquinas virtuales seguían ahí
    Todo es mejorable, estamos dispuestos a mejorar. ¿Yo? ... poco a poco.
    Nunca hay acritud en mis comentarios, si lo pareciera, seguro que me he expresado mal.

  5. #5
    Fecha de Ingreso
    18-diciembre-2009
    Ubicación
    México
    Mensajes
    478
    Post Thanks / Like
    Poder de Credibilidad
    10
    no uso tumbleweed [la versitionitis me la curo con sabayon] pero tal vez si actualizas solo el repo con zypper dup -r repo [no se si funcione con zypper up -r ]
    You can also specify repositories to be used using --repo option: zypper dup -r repo1 -r repo2 ....
    http://en.opensuse.org/SDB:Zypper_us...bution_upgrade
    o desde yast2 cambiar paquetes de sistema o proveedor, tengo entendido que con zypper dup actualiza todos los paquetes y eso te ocasiona esas faltas de dependencia [o el que pida hacer un downgrade de lugar de actualizar, para cumplir dependencias]

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. ahora, pc se cuelga aleatoriamente
    By sic in forum General OpenSUSE
    Respuestas: 6
    Último mensaje: 29-dic-2010, 16:40
  2. Inestabilidad de opensuse 10.2 (ayuda)
    By p3g4z0 in forum General OpenSUSE
    Respuestas: 25
    Último mensaje: 17-feb-2007, 11:00
  3. Problema con red en SuSE 9.0 Pro
    By arandaedgar in forum Internet, Redes y Wireless
    Respuestas: 6
    Último mensaje: 16-oct-2006, 02:52
  4. Respuestas: 1
    Último mensaje: 01-ago-2006, 18:44
  5. Suse 10 se cuelga al arrancar el escritorio
    By goordel in forum Hardware
    Respuestas: 6
    Último mensaje: 14-mar-2006, 19:21

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •