actualicé digikam a la versión 2.3.0, y no funcionaba , ( no acababa de arrancar ) ; por lo cual , ( por otros motivos irelevantes ) , reinstalé el sistema , sin formatear el Home , como ya he hecho otras veces ; pero la versión que se instala es la 1.2 ;y no se porque motivo me lanza este error :

" La base de datos ha sido utilizada con una versión más reciente de digiKam y su esquema se ha actualizado a una versión incompatible con esta (lo que significa que la de digiKam es demasiado antigua o que el formato de la base de datos es demasiado nuevo). Por favor, utilice aquella versión más reciente de digiKam "

Añado que ya borré la configuración de .kde4 por completo , y que con otro usuario se lanza el digikam sin ningún problema.

Por lo que tengo la seguridad que es algo de este usuario en concreto ; pero no acierto a eliminar esa configuración ,para dejar el sistema correcto.