Página 1 de 3 123 ÚltimoÚltimo
Mostrando resultados del 1 al 10 de 29

Tema: Problemas con Compiz + driver gráfica Nvidia

  1. #1
    Fecha de Ingreso
    20-marzo-2011
    Ubicación
    Sevilla, España
    Mensajes
    235
    Poder de Credibilidad
    9

    Exclamation Problemas con Compiz + driver gráfica Nvidia

    En mi PC de sobremesa he instalado OpenSUSE 11.4 32 bits GNOME, y el problema viene al activar los efectos de escritorio del gestor de ventanas Compiz, que básicamente es que no renderiza bien el entorno al 100%, apreciándose algunos defectos en algunas líneas en las ventanas de cualquier aplicación, haciendo que las formas o el texto si lo hubiera no se viese como es debido, por ejemplo, haciendo que el texto que aparezca en una línea afectada aparezca cortado por la mitad, o que cada vez que se abra una ventana en modo maximizado aparezca una línea negra que recorre toda la parte inferior de la ventana. Son defectos que desaparecen si demaximizas y vuelves a maximizar una ventana, pero es muy molesto tener que hacerlo siempre.

    La tarjeta gráfica de mi equipo es una Nvidia 6200 GS TurboCache, y he probado a utilizar los drivers x11-video-nvidiaG02 (260.19.44-24.1), x11-video-nvidiaG01 (173.14.28-28.1) y x11-video-nvidia (96.43.19-26.1) con los módulos correspondientes al kernel default de OpenSUSE 11.4, así como con los módulos correspondientes al kernel desktop, sin que en ningún caso haya mejorado la experiencia.
    En el único caso en que la experiencia fue distinta (para peor) fue en el caso del driver x11-video-nvidia (con el módulo nvidia-gfx-kmp-default), con el que al activar los efectos de escritorio desaparecían completamente los bordes de todas las ventanas, y volvían a aparecer al desactivar los efectos.

    Decir también que la aplicación de los Ajustes de NVIDIA del servidor X (nvidia-settings) solo he podido abrirla usando el driver x11-video-nvidia (96.43.19-26.1), mientras que con los otros drivers al querer abrirla desde el menú, el clickar sobre ella no tiene ningún efecto, y al ejecutarla por consola me salta el siguiente mensaje:

    Código:
    varyheavy@VaryComputer:~> nvidia-settings
    
    ERROR: The attribute 'ForceGenericCpu' specified on line 26 of configuration
           file '/home/varyheavy/.nvidia-settings-rc' cannot be assigned (it is a
           read-only attribute).
    También he probado a instalar el xorg-x11-driver-video-nouveau junto con el mesa-nouveau3d pero no sé cómo hacer para que el sistema pase a utilizar este driver :S, ¿cómo se hace el cambio de driver gráfico teniendo más de uno instalado?
    Y lo más importante: ¿Qué podría hacer para resolver el problema del renderizado de las ventanas con Compiz?
    En Mandriva también estuve usando en su día GNOME + Compiz y nunca tuve problemas de este tipo, todas las ventanas se mostraban correctamente. ¿Qué puede estar pasando en OpenSUSE?
    Última edición por VaryHeavy; 24-abr-2011 a las 08:19

  2. #2
    Fecha de Ingreso
    06-enero-2008
    Ubicación
    Almazora
    Mensajes
    3.474
    Poder de Credibilidad
    15
    Hola, decirte que mi experiencia con Gnome+Compiz no fué del todo grata. En mi opinión, Compiz falla mucho y no te digo Emerald, que todo lo que tiene de bonito lo tiene de fallas XD...
    Para el tema de efectos, Kwin en kde cada día está mejor, aunque no tiene tantas pijaditas.
    El tema del driver, desinstalando todo lo de Nvidia te cargará el driver libre por defecto, o eso era como solía pasar antes de que se dejara de escribir en el xorg.conf.
    Espero serte de ayuda, salu2
    Si tienes el vibrato de BB King, el tapping de Van Halen, la velocidad de Malmsteen y la guitarra de Vai... enhorabuena eres un gran imitador.

  3. #3
    Fecha de Ingreso
    23-marzo-2006
    Ubicación
    Sector Horchata
    Mensajes
    1.719
    Poder de Credibilidad
    15
    hola
    igual con los ultimos drivers de nvidia la version 271 creo. No estan en el repo de nvidia de opensuse todavia, pero los puedes bajar como binario de la web de nvidia

    Salu2

  4. #4
    Fecha de Ingreso
    08-agosto-2010
    Ubicación
    Venezuela
    Mensajes
    2.371
    Poder de Credibilidad
    11
    en este repo tienen una version mas estable de compiz que la que viene por defecto

  5. #5
    Fecha de Ingreso
    20-marzo-2011
    Ubicación
    Sevilla, España
    Mensajes
    235
    Poder de Credibilidad
    9
    Cita Iniciado por arag Ver Mensaje
    en este repo tienen una version mas estable de compiz que la que viene por defecto
    He instalado Compiz de ese repo pero hay dependencias que no están ahí, como por ejemplo el imprescindible compiz-manager, el cual solo está disponible en los repositorios principales y pide como dependencia la versión de Compiz que viene en los repos principales, así que probé a instalar el paquete compiz-manager desde los repositorios principales junto con el Compiz del repo que me has facilitado ignorando las dependencias, y aunque puedo abrir el CCSM, no me deja activar los efectos de escritorio, se ve que lo intenta porque el escritorio hace cosas raras, pero no es capaz de activar los efectos.
    Última edición por VaryHeavy; 26-abr-2011 a las 05:10

  6. #6
    Fecha de Ingreso
    20-marzo-2011
    Ubicación
    Sevilla, España
    Mensajes
    235
    Poder de Credibilidad
    9
    Cita Iniciado por xisco Ver Mensaje
    hola
    igual con los ultimos drivers de nvidia la version 271 creo. No estan en el repo de nvidia de opensuse todavia, pero los puedes bajar como binario de la web de nvidia

    Salu2
    He intentado instalarlo, pero me da error la instalación.

  7. #7
    Fecha de Ingreso
    08-agosto-2010
    Ubicación
    Venezuela
    Mensajes
    2.371
    Poder de Credibilidad
    11

  8. #8
    Fecha de Ingreso
    20-marzo-2011
    Ubicación
    Sevilla, España
    Mensajes
    235
    Poder de Credibilidad
    9
    Cita Iniciado por arag Ver Mensaje
    prueba con este otro repo
    Tampoco es perfecto, pero al menos el Compiz de ese repo va un poco mejor, al menos ya no se ven las líneas defectuosas en medio de la pantalla, aunque siga estando presente la línea negra en las ventanas maximizadas por defecto.
    Última edición por VaryHeavy; 26-abr-2011 a las 14:13

  9. #9
    Fecha de Ingreso
    18-mayo-2008
    Mensajes
    2.104
    Poder de Credibilidad
    13
    Hola.

    Cita Iniciado por VaryHeavy Ver Mensaje
    La tarjeta gráfica de mi equipo es una Nvidia 6200 GS TurboCache, y he probado a utilizar los drivers x11-video-nvidiaG02 (260.19.44-24.1), x11-video-nvidiaG01 (173.14.28-28.1) y x11-video-nvidia (96.43.19-26.1) con los módulos correspondientes al kernel default de OpenSUSE 11.4, así como con los módulos correspondientes al kernel desktop, sin que en ningún caso haya mejorado la experiencia.
    En el único caso en que la experiencia fue distinta (para peor) fue en el caso del driver x11-video-nvidia (con el módulo nvidia-gfx-kmp-default), con el que al activar los efectos de escritorio desaparecían completamente los bordes de todas las ventanas, y volvían a aparecer al desactivar los efectos.
    Tu tarjeta de vídeo es reciente, solo deberías usar la versión G02. Supongo también que desinstalarías una versión antes de instalar otra.

    Cita Iniciado por VaryHeavy Ver Mensaje
    Decir también que la aplicación de los Ajustes de NVIDIA del servidor X (nvidia-settings) solo he podido abrirla usando el driver x11-video-nvidia (96.43.19-26.1), mientras que con los otros drivers al querer abrirla desde el menú, el clickar sobre ella no tiene ningún efecto, y al ejecutarla por consola me salta el siguiente mensaje:

    Código:
    varyheavy@VaryComputer:~> nvidia-settings
    
    ERROR: The attribute 'ForceGenericCpu' specified on line 26 of configuration
           file '/home/varyheavy/.nvidia-settings-rc' cannot be assigned (it is a
           read-only attribute).
    Cambia el nombre al archivo y vuelve a ejecutarlo a ver si funciona. Posiblemente está relacionado con haber instalado versiones del controlador que no corresponden con el modelo de tu tarjeta.

    Cita Iniciado por VaryHeavy Ver Mensaje
    También he probado a instalar el xorg-x11-driver-video-nouveau junto con el mesa-nouveau3d pero no sé cómo hacer para que el sistema pase a utilizar este driver :S, ¿cómo se hace el cambio de driver gráfico teniendo más de uno instalado?
    Borrando todos los paquetes de NVIDIA se activa el controlador de nouveau automáticamente. Por otro lado, instalar cosas para ver si suena la flauta lleva en más ocasiones a estropicio que a algo positivo (aunque a veces pasa XD). De momento el 3D para el controlador de nouveau (mesa-nouveau3d) se considera experimental y puede no funcionar en absoluto, producir artefactos gráficos o funcionar perfectamente.

    Cita Iniciado por VaryHeavy Ver Mensaje
    Y lo más importante: ¿Qué podría hacer para resolver el problema del renderizado de las ventanas con Compiz?
    En Mandriva también estuve usando en su día GNOME + Compiz y nunca tuve problemas de este tipo, todas las ventanas se mostraban correctamente. ¿Qué puede estar pasando en OpenSUSE?
    Prueba cambiando las opciones de configuración. Desactiva todos los efectos sin desactivar Compiz y comprueba si se ve bien. Si es así los vas activando uno a uno hasta dar con el que produce el fallo. Yo lo estuve usando un tiempo en sustitución de Kwin y funcionaba perfectamente.

    Cita Iniciado por VaryHeavy Ver Mensaje
    He instalado Compiz de ese repo pero hay dependencias que no están ahí, como por ejemplo el imprescindible compiz-manager, el cual solo está disponible en los repositorios principales y pide como dependencia la versión de Compiz que viene en los repos principales, así que probé a instalar el paquete compiz-manager desde los repositorios principales junto con el Compiz del repo que me has facilitado ignorando las dependencias, y aunque puedo abrir el CCSM, no me deja activar los efectos de escritorio, se ve que lo intenta porque el escritorio hace cosas raras, pero no es capaz de activar los efectos.
    Mezclar paquetes de distintas versiones no es una buena idea.

    Cita Iniciado por VaryHeavy Ver Mensaje
    He intentado instalarlo, pero me da error la instalación.
    ¿Cuál? ¿Qué comandos has usado para instalarlo?

    Un saludo.

  10. #10
    Fecha de Ingreso
    20-marzo-2011
    Ubicación
    Sevilla, España
    Mensajes
    235
    Poder de Credibilidad
    9
    Bueno, había conseguido un funcionamiento medianamente decente de Compiz con la última versión que instalé, del último repo que me proporcionó Arag. Pero hace 2 días vinieron un montón de actualizaciones, entre las que estaba la de Compiz, que si no recuerdo mal se ha actualizado a la versión 0.9.4, y ahora va PEOR que nunca. Al activar los efectos de escritorio, el contenido de las ventanas maximizadas se ve completamente en blanco y la única forma de recuperar el funcionamiento normal es desactivando los efectos.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. Problema con mi placa de Sonido en OpenSuse 11.2
    By Prideone in forum Hardware
    Respuestas: 10
    Último mensaje: 21-ene-2010, 10:18
  2. driver nvidia problemas resolucion
    By korn_head in forum Software
    Respuestas: 13
    Último mensaje: 24-nov-2009, 06:58
  3. Respuestas: 43
    Último mensaje: 30-oct-2008, 10:29
  4. ayuda con laptop HP dv6420la y driver Nvidia
    By zchronos in forum Hardware
    Respuestas: 6
    Último mensaje: 28-feb-2008, 09:54
  5. Error driver NVidia en openSUSE 10.3
    By Clufis in forum Hardware
    Respuestas: 8
    Último mensaje: 12-nov-2007, 14:54

Tags for this Thread

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •