Mostrando resultados del 1 al 6 de 6

Tema: Wine en versionas anteriores

  1. #1
    Fecha de Ingreso
    27-agosto-2008
    Ubicación
    Chincha - Peru
    Mensajes
    429
    Poder de Credibilidad
    11

    Wine en versionas anteriores

    Hola. Una consulta para los grandes.
    Hasta hace una semana estaba trabajando con openSUSE 11.3 32bits, el cual iba como la seda y podia trabajar sin problemas con el Office 2003 con macros (Me veia forzado a usarlo por las macros y por la inclusion de archivos ocs para la ejecuchon de macros en una hoja de trabajo.)
    La version del wine era la 1.2.

    Ahora tengo equipo nuevo, con 4gb de ram. Asi que como actualizar el equipo tambien actualice mi SO a openSUSE 11.4 64bits (Sinceramente la percibo bastante inestable y con problemillas, pero aun estoy batallandolo)

    En esta oportunidad viene con wine 1.3.17. Creo que al ser una version superior, que supuestamente corrige problemas, las palicaciones wine deberia ir mejor; pero la realidad es diferente. Ni siquiera me permite instalar el MS Office.

    Y aca la pregunta del millon: Como hago para regresar a wine 1.2 (Version anterios) o a wine 1.1 en la que tambien me corria sin problemas el MS Offcie 2003.

    Espero una manito, y no se molesten por lo del MS Office, pero por el laboro debo usar un libro con macros con archivos ocx.

  2. #2
    Fecha de Ingreso
    18-mayo-2008
    Mensajes
    2.104
    Poder de Credibilidad
    13
    Hola.

    Antes de pensar en utilizar versiones anteriores de Wine, ¿recuerdas si cuando funcionaba habías instalado algún programa antes usando winetricks -como mfc40, msvcrt, comctl32, etc.- que fuera necesario para poder instalar MS Office? Si no fue así, se me ocurre que puedes mirar en los repositorios de la versión 11.3 de openSUSE y descargar los paquetes de allí. Luego los instalas y esperemos que no den problemas de dependencias. También puedes mirar en la página de Wine a ver si ha aparecido algún error reciente que afecte a la versión de MS Office que usas.

    Un saludo.

  3. #3
    Fecha de Ingreso
    27-agosto-2008
    Ubicación
    Chincha - Peru
    Mensajes
    429
    Poder de Credibilidad
    11
    Hola jcls.

    Gracias por responder.

    Al respecto del winetricks, lo estoy usando de la misma forma que antes. Instalo los siguientes complementos: dcom98, gdiplus, vb6run, riched20, riched30, vcrun6, vcrun2005, wsh56.

    Con eso el MS Office 2003 corria macros sin problemas, pero ahora no.

    Por el momento tengo que salvar la situacion con el virtualbox en su version 4. Pero al cambiar de version, el utocad 2010 (q lo corria si bien algo lagueado en la version anterior, en esta nueva version el autocad colapsa.

    Aun sigo experimentando.

    Consulta adiconal, derrepente el wine me esta molestando debido a que ahora uso una version de 64bits; y claro esta, openSUSE no deja correr la version de 32bits del wine sobre la plataforma de 64, pero sale un mensaje que no se como ejecutarlo.

    You're using a 64-bit WINEPREFIX, most of winetricks has been fixed for 64-bit, but you may still have problems. You can force a 32-bit WINEPREFIX by using WINEARCH=win32.

    Que quiere decir con "WINEARCH=win32"?? Ya lo probe en la consola con el wine y con el winetrics y nada de nada.

  4. #4
    Fecha de Ingreso
    18-mayo-2008
    Mensajes
    2.104
    Poder de Credibilidad
    13
    Hola.

    Sobre WINEARCH=win32 solo tienes que buscar eso mismo y verás que aparecen montones de resultados, por ejemplo éste de la wiki de Arch Linux. El mismo mensaje de error te indica que pueden aparecer problemas si se usa winetricks en modo 64 bits, y de ahí la sugerencia que te hace de que utilices WINEARCH=win32 para forzar un entorno de ejecución de 32 bits (en el enlace anterior viene cómo se emplea).

    Un saludo.

  5. #5
    Fecha de Ingreso
    27-agosto-2008
    Ubicación
    Chincha - Peru
    Mensajes
    429
    Poder de Credibilidad
    11
    Cita Iniciado por jcsl Ver Mensaje
    Hola.

    Sobre WINEARCH=win32 solo tienes que buscar eso mismo y verás que aparecen montones de resultados, por ejemplo éste de la wiki de Arch Linux. El mismo mensaje de error te indica que pueden aparecer problemas si se usa winetricks en modo 64 bits, y de ahí la sugerencia que te hace de que utilices WINEARCH=win32 para forzar un entorno de ejecución de 32 bits (en el enlace anterior viene cómo se emplea).

    Un saludo.
    Haber haber si tanta belleza es cierto. Lo voy a probar y comento como me fue.
    Por otro lado, consideras que la inestabilidad de KDE 4.6 afecta a las aplicaciones no KDE (wine, virtual box)?

  6. #6
    Fecha de Ingreso
    18-mayo-2008
    Mensajes
    2.104
    Poder de Credibilidad
    13
    Hola.
    Cita Iniciado por UnderUp Ver Mensaje
    Por otro lado, consideras que la inestabilidad de KDE 4.6 afecta a las aplicaciones no KDE (wine, virtual box)?
    En mi opinión, directamente no, pero indirectamente puede. Con indirectamente quiero decir que si un fallo de KDE provoca que el sistema sea inestable, todas las aplicaciones se verán afectadas. Por ejemplo, si se cierra la sesión sola se cerrarán todas las aplicaciones que estén funcionando. Pero Wine en sí creo que no tiene nada que ver con el escritorio que se use.

    Un saludo.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. [GUIA] Poner photoshop [WINE]
    By -ZAP- in forum FAQs, Manuales y Tutoriales
    Respuestas: 6
    Último mensaje: 12-oct-2008, 17:01
  2. Instalar dreamweaver CS3 con wine en openSUSE 11
    By poporembo in forum Virtualización
    Respuestas: 7
    Último mensaje: 02-oct-2008, 22:26
  3. Anuncio oficial salida de Wine 1.0
    By Dux in forum Portal de ForoSUSE
    Respuestas: 6
    Último mensaje: 18-jun-2008, 16:56
  4. Crear comics - Comic Life bajo wine
    By migtei in forum Software
    Respuestas: 2
    Último mensaje: 06-jun-2008, 15:25
  5. Respuestas: 6
    Último mensaje: 03-sep-2007, 12:29

Tags for this Thread

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •