Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Mostrando resultados del 1 al 2 de 2

Tema: Problema con la ñ y acentos

  1. #1
    Fecha de Ingreso
    30-octubre-2010
    Mensajes
    1
    Post Thanks / Like
    Poder de Credibilidad
    0

    Problema con la ñ y acentos

    Buenas tardes, he instalado recientemente la versión 11.3 y tengo no pocos problemas, alguno de ellos tan básico como que no puedo gestionar (copiar, renombrar, ...) ningún fichero que contenga una ñ o acentos, que aparecen con un signo de interrogación. ¿Alguna sugerencia?
    Gracias

  2. #2
    Fecha de Ingreso
    18-mayo-2008
    Mensajes
    2.104
    Post Thanks / Like
    Poder de Credibilidad
    14
    Hola.

    Supongo que quieres decir que no puedes renombrarlos desde el administrador de archivos que usas, ¿no? Es un problema frecuente que está relacionado con la codificación de caracteres y no con cuáles sean estos. Los puedes renombrar desde la consola ejecutando, desde el directorio donde esté el archivo, la orden:

    mv nombre_antiguo nombre_nuevo

    Si aún así no funciona lo puedes hacer usando el inode del archivo (es un número asociado con él).

    Primero obtienes el inode del archivo: ls -il nombre_del_archivo_problemático

    El resultado que obtienes es una línea que empieza con un número, el inode del archivo.

    Luego lo puedes renombrar con: find . -inum número_del_inode -exec mv -i {} nombre_nuevo \;

    Nota: si después de escribir uno o más caracteres del nombre del archivo pulsas la tecla Tabulador el nombre se completa solo.

    Un saludo.
    Última edición por jcsl; 30-oct-2010 a las 21:44 Razón: Corregir errata.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. Respuestas: 17
    Último mensaje: 04-feb-2009, 08:58
  2. plasma en kde4.1 no arranca
    By ÆPEDRAZA in forum Software
    Respuestas: 18
    Último mensaje: 27-sep-2008, 00:13
  3. Aurora Engine 1.4 para Gtk problema
    By larva_pro in forum Escritorios: KDE, Gnome, otros...
    Respuestas: 0
    Último mensaje: 24-jul-2008, 22:29
  4. Respuestas: 2
    Último mensaje: 16-dic-2006, 22:11
  5. Openoffice 2.0 y losacentos (problema nuevo)
    By spartano in forum Software
    Respuestas: 8
    Último mensaje: 01-ago-2005, 21:30

Tags for this Thread

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •