Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Mostrando resultados del 1 al 10 de 10

Tema: Conflictos con el KDE 3.3

  1. #1
    kabukiman Invitado

    Conflictos con el KDE 3.3

    Hola!

    Estoy intentando instalar la última versión del Kde a través del Apt. Pero, después de bajarlo todo, cuando va a instalar me da una serie de conflictos con paquetes que ya tengo:

    file /opt/kde3/share/config/khotnewstuffrc from install of kdelibs3-3.3.0-7 conflicts with file from package kdepim3-3.2.1-35
    file /opt/kde3/bin/ghns from install of kdelibs3-3.3.0-7 conflicts with file from package kdepim3-organizer-3.2.1-35
    file /opt/kde3/bin/khotnewstuff from install of kdelibs3-3.3.0-7 conflicts with file from package kdepim3-organizer-3.2.1-35
    file /opt/kde3/lib/libknewstuff.la from install of kdelibs3-3.3.0-7 conflicts with file from package kdepim3-organizer-3.2.1-35
    file /opt/kde3/lib/libknewstuff.so.1.0.0 from install of kdelibs3-3.3.0-7 conflicts with file from package kdepim3-organizer-3.2.1-35
    file /opt/kde3/share/mimelnk/audio/x-ms-wma.desktop from install of kdelibs3-3.3.0-7 conflicts with file from package kaffeine-0.4.1-84.2
    file /opt/kde3/bin/kdepasswd from install of kdebase3-3.3.0-8 conflicts with file from package kdeutils3-3.2.1-61
    file /opt/kde3/share/applications/kde/kdepasswd.desktop from install of kdebase3-3.3.0-8 conflicts with file from package kdeutils3-3.2.1-61

    Se han de desinstalar antes esos paquetes que crean conflictos? No habrá ningún problema en hacerlo?

    Un saludo

  2. #2
    Fecha de Ingreso
    27-julio-2004
    Ubicación
    En un lugar de la mancha ...
    Mensajes
    2.348
    Post Thanks / Like
    Poder de Credibilidad
    18
    Hola

    Cita Iniciado por kabukiman
    Se han de desinstalar antes esos paquetes que crean conflictos? No habrá ningún problema en hacerlo?
    Pues sí, la manera más fácil de solucionar los conflictos sería desinstalar esos paquetes primero. La mayoría de conflictos parece que te ocurren con kdepim3 y kdepim3-organizer. De esos también habrás bajado la nueva versión no??

    Una vez los desinstales ya deberías poder instalar los paquetes en sus nuevas versiones sin problemas
    La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
    "No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"

  3. #3
    kabukiman Invitado
    Ya los he desinstalado, los marco para bajar e instalar junto a lo demás, está todo correcto, me sale una ventana diciendo que se están aplicando los cambios ... pero tras unos segundos desaparece y no sucede nada. Abajo (en el synaptic) se ve que los paquetes aún están por instalar o actualizar

    Que es lo que ocurre?


  4. #4
    Fecha de Ingreso
    27-julio-2004
    Ubicación
    En un lugar de la mancha ...
    Mensajes
    2.348
    Post Thanks / Like
    Poder de Credibilidad
    18
    Pues no sabría decirte ... yo el synaptic nunca lo uso siempre lo hago directamente por la consola por apt

    En cualquier caso si tienes todos los paquetes bajados ya lo puedes instalar de muchas formas ... por ejemplo si los tienes todos en una carpeta sólo ejecutas en la consola desde esa carpeta (y como root):

    rpm -Uvh *.rpm

    Así además te aseguras que te los instala en el orden correcto
    La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
    "No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"

  5. #5
    kabukiman Invitado

    Una complicación (creo)

    Cuando iban a bajar los paquetes me decía que había que desinstalar uno, el cryptplug. Ahora si voy al Yast a quitarlo, me dice que hay un conflicto con el kdebase3-suse que lo requiere.

    - Con lo que me bajo ya no haría falta este paquete y lo puedo quitar sin preocuparme de los conflictos?

    - O tengo que desinstalar también el kdebase3-suse y volverlo a instalar?


  6. #6
    Fecha de Ingreso
    27-julio-2004
    Ubicación
    En un lugar de la mancha ...
    Mensajes
    2.348
    Post Thanks / Like
    Poder de Credibilidad
    18
    Pues si hay cualquier tipo de conflicto lo mejor es eliminarlo primero, luego instalas la nueva versión y ya no debería darte problema

    En cualquier caso si intentas instalar con el comando que te puse, o de cualquier otra manera, te avisará igualmente si hay algún conflicto a la hora de instalar, así que si lo intentas instalar y no te da ningún aviso es que está bien

    Para desinstalar paquetes puedes hacerlo también fácilmente desde la consola, con el mismo comando rpm, en este caso usando el parámetro -e (erase)

    rpm -e nombrepaquete

    Ten en cuenta que tienes que poner el nombre del paquete, no del fichero rpm, es decir, pondrías por ejemplo:

    rpm -e kde3-i18n-es

    y no: rpm -e kde3-i18n-es-3.3.0-3.rpm

    Un saludo
    La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
    "No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"

  7. #7
    kabukiman Invitado
    He probado a instalar con el comando que pusiste, y al parecer ese paquete lo ha borrado y lo demás se instala bién.

    Lo que pasa es que durante en la instalación me salen varias veces: wrong permissions 0755

    Y cuando voy al Centro de Control, me dice que el Kde es 3.3 pero el índice de la izquierda está vacío

  8. #8
    Fecha de Ingreso
    05-agosto-2004
    Ubicación
    Alacant
    Mensajes
    1.455
    Post Thanks / Like
    Poder de Credibilidad
    17
    Si os sirve de algo yo tuve que desinstalar todo kde para poder instalar la versión 3.3... ya sé que soy un poco bestia, pero me harté de dependencias y dije... ¡ahora verás!, y borré todo kde. Eso sí, luego, instalé la versión 3.3 enseguidita.
    Software is like sex: it's better when it's free.

    SomGNU | Desarmats

  9. #9
    Fecha de Ingreso
    27-julio-2004
    Ubicación
    En un lugar de la mancha ...
    Mensajes
    2.348
    Post Thanks / Like
    Poder de Credibilidad
    18
    Cita Iniciado por kabukiman
    al parecer ese paquete lo ha borrado y lo demás se instala bién.
    Que paquete exactamente?? Has probado a volver a instalarlo ahora??

    Cita Iniciado por kabukiman
    Y cuando voy al Centro de Control, me dice que el Kde es 3.3 pero el índice de la izquierda está vacío
    El índice de la izquierda te refieres al panel que sale con las diferentes opciones?? No te sale ni el texto ni los iconos??

    Al actualizar la versión de kde tienes que reiniciar el servidor gráfico .. supongo lo habrás hecho no??

    Cita Iniciado por Mdk
    Si os sirve de algo yo tuve que desinstalar todo kde para poder instalar la versión 3.3... ya sé que soy un poco bestia,
    Sólo un poco??
    La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
    "No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"

  10. #10
    kabukiman Invitado

    Cool

    Cita Iniciado por chuzo
    El índice de la izquierda te refieres al panel que sale con las diferentes opciones?? No te sale ni el texto ni los iconos??

    Al actualizar la versión de kde tienes que reiniciar el servidor gráfico .. supongo lo habrás hecho no??
    Has supuesto demasiado

    He reiniciado y ahora todo está bién

    Muchas gracias

    Pd: me gusta esto del APT

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •