Mostrando resultados del 1 al 8 de 8

Tema: Solución para eliminar nouveau

  1. #1
    Fecha de Ingreso
    18-mayo-2008
    Mensajes
    2.104
    Poder de Credibilidad
    13

    Solución para eliminar nouveau

    Hola.

    La solución está en las notas de la versión:

    ...it is even possible to disable loading of the DRM module in initrd completely. For this set the NO_KMS_IN_INITRD sysconfig variable to yes via YAST, which then recreates initrd afterwards. Reboot your machine...

    Traducción:

    ...es posible incluso deshabilitar por completo la carga del módulo DRM en initrd. Para esto asigna yes a la variable de sysconfig NO_KMS_IN_INITRD, que recreará initrd luego. Reinicia tu máquina...

    Los pasos para hacerlo son:

    • YaST -> Editor para los archivos /etc/sysconfig
    • Pulsar el botón Buscar
    • Escribir kms en el cuadro de diálogo que aparece
    • Pulsar el botón Ir a al aparecer el resultado de la búsqueda
    • Cambiar no por yes donde pone Configuración de: NO_KMS_IN_INITRD
    • Aceptar
    • Reiniciar

    Ya se puede instalar el controlador de NVIDIA de forma manual como de costumbre. No hace falta añadir el controlador nouveau a la lista negra ni usar nomodeset ni modprobe/rmmod ni nada más. La única diferencia con el método antiguo es que ahora, al no estar SaX2, hay que usar nvidia-xconfig para generar el fichero xorg.conf. Con el nuevo Xorg se puede usar éste archivo o los que hay en el directorio /etc/X11/xorg.conf.d.

    Un saludo.
    Última edición por jcsl; 16-jul-2010 a las 13:25

  2. #2
    Fecha de Ingreso
    19-diciembre-2008
    Ubicación
    Villavicencio, Colombia
    Mensajes
    694
    Poder de Credibilidad
    11
    Buena esa, lastima que venia desde las rc y pues ahora en la final me va de lujo, el que haga una instalación limpia de la definitiva y tenga nvidia que nos comente.

  3. #3
    Fecha de Ingreso
    18-mayo-2008
    Mensajes
    2.104
    Poder de Credibilidad
    13
    Hola.

    Aunque instalé la última milestone y desde entonces he ido actualizando, he hecho una instalación limpia y he instalado el controlador de NVIDIA de esta forma. No he tenido ningún problema para hacerlo.

    Un saludo.

  4. #4
    Fecha de Ingreso
    18-diciembre-2009
    Ubicación
    México
    Mensajes
    478
    Poder de Credibilidad
    10
    yo solo agregue este repo.
    y me instalo el ultimo driver de nvidia sin necesidad de desactivar nouveau o desinstalarlo..

    fuente.
    Última edición por sieg84; 16-jul-2010 a las 03:02

  5. #5
    Fecha de Ingreso
    10-diciembre-2009
    Ubicación
    /home/Concepción/Chile
    Mensajes
    332
    Poder de Credibilidad
    10
    Cita Iniciado por sieg84 Ver Mensaje
    yo solo agregue este repo.

    y me instalo el ultimo driver de nvidia sin necesidad de desactivar nouveau o desinstalarlo..

    fuente.
    Pues me ganaste, precisamente iba a abrir un tema para ponerlo. Mañana hago la instalación y compruebo todo, pero por lo que se ve, funciona de perlas.

  6. #6
    Fecha de Ingreso
    13-septiembre-2006
    Mensajes
    62
    Poder de Credibilidad
    13

    Error de dependencia al instalar nvidia

    Hola a todos:
    He ido a instalar el driver nvidia según los pasos explicados y a la primera vez funcionó a la perfección, y digo a la primera, porque luego de formatear el equipo por diversos motivos, volví a instalar opensuse 11.3, después instalé de nuevo el repositorio de nvidia pero me saltó el error de dependencia que necesitaba "nvidia-gfxGO2-kmp". He buscado pero no sé en que repositorio está, ya que he instalado practicamente todos los repositorios de la comunidad.

    ¿Alguien me echa una manita?.

    Gracias de antemano

  7. #7
    Fecha de Ingreso
    16-noviembre-2009
    Mensajes
    10
    Poder de Credibilidad
    0
    Pues yo que estoy empezando con opensuse, tengo una grafica integrada 7050 de nvidia y fue agregar los repositorios desde yast, entrar en añadir/quitar programa me salio que me iba a instalar uos paquete nvidia-gx02 o algo asi, reinicie y todo me funciona sin hacer nada. abri el gxgears y las ruedas se mueven asi que supongo que estara todo bien instalado.

    Salu2:Euphoria

  8. #8
    Fecha de Ingreso
    05-diciembre-2012
    Mensajes
    87
    Poder de Credibilidad
    7
    A mi me pasa una cosa super curiosas!
    Estoy intentando instalar "NVIDIA-Linux-x86_64-310.19.run",
    -Si NO_KMS_IN_INITRD="yes" me salta el error a la primera.
    -Si NO_KMS_IN_INITRD="no" parece que funciona, aparece la barra del %, pero luego salta el error y me cambia de nuevo, NO_KMS_IN_INITRD="yes".

    ¿En que me estoy equivocando?

    Edito:
    Como a cabezón no me gana casi nadie, lo volví a intentar y se lo a tragado.
    "Creo" ha sido por iniciar la konsola con: /sbin/init 3, ya os digo "creo".

    Pero ya está instalado.

    Gracias.
    Última edición por valver; 05-ene-2013 a las 02:54

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. Manual zypper para 11.1 (Traducción al español)
    By tranzorx in forum FAQs, Manuales y Tutoriales
    Respuestas: 11
    Último mensaje: 22-ene-2010, 00:21
  2. Carta Pública para DiabloRojo: Indignación
    By iSVQ in forum La cafetería
    Respuestas: 24
    Último mensaje: 24-nov-2009, 09:57
  3. plasma en kde4.1 no arranca
    By ÆPEDRAZA in forum Software
    Respuestas: 18
    Último mensaje: 27-sep-2008, 00:13
  4. Vocabulario Básico en GNU/Linux
    By karlggest in forum FAQs, Manuales y Tutoriales
    Respuestas: 2
    Último mensaje: 17-ene-2008, 21:33
  5. suse 10.1 y wmware
    By antaramir in forum Hardware
    Respuestas: 2
    Último mensaje: 16-nov-2006, 00:40

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •