Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Mostrando resultados del 1 al 9 de 9

Tema: Problema al instalar 11.3 formato de particion /home ext4 perdida

  1. #1
    Fecha de Ingreso
    25-julio-2007
    Mensajes
    35
    Post Thanks / Like
    Poder de Credibilidad
    0

    Problema al instalar 11.3 formato de particion /home ext4 perdida

    Problema principal, he intalado 11.3 al crear particiones he conservado el /home que esta en /dev/sda3 y su formato era ext4, a la hora de realizar la instalación me dio un codigo de error con dicha partición, en concreto el -3003 (que no podia montarla) pues nada seguí adelante, me dije, si no la monta ahora ya la montaré yo. ¡Sorpresa! entro al gestor de particiones, intento montarla y............. como no tiene formato no puede montarla.

    Hay alguna forma humana o inhumana de ponerle de nuevo el formato ext4 sin perder todos los datos claro esta. Por lo demas esta versión parece mas rápida

    De momento intentaré con el sistema de rescate a ver que me cuenta
    AMD Athlon(tm) 64 X2 Dual Core Processor 4400+
    Memoria total (RAM): 2.0 GB
    openSUSE 11.2 (32bits)
    nVidia GeForce 7300 SE
    KDE: 4.3

  2. #2
    Fecha de Ingreso
    08-septiembre-2005
    Ubicación
    ±43º21'N8º22'W
    Mensajes
    1.232
    Post Thanks / Like
    Poder de Credibilidad
    16
    Cita Iniciado por sunbloquer Ver Mensaje
    ........ como no tiene formato no puede montarla.
    Ummmm ... salvo borrado accidental ... formato ... tiene que tener. Que no lo "vea" es otra cosa.
    Obviedad innecesaria: no hacer nada que suene a formatear, nada que suene a asignar-reasignar formato, etc.

    Yo usaría un cd-vivo (para asunto de particiones me gusta PartedMagic y similares) para ver la situación real de las particiones.
    Luego, adecuando el fstab debiera dar resultados
    #fdisk -l
    #nano /etc/fstab
    Todo es mejorable, estamos dispuestos a mejorar. ¿Yo? ... poco a poco.
    Nunca hay acritud en mis comentarios, si lo pareciera, seguro que me he expresado mal.

  3. #3
    Fecha de Ingreso
    25-julio-2007
    Mensajes
    35
    Post Thanks / Like
    Poder de Credibilidad
    0
    Hola XisEme, de momento esta pasando el Recuperar Particiones perdidas pero del 11.2, el sistema de rescate de la 11.3 se queda en linea de comandos.

    La particion no fue formateada, de hecho yo edite esa particion para que no fuera formateada.

    La particion existe, pero la ext4 desaparecio cuando he reinstalado la 11.2 lo he hecho igual y me ha dejado el home como siempre.

    Bueno intento esto y paso al plan B.

    Gracias
    AMD Athlon(tm) 64 X2 Dual Core Processor 4400+
    Memoria total (RAM): 2.0 GB
    openSUSE 11.2 (32bits)
    nVidia GeForce 7300 SE
    KDE: 4.3

  4. #4
    Fecha de Ingreso
    25-julio-2007
    Mensajes
    35
    Post Thanks / Like
    Poder de Credibilidad
    0
    Aqui estan las particiones



    Código:
    fdisk -l
    
    Disk /dev/sda: 320.1 GB, 320072933376 bytes
    255 heads, 63 sectors/track, 38913 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x0008b5e1
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sda1               1         262     2103296   82  Linux swap / Solaris
    Partition 1 does not end on cylinder boundary.
    /dev/sda2   *         262        2873    20972544   83  Linux
    /dev/sda3            2873       38914   289494016   83  Linux
    y el fstab pues nose como cogerlo, este supongo que sera el del livecd

    Código:
    devpts  /dev/pts   devpts  mode=0620,gid=5 0 0
    proc    /proc      proc    defaults 0 0
    sysfs   /sys       sysfs   noauto 0 0
    /dev/root / defaults 0 0
    Encontre algo por ahi y haciendo un fdisk a la particion me encuentro esto

    Código:
    fdisk /dev/sda3
    Device contains neither a valid DOS partition table, nor Sun, SGI or OSF disklabel
    Building a new DOS disklabel with disk identifier 0x5af3464c.
    Changes will remain in memory only, until you decide to write them.
    After that, of course, the previous content won't be recoverable.
    
    
    The number of cylinders for this disk is set to 36040.
    There is nothing wrong with that, but this is larger than 1024,
    and could in certain setups cause problems with:
    1) software that runs at boot time (e.g., old versions of LILO)
    2) booting and partitioning software from other OSs
       (e.g., DOS FDISK, OS/2 FDISK)
    Warning: invalid flag 0x0000 of partition table 4 will be corrected by w(rite)
    Última edición por sunbloquer; 15-jul-2010 a las 22:56
    AMD Athlon(tm) 64 X2 Dual Core Processor 4400+
    Memoria total (RAM): 2.0 GB
    openSUSE 11.2 (32bits)
    nVidia GeForce 7300 SE
    KDE: 4.3

  5. #5
    Fecha de Ingreso
    08-septiembre-2005
    Ubicación
    ±43º21'N8º22'W
    Mensajes
    1.232
    Post Thanks / Like
    Poder de Credibilidad
    16
    Ya que no hay /home y por ende, entiendo que usuarios tampoco; arrancando openSUSE como root (las X no son necesarias) editar el fstab para modificarlo adecuadamente.

    #nano /etc/fstab

    debiera devolver (sino modificar) algo como

    /dev/disk/by-id/xxxxx-part2 / ext4 acl,user_xattr 1 1
    /dev/disk/by-id/xxxxx-part1 swap swap defaults 0 0
    /dev/disk/by-id/xxxxx-part3 /home ext4 defaults 1 2
    Todo es mejorable, estamos dispuestos a mejorar. ¿Yo? ... poco a poco.
    Nunca hay acritud en mis comentarios, si lo pareciera, seguro que me he expresado mal.

  6. #6
    Fecha de Ingreso
    06-noviembre-2007
    Ubicación
    Chiclayo - Perú
    Mensajes
    826
    Post Thanks / Like
    Poder de Credibilidad
    13
    Por si las dudas dale una revisada al disco.

    # DESMONTAR!!!
    # fsck -c -y /dev/eldisco

    "No existen los problemas, tan solo soluciones"
    Linux user #460594

  7. #7
    Fecha de Ingreso
    25-julio-2007
    Mensajes
    35
    Post Thanks / Like
    Poder de Credibilidad
    0
    Bueno, modifique el fstab ya que no aparecia la linea que hacia referencia a sda3 pero lo modifica visualmente, realizando un fdisk muestra la informacion del disco y al final

    Disk /dev/sda3 doesnt containt a valid partition table

    un dmesg tambien dice que EXT4fs Cant find ext4file

    el comando

    # DESMONTAR!!!
    # fsck -c -y /dev/sda3

    dice The superblock could not be read or does not describe a correct ext2

    Mucho me temo que tendre que formatear y perder todo lo guardado durante años. Si formateo lo que se reescribe en home es minimo, podre recuperar datos.............

    Gracias
    Última edición por sunbloquer; 16-jul-2010 a las 10:17
    AMD Athlon(tm) 64 X2 Dual Core Processor 4400+
    Memoria total (RAM): 2.0 GB
    openSUSE 11.2 (32bits)
    nVidia GeForce 7300 SE
    KDE: 4.3

  8. #8
    Fecha de Ingreso
    25-julio-2007
    Mensajes
    35
    Post Thanks / Like
    Poder de Credibilidad
    0
    Por todo lo que he leido por ahí, pruebas propias, etc, etc no hay nada que hacer con el tema de extension de partición perdida, la cuestión es saber la causa de ello. Desde una instalacion limpia de Suse 11.2 con /home a una de 11.3 y conservando el /home con la misma ext (ext4) esta desaparece.

    Al final:

    He realizado una instalación formateando la particion /dev/sda3 (/home) para que la reconozca obviamente como ext4 sin problemas.

    He intentando recuperar los datos de esa partición con Foremost y el resultado nefasto, ha encontrado muchos archivos pero al fin y al cabo repetidos, vamos, lo que es nada.

    Doy este post por solucionado y abro otro para otra duda que tengo, muchas gracias a todos por la ayuda u opiniones prestadas.
    AMD Athlon(tm) 64 X2 Dual Core Processor 4400+
    Memoria total (RAM): 2.0 GB
    openSUSE 11.2 (32bits)
    nVidia GeForce 7300 SE
    KDE: 4.3

  9. #9
    Fecha de Ingreso
    07-febrero-2007
    Ubicación
    Ourense
    Mensajes
    8.680
    Post Thanks / Like
    Poder de Credibilidad
    22
    Una cosilla que puede ser interesante en ciertos casos... si lo único que has perdido es la partición, y conoces la tabla de particiones (o tienes mucha paciencia) puedes restaurarla simplemente, no se verá afectado su contenido. La tabla de particones no es más que un archivo de texto que indica que particiones hay y en qué lugar físico del disco están...

    En cuanto a recuperarlas a mano, bueno, una partición de unos cuantos gigas no sé yo... pero posible, es.

    Salud!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. Problema Instalar compiz en 11.2 (64bits)
    By Nahamen in forum Software
    Respuestas: 5
    Último mensaje: 30-nov-2009, 04:28
  2. Problema para instalar goblin
    By atimus in forum Instalación y Actualizaciones
    Respuestas: 0
    Último mensaje: 11-sep-2009, 11:30
  3. Respuestas: 4
    Último mensaje: 14-mar-2009, 00:52
  4. Problema al instalar driver nvidia
    By emi87 in forum Hardware
    Respuestas: 11
    Último mensaje: 25-feb-2009, 23:46
  5. problema al instalar linux 9.2
    By hibikete32 in forum Instalación y Actualizaciones
    Respuestas: 1
    Último mensaje: 17-oct-2005, 13:35

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •