Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Mostrando resultados del 1 al 5 de 5

Tema: Problemas con APT y dependencias

  1. #1
    Dudu678 Invitado

    Problemas con APT y dependencias

    Todo confiado, pretendiendo instalar APT seguí un manual.

    Me bajé todos los rpm de ftp://ftp.gwdg.de/pub/linux/suse/apt...PMS.suser-rbos según rezaba el manual. Seguidamente a esto, ejecuté un yast -i *.rpm como root en una carpeta donde sólo tenía esos paquetes rpm.

    Bien, la gracia es que me salta un

    La instalación del paquete ./synaptic-0.53-0.suse091.rb.1.i586.rpm ha fallado.

    Y ahí se queda pillada la consola. Al abrir el Instalar/desinstalar software este del Yast, pos me tira la leche:

    Código PHP:
    #### YaST2 conflicts list - generated 2004-09-02 21:53:42 ####

    apt no disponible
        Requerido por
    :
            
    synaptic requiere apt >= 0.5.15-
        
    Resoluci� de conflictos:
            
    ( ) Eliminar el paquete correspondiente
                Borrar synaptic
            
    ( ) Ignorar conflicto y arriesgarse a incoherencias en el sistema
    Conflicto synaptic 0.53
    -0.suse091.rb.1
        Requisitos sin resolver
    :
            
    synaptic requiere apt >= 0.5.15-
            
    synaptic requiere libapt-pkg-libc6.3-5.so.0
        Resoluci
    � de conflictos:
            
    ( ) No definir synaptic como protegido
            
    ( ) Ignorar conflicto y arriesgarse a incoherencias en el sistema
    Conflicto xmlto 0.0.18
    -20
        Resoluci
    � de conflictos:
            
    ( ) No definir xmlto como protegido
            
    ( ) Ignorar conflicto y arriesgarse a incoherencias en el sistema
    libapt
    -pkg-libc6.3-5.so.0 no disponible
        Requerido por
    :
            
    synaptic requiere libapt-pkg-libc6.3-5.so.0
        Resoluci
    � de conflictos:
            
    ( ) Eliminar el paquete correspondiente
                Borrar synaptic
            
    ( ) Ignorar conflicto y arriesgarse a incoherencias en el sistema

    #### YaST2 conflicts list END ### 
    Antes de tocar nada pregunto... cómo arreglo todo este embrollo de forma fácil y me pillo el apt sin complicaciones?

    También debo comentar que al hacer un rpm -i a esos paquetes me dice que necesito la tira de cosas, algunas de las cuales no están en el DVD de suse, y no puedo instalar de forma cómoda porque no tengo APT.

    Gracias por todo de antemano.
    Última edición por Dudu678; 02-sep-2004 a las 23:56

  2. #2
    benysar Invitado
    Si pincho en la pagina que has puesto, me sale uan de un ftp, asi que no se que paquetes te has baado.
    Principalmente los errores van encaminados a que te falta el apt y el apt-libs (que son el alma de sinaptyc)

  3. #3
    Dudu678 Invitado
    Los he bajado todos. Se suponía que tendría q hacer eso :S pero me da que no.

  4. #4
    Dudu678 Invitado
    Añado información extra:

    Ese error que comenté que da el yast, al darle a más información dice:

    ERROR(InstTarget:E_RpmDB_subprocess_failed)
    rpm output:
    /var/tmp/rpm-tmp.53160: line 1: scrollkeeper-update: command not found
    error: %post(synaptic-0.53-0.suse091.rb.1) scriptlet failed, exit status 127
    2004-09-03 00:05:32 xmlto-0.0.18-rb.suse091.1.i586.rpm installed ok
    2004-09-03 00:05:39 synaptic-0.53-0.suse091.rb.1.i586.rpm install failed

    Hay más cosas, pero no las puedo ver. Como dije, se queda pillado.

  5. #5
    benysar Invitado
    otia, no, nod debes instalarlos todos.
    baja e instala estos cuatro.
    ftp://ftp.gwdg.de/pub/linux/suse/apt....rb.5.i586.rpm
    ftp://ftp.gwdg.de/pub/linux/suse/apt....rb.5.i586.rpm
    ftp://ftp.gwdg.de/pub/linux/suse/apt....rb.5.i586.rpm
    ftp://ftp.gwdg.de/pub/linux/suse/apt....rb.1.i586.rpm

    seguramente te faltará alguno mas, pero se va viendo cuando lo intentes instalar

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •