Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Página 1 de 2 12 ÚltimoÚltimo
Mostrando resultados del 1 al 10 de 13

Tema: Firefox y Thunder Bird

  1. #1
    JuanJ Invitado

    Question Firefox y Thunder Bird

    Tengo un problema con estos dos programas, cada vez que actualizo algo via Synaptic estos dos programas dejan de trabajar y tengo que instalarlos de nuevo,.
    ¿Hay alguna solucion?

  2. #2
    Fecha de Ingreso
    27-julio-2004
    Ubicación
    En un lugar de la mancha ...
    Mensajes
    2.348
    Post Thanks / Like
    Poder de Credibilidad
    18
    Cita Iniciado por JuanJ
    cada vez que actualizo algo via Synaptic estos dos programas dejan de trabajar y tengo que instalarlos de nuevo,.
    Y qué problema te dan exactamente?? Supongo que será al actualizar alguna librería aunque no se ... yo actualizo todo por apt-get, que al final es lo mismo que synaptic, y también uso esos 2 programas y nunca me han dado fallo ...
    La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
    "No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"

  3. #3
    JuanJ Invitado

    Unhappy

    Pues que quiero arrancar el firefox o el el thunderbird y no hay manera, se queda el icono del puntero dando botes durante un tiempo y luego no pasa nada.
    Tratando de ejecutar el firefox desde la consola y como usuario me sale este mensaje:
    ./firefox-installer-bin: error while loading shared libraries: /opt/gnome/lib/libgtk-x11-2.0.so.0: undefined symbol: g_type_class_add_private

    Y desde la consola como root:
    Xlib: connection to ":0.0" refused by server
    Xlib: No protocol specified


    (firefox-bin:5129): Gtk-WARNING **: cannot open display:

  4. #4
    Fecha de Ingreso
    27-julio-2004
    Ubicación
    En un lugar de la mancha ...
    Mensajes
    2.348
    Post Thanks / Like
    Poder de Credibilidad
    18
    Cita Iniciado por JuanJ
    Y desde la consola como root:
    Xlib: connection to ":0.0" refused by server
    Xlib: No protocol specified

    (firefox-bin:5129): Gtk-WARNING **: cannot open display:
    Ese problema es un tema de permisos, ya ha salido varias veces por el foro. La explicación sería que tú te conectas al servidor gráfico como usuario, entonces el resto de usuarios no tienen permiso para poder conectarse ...

    La manera de arreglarlo es: como usuario ejecutas xhost +, de esa forma das permiso o quitas la restricción, luego ya como root podrías ejecutar el comando. Prueba a ver si te da el mismo fallo que como usuario, o a ver qué pasa ...

    Imagino que habrás actualizado algún paquete relacionado con las librerías gráficas, y por eso te da el fallo al arrancar, aunque ya digo que a mí no me ha pasado hasta el momento que recuerde

    El firefox lo tienes instalado como rpm o como fichero tar?? Es posible que eso también tenga que ver, porque yo lo tengo como rpm aunque el thunderbird sí que lo tengo como tar y en ese no he tenido problemas nunca, así que no se, con el thunderbird es el mismo error el que te aparece??
    La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
    "No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"

  5. #5
    JuanJ Invitado

    Red face

    Cita Iniciado por chuzo
    La manera de arreglarlo es: como usuario ejecutas xhost +, de esa forma das permiso o quitas la restricción, luego ya como root podrías ejecutar el comando. Prueba a ver si te da el mismo fallo que como usuario, o a ver qué pasa ...
    Disculpa mi ignorancia, pero ¿donde y como tengo que ejecutar xhost +?


    El firefox lo tienes instalado como rpm o como fichero tar?? Es posible que eso también tenga que ver, porque yo lo tengo como rpm aunque el thunderbird sí que lo tengo como tar y en ese no he tenido problemas nunca, así que no se, con el thunderbird es el mismo error el que te aparece??
    Pues la verdad, creo que he instalado con el Yast y luego con un tar en el directorio home. Pero dando vueltas por ahi veo que hay el archivo firefox en varias carpetas, en /home/.... es una,
    en /opt/MozillaFirefox/firefox

    Y con el thunderbird el error que da es este:
    /home/manu/Programas/thunderbird/thunderbird-bin: error while loading shared libraries: /opt/gnome/lib/libpangoft2-1.0.so.0: undefined symbol: g_type_class_add_private

  6. #6
    Fecha de Ingreso
    27-julio-2004
    Ubicación
    En un lugar de la mancha ...
    Mensajes
    2.348
    Post Thanks / Like
    Poder de Credibilidad
    18
    Cita Iniciado por JuanJ
    Disculpa mi ignorancia, pero ¿donde y como tengo que ejecutar xhost +?
    xhost es un comando, y + sería el parámetro que se le pasa en este caso, así que sólo tienes que ponerlo en la consola, como usuario normal:

    carlos@carlos:~> xhost +
    access control disabled, clients can connect from any host


    Luego ya puedes usar su para pasar a ser root y probar a ejecutar firefox de nuevo


    Cita Iniciado por JuanJ
    Pues la verdad, creo que he instalado con el Yast y luego con un tar en el directorio home. Pero dando vueltas por ahi veo que hay el archivo firefox en varias carpetas, en /home/.... es una,
    en /opt/MozillaFirefox/firefox
    Pues entonces parece que tienes 2 versiones diferentes del programa ... lo que no se si ambas serán la misma versión Prueba a ejecutar también la que tienes en /opt a ver si esa te funciona, esa debe ser la que instalaste por Yast, porque la versión en rpm se instala allí. Lo mejor es tener sólo una versión de las 2 ... los problemas te pueden venir también por ahí, al poder producirse conflictos entre las diferentes librerías ..

    Para lo del thunderbird asegúrate de tener instalado el paquete pango. Yo tengo exactamente la siguiente versión:

    carlos@carlos:~> rpm -q pango
    pango-1.4.1-0.gbv.1


    y tengo el Thunderbird 0.7.3
    La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
    "No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"

  7. #7
    JuanJ Invitado
    Si tengo el pango y con esa misma version.
    He hecho eso que me has dicho y nada todo sigue igual.

  8. #8
    Fecha de Ingreso
    27-julio-2004
    Ubicación
    En un lugar de la mancha ...
    Mensajes
    2.348
    Post Thanks / Like
    Poder de Credibilidad
    18
    Cita Iniciado por JuanJ
    He hecho eso que me has dicho y nada todo sigue igual.
    Pero al ejecutar el xhost + el error al ejecutar firefox como root debe ser otro no??

    Al reinstalar los programas (bien firefox o thunderbird) ya funcionan bien sin hacer nada más?? No se ... es bastante raro
    La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
    "No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"

  9. #9
    JuanJ Invitado
    Cita Iniciado por chuzo
    Pero al ejecutar el xhost + el error al ejecutar firefox como root debe ser otro no??
    Pues si, el error es el mismo.

    Al reinstalar los programas (bien firefox o thunderbird) ya funcionan bien sin hacer nada más?? No se ... es bastante raro
    No he reinstalado de momento, porque tengo los marcadores en firefox que no quisiera perder, y en Thunderbird me fastidiaría bastante tener que configurar de nuevo todas las cuentas y perder algunos mensajes que tengo.

  10. #10
    Fecha de Ingreso
    27-julio-2004
    Ubicación
    En un lugar de la mancha ...
    Mensajes
    2.348
    Post Thanks / Like
    Poder de Credibilidad
    18
    Cita Iniciado por JuanJ
    No he reinstalado de momento, porque tengo los marcadores en firefox que no quisiera perder, y en Thunderbird me fastidiaría bastante tener que configurar de nuevo todas las cuentas y perder algunos mensajes que tengo.
    Eso guardando lo que son las carpetas de tu perfil no habría problema luego en recuperarlos de nuevo Toda la información se guarda en tu carpeta home: /home/usuario/.thunderbird y /home/usuario/.mozilla/firefox (ten en cuenta que las dos carpetas comienzan por . por lo que son ocultas)

    El programa lo puedes reinstalar sin peligro de perder nada (siempre puedes hacer una copia de la carpeta de perfil por si acaso), porque a esas carpetas no les afecta, pero no tengo muy claro que haciendo eso ya se solucione ... por lo que pusiste en tu primer post había entendido que si lo volvias a instalar ya funcionaban bien

    Pero te siguen saliendo los mensajes de:

    Xlib: connection to ":0.0" refused by server
    Xlib: No protocol specified

    (firefox-bin:5129): Gtk-WARNING **: cannot open display:


    Si salen esos es que no lo has hecho bien, tendrías que hacer lo siguiente:

    • Como usuario ejecutar xhost + (te debería salir el mensaje que puse antes en mi post)
    • Pasar a ser root: su y pones la password normalmente
    • Ya como root ejecutar firefox


    Sigues esos pasos exactamente??
    La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
    "No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •