Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Mostrando resultados del 1 al 5 de 5

Tema: Problemas al actualizar...

  1. #1
    Fecha de Ingreso
    04-julio-2005
    Mensajes
    3
    Post Thanks / Like
    Poder de Credibilidad
    0

    problemas al actualizar...

    Buenas a todo el mundo

    Me gusta linux, y esta distribución me parece la caña. Bueno, a lo importante: Tengo SuSE 9.2.
    Como me mola mucho, he instalado el apt para actualizar los paquetes de forma más facil y rápida que con YOU.

    Y me iba bien actualizar el Sistema. Tanto por una herramienta o por otra.
    Hace un par de semanas instalé oracle 9.2
    El problema me vino cuando quise actualizar el sistema inmediatamente despues.

    Mediante apt, me dá error al actualizar mediante apt-get upgrade.
    Mediante YOU, como borré los ficheros del directorio /var/lib/YaST2/YOU/mnt (creo que es ese, ya que es el de por defecto) para recuperar espacio, me baja los ficheros, aplica el delta, pero cuando va a instalar los RPMS actualizados, me da error y no actualiza.

    Pregunta: Sabéis alguno de vosotros si hay algún problema con los últimos RPMS? Es muy raro que de pronto deje de actualizar bien.


    Bueno un saludo a todos.

  2. #2
    Fecha de Ingreso
    27-julio-2004
    Ubicación
    En un lugar de la mancha ...
    Mensajes
    2.348
    Post Thanks / Like
    Poder de Credibilidad
    19
    Cita Iniciado por novato
    pero cuando va a instalar los RPMS actualizados, me da error y no actualiza.
    Y cuál es el error que da exactamente??
    La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
    "No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"

  3. #3
    Fecha de Ingreso
    04-julio-2005
    Mensajes
    3
    Post Thanks / Like
    Poder de Credibilidad
    0

    Problemas al actualizar....

    Perdona por la tardanza....
    No he podido entrar en el foro hasta hoy.

    El error te lo pongo con solo un archivo a actualizar. Es como si la bbdd de paquetes se fuera al carajo.
    Los RPMS me los baja tanto en apt, como a través de YOU, pero al instalar cualquier paquete a través de ellos, me sale este error.

    Mira te mando el log del error:

    Gracias por vuestra ayuda...

    -------------------------------------------------------
    maestro:~ # apt-get install telnet
    Reading Package Lists... Done
    Building Dependency Tree... Done
    The following packages will be upgraded
    telnet
    1 upgraded, 0 newly installed, 0 removed and 28 not upgraded.
    Need to get 56.2kB of archives.
    After unpacking 53B of additional disk space will be used.
    Get:1 ftp://ftp.gwdg.de SuSE/9.2-i386/update telnet 1.1-41.4 [56.2kB]
    Fetched 56.2kB in 18s (2966B/s)
    Checking GPG signatures...
    Committing changes...
    Preparing... ########################################### [100%]
    1:telnet ########################################### [100%]
    rpmdb: PANIC: Invalid argument
    rpmdb: fatal region error detected; run recovery
    rpmdb: fatal region error detected; run recovery
    rpmdb: fatal region error detected; run recovery
    rpmdb: fatal region error detected; run recovery
    rpmdb: fatal region error detected; run recovery
    error: db4 error(-30982) from dbcursor->c_put: DB_RUNRECOVERY: Fatal error, run
    database recovery
    rpmdb: fatal region error detected; run recovery
    error: db4 error(-30982) from db->sync: DB_RUNRECOVERY: Fatal error, run databas
    e recovery

    --------------------------------------

  4. #4
    Fecha de Ingreso
    27-julio-2004
    Ubicación
    En un lugar de la mancha ...
    Mensajes
    2.348
    Post Thanks / Like
    Poder de Credibilidad
    19
    Parece que tienes algunos problemas con la base de datos de los paquetes

    Puedes probar a regenerar la base de datos:

    rpm --rebuilddb
    La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
    "No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"

  5. #5
    Fecha de Ingreso
    04-julio-2005
    Mensajes
    3
    Post Thanks / Like
    Poder de Credibilidad
    0

    Thumbs up Problemas al actualizar....

    Muchas gracias

    Eres un hacha, tío.
    Parece que ya actualiza bien el SO. Lo apunto.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. Pequeños problemas tras actualizar KDE 3.4
    By Clufis in forum Escritorios: KDE, Gnome, otros...
    Respuestas: 3
    Último mensaje: 05-abr-2005, 17:35
  2. Problemas con el teclado al actualizar KDE
    By rpadin in forum Escritorios: KDE, Gnome, otros...
    Respuestas: 6
    Último mensaje: 30-mar-2005, 19:13
  3. Respuestas: 2
    Último mensaje: 05-feb-2005, 22:43
  4. Respuestas: 0
    Último mensaje: 13-ene-2005, 20:26
  5. MPlayer ?? Problemas .. ..
    By schwartz in forum Software
    Respuestas: 25
    Último mensaje: 20-nov-2004, 21:19

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •