Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Mostrando resultados del 1 al 6 de 6

Tema: Problemilla con Apt

  1. #1
    Fecha de Ingreso
    05-agosto-2004
    Ubicación
    Alacant
    Mensajes
    1.455
    Post Thanks / Like
    Poder de Credibilidad
    18

    Problemilla con Apt

    ¡Buenas!

    A ver si me echáis una mano. He puesto a actualizar el OpenOffice mediante Apt. La cuestión es que a mitad de descarga he tenido que pararlo de golpe.

    Cuando ahora vuelvo a intentar descargarlo me dice lo siguiente el apt:

    linux:/home/mdk # apt-get install OpenOffice_org
    Leyendo listas de paquetes... Done
    Construyendo árbol de dependencias... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.

    Since you only requested a single operation it is extremely likely that
    the package is simply not installable and a bug report against
    that package should be filed.
    La siguiente información puede ayudar a resolver la situación:

    The following packages have unmet dependencies:
    OpenOffice_org: PreDepends: coreutils but it is not installable
    PreDepends: /usr/bin/update-mime-database but it is not installable
    Depends: myspell-american but it is not installable
    Depends: myspell-british but it is not installable
    PreDepends: /bin/sh but it is not installable
    PreDepends: /bin/sh but it is not installable
    PreDepends: /bin/sh but it is not installable
    Depends: /bin/sh but it is not installable
    Depends: /bin/awk but it is not installable
    Depends: /bin/bash but it is not installable
    Depends: /bin/sh but it is not installable
    Depends: /usr/bin/perl but it is not installable
    Depends: libICE.so.6
    Depends: libSM.so.6
    Depends: libX11.so.6
    Depends: libXaw.so.8
    Depends: libXext.so.6
    Depends: libXt.so.6
    Depends: libatk-1.0.so.0 but it is not installable
    Depends: libbonobo-2.so.0 but it is not installable
    Depends: libc.so.6
    Depends: libc.so.6(GLIBC_2.0)
    Depends: libc.so.6(GLIBC_2.1)
    Depends: libc.so.6(GLIBC_2.1.2)
    Depends: libc.so.6(GLIBC_2.1.3)
    Depends: libc.so.6(GLIBC_2.2)
    Depends: libc.so.6(GLIBC_2.3)
    Depends: libc.so.6(GLIBC_2.3.2)
    Depends: libcurl.so.3 but it is not installable
    Depends: libdl.so.2
    Depends: libdl.so.2(GLIBC_2.0)
    Depends: libdl.so.2(GLIBC_2.1)
    Depends: libexpat.so.0 but it is not installable
    Depends: libfreetype.so.6 but it is not installable
    Depends: libgcc_s.so.1
    Depends: libgcc_s.so.1(GCC_3.0)
    Depends: libgcc_s.so.1(GCC_3.3)
    Depends: libgcc_s.so.1(GLIBC_2.0)
    Depends: libgdk-x11-2.0.so.0 but it is not installable
    Depends: libgdk_pixbuf-2.0.so.0 but it is not installable
    Depends: libglib-2.0.so.0
    Depends: libgmodule-2.0.so.0
    Depends: libgnomevfs-2.so.0
    Depends: libgobject-2.0.so.0
    Depends: libgtk-x11-2.0.so.0 but it is not installable
    Depends: libjawt.so
    Depends: libjpeg.so.62 but it is not installable
    Depends: libldap-2.2.so.7
    Depends: libm.so.6
    Depends: libm.so.6(GLIBC_2.0)
    Depends: libneon.so.24 but it is not installable
    Depends: libnspr4.so
    Depends: libnss3.so
    Depends: libnss3.so(NSS_3.2)
    Depends: libnss3.so(NSS_3.3)
    Depends: libnss3.so(NSS_3.4)
    Depends: libnss3.so(NSS_3.6)
    Depends: libnss3.so(NSS_3.7)
    Depends: libnss3.so(NSS_3.9)
    Depends: libnss3.so(NSS_3.9.3)
    Depends: libpango-1.0.so.0 but it is not installable
    Depends: libpangox-1.0.so.0 but it is not installable
    Depends: libpangoxft-1.0.so.0 but it is not installable
    Depends: libplc4.so
    Depends: libplds4.so
    Depends: libpthread.so.0
    Depends: libpthread.so.0(GLIBC_2.0)
    Depends: libpthread.so.0(GLIBC_2.1)
    Depends: libpthread.so.0(GLIBC_2.2)
    Depends: libpthread.so.0(GLIBC_2.3.2)
    Depends: libpython2.4.so.1.0 but it is not installable
    Depends: libsmime3.so
    Depends: libsmime3.so(NSS_3.2)
    Depends: libsmime3.so(NSS_3.4)
    Depends: libsoftokn3.so
    Depends: libssl3.so
    Depends: libstartup-notification-1.so.0 but it is not installable
    Depends: libstdc++.so.5 but it is not installable
    Depends: libstdc++.so.5(CXXABI_1.2) but it is not installable
    Depends: libstdc++.so.5(GLIBCPP_3.2) but it is not installable
    Depends: libxml2.so.2
    Depends: libz.so.1 but it is not installable
    E: Broken packages
    He hecho un rpm --rebuildb, un apt-get -f install... y ná de ná. Intento instalar otras cosas y me sale más de lo mismo.

    ¿Qué he hecho?
    Software is like sex: it's better when it's free.

    SomGNU | Desarmats

  2. #2
    Fecha de Ingreso
    01-diciembre-2004
    Mensajes
    669
    Post Thanks / Like
    Poder de Credibilidad
    16
    si usas la opcion -reinstall? te deja?

  3. #3
    Fecha de Ingreso
    05-agosto-2004
    Ubicación
    Alacant
    Mensajes
    1.455
    Post Thanks / Like
    Poder de Credibilidad
    18
    ¿rpm -reinstall?
    ¿apt-get reinstall o -reinstall?

    Ninguno de los dos arreglan el problema
    Software is like sex: it's better when it's free.

    SomGNU | Desarmats

  4. #4
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.649
    Post Thanks / Like
    Poder de Credibilidad
    10
    apt-get --reinstall install OpenOffice_org

    fuente: man apt-get.

    --reinstall
    Re-Install packages that are already installed and at the newest
    version. Configuration Item: APT::Get::ReInstall.
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  5. #5
    Fecha de Ingreso
    05-agosto-2004
    Ubicación
    Alacant
    Mensajes
    1.455
    Post Thanks / Like
    Poder de Credibilidad
    18
    Pues me sigue saliendo lo mismo...

    He actualizado de nuevo las fuentes y tampoco ha servido de mucho.

    A ver si con un upgrade...

    En fins...

    Edito: he probado con upgrade y... me dice que no hay nada que actualizar. Es curioso, porque nunca he hecho un upgrade (por eso de no querer joder el sistema), y eso que el sources.list lo tengo bien cargadito.

    Qué cosa más rara.

    Tomo nota de que no debo dejar al APT a medias, que me lo estará recordando durante días.
    Última edición por Mdk; 25-jun-2005 a las 10:19
    Software is like sex: it's better when it's free.

    SomGNU | Desarmats

  6. #6
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.649
    Post Thanks / Like
    Poder de Credibilidad
    10
    Si lees lo de negrita, hay que tocar un fichero de configuracion y ponerle lo que viene, he estado mirando y no me preguntes cual es el fichero que hay que tocar.
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. Error al compilar el pure-ftpd-1.0.12
    By criosg in forum Internet, Redes y Wireless
    Respuestas: 7
    Último mensaje: 28-mar-2008, 17:29
  2. Problemilla con la consola
    By Masta90 in forum Software
    Respuestas: 2
    Último mensaje: 07-jun-2005, 21:18
  3. problemilla con sonido de la tv
    By lork in forum Hardware
    Respuestas: 0
    Último mensaje: 24-abr-2005, 04:44
  4. Problemilla KDE
    By avalanch in forum Escritorios: KDE, Gnome, otros...
    Respuestas: 1
    Último mensaje: 30-nov-2004, 21:57

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •