Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Página 1 de 2 12 ÚltimoÚltimo
Mostrando resultados del 1 al 10 de 16

Tema: Dudas y problemas, nuevo en SuSe

  1. #1
    Hayabusa Invitado

    Dudas y problemas, nuevo en SuSe

    Hola.

    Bueno, ya he instalado SuSe y llevo desde ayer por la noche echándole un ojo y probando cosas y eso. Hoy me he decidido a instalar un programa, amule, del cual he oído hablar muy bien.
    He bajado el programa de la web oficial, este enlace concretamente: http://www.amule.org/files/details.php?file=124
    Bueno, como no tengo NI IDEA DE LINUX, he buscado en este foro y en internet y he visto que los archivos .rpm no vienen comprimidos, y no necesitan más que ser instalados... quizá me he quivocado en esto (muy seguramente). Primero he probado a instalarlo con YaST, donde me ha salido el siguiente error:

    No se que tengo que hacer allí o si es grave, asi qué directamente he cancelado la instalación y no he hecho nada. Echadme una mano con eso del Open Office y del aMule, plz.
    He intentando instalaro a través de la Consola de comandos. Como no tenía ni idea he buscado en el foro y he visto cómo debía hacerlo: rpm -Uhv nombredelfichero.rpm En mi caso seria: rpm -Uhv aMule-2.0.3-1.i586-SuSE_9.3.rpm Tras escribir este comando y darle al Intro me ha dado error, diciendo esto: libgd.so.2 is needed by aMule-2.0.3-1
    libwx_base-2.6.so.0 is needed by aMule-2.0.3-1
    libwx_base-2.6.so.0(WX_2.6) is needed by aMule-2.0.3-1
    libwx_base_net-2.6.so.0 is needed by aMule-2.0.3-1
    libwx_base_net-2.6.so.0(WX_2.6) is needed by aMule-2.0.3-1
    libwx_base_xml-2.6.so.0 is needed by aMule-2.0.3-1
    libwx_gtk_adv-2.6.so.0 is needed by aMule-2.0.3-1
    libwx_gtk_adv-2.6.so.0(WX_2.6) is needed by aMule-2.0.3-1
    libwx_gtk_core-2.6.so.0 is needed by aMule-2.0.3-1
    libwx_gtk_core-2.6.so.0(WX_2.6) is needed by aMule-2.0.3-1
    libwx_gtk_html-2.6.so.0 is needed by aMule-2.0.3-1
    libwx_gtk_qa-2.6.so.0 is needed by aMule-2.0.3-1
    libwx_gtk_xrc-2.6.so.0 is needed by aMule-2.0.3-1

    He probado ponerme como administrador con sudo bash (aunque ya lo era, soy el único usuario del equipo) y me dice exactamente lo mismo.
    Tras probar a abrir YaST directamente, sin instalar nada, solo abrirlo, me ha salido de nuevo automáticamnete lo del Open Office, el mismo mensaje que en el Amule pero solo del Oppen Office. Por cierto, el Open Office me va perfecto, lo he probado y todo OK.
    ¿Me podéis decir que falla y ayudarme a instalarlo?

    Me ha bajado unos Codecs de Windows que he encontrado buscando por el foro, tambien en .rpm, he intentado instalarlos con YaST y me dice lo mismo que con aMule, no sé de que del Open Office

    -A parte de esto, tengo algunas dudas sobre los reproductores de videos y audio que lleva mi SuSe por defecto.
    Me explico; tengo Kaffeine, Real Player 10, Jukebox, y amaroK 1.2
    De todos ellos el unico que me reproduce archivos de audio (en mp3) es Real Player 10. Los demás me permiten poner listas de reproducción pero no empiezan a reproducir al canción.
    ¿Porqué?
    Al intentar reproducir videos, he probado con un avi y con wmv. El avi no me ha ido, y el wmv, como era de esperar, tampoco. Se ha abierto solo con kaffeine al clikar sobre el. Con el avi me dice Se ha producido un error mientras se cargaba una biblioteca o un decodificador: wmvdmod.dll. Con el wmv No se ha encontrado ningún complemento para manejar este recurso seguido de la ubicacion y nombre del archivo.


    Estoy perdidisimo con el tema de los programas en Linux... crei que con YaST seria sencillo (no me gusta nada usar la consola...), asi que me gustaría usarlo siempre que sea posible y no sé porque me da ese error, me da miedo ignorarlo o decirle que haga algo

    EDITADO Casi me olvido, mi SuSe es el 9.3 Professional y mi PC, aunque no se si es importante decirlo, un AMD Athlon XP 1666 Mhz, 384 Mb RAM y el disco duro un Maxtor ATA de 40 Gb. Si necesitáis más datos para ayudarme pedidmelos
    Última edición por Hayabusa; 21-jun-2005 a las 13:23

  2. #2
    Fecha de Ingreso
    05-agosto-2004
    Ubicación
    Alacant
    Mensajes
    1.455
    Post Thanks / Like
    Poder de Credibilidad
    18
    Pues el amule te falla al intentar instalarlo porque te faltan algunas librerías (que también te las podías descargar de la web oficial). Primero debes instalar las librerías y luego instalar el amule.

    Te recomiendo que configures el programa APT. Te permitirá bajarte e instalar programas y todas sus dependencias con un simple comando.

    Te dejo una guía de cómo configurarlo.

    Una vez lo tengas instalado, instalar el amule será tan fácil como escribir en consola y como root:

    # apt-get install amule
    Un saludo
    Software is like sex: it's better when it's free.

    SomGNU | Desarmats

  3. #3
    Hayabusa Invitado
    Que rapidez! Gracias, Mdk Ahora mismo me bajo lo que dices. Pero lo del Open Office porque es? Que hago con eso? Lo dejo pasar? Le digo que le ignore o que? Me da un poco de miedo tocar algo mal y joderla.

    Otra cosa respecto a mi mensaje anterior, ahora AMAROK SI QUE ME VA Asi que en lo del audio no hace falta que me ayudéis, pero si en lo del video, por favor

    EDITADO Uh... De la web que me has pasado, Mdk, he pinchado en el enlace apt para SuSe 9.3 y me lleva a este ftp: ftp://ftp.gwdg.de/pub/linux/suse/apt...MS.suser-rbos/ Cual de todos ellos es el que debo descargar?
    Última edición por Hayabusa; 21-jun-2005 a las 13:54

  4. #4
    Fecha de Ingreso
    05-agosto-2004
    Ubicación
    Alacant
    Mensajes
    1.455
    Post Thanks / Like
    Poder de Credibilidad
    18
    Te tienes que descargar casi todos los archivos.

    La cosa funciona de la siguiente forma (como explica la guía):

    Debes instalar el apt y el apt4rpm. Por lo que esos son los primeros que te deberías bajar, pero al instalarlos verás que te pide dependencias (que si tal librería, que si cual programa), entonces miras cuál es el que te falta y te lo bajas de ese ftp. Por ejemplo, seguro que te pide el per-xml-sax, pues te lo bajas y lo instalas.

    Una vez que lo tengas instalado todo ya no te tendrás que preocupar de esas cosas de las dependencias.

    No te preocupes por lo del openoffice, son dependencias que ahora no importan. Cuando instales el amule las dependencias las resolverá solo y no te tendrás que preocupar.
    Software is like sex: it's better when it's free.

    SomGNU | Desarmats

  5. #5
    Hayabusa Invitado
    Hola de nuevo.

    He hecho todo lo que pone en la guia que me has pasado; bajar TODOS los archivos del ftp, instalar el Apt4rpm y el apt-0.5. Durante la instalación también me ha salido eso de inconcluencias relacionadas con el Open Office, así que le he dado a ignorarlas... no sé si he hecho esto bien. Siguiendo tu guía he intentado cambiar el archivo sources.list de # /etc/apt/, pero me dice El documento no se pudo guardar, porque no fue posible escribir en file:///etc/apt/sources.list
    Compruebe que tiene permiso de acceso a este archivo o si hay suficiente espacio disponible en el disco.
    y no me deja
    Lo mismo cuando trato de editar el fichero gpg-checker.conf en /etc/apt/apt.conf.d
    Yo estoy como Adknistrador o superusuario, creo... soy el único usuario del equipo, configuré yo mismo la cuenta de superusario, escribi el password y lo tengo y me lo acepta el YaST u otras aplicaciones... ¿Que tengo que hacer entonces?

    Cuando lo intento hacer desde la terminal (a duras penas se moverme por ella...) me dice apt-get update
    apt-get: error while loading shared libraries: libapt-pkg-libc6.3-5.so.2: cannot open shared object file: No such file or directory


    Que dificil es esto o que inutil soy yo en Linux coñe xD

    EDITADO No se si sirve de algo... pero esto me sale en el YaST tras hacerlo todo:
    Cuando le doy a "Comprobar dependencias" me dice que todas son correctas.
    Le da a lo que le de, vuelvo a YaST y siguien ahí, no me explico porqué.
    Última edición por Hayabusa; 21-jun-2005 a las 17:19

  6. #6
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.649
    Post Thanks / Like
    Poder de Credibilidad
    10
    Hombre Hayabusa, tu por aqui, pense que estabas disfrutando de Suse 9.3, pero veo que tienes problemas.

    Primero decirte que tiene razon Mdk, si instalas apt-get y synaptic (el entorno grafico de apt) la instalacion de programas para Suse es un juego de niños, pero primero tienes que instalar apt y veo que te falta una libreria de apt llamada "apt-libs" para que te funcione apt-get, ojo procura instalar la misma version de apt instalado, por eso tienes los mensajes de error: falta libapt-pkg-libc6.3-5.so.2.

    Dices que eres el unico usuario del equipo, como yo, y te has configurado como Administrador. Aqui siento decirte que en Suse y por extension en Linux, solo hay un superusuario el "root", espero que te acuerdas la contraseña, y para editar esos ficheros que hablas tienes que ser el superusuario "root".
    Hay dos maneras:
    1. Abre el panel de programas->Sistema->Administrador de archivos->Administrador de archivos - modo superusuario.
    2. Abre una consola o Konsole, teclea "kdesu kate" y editas el fichero.
    Última edición por DiabloRojo; 21-jun-2005 a las 17:57
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  7. #7
    Hayabusa Invitado
    Nada... ni como superusuario ni de ninguna manera.
    De todas formas ya instalé aMule por otro medio (bajando otro rpm).
    Aunque me gustaría terminar lo de synaptic porque lo he visto alguna vez que otra y es muy interesante, así qué dónde puedo descargarme la librería qué me falta; libapt-pkg-libc6.3-5.so.2 ?

  8. #8
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.649
    Post Thanks / Like
    Poder de Credibilidad
    10
    Cita Iniciado por Hayabusa
    Nada... ni como superusuario ni de ninguna manera.
    No me digas, la verdad es que alucino, no lo habras borrado el superusuario root y has creado uno con los privilegios del administrador. En la primera imagen, veo que tienes espacio de sobra en /, haz una prueba, abre una consola, teclea "whoami", postea lo que aparece, teclea "su" y mete la contraseña de root y vuelve a teclear "whoami" y posteas lo que aparece.
    Aunque me gustaría terminar lo de synaptic porque lo he visto alguna vez que otra y es muy interesante, así qué dónde puedo descargarme la librería qué me falta; libapt-pkg-libc6.3-5.so.2 ?
    Pero bueno , de mismo sitio que te has bajado los rpms apt y apt4rpm. Si no lo sabes tu de donde te los has bajado como voy a saberlo yo, recuerda es el fichero apt-libs..version.rpm siendo version la misma que apt.version.rpm.
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  9. #9
    Hayabusa Invitado
    No me digas, la verdad es que alucino, no lo habras borrado el superusuario root y has creado uno con los privilegios del administrador. En la primera imagen, veo que tienes espacio de sobra en /, haz una prueba, abre una consola, teclea "whoami", postea lo que aparece, teclea "su" y mete la contraseña de root y vuelve a teclear "whoami" y posteas lo que aparece.
    Claro Si no te importa he tapado mi nombre de usuario, pero vamos que va ahí y que sí, todo bien, primero como usuario y luego como superusuario, y sigue sin dejarme:



    Cita:
    Aunque me gustaría terminar lo de synaptic porque lo he visto alguna vez que otra y es muy interesante, así qué dónde puedo descargarme la librería qué me falta; libapt-pkg-libc6.3-5.so.2 ?
    Pero bueno , de mismo sitio que te has bajado los rpms apt y apt4rpm. Si no lo sabes tu de donde te los has bajado como voy a saberlo yo, recuerda es el fichero apt-libs..version.rpm siendo version la misma que apt.version.rpm.
    Ya, pero eso que son del ftp de la web que me ha puesto Mdk: http://www.spalinux.net/modules.php?...showpage&pid=7
    El FTP es este: ftp://ftp.gwdg.de/pub/linux/suse/apt...MS.suser-rbos/
    Y en este no esta el archivo que me falta

    EDITADO: Ya he podido modificarlos! Era culpa mia, que intentaba editar desde una nueva ventana de Konqueror y no desde la abierta con el modo superusuario. Mis disculpas.
    Voy a probar lo que me has puesto, Marcel, y ahora pongo que tal me ha ido
    Última edición por Hayabusa; 21-jun-2005 a las 21:28

  10. #10
    Fecha de Ingreso
    08-junio-2005
    Mensajes
    86
    Post Thanks / Like
    Poder de Credibilidad
    16
    Cita Iniciado por Hayabusa
    Ya, pero eso que son del ftp de la web que me ha puesto Mdk: http://www.spalinux.net/modules.php?...showpage&pid=7
    El FTP es este: ftp://ftp.gwdg.de/pub/linux/suse/apt...MS.suser-rbos/
    Y en este no esta el archivo que me falta
    Me parece que es este:

    ftp://ftp.gwdg.de/pub/linux/suse/apt...3.rb0.i586.rpm

    Aprobecha de instalar synaptic:
    ftp://ftp.gwdg.de/pub/linux/suse/apt...3.rb0.i586.rpm
    Saludos
    Marcel - M3
    Linux User #328858
    http://counter.li.org/

    "El amor a la libertad es amor a los demás; el amor al poder es amor a nosotros mismos." -- William Hazlitt

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. Problemas Instalar APT Suse 9.2
    By Visions in forum Software
    Respuestas: 11
    Último mensaje: 08-may-2005, 16:14
  2. Nuevo con linux, nuevo con SuSe II
    By Essex in forum Hardware
    Respuestas: 38
    Último mensaje: 16-abr-2005, 18:14
  3. Nuevo en Linux.. problemas con todo T.T
    By Zerg in forum Hardware
    Respuestas: 13
    Último mensaje: 15-abr-2005, 13:09
  4. Nuevo con linux, nuevo con SuSe
    By Essex in forum General OpenSUSE
    Respuestas: 13
    Último mensaje: 09-abr-2005, 20:06
  5. Aviso de seguridad
    By Kunael in forum Internet, Redes y Wireless
    Respuestas: 1
    Último mensaje: 05-ago-2004, 22:35

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •