Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Mostrando resultados del 1 al 3 de 3

Tema: Error instalando paquetes rpm, y con paquetes instalados por rpm

  1. #1
    taromaru Invitado

    Error instalando paquetes rpm, y con paquetes instalados por rpm

    Buenas, una vez instalado todo suse me he dispuesto a instalar mis paquetes favoritos, y he notado que no me desenvuelvo igual que con otras distros con gestores de paquetes distintos. Por ejemplo, he instalado apt4rpm y he actualizado el archivo sources.list y apt.
    El problema es que el comando apt-cache search no retorna tantos resultados como esperaba. Por ejemplo no encuantra los editores ligeros nano y ee, que los prefiero a vi. Estoy convencido que algo estoy haciendo mal ya que apt4rpm es una herramienta muy potente y usada por miles de usuarios. Sera por algo
    Ahora obtengo esto al llamar a apt:

    error: cannot get exclusive lock on /var/lib/rpm/Packages
    error: cannot open Packages index using db3 - Operación no permitida (1)
    error: cannot open Packages database in /var/lib/rpm

    Otro asunto es que algunas aplicaciones instaladas por rpm no tienen bien resueltas sus dependencias, por ejemplo firefox.
    Obtengo esto al llamarlo en un terminal:

    ** (Gecko:5091): WARNING **: No builtin or dynamically loaded modules
    were found. Pango will not work correctly. This probably means
    there was an error in the creation of:
    '/etc/opt/gnome/pango/pango.modules'
    You may be able to recreate this file by running pango-querymodules.

    (Gecko:5091): GLib-GObject-CRITICAL **: file gobject.c: line 1561 (g_object_ref): assertion `G_IS_OBJECT (object)' failed

    ** (Gecko:5091): CRITICAL **: file pango-engine.c: line 68 (_pango_engine_shape_shape): assertion `PANGO_IS_FONT (font)' failed

    ** ERROR **: file shape.c: line 75 (pango_shape): assertion failed: (glyphs->num_glyphs > 0)
    aborting...

    Por ello me gustaria que comentarais como haceis vosotros para resolver las dependencias, y que puedo hacer para desbloquear apt.

    Gracias de antemano!

  2. #2
    taromaru Invitado
    De este mismo foro cai en la cuenta de como se actualizaba la base de datos de los paquetes rpm y al ejecutar rpm --rebuilddb he solucionado parte de los problemas. Ya puedo instalar rpms!

  3. #3
    Fecha de Ingreso
    27-julio-2004
    Ubicación
    En un lugar de la mancha ...
    Mensajes
    2.348
    Post Thanks / Like
    Poder de Credibilidad
    19
    Me alegro que lo solucionaras, siempre viene bien buscar por el foro antes de poner un tema, puedes encontrar directamente lo que buscas y además ahorrar tiempo
    La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
    "No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. Comprobar paquetes sin instalar
    By DiabloRojo in forum Instalación y Actualizaciones
    Respuestas: 2
    Último mensaje: 24-mar-2005, 20:53

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •