Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Página 1 de 3 123 ÚltimoÚltimo
Mostrando resultados del 1 al 10 de 28

Tema: Me estoy volviendo loco.

  1. #1
    JuanJ Invitado

    Question Me estoy volviendo loco.

    El caso es que quiero actualizar a la versión 3.3 del KDE, pero con synaptic no sé como hacerlo y tengo miedo a cargarme algo, le doy a actualizar sissteme y empieza a bajar ficheros, luego no sé como hay que seguir.
    ¿Alguien me echa una mano?
    ¿Donde guarda synaptic los ficheros?
    También he intentado hacerlo mediante el escript que riven ha puesto en otro tema http://www.rlmorgan.com/download/kde4suse.sh pero tampoco puedo hacerlo porque no sé como se ejecutan los scripts en un terminal de linea. Sé entrar en el terminal de linea, acceder a los direcctorios donde está el script, pero no sé como hay que hacer para ejecutarlo.
    Otras, ¿como hay que hacer para salir del terminal de linea sin reiniciar el sistema?
    ¿Algún sitio, publicación o algo para saber mas sobre los comandos y forma de utilizar el terminal de línea?

    Gracias

  2. #2
    Fecha de Ingreso
    27-julio-2004
    Ubicación
    En un lugar de la mancha ...
    Mensajes
    2.348
    Post Thanks / Like
    Poder de Credibilidad
    18
    Cita Iniciado por JuanJ
    ¿Donde guarda synaptic los ficheros?
    Pues apt los guarda en /var/cache/apt/archives/. Imagino que synaptic también, al no ser más que una interfaz gráfica para apt

    Para ejecutar un script sería igual que si quieres ejecutar un programa, te vas a la carpeta donde lo tienes guardado y pones:

    ./kde4suse.sh

    y debería comenzar

    En cualquier caso para actualizar KDE siempre tienes la opción de bajarte los ficheros a mano (o usar apt o synaptic sólo para lo que es descargar los ficheros) y luego instalarlos tú, bien con Yast o desde la consola normalmente

    Un saludo
    La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
    "No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"

  3. #3
    benysar Invitado
    En el caso de synaptic, Dale "refrescar" so hará que analice todos ls repositorios que le has dicho en el config. Una vez terminado, en "vista", elige: "actualizable" y te saldrán todos los paquetes que puedes actualizar. Una vez marcados, le das a "aplicar" y comenzará la descarga...una vez descargados, sin hacer nada comenzará la instaación

  4. #4
    JuanJ Invitado
    Hecho esto sigo teniendo problemas, no me actualiza nada.
    Cuando parece que está actualizando sale una ventana de aviso que no me da tiempo mas que a leer "UnKnow

  5. #5
    JuanJ Invitado
    Ahora he visto que algo mas: Unknow signature var/.....

  6. #6
    benysar Invitado
    Cita Iniciado por JuanJ
    Ahora he visto que algo mas: Unknow signature var/.....
    edita el script etc/apt/apt.conf.d/gpg-checker.conf y cambia el valor , e tal manera que te qude asi:
    // Make GPG::Check no; to disable gpg checking
    // It can still be used in combination with --checksig
    GPG::Check no;
    Scripts::PM::Pre:: gpg-checker.lua;

  7. #7
    JuanJ Invitado
    Hecho esto que me dices ahora mientras intenta realizar la instalación me sale este mensaje:

    Mientras se preparaba la instalación:

    file /usr/bin/xine-bugreport from install of xine-ui-0.99.2-0.pm.0 conflicts with file from package xine-devel-0.99.rc3a-101
    file /usr/share/man/de/man1/xine-bugreport.1.gz from install of xine-ui-0.99.2-0.pm.0 conflicts with file from package xine-devel-0.99.rc3a-101
    file /usr/share/man/man1/xine-bugreport.1.gz from install of xine-ui-0.99.2-0.pm.0 conflicts with file from package xine-devel-0.99.rc3a-101

  8. #8
    Fecha de Ingreso
    16-julio-2004
    Ubicación
    /home/riven
    Mensajes
    930
    Post Thanks / Like
    Poder de Credibilidad
    10
    Elimina los paquetes de Xine que tengas instalados.
    Nunca olvido una cara pero con la suya voy a hacer una excepción.
    Estos son mis principios. Si no le gustan tengo otros.


  9. #9
    JuanJ Invitado
    Pues creo que ya la he pidfiado.
    He ejecutado el script kde4suse.sh, he respondido que "yes" a todas las preguntas(no descargó nada), y luego he ejecutado, no me acuerdo bien como era la sintaxis pero algo así como yast2 -i *.rpm,estaba dentro del directorio /home/JuanJ, y ahi tenia unos cuantos archivos de actualización del Kde 3.3, en esto empieza a instalar, me tengo que ir y cuando vuelvo, reinicio y veo que la version de kde es la 3.3 , luego voy y arranco el synaptic y me sale un mensaje "Null", pulso en aceptar y se cierra solo, voy al instalar/desinstalar so de Yast y me sale n una barbaridad de dependencias erroneas, le doy a ignorar todo.
    Salgo de Yast, y vuelvo a reiniciarlo, compruebo de nuevo las dependencias y me dice que todas las dependencias son correctas.
    En principio todo funciona bien.
    La pregunta ahora es ¿que es lo que pasará y como se puede solucionar el problema de synaptic, ya lo he desinstalado y vuelto a instalar pero sigue igual?

  10. #10
    benysar Invitado
    Seguramente tendrás la base de datos corrupta.
    ejecuta como root "rpm --rebuilddb" a ver si se soluciona el problema

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •