Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Página 1 de 2 12 ÚltimoÚltimo
Mostrando resultados del 1 al 10 de 17

Tema: openSuse no inicia, he cambiado la tabla de particiones [SOLUCIONADO]

  1. #1
    Fecha de Ingreso
    03-agosto-2007
    Ubicación
    Sevilla (España)
    Mensajes
    461
    Post Thanks / Like
    Poder de Credibilidad
    12

    openSuse no inicia, he cambiado la tabla de particiones [SOLUCIONADO]

    Hola,

    Voy ha plantear un problema que por supuesto ya estoy buscando, y he buscado bastante, pero sinceramente, no se ni como buscarlo, incluso no sabía en qué sección ponerlo en el foro.

    Problema: He instalado el wifislax en mi ordenador (como si hubiese sido otro digo yo), primero me fui al windows y modifiqué la tabla de particiones de la siguiente forma:

    Estado Inicial:
    *particion primaria (20GB) para windows (ntfs)
    *particion extendida (100) :
    - particion (80 GB) como almacen (ntfs)
    - particion (19 GB) para opensuse (ext3)
    - particion (1GB) como swap (swap)

    Estado final:
    *particion primaria (20GB) para windows (ntfs)
    *particion extendida (100) :
    - particion (75 GB) como almacen (ntfs) (redimensionada)
    - particion (5 GB) para wifislax
    - particion (19 GB) para opensuse
    - particion (1GB) como swap

    (Todas las cifras son más o menos, tengo un disco de 120 GB)

    Tras instalar el wifislax creia que todo estaba correcto, windows corria, wifislax corria, y por ultimo openSuse, kk.

    Iniciando el opensuse el sistema se queda parando indicando un error como el que sigue:
    kernel panic ... VFS: bloq error (0,0) ...

    (Siento no poner el error correctamente, la proxima vez que inicie edito y lo pongo correcto, pero creo que se entiende de qué va)

    Yo entiendo que como antes el opensuse era /dev/sda6 y ahora ese /dev/sda6 es el wifislax (por haberlo puesto antes en la tabla de particiones) el opensuse ha pasado ha ser /dev/sda7, realmente el sistema no puede arrancar porque no sabe donde estan los ficheros (supongo que intenta iniciar wifislax, porque corresponde con las rutas que el tenia antes).

    No se como arreglar esto, tal vez sea sencillo, modificando algun ficherito en el openSuse que le haga saber que ahora tiene que buscar las cosas en /dev/sda7 pero no tengo ni idea de cual puede ser.


    Gracias por adelantado, y sino lo soluciono, que no creo que sea un caso unico pero no se si alguien lo habra solucionado sin formatear todo, jj
    En ocasiones, se pueden ajustar los tipos para permitir la operación.

  2. #2
    Fecha de Ingreso
    17-agosto-2006
    Ubicación
    At the computer
    Mensajes
    204
    Post Thanks / Like
    Poder de Credibilidad
    13
    usas grub?

    si es asi copia aca el fichero /etc/grub/menu.lst

    si no es asi yo no te podría ayudar mucho

  3. #3
    Fecha de Ingreso
    03-agosto-2007
    Ubicación
    Sevilla (España)
    Mensajes
    461
    Post Thanks / Like
    Poder de Credibilidad
    12
    Si uso grub, salvo que antes tenia el grub del openSuse y ahora tengo un grub que me ha puesto el wifislax, voy ha intentar copiar el fichero ese (del cual ya hace mencion el wifislax en su manual de instalacion) desde el wifislax al openSuse (creo que es eso lo que me dices), pero no es problema del grub, ya te digo que el grub actual sabe que tengo el openSuse, pero cuando le doy a iniciar es el unico que no inicia.
    En ocasiones, se pueden ajustar los tipos para permitir la operación.

  4. #4
    Fecha de Ingreso
    03-agosto-2007
    Ubicación
    Sevilla (España)
    Mensajes
    461
    Post Thanks / Like
    Poder de Credibilidad
    12
    Estoy buscando el archivo menu.lst pero no se encuentra en /etc/grub/menu.lst parece que se encuentra en /boot/grub/menu.lst espero no equivocarme y gracias por tu excepcional rapidez,

    ...

    No ha funcionado se sigue quedando donde antes, ahora pongo el mensaje de error completo:

    VFS: Cannot open root device "sda7" or unknown -block(0,0)
    Please append a correct "root=" boot option
    Kernel panic -not syncing: VFS: Unable to mount root fs on unknown -block(0,0)
    Última edición por jncruces; 30-ago-2007 a las 21:13
    En ocasiones, se pueden ajustar los tipos para permitir la operación.

  5. #5
    Fecha de Ingreso
    07-julio-2006
    Ubicación
    Málaga...por poco tiempo!!
    Mensajes
    2.151
    Post Thanks / Like
    Poder de Credibilidad
    15
    Prueba reparar la tabla de particiones. Hay muchas aplicaciones (Partition Magic es la única que conozco) aunque tambien tenemos Gpart y TestDi. Lo que explica en este link:

    http://blogdrake.net/node/2882

    Saludos y suerte! Estas cosas son jodidillas

    How-to VirtualBox <~ Guía sobre VirtualBox

  6. #6
    Fecha de Ingreso
    07-febrero-2007
    Ubicación
    Ourense
    Mensajes
    8.523
    Post Thanks / Like
    Poder de Credibilidad
    21
    Si tú no lo cambias, a la nueva partición se le asignará el siguiente número, es decir, openSuSE no cambia de partición (sda6) ...

    Si no te ha funcionado lo de reparar, postea el archivo de menú del grub que uses ...

    Salud!!

  7. #7
    Fecha de Ingreso
    03-agosto-2007
    Ubicación
    Sevilla (España)
    Mensajes
    461
    Post Thanks / Like
    Poder de Credibilidad
    12
    Hoy mismo en cuanto llegue a mi casa después del trabajo me pondre ha probar esos dos programitas.

    Por la tarde además también posteare el archivo menu.lst pero no es problema de ese archivo ni del grub, incluso el mismo opensuse hace 6 o 7 pasitos de incio.

    Analizando el problema llego a la conclusion de que el problema ha sido del partition magic (ha creado la nueva particion pero no ha enlazado bien la siguiente en el disco, es decir la particion sda7 existe pero tiene un comienzo confuso a mi entender), ya he probado con el mismo partition magic al analizar pero falla (el partition magic peta como programa de windows que es) y hoy probare el nuevo partition magic que me he bajado también.
    También decir que desde el wifislax puedo acceder a esa particion, es decir los datos están ahi, todo esta ahi, creo que los primeros inodes son los que estan dañados.



    Pero la vida sigue, los discos se formatean y se vuelven a formatear, he lanzado el tema por intentar resolverlo para aprender más, tanto yo como vosotros, siempre se que puedo volver ha meter el dvd del opensuse y volver ha instalar!!! Esto es un consejo para todo el mundo (la gente se asusta por estos problemas y no tienen por qué).
    Última edición por jncruces; 31-ago-2007 a las 09:28
    En ocasiones, se pueden ajustar los tipos para permitir la operación.

  8. #8
    Fecha de Ingreso
    07-julio-2006
    Ubicación
    Málaga...por poco tiempo!!
    Mensajes
    2.151
    Post Thanks / Like
    Poder de Credibilidad
    15
    De todos modos tenemos muchas alternativas amigo! Tenemos el SysRescue para salvar esos datos en caso de que no puedas solucionarlo.

    Existen tambien CD's como el utilisimo Hirens Boot CD que tienen programas para arreglar el MBR y la tabla de particiones asi como el Partition Magic, que también arregla el MBR y la tabla de particiones.


    Saludos!

    How-to VirtualBox <~ Guía sobre VirtualBox

  9. #9
    Fecha de Ingreso
    19-marzo-2005
    Ubicación
    En un lugar del planeta Tierra
    Mensajes
    17.239
    Post Thanks / Like
    Poder de Credibilidad
    10
    Si no has redimensionado la particion de OpenSuse no deberias tener problemas con la tabla de particiones sino con el grub de wifislax y, tambien, con OpenSuse si ha cambiado el numero de la particion, para eso tienes que editar el fstab de OpenSuse en la linea donde se define el punto de montaje de la particion root, esa linea donde aparece '/'.

    Unos datos necesarios son el "fdisk -l" y el contenido de /boot/grub/menu.lst de wifislax suponiendo que se utilice ese grub. Tambien el contenido de fstab de OpenSuse.

    Os cuento por experiencia mia que se puede mover el contenido de una particion que contenga un SO GNU/Linux a otra particion, aunque sea a otro disco duro, y que funcione. El truco es editar el fichero fstab de la particion movida y editar el menu.lst del grub a utilizar para que apunte a la nueva particion. Ojo, con el nuevo concepto de etiquetas de Hal en fstab, las cosas cambian.

    EDITADO: En el foro he explicado varias veces esta tematica.
    Si fuera un problema de inodes de OpenSuse con fsck desde wifislax lo puedes arreglar.
    Última edición por DiabloRojo; 31-ago-2007 a las 11:55
    NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
    Síguenos en TWITTER y en FACEBOOK
    Código:
    Buscador de   Alojamiento      Alojamiento     Otros
     paquetes:    de imágenes:     de ficheros:    buscadores:
    Search        TinyPic          Ifile Wuala     Simple y Facil
    Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

  10. #10
    Fecha de Ingreso
    03-agosto-2007
    Ubicación
    Sevilla (España)
    Mensajes
    461
    Post Thanks / Like
    Poder de Credibilidad
    12
    El grub esta perfecto, ya lo vereis hoy cuando postee el menu.lst, el problema tiene que estar en el propio opensuse, mirare eso del fstab y lo del fsck.

    Se me esta acumulando el trabajo, jj
    estoy deseando salir del trabajo para empezar con el opensuse.
    En ocasiones, se pueden ajustar los tipos para permitir la operación.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. ¿porque ubuntu es mas popular q suse?
    By goundzchecky in forum El Contubernio
    Respuestas: 161
    Último mensaje: 16-ago-2012, 15:01
  2. ya instaler OpenSUSE pero no inicia graficos
    By jclaurian in forum Instalación y Actualizaciones
    Respuestas: 4
    Último mensaje: 31-ago-2007, 04:23
  3. Respuestas: 19
    Último mensaje: 19-ago-2007, 03:28
  4. No veo particiones windows es opensuse 10.2
    By ersolan in forum Hardware
    Respuestas: 4
    Último mensaje: 23-may-2007, 01:23
  5. Respuestas: 2
    Último mensaje: 13-feb-2006, 23:25

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •