Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Mostrando resultados del 1 al 6 de 6

Tema: mis problemas actualizando el sistema con apt!!!

  1. #1
    rpadin Invitado

    Unhappy mis problemas actualizando el sistema con apt!!!

    Buenas ...

    Después de dejar todo hecho unos zorros y reinstalar el sistema ... y a la hora de hacer una actualización de este con apt ... me da unos errorcillos ... os cuento:
    Primero: Hago apt-get update
    Segundo: Hago apt-get upgrade

    Y al final del proceso de upgrade me suelta este error:

    Committing changes...
    Preparing... ########################################### [100%]
    file /opt/kde3/share/services/popmail-conduit.desktop from install of kdepim3-kpilot-3.4.0-17 conflicts with file from package kdepim3-3.3.0-32.3
    E: Error while running transaction
    E: Handler silently failed


    ¿A que se debe?
    ¿Como puedo instalar/actualizar el resto de paquetes?, ¿con rpm -Uuv *.rpm?

    Un saludo
    Ramiro

  2. #2
    Goltnor Invitado

    Talking Bueno

    Hola amigo, bueno pareciera que tienes un problema de dependencias al instalar una version mas nueva, intenta con: apt-get update seguido de apt-get dist-upgrade o sino prueba con apt-get dist-upgrade -f

    Espero que te sirva...

    Cualquier cosa preguntas para ayudar


  3. #3
    Fecha de Ingreso
    27-julio-2004
    Ubicación
    En un lugar de la mancha ...
    Mensajes
    2.348
    Post Thanks / Like
    Poder de Credibilidad
    19
    Desinstala el paquete que da conflicto:

    rpm -e kdepim3

    (si para desinstalar ese hace falta eliminar algún otro lo haces también, luego se instala la versión nueva así que no hay problema )

    luego puedes repetir el apt-get upgrade y te lo debería hacer bien

    Un saludo

    P.D: Nos vamos a SW
    Última edición por chuzo; 09-abr-2005 a las 22:13
    La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
    "No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"

  4. #4
    Goltnor Invitado

    Talking ¿?

    Cita Iniciado por chuzo
    Desinstala el paquete que da conflicto:
    rpm -e kdepim3
    (si para desinstalar ese hace falta eliminar algún otro lo haces también, luego se instala la versión nueva así que no hay problema )
    Amigo Chuzo pero con apt-get dist-upgrade -f se resuelve eso no?, lo digo porq lo he hecho asi y me ha resultado

    Saludos


  5. #5
    Fecha de Ingreso
    27-julio-2004
    Ubicación
    En un lugar de la mancha ...
    Mensajes
    2.348
    Post Thanks / Like
    Poder de Credibilidad
    19
    Cita Iniciado por goltnor
    lo digo porq lo he hecho asi y me ha resultado
    Pues si lo has probado y funciona está claro que sí

    Lo que hace la opción -f es intentar arreglar los problemas de dependencias, literalmente si miras la ayuda del programa pone "Attempt to fix dependencies while doing one of the above".

    En casos tan simples como este, en que la dependencia se arregla simplemente desinstalando un paquete pues lo hará bien seguramente, por lo que dices así es, pero en otros casos más complejos la opción para arreglar las dependencias puede pasar por eliminar todos los paquetes que "estorben", lo cual no siempre es solución, por lo que hay que usar con cierto cuidado esa opción no hay que tener la idea de que se trata de algo "mágico" que siempre va a arreglar los problemas
    La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
    "No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"

  6. #6
    Goltnor Invitado

    Talking Thanks

    Cierto lo que dices, solo lo he usado cuando el me lo ha indicado que hay problemas pero nada mas...Incluso una guia que he estado viendo de apt para Ubuntu dice esto:
    apt-get dist-upgrade -f Attempt to fix dependencies while doing one of the above. Note that apt-get install -f does not require a <package> argument.

    Y bueno ya lo he confirmado con lo que me has dicho

    Thanks a lot


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. ¿El Sistema Operativo de Google?
    By Goltnor in forum La cafetería
    Respuestas: 9
    Último mensaje: 05-mar-2005, 17:07
  2. Problemas con el módem y el sonido
    By Juanito in forum Hardware
    Respuestas: 20
    Último mensaje: 04-dic-2004, 15:03
  3. MPlayer ?? Problemas .. ..
    By schwartz in forum Software
    Respuestas: 25
    Último mensaje: 20-nov-2004, 21:19
  4. Graves problemas de seguridad en productos Mozilla
    By chuzo in forum Internet, Redes y Wireless
    Respuestas: 0
    Último mensaje: 16-sep-2004, 14:20
  5. Problemas con APT y dependencias
    By Dudu678 in forum Software
    Respuestas: 4
    Último mensaje: 03-sep-2004, 00:43

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •