Gracias Gracias:  0
Me Gusta Me Gusta:  0
No me Gusta No me Gusta:  0
Mostrando resultados del 1 al 9 de 9

Tema: Error "bad magic" al actualizar con apt

  1. #1
    Fecha de Ingreso
    05-agosto-2004
    Ubicación
    Alacant
    Mensajes
    1.455
    Post Thanks / Like
    Poder de Credibilidad
    18

    Error "bad magic" al actualizar con apt

    ¡Hola a todos!

    Estoy actualizando con apt y con bastantes paquetes me está apareciendo

    Código:
    "error: unpacking of arcive failed: cpio Bad magic"
    ¿Tenéis idea de por qué puede ser? He instalado SuSE 9.2 desde cero y una vez iniciado me he puesto a actualizar con apt, y en la instalación de muchos paquetes me ha pasado eso. Por ejemplo el kpowersave, tcsh, mc, kernel-docs...
    Software is like sex: it's better when it's free.

    SomGNU | Desarmats

  2. #2
    Fecha de Ingreso
    27-julio-2004
    Ubicación
    En un lugar de la mancha ...
    Mensajes
    2.348
    Post Thanks / Like
    Poder de Credibilidad
    19
    Hola

    Es posible que tengas la entrada correspondiente a update-drpm dentro de tu fichero sources.list?? Si no recuerdo mal el error venía por ahí, si tienes esa entrada prueba a quitarla (en general todos los componentes *-drpm) y repetir el proceso, a ver qué tal

    Un saludo
    Última edición por chuzo; 18-mar-2005 a las 19:45
    La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
    "No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"

  3. #3
    Fecha de Ingreso
    05-agosto-2004
    Ubicación
    Alacant
    Mensajes
    1.455
    Post Thanks / Like
    Poder de Credibilidad
    18
    Sí que tenía esa entrada. La he quitado y voy a probar. Ahora te cuento.
    Software is like sex: it's better when it's free.

    SomGNU | Desarmats

  4. #4
    Fecha de Ingreso
    05-agosto-2004
    Ubicación
    Alacant
    Mensajes
    1.455
    Post Thanks / Like
    Poder de Credibilidad
    18
    Bueno, ahora me da unos errores "estupendos de la muerte":

    Al hacer el apt-get upgrade baja todos los paquetes y a la hora de instalarlos aperece el siguiente error. Esto es sólo un parte, pero es que se repite una y otra vez:

    Código:
    rpmdb: fatal region error detected; run recovery
    error: db4 error(-30982) from db->get: DB_RUNRECOVERY: Fatal error, run database recovery
    error: error(-30982) getting "�Z" records from Filemd5s index
    rpmdb: fatal region error detected; run recovery
    error: db4 error(-30982) from db->get: DB_RUNRECOVERY: Fatal error, run database recovery
    error: error(-30982) getting "яNrhs��F@" records from Filemd5s index
    rpmdb: fatal region error detected; run recovery
    error: db4 error(-30982) from db->get: DB_RUNRECOVERY: Fatal error, run database recovery
    error: error(-30982) getting "=!#9�F@" records from Filemd5s index
    rpmdb: fatal region error detected; run recovery
    error: db4 error(-30982) from db->get: DB_RUNRECOVERY: Fatal error, run database recovery
    error: error(-30982) getting "v+l=���F@" records from Filemd5s index
    rpmdb: fatal region error detected; run recovery
    error: db4 error(-30982) from db->get: DB_RUNRECOVERY: Fatal error, run database recovery
    error: error(-30982) getting "�8-`▒R_o�F@" records from Filemd5s index
    rpmdb: fatal region error detected; run recovery
    error: db4 error(-30982) from db->get: DB_RUNRECOVERY: Fatal error, run database recovery
    error: error(-30982) getting "bH
    FX\�E��F@" records from Filemd5s index
    rpmdb: fatal region error detected; run recovery
    error: db4 error(-30982) from db->get: DB_RUNRECOVERY: Fatal error, run database recovery
    error: error(-30982) getting "�����-�F@" records from Filemd5s index
    rpmdb: fatal region error detected; run recovery
    error: db4 error(-30982) from db->get: DB_RUNRECOVERY: Fatal error, run database recovery
    error: error(-30982) getting "FXzZ8" records from Filemd5s index
    rpmdb: fatal region error detected; run recovery
    error: db4 error(-30982) from db->get: DB_RUNRECOVERY: Fatal error, run database recovery
    error: error(-30982) getting "�Akw8�#F@" records from Filemd5s index
    rpmdb: fatal region error detected; run recovery
    error: db4 error(-30982) from db->get: DB_RUNRECOVERY: Fatal error, run database recovery
    También, al intentar instalar el firefox me dice lo siguiente:

    Código:
    linux:/home/mdk # apt-get install MozillaFirefox
    Leyendo listas de paquetes... Done
    Construyendo árbol de dependencias... Done
    Se instalarán los paquetes NUEVOS siguientes:
      MozillaFirefox
    0 upgraded, 1 newly installed, 0 removed and 53 not upgraded.
    Need to get 7806kB of archives.
    After unpacking 22,5MB of additional disk space will be used.
    Get:1 ftp://ftp.gwdg.de SuSE/9.2-i386/update-prpm MozillaFirefox 1.0.1-9.1 [7806kB]
    Fetched 7806kB in 2m41s (48,4kB/s)
            MozillaFirefox = 0.10.0-14 | MozillaFirefox = 0.10.0-14.2 | MozillaFirefox = 1.0-6.1 is needed by MozillaFirefox-1.0.1-9.1
    E: Transaction set check failed
    Software is like sex: it's better when it's free.

    SomGNU | Desarmats

  5. #5
    Fecha de Ingreso
    27-julio-2004
    Ubicación
    En un lugar de la mancha ...
    Mensajes
    2.348
    Post Thanks / Like
    Poder de Credibilidad
    19
    Parece que tienes algunos "ligeros problemas" con la base de datos de los paquetes

    Puedes probar a regenerar la base de datos:

    rpm --rebuilddb

    Después ya no te debería dar esos fallos Si el de Firefox sigue saliendo pon el contenido del sources.list y lo vemos, tiene pinta de estar ahí el error
    La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
    "No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"

  6. #6
    HLeon Invitado
    A mi también me estaban dando errores de BAD MAGIC, parece q es problema de los paquetes, sin embargo lo actualice por YAST y no hubo problema.
    A mi manera de ver, no es problema de tu SusE, si no de los paquetes.

    Saludos,

    Hleon

  7. #7
    Fecha de Ingreso
    05-agosto-2004
    Ubicación
    Alacant
    Mensajes
    1.455
    Post Thanks / Like
    Poder de Credibilidad
    18
    Bueno, también puede ser culpa de mis sources del apt... hay algunas que no sé ni lo que quieren decir, pero es que a veces necesito algún tipo de librerías y no sé de donde sacarlo. Voy a probar con lo que dice Chuzo.

    Lo acabo de probar y funciona perfectamente... si es que lo que no sepa Chuzo..

    ¡Asias!

    ¡¡Ya tengo el ordenador a la última!!
    Software is like sex: it's better when it's free.

    SomGNU | Desarmats

  8. #8
    Fecha de Ingreso
    27-julio-2004
    Ubicación
    En un lugar de la mancha ...
    Mensajes
    2.348
    Post Thanks / Like
    Poder de Credibilidad
    19
    Cita Iniciado por HLeon
    A mi también me estaban dando errores de BAD MAGIC, parece q es problema de los paquetes, sin embargo lo actualice por YAST y no hubo problema.
    A mi manera de ver, no es problema de tu SusE, si no de los paquetes.
    Bueno, no se trata de que sea problema de SuSE, sino como ya puse de las entradas que puedas tener en el fichero de fuentes

    Las entradas *-drpm no son paquetes rpm "normales", son más bien parches que actualizan otros paquetes, por lo que el modo de instalación es diferente

    Al actualizar por Yast si te fijas te suele poner mensajes del tipo "Aplicando delta" (la d de drpm vendría de ahí precisamente ), de forma que esos paquetes varían en su forma de instalación, y por alguna razón apt los considera erróneos, supongo que porque al ser el formato diferente no se encuentra la estructura que se espera encontrarse, que sería la de los rpm "normales"

    Un saludo
    La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
    "No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"

  9. #9
    HLeon Invitado
    Muy buen dato.....
    Si había visto lo de "Aplicando Delta" pero no tenía ni idea de que era.

    Gracias!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Temas Similares

  1. Como actualizar Kernel en suse 9.2 version dvd - iso?
    By Kou in forum Instalación y Actualizaciones
    Respuestas: 0
    Último mensaje: 19-feb-2005, 22:51
  2. Respuestas: 0
    Último mensaje: 13-ene-2005, 20:26
  3. Actualizar Firefox.
    By isicapi in forum Software
    Respuestas: 9
    Último mensaje: 14-nov-2004, 14:09
  4. Actualizar el Amarok con APT ?
    By schwartz in forum Software
    Respuestas: 5
    Último mensaje: 27-ago-2004, 22:28
  5. Es conveniente actualizar la 9.1?
    By Oesoto in forum General OpenSUSE
    Respuestas: 5
    Último mensaje: 06-ago-2004, 20:33

Marcadores

Normas de Publicación

  • No puedes crear nuevos temas
  • No puedes responder mensajes
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •