PDA

Ver la Versión Completa : Instalar version 8.24.8 del driver ATI para PC x86



DiabloRojo
26-abr-2006, 17:41
NUEVO MANUAL sobre una version superior: Instalar version 8.33.6-x86.x86_64 del driver ATI (http://www.forosuse.org/forosuse/showthread.php?t=11066)

Instalar la nueva version 8.24.8 del driver ATI para maquinas x86

Comprobar que cumplas los requirimientos minimos del driver: https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/linux_8.24.8.html#172686

Descargamos el nuevo driver de ATI en una carpeta nueva: https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/ati-driver-installer-8.24.8-x86.run

Abrir una consola, entrado en la carpeta del driver con el comando "cd carpeta", para cambiar los permisos de ejecucion con:

chmod +x ati-driver-installer-8.24.8-x86.run
Cambiar de usuario a superusuario root con el comando:

su
Ejecutarlo

sh ./ati-driver-installer-8.24.8-x86.run
Selecionar el modo automatico o "Automatic" y una vez instalado ejecutar para configurar automaticamente:

/usr/X11R6/bin/aticonfig --initial
/usr/X11R6/bin/aticonfig --overlay-type=Xv


REINICIALIZAR el PC.

Una vez reinicializado, probar los comandos:
fglrxinfo (informa de la tarjeta grafica)
glxinfo (idem pero mas completo, entre ellos si tenemos aceleracion 3D: "direct rendering: Yes")
glxgears (frames en 2D)
fgl_glxgears (frames en 3D)


diablorojo@linux:~> fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9600 XT Generic
OpenGL version string: 2.0.5755 (8.24.8)

diablorojo@linux:~> glxinfo | more
name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2

diablorojo@linux:~> glxgears
16194 frames in 5.0 seconds = 3238.800 FPS
19901 frames in 5.0 seconds = 3980.200 FPS
51285 frames in 5.0 seconds = 10257.000 FPS
56872 frames in 5.0 seconds = 11374.400 FPS

diablorojo@linux:~> fgl_glxgears
Using GLX_SGIX_pbuffer
2547 frames in 5.0 seconds = 509.400 FPS
2871 frames in 5.0 seconds = 574.200 FPS
2871 frames in 5.0 seconds = 574.200 FPS
2862 frames in 5.0 seconds = 572.400 FPS


Comprobamos que estan cargados los drivers de la tarjeta grafica ATI

diablorojo@linux:~> lsmod | grep fglrx
fglrx 477568 7
agpgart 38476 2 fglrx,intel_agp
diablorojo@linux:~> lsmod | grep agp
intel_agp 26652 1
agpgart 38476 2 fglrx,intel_agp

NOTA
En caso de que no funcione y no nos salga el modulo fglrx de los anteriores comandos, hay que localizar el error con:

diablorojo@linux:~> dmesg | grep fglrx

diablorojo@linux:~> cat /var/log/Xorg.0.log | grep '(EE)'
Y buscar dichos errores por Internet, otro sitio para mirarlos es en el mejor foro de ATI: http://www.rage3d.com


Funciona de primera, por fin puedo decir que ATI ha resuelto todos los problemas.

¡Ya era hora!.

keops
26-abr-2006, 19:20
Hola,

Buen manual, DR, corto y preciso.

Sólo dos puntualizaciones:
-Para los que tengan acutalizado el Xorg a 6.9, todavia no funciona (sólo hasta la versión 6.8, según ATI).
-Al actualizar el kernel, hay que repetir la operación (según suse).

Por lo demás, ya era hora que ATI se pusiera las pilas con su driver para linux.

Salu2.

DiabloRojo
26-abr-2006, 20:54
Sólo dos puntualizaciones:
-Para los que tengan acutalizado el Xorg a 6.9, todavia no funciona (sólo hasta la versión 6.8, según ATI).
-Al actualizar el kernel, hay que repetir la operación (según suse).Gracias por los matices, keops :p
Ya veremos con la Suse 10.1 si trae Xorg 6.9 ya que habra que esperar a que ATI genere una nueva version que lo soporte y estaremos sin driver por una temporada :(
Lo de repetirlo cuando actualizas el kernel ya lo sabia, pero bueno es ponerlo para que los demas lo sepa ;)

PokeP
26-abr-2006, 22:13
En el emcabezamiento de mi xorg.con, aparece "Version 7.1", es esto la version del Xorg, si es así, como puedo desactualizarlo a la 6.8, para que funcionen los drivers de ATI? y si no es eso la version de Xorg, como puedo saber cual es?
Gracias.

tomeu
27-abr-2006, 15:56
Ante todo gracias por el Manual.
Como llevaba tiempo sin trastear con mi PCera me puse con él, tras el paso de reiniciar el PC, vino el primer acojone, pues no entraba el modo gráfico.
Hice desde Failsave un

init 3
sax2 -m 0=vesa
init 5

El primer paso supongo que era superfluo, pues entrando en modo Failsave se inicia en ese nivel ¿no?. La cuestión es que ya tengo el modo gráfico, pero seguidamente al hacer las comprobaciones y comparándolas con las que pones DR veo unas diferencias (aparte de las lógicas) que me dan mala espina, las pego seguidamente por si puedes darles un vistazo y decirme si hay algo mal y modo de corregirlas (si este post molesta dentro del "Cómo", ya me dices donde lo movéis).

Gracias anticipadas.


tomeu@pctomeu:~> fglrxinfo
Xlib: extension "XFree86-DRI" missing on display ":0.0".
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)

tomeu@pctomeu:~> glxinfo | more
Xlib: extension "XFree86-DRI" missing on display ":0.0".
name of display: :0.0
display: :0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read,
GLX_SGIS_multisample, GLX_SGIX_fbconfig
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_ATI_pixel_format_float,
GLX_ATI_render_texture
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_multisample
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)
OpenGL extensions:
GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
GL_EXT_texture_lod_bias
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x22 24 tc 0 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 1 0 None
0x23 24 tc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 1 0 None
0x24 24 tc 0 32 0 r y . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
0x25 24 tc 0 32 0 r . . 8 8 8 8 0 16 8 16 16 16 16 1 0 None

tomeu@pctomeu:~> glxgears
Xlib: extension "XFree86-DRI" missing on display ":0.0".
2299 frames in 5.0 seconds = 459.800 FPS
2760 frames in 5.0 seconds = 552.000 FPS
2760 frames in 5.0 seconds = 552.000 FPS
2760 frames in 5.0 seconds = 552.000 FPS
2880 frames in 5.0 seconds = 576.000 FPS
2760 frames in 5.0 seconds = 552.000 FPS
2760 frames in 5.0 seconds = 552.000 FPS
2760 frames in 5.0 seconds = 552.000 FPS
2760 frames in 5.0 seconds = 552.000 FPS
2760 frames in 5.0 seconds = 552.000 FPS
2513 frames in 5.0 seconds = 502.600 FPS
2760 frames in 5.0 seconds = 552.000 FPS
2640 frames in 5.0 seconds = 528.000 FPS
2760 frames in 5.0 seconds = 552.000 FPS
2760 frames in 5.0 seconds = 552.000 FPS
X connection to :0.0 broken (explicit kill or server shutdown).
La última línea salió tras cerrar la ventana X con las ruedas.

tomeu@pctomeu:~> fgl_glxgears
Using GLX_SGIX_pbuffer
Xlib: extension "XFree86-DRI" missing on display ":0.0".
X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 143 (GLX)
Minor opcode of failed request: 5 (X_GLXMakeCurrent)
Serial number of failed request: 30
Current serial number in output stream: 30
Aquí parece que los errores son más evidentes.

tomeu@pctomeu:~> lsmod | grep fglrx
tomeu@pctomeu:~>
Aquí no salió nada :(

DiabloRojo
27-abr-2006, 18:04
En el emcabezamiento de mi xorg.con, aparece "Version 7.1", es esto la version del Xorg, si es así, como puedo desactualizarlo a la 6.8, para que funcionen los drivers de ATI? y si no es eso la version de Xorg, como puedo saber cual es?
Gracias.En Yast->Software->Instalar/deinstalar puedes volver a la primitiva version de Xorgf 6.8.

Ante todo gracias por el Manual.
Como llevaba tiempo sin trastear con mi PCera me puse con él, tras el paso de reiniciar el PC, vino el primer acojone, pues no entraba el modo gráfico.
Hice desde Failsave un

init 3
sax2 -m 0=vesa
init 5Hola tomeu, doy por hecho que tienes una ATI y que a instalar el driver de eat guia te has quedado sin servidor grafico, obligandote a utilizar el driver de vesa, ¿no?.
Sospecho que te pasa lo mismo que a PokeP que tendras una version superior a 6.8, puedes comprobarlo en el fichero /var/log(Xorg.0.log donde estaran los mensajes de error, te ruego que lo comprimas y lo adjuntes en un post.

He estado mirando los requerimientos del driver y veo que pide una version inferior o igual a la de Xorg 7.0: https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/linux_8.24.8.html

Y presta atencion que soportes o tengas instalado POSIX Shared Memory (/dev/shm), pero esto solo afecta a las aplicaciones en 3D, el resto deberia funcionar.

tomeu
27-abr-2006, 20:16
Hola Diablo, encontré la función de adjuntar archivos y acompaño el xorg.conf comprimido.

La versión de Xorg que tengo está dentro del rango, es la 6.8-100-2, es decir, la misma que venía con la distro actualizada a una subversión (examinando el paquete con yast deduzco que la actualicé con apt).

La tarjeta de video es una ATI Radeon 7000 family, antes de aplicar el manual revisé en la página de ATI si ese driver servía para esa versión y me dio la impresión de que sí.

Con todo, debo decir, que a pesar de lo comentado, he notado una ligera mejora en la definición de la pantalla, y tanto con SuSE como con Ubuntu (partición a la que también apliqué el cambio). Es más, puedo añadir que ese fallo de no poder iniciarse el entorno gráfico al reiniciar no me sucedió con Ubuntu, en la cual (eso sí) me dice que me faltan unas librerías, pero que en cambio la mejora se ha hecho más evidente, sobre todo con firefox, que antes al lanzarlo siempre me quedaba un poco desplazado, y ahora sale perfecto.

Me gustaría dar más datos, pero ya estoy en casa (con el portátil), y a éste no le puedo aplicar el manual, pues la tarjeta de video no es ATI (creo, el hardware no es ni de largo mi fuerte) pues dice "Intel 855GM".

:adios:

tomeu
28-abr-2006, 11:43
He vuelto a instalar el driver, y como antes me quedé sin entorno gráfico; antes de poner el driver vesa he hecho copias y comprimido los archivos xorg.conf y Xorg.0.log que añado a éste.

Antes de intentar un init 5 con vesa lo he intentado con fglrx
sax2 -m 0=fglrx sin ningún resultado; ha creado un fichero log de sax2 (Sax2.log) que también posteo por si puede ser de interés.

Gracias de nuevo.

Ah!, en /dev/shm solo tengo el fichero "jack-shm-registry"

DiabloRojo
28-abr-2006, 20:24
(EE) No devices detected.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
at http://wiki.X.Org


No te detecta la tarjeta grafica y aparte la tarjeta es muy vieja, estas seguro de que es el drive adecuado.

torronet
29-abr-2006, 00:42
Hola!!

Ante todo agradecer a DiabloRojo el excelente tutoríal que ha creado. Desde que poseo mi flamante Acer Aspire 1690, había intentado configurar más de 50 veces la aceleración 3d de mi Ati X600 y ya incluso me había dado por vencido intentando instalarla. Gracias a él lo he conseguido. :aplausos:

Aunque por desgracia, de esta instalación a derivado un problema del que desconozco la gravedad... No consigo arrancar el Sax2!! ¿ Se trata de un problema común a todos los que han instalado estos drivers o únicamente lo sufro yo ?

Un saludo y gracias anticipadas :)

DiabloRojo
29-abr-2006, 08:58
¿ Se trata de un problema común a todos los que han instalado estos drivers o únicamente lo sufro yo ?Me parece que es un error frecuente, lo que no se si esta asociado a la version de Xorg o a la antiguedad de la tarjeta o, mas probable, a la herencia del fichero xorg.conf anterior a la instalacion del driver (lo digo por las diferencias existentes entre los ficheros adjuntos de tomeu y el mio).

Mira el fichero /var/log/Sax.log o similar donde encontraras el error, comprimelo y adjuntalo para que lo vea, como ha hecho tomeu con el suyo.

tomeu
29-abr-2006, 11:06
No te detecta la tarjeta grafica y aparte la tarjeta es muy vieja, estas seguro de que es el drive adecuado.
Lo de que la tarjeta gráfica sea demasiado vieja es lo que me temía :-(

Lo de ser el drive adecuado, quizás haya confundido como lo mismo la Radeon 700 series y la Radeon 7000

Por lo que ahora veo aquí https://support.ati.com/ics/support/default.asp?deptID=899&task=knowledge&folderID=4778

me temo que ese driver no sirve para mi PCera.

DiabloRojo
29-abr-2006, 13:16
Utiliza el driver radeon ya que soporta tu tarjeta, miralo que te servira de ajuste fino: http://www.die.net/doc/linux/man/man4/radeon.4.html

La opcion es "sax2 -m 0=radeon". Y un ejemplo: http://blogdrake.net/node/49

tomeu
30-abr-2006, 09:12
Muchas gracias; tan pronto esté delante de ese PC lo probaré como me dices. Fantásticos los enlaces!!

Por otro lado, hoy he visto que el PC de mis hijos tiene una ATI Radeon 9200, así que como por poco que pueda voy a aplicar tu manual con él.

:( Pues fue mal. No sé porqué, ya que parece que todo se había instalado correctamente, y no he tenido problemas con el inicio del entorno gráfico. Sigue usando el otro driver y en yast, no puedo ir a la configuración de pantalla; si escribo sax2 en consola o intérprete de comandos, parece que va a iniciar y luego ná.

Paso los mismos archivos, por si tienes un momento y le das un vistazo. Gracias.

sas
30-abr-2006, 12:52
Hola, bueno mi problema es que instalo el dirver de ati el 8.24.8 -x86, en un portatil acer travelmate 4002, en el que tengo suse 10.0, y la instalacion la hice de la forma que viene en este foro, salio casi del todo bien, salvo que no tengo aceleracion 3D, la tarjeta grafica que tengo es una ati mobility radeon 9700, que segun vi en la pagina de ati esta soportada, pongo lo que me sale en la consola al introducir los comando de fglrxconfig y glxinfo, por que me interesa que si se puede activar la aceleracion 3 D a ver si alguien me puede explicar como hacerlo, esto es lo que me sale:
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)

sas@Portatil-Tux:~/Desktop> glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read,
GLX_SGIS_multisample, GLX_SGIX_fbconfig
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_ATI_pixel_format_float,
GLX_ATI_render_texture
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_multisample
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)
OpenGL extensions:
GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
GL_EXT_texture_lod_bias
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x23 24 tc 0 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 1 0 None
0x24 24 tc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 1 0 None
0x25 24 tc 0 32 0 r y . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
0x26 24 tc 0 32 0 r . . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
0x27 24 dc 0 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 1 0 None
0x28 24 dc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 1 0 None
0x29 24 dc 0 32 0 r y . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
0x2a 24 dc 0 32 0 r . . 8 8 8 8 0 16 8 16 16 16 16 1 0 None



si alguien sabe como puedo solucionarlo le doy las gracias.

DiabloRojo
01-may-2006, 10:05
:( Pues fue mal. No sé porqué, ya que parece que todo se había instalado correctamente, y no he tenido problemas con el inicio del entorno gráfico. Sigue usando el otro driver y en yast, no puedo ir a la configuración de pantalla; si escribo sax2 en consola o intérprete de comandos, parece que va a iniciar y luego ná.No se que me estas hablando de tu ATI o la de tus hijos.

Mirando los mensajes, te falla la carga del driver fglrx pero no te debe impedir que tengas entorno grafico, es decir, sin 3D. Sospecho que no se te carga el 2º driver de agppart referido a tu chipset de la placa base.

DiabloRojo
01-may-2006, 10:09
Hola, bueno mi problema es que instalo el dirver de ati el 8.24.8 -x86, en un portatil acer travelmate 4002, en el que tengo suse 10.0, y la instalacion la hice de la forma que viene en este foro, salio casi del todo bien, salvo que no tengo aceleracion 3D, la tarjeta grafica que tengo es una ati mobility radeon 9700No se si ATI tienes driver especificos para Notebooks, ya que he visto un enlace.

Copia y comprime el fichero /var/log/Xorg.0.log y lo adjuntas como ha hecho tomeu.

tomeu
01-may-2006, 10:17
No se que me estas hablando de tu ATI o la de tus hijos.

Mirando los mensajes, te falla la carga del driver fglrx pero no te debe impedir que tengas entorno grafico, es decir, sin 3D.
Perdón por la ambigüedad; la de mis hijos con la ATI Radeon 9200.
Y efectivamente, tengo entorno gráfico, sin 3D, y sin poder iniciar sax2, ni desde consola, ni desde yast.
He visto en un post anterior que a torronet le ha pasado lo mismo; enseguida que pueda comprimo y pongo el sax2.log
Gracias por tu paciencia :)

Una pregunta ¿Tenía que tener instalados algunos otros paquetes para que eso funcionara bien del todo? Por el enlace que me pusiste a propósito del otro PC, la siguiente cuestión, así como en el foro de ubuntu, hablan de paquetes que hay previamente que instalar.
http://blogdrake.net/node/861
http://www.ubuntu-es.org/node/11919

sas
01-may-2006, 11:13
bueno a ver si con esto da una idea de que puede ser, en la pagina de ati viene un apartado en descarga de drivers referente a notebooks con graficos ati, y me sale el driver propietario de ati para la descarga, que es el que he instalado,te mando el archivo comprimido. Muchas gracias.

DiabloRojo
01-may-2006, 12:52
tomeu y sas, veo que teneis el mismo problema, ruego que me deis las salidas de los comandos:
lspci | grep AGP
ls /lib/modules/`uname -r`/kernel/drivers/char/agp
lsmod | grep agp


Una pregunta ¿Tenía que tener instalados algunos otros paquetes para que eso funcionara bien del todo? Por el enlace que me pusiste a propósito del otro PC, la siguiente cuestión, así como en el foro de ubuntu, hablan de paquetes que hay previamente que instalar.No veo nada en esos enlaces para lo tuyo, son paquetes especificos de dichas distris. Lo que me mosquea es que no puedas utilizar sax2, usa la opcion -r con el sax2, mas informacion "man sax2".


te mando el archivo comprimido. Tu problema es similar a de tomeu.

sas
01-may-2006, 13:27
vaya en los dos primeros comandos no me sale nada....no creo que eso sea muy bueno verdad....
esto es lo que me sale

sas@Portatil-Tux:~> lspci | grep AGP
bash: lspci: command not found
sas@Portatil-Tux:~> ls /lib/modules/'uname -r' /kernel/drivers/char/agp
/bin/ls: /lib/modules/uname -r: No existe el fichero o el directorio
/bin/ls: /kernel/drivers/char/agp: No existe el fichero o el directorio
sas@Portatil-Tux:~> lsmod | grep agp
intel_agp 22044 1
agpgart 33096 1 intel_agp
sas@Portatil-Tux:~>

tomeu
01-may-2006, 13:37
Aquí van las salidas solicitadas y el archivo SaX.log comprimido (antes de usar la opción -r, que lo haré después de postear éste):

papa@casa:~> lspci | grep AGP
bash: lspci: command not found
papa@casa:~> ls /lib/modules/`uname -r`/kernel/drivers/char/agp
agpgart.ko amd-k7-agp.ko intel-agp.ko sworks-agp.ko
ali-agp.ko ati-agp.ko nvidia-agp.ko via-agp.ko
amd64-agp.ko efficeon-agp.ko sis-agp.ko
papa@casa:~> lsmod | grep agp
intel_agp 26652 1
agpgart 38476 1 intel_agp
papa@casa:~>

tomeu
01-may-2006, 14:02
Después de utilizar "sax2 -r", vuelve a abrirse, pero ahora parece como si el driver ati se hubiera desinstalado (en el menú K se había creado una entrada 'ATI Control', y antes tenía bastante información, después de volverse a usar sax2 sale ventana de aviso que dice "Driver does not provide the FireGL X11 extensions! Panel components will operate only partially -OK-"; al darle ok sale el centro de control de ATI con solo la información de "OpenGL: version instalada de mesa3d.org"

Las salidas de comandos puestas hace unos minutos, han cambiado y ahora son:
papa@casa:~> lspci | grep AGP
bash: lspci: command not found
papa@casa:~> su
Password:
casa:/home/papa # lspci | grep AGP
00:01.0 PCI bridge: Intel Corporation 82865G/PE/P PCI to AGP Controller (rev 02)
casa:/home/papa # ls /lib/modules/`uname -r`/kernel/drivers/char/agp
. ali-agp.ko ati-agp.ko nvidia-agp.ko via-agp.ko
.. amd64-agp.ko efficeon-agp.ko sis-agp.ko
agpgart.ko amd-k7-agp.ko intel-agp.ko sworks-agp.ko
asa:/home/papa # lsmod | grep agp
intel_agp 26652 1
agpgart 38476 2 drm,intel_agp


papa@casa:~> fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)

name of display: :0.0
display: :0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read,
GLX_SGIS_multisample, GLX_SGIX_fbconfig
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_ATI_pixel_format_float,
GLX_ATI_render_texture
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_multisample
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)
OpenGL extensions:
GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
GL_EXT_texture_lod_bias
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x23 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 1 0 None
0x24 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 1 0 None
0x25 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 1 0 Slow
0x26 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 1 0 Slow
0x27 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 1 0 None
0x28 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 1 0 None
0x29 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 1 0 Slow
0x2a 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 1 0 Slow
0x2b 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 1 0 None
0x2c 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 1 0 None
0x2d 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 1 0 Slow
0x2e 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 1 0 Slow
0x2f 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 1 0 None
0x30 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 1 0 None
0x31 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 1 0 Slow
0x32 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 1 0 Slow

DiabloRojo
01-may-2006, 18:47
vaya en los dos primeros comandos no me sale nada....no creo que eso sea muy bueno verdad....
El primero lo tienes que ejecutarlo como root y el segundo es que no tienes instalado el paquete kernel-sources, hazlo en Yast.

Las salidas de comandos puestas hace unos minutos, han cambiado y ahora son:
El primero hazlo como root. Y sobre lo otro, es normal te vuelve a salir sax2 porque te has cepillado lo anterior, si quieres vuelves a instalarlo de nuevo.

Sas y tomeu, a falta del comando lspci.... teneis casi el mismo problema, el de tomeu hay un driver de mas "drm" que no se que pinta ahi si fglrx se encarga de hacer lo que hace dri, ademas yo no lo tengo :scratchch

Otros comandos a ejecutar "dmesg | grep fglrx" y "dmesg | grep mtrr".
Mas informacion:
http://www.rage3d.com/board/forumdisplay.php?f=61
http://www.driverheaven.net/forumdisplay.php?f=103
http://wiki.cchtml.com/index.php/Main_Page

http://ati.cchtml.com/show_bug.cgi?id=306

tomeu
04-may-2006, 07:29
Sas y tomeu, a falta del comando lspci.... teneis casi el mismo problema, el de tomeu hay un driver de mas "drm" que no se que pinta ahi si fglrx se encarga de hacer lo que hace dri, ademas yo no lo tengo :scratchch


Dejando pendiente lo de poner los últimos comandos (cuando vuelva a estar delante de ese PC), la salida del comando lspci la puse como root:


papa@casa:~> su
Password:
casa:/home/papa # lspci | grep AGP
00:01.0 PCI bridge: Intel Corporation 82865G/PE/P PCI to AGP Controller (rev 02)
Para corregir lo de "drm" ¿debería quitar el paquete que lo proporciona o lo hago editando algún archivo?

Una última pregunta (por ahora), quizás boba por obvia, ¿para instalar el driver de ati tenía que tener instalado el paquete "kernel-sources"?, "gcc" ya lo tenía pero "kernel-sources" no.
http://es.opensuse.org/SDB:Instalaci%C3%B3n_de_drivers_ATI_bajo_SuSE_Linu x

sas
04-may-2006, 08:52
Bueno pues gracias por todo a ver si consigo al final ponerle a andar el 3d, si lo consigo ya lo pondre por aqui el como lo hice.chau. :adios:

DiabloRojo
04-may-2006, 17:25
Una última pregunta (por ahora), quizás boba por obvia, ¿para instalar el driver de ati tenía que tener instalado el paquete "kernel-sources"?, "gcc" ya lo tenía pero "kernel-sources" no.
http://es.opensuse.org/SDB:Instalaci%C3%B3n_de_drivers_ATI_bajo_SuSE_Linu x
Es para crear un rpm especifico para Suse 10.0, entonces es necesario kernel-sources

tomeu
09-may-2006, 15:36
Los dioses quisieron que se cascara mi tarjeta gráfica RADEON 7000, y hoy me pusieron otra ATI RADEON 9550, con lo que volví a la carga con este excelente manual.

Ya tenía preparada una batería de archivos a postear comprimidos, ya que no me llegó a funcionar tampoco del todo, cuando antes revisé el archivo Xorg.0.log y el de resumen de instalación en /usr/share/fglrx, y vi que en el segundo me decía que había fallo al no encontrar el paquete gcc y el primero me dio error de posible módulo del kernel perdido o malo

(EE) fglrx(0):DRIScreenInit failed! :o

Fue todo instalar el paquete gcc que instaló como dependencias los paquetes binutils y glibc-devel e instalé (por si las moscas) también el gcc++ volver a empezar de cero con el manual.... Y TODO PERFECTO.

tomeu@pctomeu:~> fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9550 Generic
OpenGL version string: 2.0.5755 (8.24.8)

tomeu@pctomeu:~> glxinfo | more
name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2

tomeu@pctomeu:~> glxgears
12084 frames in 5.0 seconds = 2416.800 FPS
12932 frames in 5.0 seconds = 2586.400 FPS
12932 frames in 5.0 seconds = 2586.400 FPS
12932 frames in 5.0 seconds = 2586.400 FPS
12933 frames in 5.0 seconds = 2586.600 FPS
12932 frames in 5.0 seconds = 2586.400 FPS

tomeu@pctomeu:~> fgl_glxgears
Using GLX_SGIX_pbuffer
1685 frames in 5.0 seconds = 337.000 FPS
2073 frames in 5.0 seconds = 414.600 FPS
2068 frames in 5.0 seconds = 413.600 FPS

tomeu@pctomeu:~> lsmod | grep fglrx
fglrx 477568 7
agpgart 38476 2 fglrx,intel_agp
tomeu@pctomeu:~> lsmod | grep agp
intel_agp 26652 1
agpgart 38476 2 fglrx,intel_agp

DiabloRojo
09-may-2006, 17:44
Me alegro tomeu :p que por fin tengas 3D.

jugoso
11-may-2006, 01:49
a mí me sale lo siguiente después de la instalación:


[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Message] Kernel Module : Found kernel module build environment, generating kern
el module now.
ATI module generator V 2.0
==========================
initializing...
Error:
kernel includes at /usr/src/linux/include do not match current kernel.
they are versioned as "2.6.15-jad2-default"
instead of "2.6.13-15.8-default".
you might need to adjust your symlinks:
- /usr/include
- /usr/src/linux
[Error] Kernel Module : Failed to compile kernel module - please consult readme


$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)
$

y ahora estoy con los drivers de ati, pero sin accel3d :(

la cuestión es que el yast de suse 10 me puso esos links simbólicos, ya que ahí está el source del kernel

jugoso
11-may-2006, 15:24
a mí no me funciona la guía... o sea, toy ocupando los drivers, pero no tengo accel3d
Por siaca, tengo suse 10.1 y una asus radeon 9200se (sí, es penca, pero es lo que hay) en amd sempron 32bit

instalé los drivers con el instalador de ati antes de encontrar esta guía (y de descubrir que no tenía accel3d). Creé el rpm, pero no me deja instalarlo por conflictos... lo forcé con yast y me pasé al modo consola, ejecuté el comando 'sax' con los parámetros y em arrojó error...

aquí (http://www.dcc.uchile.cl/~felema/SaX.log) dejé el log de sax

D:

tomeu
11-may-2006, 18:27
En los requisitos (primer enlace que puso DR en el manual) dice que con ese driver no es necesario el "kernel-sources" si se tiene el "kernel-headers", como este último no aparece en yast (o al menos yo no encontré) habrá que tener el "kernel-sources", y en tu primer post parece que te reporta fallo consistente es que le has metido el kernel-sources 2.6.13.... mientras que tu kernel es 2.6.15....

DiabloRojo
11-may-2006, 18:35
Te falta paquetes como el kernel-sources, el compilador gcc, etc... igual que a tomeu, mira un post suyo nº 28. Revisa que instales y cumplas los requerimientos minimos en el 1er post de este tema.

Vuelve a repetir la instalacion del driver.

EDITADO: Vaya, no me habia fijado que el kernel con coincide con el kernel-sources, haz lo que te comenta tomeu.

tomeu
11-may-2006, 19:01
.... igual que a tomeu, mira un post suyo nº 28. ....Al tanto que volveré a la carga con darte la lata ;) la instalación del driver en el pc de los ninios (ATI Radeon 9200) parece que funcionó pero me ha dado unos resultados inesperados, a saber:

1.- Hay aceleración 3D, aunque el cubo que sale girando al hacer fgl_glxgears, no tiene colores y la nitidez que tiene el mismo comando en el PC con ATI Radeon 9550 (entiendo que ello es cosa menor y que debe obedecer a que esta última es mucho más moderna).

2.- al darle al comando "glxinfo | more" no sale nada.

3.- sax2 no llega a arrancar (ni desde yast, ni desde intérprete de comandos o terminal)

DiabloRojo
11-may-2006, 19:43
Ya sabes donde se guarda el log de sax y xorg, echales un vistazo. Puedes probar sax2 en una consola virtual para ver los mensajes de error.

manolito
20-may-2006, 16:58
Hola, como estais.

Mi problema es que sax no arranca de ninguna de las maneras, el driver de ati creo que se ha instalado bien, tengo una radeon 9200 pro, pongo los test para ver si alguien me puede decir si todo esta correcto o no.

fglrxinfo

display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9000 DDR Generic
OpenGL version string: 1.3.1060 (X4.3.0-8.24.8)

glxinfo

name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read,
GLX_SGIS_multisample, GLX_SGIX_fbconfig
client glx vendor string: ATI
client glx version string: 1.3

glxgears

8995 frames in 5.0 seconds = 1799.000 FPS
9923 frames in 5.0 seconds = 1984.600 FPS
9932 frames in 5.0 seconds = 1986.400 FPS
9929 frames in 5.0 seconds = 1985.800 FPS
9930 frames in 5.0 seconds = 1986.000 FPS
9930 frames in 5.0 seconds = 1986.000 FPS
9932 frames in 5.0 seconds = 1986.400 FPS
9930 frames in 5.0 seconds = 1986.000 FPS
9931 frames in 5.0 seconds = 1986.200 FPS

fgl_glxgears

Using GLX_SGIX_pbuffer
1282 frames in 5.0 seconds = 256.400 FPS
881 frames in 5.0 seconds = 176.200 FPS
873 frames in 5.0 seconds = 174.600 FPS
886 frames in 5.0 seconds = 177.200 FPS
873 frames in 5.0 seconds = 174.600 FPS
880 frames in 5.0 seconds = 176.000 FPS
873 frames in 5.0 seconds = 174.600 FPS
888 frames in 5.0 seconds = 177.600 FPS
872 frames in 5.0 seconds = 174.400 FPS
879 frames in 5.0 seconds = 175.800 FPS
873 frames in 5.0 seconds = 174.600 FPS
888 frames in 5.0 seconds = 177.600 FPS
872 frames in 5.0 seconds = 174.400 FPS

lspci | grep AGP

# lspci | grep AGP
00:00.0 Host bridge: VIA Technologies, Inc. VT8377 [KT400/KT600 AGP] Ho st Bridge

ls /lib/modules/`uname -r`/kernel/drivers/char/agp

# ls /lib/modules/`uname -r`/kernel/driv ers/char/agp
. ali-agp.ko ati-agp.ko nvidia-agp.ko via-agp.ko
.. amd64-agp.ko efficeon-agp.ko sis-agp.ko
agpgart.ko amd-k7-agp.ko intel-agp.ko sworks-agp.ko

lsmod | grep agp

# lsmod | grep agp
via_agp 9472 1
agpgart 33096 2 fglrx,via_agp

Si estan bien me puede decir alguien como o que hacer para que funcione sax, ademas cuando estoy en internet parece que se vea un poco brroso y hace daño a la vista, pero al poner un juego se ve nitido, me puede decir alguien como solucionar esto tambien

Gracias

Saludos

DiabloRojo
20-may-2006, 17:35
Las salidas de los comandos son correctas y bien configuradas pero ha configurado una 9000 en vez de la 9200, abre una consola virtual y ejecuta sax2 para ver su salida.

El comando de configuracion es aticonfig no sax2, mira el 1er mensaje de este tema.

manolito
21-may-2006, 00:09
Hola, en la consola virtual sax2 si se ejacuta, pero cuando sale la pantalla de configuracion solo se ven lineas de un par de mm de dos tonos de azul, el raton es un cuadrado de lineas muy finas y no hay forma de configurar nada, con el comando aticonfig sale un monton de argumentos pero no se que hacer con ellos.

Las versiones son las siguientes:

XOrg, dependiendo de que esta de la 6.8.2-100 a la 6.8.2-100.5
XFree86 si es lo que sale en la consola poniendo -version es la X Window System Version 6.8.2, si no es esto dime como sacarla con yast no la encuentra
Linux x1-6-00-c0-26-a1-bb-57 2.6.13-15.8-default
glibc 2.3.5-40 todo lo que sale
POSIX Shared Memory (/dev/shm) aqui solo hay un binario, no se si es correcto

DiabloRojo
21-may-2006, 09:16
Hola, en la consola virtual sax2 si se ejacuta, pero cuando sale la pantalla de configuracion solo se ven lineas de un par de mm de dos tonos de azul, el raton es un cuadrado de lineas muy finas y no hay forma de configurar nada, con el comando aticonfig sale un monton de argumentos pero no se que hacer con ellos.Parece mas un problema del monitor que de la grafica, eso de las frecuencias verticales y horizontales, sobre aticonfig son dos opciones a ejecutar segun mi primer mensaje de este tema, repasalo.

manolito
21-may-2006, 12:14
hola, he repasado todo de hecho lo he desinstalado y lo he instalado otra vez pero sigue igual, no se si tendra que ver pero con fglrxconfig dice que no se encuentra con los de aticonfiginitial dice algo de configurar con Xorg y el segundo no da ninguna salida, la version de Xfree en yast no salia descargue la 4.3 la instale, despues instale el driver, pero no se si este ultimo paaso es crrecto.

Dime que puedo hacer.

Gracias

Saludos

DiabloRojo
21-may-2006, 13:46
¿Que Suse utilizas? porque me estas hablando de la XFree :confused:
En mi guia no habla de fglrxconfig :confused:

:confused: :confused:

Zengor
21-may-2006, 15:14
Hola antetodo gracias por la guia, tambien decir que mis driver son para x86_64, supongo que el proseso de instalacion sera mas o menos el mismo, lo he hecho y no me ha dado ningun error pero al hacer fglrxinfo y glxinfo me sale lo siguiente, si me pudieseis ayudar a poner aceleracion 3d os estaria agradecido, saludos!!

Zengor
21-may-2006, 15:23
Hola a todos, he seguido los pasos de la guia y se me instala todo bien pero no tnego aceleracion 3d y me sige saliendo la vesa esa os pongo la info

zengor@Zengor:~> fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)


zengor@Zengor:~> glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read,
GLX_SGIS_multisample, GLX_SGIX_fbconfig
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_ATI_pixel_format_float,
GLX_ATI_render_texture
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_multisample
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)
OpenGL extensions:
GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
GL_EXT_texture_lod_bias
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x23 24 tc 0 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 1 0 None
0x24 24 tc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 1 0 None
0x25 24 tc 0 32 0 r y . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
0x26 24 tc 0 32 0 r . . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
0x27 24 dc 0 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 1 0 None
0x28 24 dc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 1 0 None
0x29 24 dc 0 32 0 r y . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
0x2a 24 dc 0 32 0 r . . 8 8 8 8 0 16 8 16 16 16 16 1 0 None



zengor@Zengor:~> glxgears
506 frames in 5.0 seconds = 101.200 FPS
480 frames in 5.0 seconds = 96.000 FPS
459 frames in 5.0 seconds = 91.800 FPS
395 frames in 5.0 seconds = 79.000 FPS


zengor@Zengor:~> fgl_glxgears
Using GLX_SGIX_pbuffer
X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 143 (GLX)
Minor opcode of failed request: 5 (X_GLXMakeCurrent)
Serial number of failed request: 32
Current serial number in output stream: 32



zengor@Zengor:~> lsmod | grep fglrx
zengor@Zengor:~> lsmod | grep agp
zengor@Zengor:~>

manolito
21-may-2006, 23:51
Hola, bueno eso de las Xfree y Xorg aparte de que uno es propietario y el otro no, no se nada mas sobre ello, no se si teniendo uno no tiene que estar el otro, supongo que sera algo asi, pero nunca lo he tenido muy claro, siempre he leido lo de configurar las x con fglrxconfig y poco mas se del asunto.

Saludos

Zengor
23-may-2006, 12:08
Bueno no se bien como lo he hecho pero se me ha puesto bien todo creo, os dejo lo que me sale ahora por si estoy equivocado:

zengor@Zengor:~> fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON X800 PRO Generic
OpenGL version string: 2.0.5755 (8.24.8)



zengor@Zengor:~> glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read,
GLX_SGIS_multisample, GLX_SGIX_fbconfig
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_ATI_pixel_format_float,
GLX_ATI_render_texture
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_multisample
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON X800 PRO Generic
OpenGL version string: 2.0.5755 (8.24.8)
OpenGL extensions:
GL_ARB_multitexture, GL_EXT_texture_env_add, GL_EXT_compiled_vertex_array,
GL_S3_s3tc, GL_ARB_depth_texture, GL_ARB_fragment_program,
GL_ARB_fragment_program_shadow, GL_ARB_fragment_shader,
GL_ARB_multisample, GL_ARB_occlusion_query, GL_ARB_point_parameters,
GL_ARB_point_sprite, GL_ARB_shader_objects, GL_ARB_shading_language_100,
GL_ARB_shadow, GL_ARB_shadow_ambient, GL_ARB_texture_border_clamp,
GL_ARB_texture_compression, GL_ARB_texture_cube_map,
GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
GL_ARB_texture_env_crossbar, GL_ARB_texture_env_dot3,
GL_ARB_texture_mirrored_repeat, GL_ARB_transpose_matrix,
GL_ARB_vertex_blend, GL_ARB_vertex_buffer_object, GL_ARB_vertex_program,
GL_ARB_vertex_shader, GL_ARB_window_pos, GL_ARB_draw_buffers,
GL_ATI_draw_buffers, GL_ATI_element_array, GL_ATI_envmap_bumpmap,
GL_ATI_fragment_shader, GL_ATI_map_object_buffer, GL_ATI_separate_stencil,
GL_ATI_texture_compression_3dc, GL_ATI_texture_env_combine3,
GL_ATI_texture_float, GL_ATI_texture_mirror_once,
GL_ATI_vertex_array_object, GL_ATI_vertex_attrib_array_object,
GL_ATI_vertex_streams, GL_ATIX_texture_env_combine3,
GL_ATIX_texture_env_route, GL_ATIX_vertex_shader_output_point_size,
GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color, GL_EXT_blend_func_separate,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_clip_volume_hint,
GL_EXT_draw_range_elements, GL_EXT_fog_coord, GL_EXT_framebuffer_object,
GL_EXT_multi_draw_arrays, GL_EXT_packed_pixels, GL_EXT_point_parameters,
GL_EXT_rescale_normal, GL_EXT_secondary_color,
GL_EXT_separate_specular_color, GL_EXT_shadow_funcs, GL_EXT_stencil_wrap,
GL_EXT_texgen_reflection, GL_EXT_texture3D,
GL_EXT_texture_compression_s3tc, GL_EXT_texture_cube_map,
GL_EXT_texture_edge_clamp, GL_EXT_texture_env_combine,
GL_EXT_texture_env_dot3, GL_EXT_texture_filter_anisotropic,
GL_EXT_texture_lod_bias, GL_EXT_texture_mirror_clamp,
GL_EXT_texture_object, GL_EXT_texture_rectangle, GL_EXT_vertex_array,
GL_EXT_vertex_shader, GL_HP_occlusion_test, GL_NV_blend_square,
GL_NV_occlusion_query, GL_NV_texgen_reflection, GL_SGI_color_matrix,
GL_SGIS_generate_mipmap, GL_SGIS_texture_border_clamp,
GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod, GL_SUN_multi_draw_arrays
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x23 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x24 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x25 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x26 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x27 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 1 0 None
0x28 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 1 0 None
0x29 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 1 0 None
0x2a 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 1 0 None
0x2b 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x2c 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x2d 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x2e 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x2f 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 2 1 None
0x30 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 2 1 None
0x31 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 2 1 None
0x32 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 2 1 None
0x33 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x34 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x35 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x36 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x37 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 4 1 None
0x38 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 4 1 None
0x39 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 4 1 None
0x3a 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 4 1 None
0x3b 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x3c 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x3d 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x3e 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x3f 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 6 1 None
0x40 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 6 1 None
0x41 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 6 1 None
0x42 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 6 1 None
0x43 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x44 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x45 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x46 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x47 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 1 0 None
0x48 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 1 0 None
0x49 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 1 0 None
0x4a 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 1 0 None
0x4b 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x4c 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x4d 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x4e 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x4f 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 2 1 None
0x50 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 2 1 None
0x51 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 2 1 None
0x52 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 2 1 None
0x53 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x54 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x55 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x56 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x57 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 4 1 None
0x58 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 4 1 None
0x59 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 4 1 None
0x5a 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 4 1 None
0x5b 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x5c 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x5d 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x5e 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x5f 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 6 1 None
0x60 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 6 1 None
0x61 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 6 1 None
0x62 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 6 1 None
zengor@Zengor:~>

DiabloRojo
23-may-2006, 17:30
direct rendering: Yes :dedosarri

alexrojas
24-may-2006, 22:13
Bueno antes que nada un saludo a todos los usuarios suse y un agradecimineto por este manual a diablorojo, bueno, a mi lo que me paso fue que instale suse 10.1 y no me reconocio la tarjeta, baje el driver de la pagina de ati y lo instale, pero al tratar de entrar a suse, se traba y no lograba entrar ni siquiera en modo consola, así que me puse a buscar en internet y encontre tu tutorial y en alguno de los post lei que el suse 10.1 aún no esta soportado, así que me baje a suse 10 y esta vez agarro perfectamente la aceleración grafica, ahora bien, mi problema es que mi pc la tengo para hacer unas presentaciones (soy encargado de un laboratorio de computo) y al conectar la tv a la tarjeta de video (es una radeon 9550) en la tv se ve solo en blanco y negro, y no logro hacer que se vea a colores, podrias ayudarme con esto??

de antemano te doy las gracias por tu atención!

manolito
26-may-2006, 00:00
Hola, he reinstalado el driver un monton de veces y siempre tengo el mismo resultado no pudiendo iniciar Yast, pero me funciona el 3D, sigue reconociendo una radeon 9000 y no la 9200 pro que tengo, es de 64 Mb, no se si es por que ha de ser asi o por algun fallo, cuando termino la instalacion dice algo de configurar con Xorgcofig, pero al hacerlo se desconfigura todo, con aticonfig sale un monton de cosas pero todo en perfecto ingles y apenas entiendo nada, me podeis decir si tiene solucion o por el contrario ha de ser asi.

Gracias

Saludos

alexrojas
26-may-2006, 06:34
Bueno, el día hoy, en un rato de ocio me puse a navegar en firefox, y se me ocurrio abrir el site de ATI, en el apartado de drivers y me encontre con la maravillosa noticia de que un día antes (24/05/06) habian liberado la versión ati-driver-installer-8.25.18-x86, asegurando que era especial para red hat y suse (incluida la 10.1) la acabo de poner a bajar y mañana a primera hora reinstalo Suse 10.1 (opte por bajarme a suse 10) y pruebo el driver, una vea que lo haya hecho, posteare mis resultados, espero en esta versión del driver si poder hacer que la tv tenga color!!
Saludos!!!

alexrojas
27-may-2006, 05:54
Bueno, pues ya me he instalado el SUSE 10.1 y le he puesto el nuevo driver:
todo en modo root
chmod +x ati-driver-installer-8.25.18-x86.run ---para poder ejecutarlo
./ati-driver-installer-8.25.18-x86.run
seleccione automatic y una vez instalado
/usr/X11R6/aticonfig --initial
/usr/X11R6/aticonfig --overlay-type=Xv
reinicie y tal y como dice tu guía, tengo aceleración 3D
(revisado con fgrxinfo, glxinfo | more, glxgears fgl_glxgears, lsmod |grep fglrx y lsmod | grep agp)

así que ya funciona perfectamente el driver ATi en SUse 10.1, solo que sigo sin poder ver en la Tv a color (solo veo en Blanco y negro, en mi monitor de la pc se ve perfectos los colores), espero y puedas ayudarme con ese problema, pues es seguro que solo es una mala configuración que estoy haciendo (nota: he puesto aticonfig --tv-format-type=NTSC-M para indicarle que es el formato de mi Tv, pero ni así

saludos

DiabloRojo
27-may-2006, 08:47
Es que no tengo ni idea de como se hace. Ademas, el driver ATI te crea un icono en KDE donde puedes configurar y/o clonar la 2ª salida de video.

alexrojas
28-may-2006, 00:34
Es que no tengo ni idea de como se hace. Ademas, el driver ATI te crea un icono en KDE donde puedes configurar y/o clonar la 2ª salida de video.

Si, ya lo he visto, pero ni con eso, si hago el clon de la pantalla se me desproporciona el escritorio, además de que la tv sigue en blanco y negro :wacala: ,

De todos modos agradesco tu atención, le movere a la configuración tanto desde ATI Control como desde consola con aticonfig y si logro hacerlo funcionar posteo la solución, quiza a alguno le llegue a servir!

Saludos!!!

atreyu
30-may-2006, 00:05
Muchas gracias

alexrojas
02-jun-2006, 20:59
Por fín logre hacer que saliera la señal a la tv, solo habia que bajarse un parche (http://megahurts.dk/rune/tv_output.html) y aplicarlo, espero que a alguien más llegue a servirles este link!

Saludos!!

Brotons_XP
03-jun-2006, 14:04
Probe a cambiar el monito a LCD con maxima resolucion, y sigue sin verse el modo texto una vez tengo el driver de ati puesto.

Alguna otra solucion?

DiabloRojo
03-jun-2006, 18:42
Probe a cambiar el monito a LCD con maxima resolucion, y sigue sin verse el modo texto una vez tengo el driver de ati puesto.

Alguna otra solucion?
LCD es para portatiles, utiliza VESA.

Siroco
03-jun-2006, 20:48
he instalado el driver,pero me pasa como a tomeu,al iniciar el pc,me salta el modo grafico.La culpa la tengo yo porq tengo xorg 7.1,si desde yast paso a una version anterior de xorg se me arreglara este problema¿?¿?
vuelvo a linux ahora comento

DiabloRojo
03-jun-2006, 21:26
Creo que si.

alexrojas
04-jun-2006, 07:19
he instalado el driver,pero me pasa como a tomeu,al iniciar el pc,me salta el modo grafico.La culpa la tengo yo porq tengo xorg 7.1,si desde yast paso a una version anterior de xorg se me arreglara este problema¿?¿?
vuelvo a linux ahora comento

entra a la pagina de ATI y descargate el driver ati-driver-installer-8.25.18-x86.run, yo también tengo xorg 7.1 y me funciono con este driver

Brotons_XP
04-jun-2006, 10:00
LCD es para portatiles, utiliza VESA.

Diablo es que lo tengo instalado en un portatil y creo recordar que me dijistes que pusiera eso. A mi, por defecto, me pone CPT CPT LCD MONITOR. Y con el VESA que solucion tendria?

Un saludo

Siroco
04-jun-2006, 11:11
Me descargue ese driver y no funciona.
Tengo q decir q tengo una Ati Radeon 7000 series.
Diablo rojo tambien probe lo del link q le pasaste a tomeu(editar el xorg.conf)y tampoco.

DiabloRojo
04-jun-2006, 11:33
Me descargue ese driver y no funciona.
Tengo q decir q tengo una Ati Radeon 7000 series.
Diablo rojo tambien probe lo del link q le pasaste a tomeu(editar el xorg.conf)y tampoco.La Radeon 7000 series no funciona con el driver de este tema, tienes que poner el radeon:
sax2 -m 0=radeon

Diablo es que lo tengo instalado en un portatil y creo recordar que me dijistes que pusiera eso. A mi, por defecto, me pone CPT CPT LCD MONITOR. Y con el VESA que solucion tendria?Ojo, fijate en la frecuencia, la mejor es la de 60 y pon la maxima resolucion que soporte tu portatil. Cambia la resoluciones pulsando a la vez Crtl Alt + (signo mas) y Ctrl Alt - (signo menos) o con un programa KDE->Sistema->Miniaplicacion de escritorio->Redimesionar y rotar pantallas. Con VESA tambien puede solucionarte si no funciona LCD.

Siroco
04-jun-2006, 14:48
Aclaro algo mi problema:
Ese driver es el q me pilla Suse al instalar.Me reconoce tanto la tarjeta Ati Radeon como el monitor Hyundai,solo q no me lo llega a configurar del todo bien,la pantalla me "tiembla".Es por estoq he intentado poner otro driver por si acaso.
Ademas aunq seleccione activar la aceleracion grafica,no me funciona.

Siroco
05-jun-2006, 02:03
Bueno pues antes tenia una Ati Radeon 7000 series y no me funcionaba del todo bien.Acaban de dejarme una 9200 y lo mismo no hay 3d.He instalado los drivers de ati y nada.

barbero@unit0:~> fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)

barbero@unit0:~> glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read,
GLX_SGIS_multisample, GLX_SGIX_fbconfig
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_ATI_pixel_format_float,
GLX_ATI_render_texture
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_multisample
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)
OpenGL extensions:
GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
GL_EXT_texture_lod_bias
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x23 24 tc 0 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 1 0 None
0x24 24 tc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 1 0 None
0x25 24 tc 0 32 0 r y . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
0x26 24 tc 0 32 0 r . . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
0x27 24 dc 0 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 1 0 None
0x28 24 dc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 1 0 None
0x29 24 dc 0 32 0 r y . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
0x2a 24 dc 0 32 0 r . . 8 8 8 8 0 16 8 16 16 16 16 1 0 None

Otra vez igual.Alguna idea¿?¿?

alexrojas
05-jun-2006, 06:48
Me descargue ese driver y no funciona.
Tengo q decir q tengo una Ati Radeon 7000 series.
Diablo rojo tambien probe lo del link q le pasaste a tomeu(editar el xorg.conf)y tampoco.

mmm, no, no te va a funcionar con una ATI 7000, el driver es para para series 8500 y superiores.

elpelas
06-jun-2006, 10:15
wenas lei tu manual k supongo servira igual pa los x86_64 eso espero ejjeej.weno a mi el rendering ese no me xuta XD osea la aceleracion 3d y en muxos juegos la piden asi k si necesitas algun archivo o algun dato dimelo k me gustaria arreglarlo x cierto a lo mejor este dato te vale es una ati x600 de 256mb weeno loco responde:afirmar:

alexrojas
18-jun-2006, 05:08
por fín encontre un modo facil para poder conectar la tv a mi tarjeta de video ati radeon 9550 a colo
después de bajar el ultimo driver de ati, hago lo que dice diablorojo,
chmod +x ati-driver-installer-8.25.8-x86.run
/usr/X11R6/bin/aticonfig --initial
/usr/X11R6/bin/aticonfig --ovt=Xv

y agrego lo siguiente

/usr/X11R6/bin/aticonfig --dtop=mirror (esto le dice que debe ser un espejo de mi pc, antes probe con clone, pero el video se veia todo negro y en mirror si muestra los videos)
/usr/X11R6/bin/aticonfig --eneble-monito=crt1,tv (activa los monitores a utilizar)
/usr/X11R6/bin/aticonfig --tvf=NTSC-M (le dice el tipo de tv a usar, puede variar de donde vivas)
/usr/X11R6/bin/aticonfig --tvs=VIDEO
/usr/X11R6/bin/aticonfig --psc=on (le dice que debe activar el pseudo color a 16 bits)

reinicio la pc y en caso de que siga sin verse, editas el archivo

/etc/X11/xorg.conf
para que quede así

Section "Device"
Identifier "aticonfig-Device[0]"
Driver "fglrx"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "on"
Option "DesktopSetup" "clone"
Option "TVStandard" "VIDEO"
Option "TVFormat" "NTSC-M"
Option "FSAAEnable" "off"
Option "PseudoColorVisuals" "on"

Nota: solo edita la Sección "Device"
probe con editarlo sin meter los parametros desde consola, pero no me lo acepto.

vuelve a reiniciar y ya tienes la salida en tu tv a color!

y con unos graficos muuuy buenos!!!

espero le sirva a alguién más!!

Saludos!!

metalklesk
20-jun-2006, 07:02
entra a la pagina de ATI y descargate el driver ati-driver-installer-8.25.18-x86.run, yo también tengo xorg 7.1 y me funciono con este driver


hola, de donde sacaste el xorg 7.1 para suse ?? esta en rpm en alguna parte ?? pregunto por que he tenido problemas para instalar el ultimo driver sobre xorg 6.9, simplemente no va (la instalacion si, la x no). Probe con el driver anterior (8.24) y me funciona pero mal, me explico:

si entro en modo normal a suse (normal desde grub) carga la x y entra al escritorio pero se ve todo de colores, osea como artifacts, todo mal, imposible de usar.

si entro en modo failsafe (desde grub) parte todo bien, pongo startx y carga kde y se ve de lujo, con aceleracion 3d y todo.

Entonces como veran funciona bien en modo failsafe y no en modo normal.

Me imagino que el problema es xorg 6.9, ya que el otro dia probe kubuntu dapper (trae xorg 7.0) y el ultimo driver funciono de inmediato.

saludos!!

klesk_666

alexrojas
21-jun-2006, 04:44
hola, de donde sacaste el xorg 7.1 para suse ?? esta en rpm en alguna parte ?? pregunto por que he tenido problemas para instalar el ultimo driver sobre xorg 6.9, simplemente no va (la instalacion si, la x no). Probe con el driver anterior (8.24) y me funciona pero mal, me explico:

si entro en modo normal a suse (normal desde grub) carga la x y entra al escritorio pero se ve todo de colores, osea como artifacts, todo mal, imposible de usar.

si entro en modo failsafe (desde grub) parte todo bien, pongo startx y carga kde y se ve de lujo, con aceleracion 3d y todo.

Entonces como veran funciona bien en modo failsafe y no en modo normal.

Me imagino que el problema es xorg 6.9, ya que el otro dia probe kubuntu dapper (trae xorg 7.0) y el ultimo driver funciono de inmediato.

saludos!!

klesk_666

En realidad no se como fue, pero así me lo instalo desde el DVD, ahora bien, el driver funciona también con xorg 6.9 (lo probe en la laptop y ahi tiene 6.9).

ShakaGoldSaint
24-jun-2006, 20:42
Saludos gente, hace unas semanas instale el Suse 10.1 en mi athlon64 con una ati radeon x800 gto, logre instalar los drivers propietarios de ati (8.25.18) y echar a andar la aceleración 3D, tenia hasta hace poco funcionando el XGL y los juegos con aceleración se portaban bien, lo unico es que desde que instale esos drivers, la pantalla de inicio del suse, cambio de la de fondo azul estilizada a una bastante extraña de color gris con únicamente dos cuadros de texto, "username, password" y el logo de suse en el fondo, abajo a la izquiera sale una miniconsola de ati que primeramente mostraba constantemente errores de lectura o algo así en la memoria de la tarjeta :scared:, solo se puede entrar como root, de otra forma, si trato de entrar como usuario normal, trata de entrar pero al rato regresa la misma pantalla de inicio, así que solo podía usar mi pc como root en modo gráfico :molesto:, cada que se cambia el modo de pantalla, por ejemplo al levantar el x-server, se muestran varias imágenes distorsionadas, una de ellas al parecer es el logo de ati, pero no se distingue del todo, el Ati Control Panel jamás sirvio, le doy click y no pasa nunca nada, cuando le doy desde la interfaz gráfica por consola a "init 3", sale otra de esas imágenes distorsionadas y suse se cuelga.

Luego en una oportunidad al iniciar suse note que la miniconsola de ati que salia al principio dejo de mostrar los errores de lectura,...... por un momento me alegré....., pero luego me di cuenta que habia perdido la aceleración 3D (adios XGL ='( ) y ademas que no puedo cambiar la resolución de la pantalla que se fija a 640x480, como si ya no tuviera suficientes problemas :mad:.

Intente reinstalar los drivers pero nada :tstress:, que me dicen? alguna de estas cosas les ha pasado a alguno de ustedes?, porque se fue todo a la basura de repente?, son la mayoria bugs con los que hay que "aprender a vivir" por el momento?.

Cuando instale por primera vez los drivers, no instale la version 6.8 del Xorg y conserve la que trae el suse 10.1, será que eso tuvo algo que ver con la estrepitosa caida de los drivers de ati en mi pc?

EDIT (6/08/2006): Luego de semanas de abandonar a SuSE volvi a instalar todo esta vez con los drivers 8.27.10, y todo marcha bien

[Apocalipsis]
26-jun-2006, 23:49
hola pelea: no se que he hecho mal, pero siempre, siempre que instalo sin importar que manual sigo :chillando no se me activa la aceleracion 3D de mi ATI ALL IN WONDER 9600
almenos la aceleracion 3D, pero hize el rpm para mi distro (suse 10.0) instalado los drivers automaticamente, configurandolos segun el manual, pero no he podino en ninguna ocacion hacerlo

bueno, si alguien ya lo hixo en una ati all in wonder 9600 se lo agradeceria mucho que me dijera como

Algun consejo?

de antemano muchisisisisissisisisisisisisisissisisisisisisisis isissisisisisisimas gracias :)

tomeu
27-jun-2006, 13:39
Ya volvieron a actualizar la versión del ATI driver a la 8.26.18 (https://support.ati.com/ics/support/default.asp?deptID=894&task=knowledge&folderID=27)

Pero por lo que veo no todas las actualizaciones son para mejor :negar:


ATI driver 8.25.18
tomeu@pctomeu:~> fglrxinfo
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9550 Generic
OpenGL version string: 2.0.5814 (8.25.18)

tomeu@pctomeu:~> glxgears
12974 frames in 5.0 seconds = 2594.749 FPS
13013 frames in 5.0 seconds = 2602.544 FPS
13008 frames in 5.0 seconds = 2601.555 FPS
13019 frames in 5.0 seconds = 2603.615 FPS
13017 frames in 5.0 seconds = 2603.283 FPS
tomeu@pctomeu:~> fgl_glxgears
Using GLX_SGIX_pbuffer
1898 frames in 5.0 seconds = 379.600 FPS
2014 frames in 5.0 seconds = 402.800 FPS
2089 frames in 5.0 seconds = 417.800 FPS
2076 frames in 5.0 seconds = 415.200 FPS
2081 frames in 5.0 seconds = 416.200 FPS

ATI driver 8.26.18
tomeu@pctomeu:~> fglrxinfo
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9550 Generic
OpenGL version string: 2.0.5879 (8.26.18)

tomeu@pctomeu:~> glxgears
12895 frames in 5.0 seconds = 2578.807 FPS
12926 frames in 5.0 seconds = 2585.104 FPS
12921 frames in 5.0 seconds = 2584.145 FPS
12930 frames in 5.0 seconds = 2585.902 FPS
12930 frames in 5.0 seconds = 2585.982 FPS

tomeu@pctomeu:~> fgl_glxgears
Using GLX_SGIX_pbuffer
1754 frames in 5.0 seconds = 350.800 FPS
2071 frames in 5.0 seconds = 414.200 FPS
2078 frames in 5.0 seconds = 415.600 FPS
2065 frames in 5.0 seconds = 413.000 FPS
2070 frames in 5.0 seconds = 414.000 FPS

DiabloRojo
27-jun-2006, 17:49
Pero por lo que veo no todas las actualizaciones son para mejor :negar: No entiendo lo que dices, y que son esas dos ventanas de CODE

tomeu
27-jun-2006, 19:12
No entiendo lo que dices, y que son esas dos ventanas de CODE
Las edito para mayor claridad: los resultados de FPS son un "pelo" menores con el driver 8.26.18 que con el anterior 8.25.18

alexrojas
03-jul-2006, 00:29
Se me ocurrio probar el nuevo SuSE Enterprise Desktop 10 y viendo gnome, se ve que trabajaron mucho en él, se ve muuy bien, solo que al instalar el driver de ATI pareciera que se instala (buenos graficos), pero al tratar de poner xgl, no funciona, así que me puse a ver que podría ser (ya que gdm si carga), y al probar glxinfo, me marca que no tiene direct rendering, he probado instalarlo varias veces y no logro que sea en = yes, como nota alterna he probado los ultimos drivers de ati 8.25.18 y6 8.26.18

alexrojas
05-jul-2006, 05:37
al parecer el error fue poner el nuevo driver, ya que ahora que he formateado y reinstalado SED10 meti el anterior driver y quedo bien!

KaLPo
11-jul-2006, 11:23
Esto es frustrante...

Bueno, de nuevo acudo a los expertos para que me enseñen a solucionar mis problemas:


# POSIX Shared Memory (/dev/shm) support is required for 3D apps
No se que es eso, lo siento pero no tengo ni papa. Si se refiere a tener el directorio (/dev/shm), lo tengo, sino, nose si lo tengo.


# glibc version 2.2 or 2.3
Tengo la version 2.4 y me he bajado la version 2.3 pero no se instalarla porque me viene en tar.gz


# Linux kernel 2.4 or higher
Eso va bien



# XOrg 6.7 or 6.8; XFree86 version 4.3
Imagino que habra que elegir uno de ambos, puesto que tengo en el pc de serie la 6.9 de xorg deberia intentar instalar la 6.8 pero no me deja desde un RPM. Asi que bueno, quiza haga alguna barvaridad de las mias asi que le he dado a instalar el XFree86 4.3 y se me bloqueo el pc...

Bueno, ¿Como puedo pasar este primer paso de requisitos minimos?

DiabloRojo
11-jul-2006, 18:51
Los requisitos no son FIJOS, es decir, que si tienes una version superior te vale, asi que repasa el tema y no te obsesiones si tus versiones son superiores a las que pide el driver.
En el 1º con ver que existe esa carpeta te vale.

tomeu
11-jul-2006, 19:32
Fíjate que el manual se hizo con la versión del driver 8.24.x y aunque los pasos a seguir son los mismos, actualmente el driver está en la versión 8.26.x

La versión de xorg que tengo creo que es la 6.9 ó la 7.0 (ahora no recuerdo pq estoy con wimblows :( ), el driver viene preparado para la última versión de xorg.

Lo de glibc, es como el kernel, la versión que indicada es de mínimos. Lo que tienes que revisar es el resto de paquetes de 32 bits necesarios de instalar si estás con un pc de 64 bits.

freezer27
15-jul-2006, 21:21
mi portatil tiene una ati mobility 9700, le puedo activar bien el 3d, pero cuando le pongo el XGL, me corre todo extremadamente lento, como cuando corro un juego y el 3d esta deshabilitado. En el centro de control me tira q mi tarjeta no está en la base de datos de XGL, pero lo puedo habilitar, aunq tengo el mismo problema q comenté antes.

Mi pregunta es, ¿será q nunca podré tener XGL en mi laptop? xq en la de escritorio tengo una NVidia y funciona de pelos.

PD. Mi laptop es una toshiba M30X y la ati mobility 9700 me la reconoce como ATI RV350 NP (en la lista de chipset soportados de ati por XGL no aparece este modelo). No se si talvez sacarán otra version de XGL donde la soporte... :scared:

Lord_Scarl
19-jul-2006, 07:46
me he leido este tema completo y tengo el problema de la mayoria todo sale bien, y al reiniciar mejora la apariencia pero sigue usando los drivers de mesa.org y me lanza este error:

[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Message] Kernel Module : Found kernel module build environment, generating kernel module now.
ATI module generator V 2.0
==========================
initializing...
Error:
kernel includes at /usr/src/linux/include do not match current kernel.
they are versioned as "2.6.13-15-default"
instead of "2.6.13-15.10-default".
you might need to adjust your symlinks:
- /usr/include
- /usr/src/linux
[Error] Kernel Module : Failed to compile kernel module - please consult readme.

he hecho todo lo que se me ocurre pero no lo puedo solucionar, agardeceria su ayuda, Saludos Gracias

DiabloRojo
19-jul-2006, 17:35
El kernel y el kernel-source NO son de la misma version. Igualalos.

Lord_Scarl
20-jul-2006, 03:11
los iguale y volvi a reinstalar el driver Ati, al poner fglrxinfo me sale lo mismo:

lord_scarl@linux:~> fglrxinfo
Xlib: extension "XFree86-DRI" missing on display ":0.0".
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)

la unica diferencia que note es en el centro de control de ati ahora si me puede dar la version del bios cosa que antes no

el cubo no me sale:
lord_scarl@linux:~> fglrxinfo
Xlib: extension "XFree86-DRI" missing on display ":0.0".
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)

y no tengo 3d, que mas me puede estar fallado?? adjunto mi archivo de fglrx-install.log por si en algun ratillo que tengan libre lo pudieran checar saludos y gracias, para el erchivo solo hay que BORRAR la extencion .zip :p

PD cada que vuelvo a instalar no debo primero desisntalar la instalacion anterior?? ya q no hice eso, si debo de hacaerlo como lo hago, desde yast que paquetes elimino, Saludos y Gracias de Nuevo :adios:

DiabloRojo
20-jul-2006, 17:02
Los errores son del compilador, verifica que cumples los requisitos minimos, miralos.

Lord_Scarl
21-jul-2006, 23:48
que tal, veras mi version de Xorg es 6.8.2
de kernel es 2.6.13-15.10default
de glibc es 2.3.5-40
de POSIX esa no se cual sea la version, me meti a la carpeta ahi aparece y me sale un archivo, y en Yast al poner POSIX sale como 8 paquetes, de los cuales tenia como 4 instalados, y prosegui a instalar los demas, y ni asi, luego atualice el kernel a la 2.6.13-15.11default y tampoco, agrego el archivo pero creo que es igual al anterior, el error los da en el MAKE, Saludos :adios:

DiabloRojo
22-jul-2006, 09:49
¿que estas intentando hacer?, ¿has seguido mi guia?, ¿en donde pone make?.

Los errores son de instrucciones del lenguaje c, etc... que no es mi fuerte.

Lord_Scarl
24-jul-2006, 05:57
si he seguido tu guia, y nunca dice nada de make, a lo que me refiero es que el archivo que pongo en el post anterior, al final del archivo, dice una linea:[Make] y es ahi donde dice el error, segun yo

DiabloRojo
24-jul-2006, 16:39
No soy experto en compilacion del driver, pero los mensajes son indicativos de ello, que falla por diversas variables, has comprobado de haber instalado toda la seleccion de "Compilador de C...", lo mismo con el kernel-souce, puedes hacerlo en Yast.

DarkT
27-jul-2006, 06:26
Hola gente, tengo exactamente el mismo problema que Tomeu. Ati 9200, instale el driver siguiendo los pasos del manual, al reiniciar, no puedo entrar al sax2 y tampoco tengo aceleracion. Si hago un Ctrl+Alt+F1, init 3, cuando pongo sax2 me sale lo siguiente:
SAX2: no X-server is running
SAX2: will start own server is needed.
Alguna sugerencia??

DiabloRojo
27-jul-2006, 16:56
No puede cargar el servidor grafico, te funcionaba antes o no.

DarkT
27-jul-2006, 19:08
me funcionaba antes de cargar el driver, creo que el error comenzó partir de la linea sax2 - r -m 0=fglrx, probé sax2 -r -a, pero ni modo ya que salta el mismo mensaje, tengo forma de por lo menos volver atrás?, porque como se ve ahora las fuentes de letra no me convencen

DarkT
27-jul-2006, 19:11
otro mensaje que aparece al ejecutar sax2: "ups lost card during probing... abort"

Lord_Scarl
28-jul-2006, 16:14
pss instale todo lo que me aparecio al poner Compliador C, todos los paquetes de QT y parece que mejoro esto me arroja el archivo fglrx-install.log:

[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Message] Kernel Module : Found kernel module build environment, generating kernel module now.
ATI module generator V 2.0
==========================
initializing...
cleaning...
assuming new VMA API since we do have kernel 2.6.x...
doing Makefile based build for kernel 2.6.x and higher
make -C /lib/modules/2.6.13-15.11-default/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules
make[1]: Entering directory `/usr/src/linux-2.6.13-15.11-obj/i386/default'
make -C ../../../linux-2.6.13-15.11 O=../linux-2.6.13-15.11-obj/i386/default modules
CC [M] /lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2137: aviso: se definió ‘deferred_flush’ pero no se usa
LD [M] /lib/modules/fglrx/build_mod/2.6.x/fglrx.o
Building modules, stage 2.
MODPOST
Warning: could not find /lib/modules/fglrx/build_mod/2.6.x/.libfglrx_ip.a.GCC4.cmd for /lib/modules/fglrx/build_mod/2.6.x/libfglrx_ip.a.GCC4
CC /lib/modules/fglrx/build_mod/2.6.x/fglrx.mod.o
LD [M] /lib/modules/fglrx/build_mod/2.6.x/fglrx.ko
make[1]: Leaving directory `/usr/src/linux-2.6.13-15.11-obj/i386/default'
build succeeded with return value 0
duplicating results into driver repository...
done.
==============================
- recreating module dependency list
- trying a sample load of the kernel modules
failed.
[Error] Kernel Module : Failed to install compiled kernel module - please consult readme.

AL CARGAR ME SALE LO MISMO DE MESA3D POR SIERTO EL DRIVER ES EL 8.25, OTRA COSA K NO ENTENDI FUE QUE AL APAGAR LA MAQUINA Y PRENDERLA AYER NO ENTRO KDE ME SALIA ALGO DE QUE NO ENCONTRABA KDEINIT, ABRI EN MODO A PRUEBA DE FALLO Y ME SALIA ESTO:

- bash-3.00$

no se si sea un error o k, entre con modo de windowmaker y abri yast y no entontre ningun paquete con el nombre de kdeinit ni nada parecido, solo volvi a intentar abrir Kde y ahora si jalo, Saludos

keops
29-jul-2006, 21:45
Hola,

Os traigo una noticia para los que somos usuarios de ATI.
Los chicos de SuSE con el visto bueno de los de ATI, han creado unos "rpm" especificos para SuSE (a partir de la versión 10.1) y SLED 10, (en esa versión ya viene "de fabrica").
Lo único que hay que hacer es añadir una dirección como repositorio al Yast y el se encargará de los paquetes.

Os dejo la dirección de donde he sacado eso, (no lo he provado en el SuSE 10.1 pero en el SLED 10 funciona).

http://www.suse.de/~sndirsch/ati-installer-HOWTO.html

Salu2.

Lord_Scarl
31-jul-2006, 06:25
pss lo logre al fin!!!!, :dedosarri , pongo como lo hice por si a alguien le sirve:

lo que hice fui abrir la terminal, ponerme como root y escribir
sax2 -r
te muestra unos codigos y luego parece que te saca a "init3" pero vuelve rapido y aparece la ventana de Sax2 y me configuro algo en el sax, sobre el monitor, mi monitor es un Samsung Syncmaster 551v y lo tenia como un Samsung v550 y al configurarlo el Sax2 lo puso como Sam Samsung Syncmaster, despues yo me meti a configurar el monitor y puse el tamaño en pulgadas y en mm (esto se cambia en la segunda pestaña) y en la pestaña donde estan las frecuencias puse las correspondientes, di Aceptar y luego al salir me pregunto si queria probar le puse que si y acomode la pantalla, y reinicie

ya reiniciada la letra se veia muy chica y no se veia muy bien, asi que abri terminal e hice exactamente lo que dice la guia de Diablorojo, solo k en vez de reiniciar solo cerre la sesion y cuando volvi a entrar ya funcionaba, asui pongo lo me arrojo la terminal:

al poner fglrxinfo:
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9250/9200 Series DDR Generic
OpenGL version string: 1.3.1091 (X4.3.0-8.27.6)

luego:

lord_scarl@linux:~> glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read,
GLX_SGIS_multisample, GLX_SGIX_fbconfig
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_ATI_pixel_format_float,
GLX_ATI_render_texture
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_multisample
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9250/9200 Series DDR Generic
OpenGL version string: 1.3.1091 (X4.3.0-8.27.6)
OpenGL extensions:
GL_ARB_multitexture, GL_EXT_texture_env_add, GL_EXT_compiled_vertex_array,
GL_S3_s3tc, GL_ARB_occlusion_query, GL_ARB_point_parameters,
GL_ARB_texture_border_clamp, GL_ARB_texture_compression,
GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
GL_ARB_texture_env_combine, GL_ARB_texture_env_crossbar,
GL_ARB_texture_env_dot3, GL_ARB_texture_mirrored_repeat,
GL_ARB_transpose_matrix, GL_ARB_vertex_blend, GL_ARB_vertex_buffer_object,
GL_ARB_vertex_program, GL_ARB_window_pos, GL_ATI_element_array,
GL_ATI_envmap_bumpmap, GL_ATI_fragment_shader, GL_ATI_map_object_buffer,
GL_ATI_texture_env_combine3, GL_ATI_texture_mirror_once,
GL_ATI_vertex_array_object, GL_ATI_vertex_attrib_array_object,
GL_ATI_vertex_streams, GL_ATIX_texture_env_combine3,
GL_ATIX_texture_env_route, GL_ATIX_vertex_shader_output_point_size,
GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color, GL_EXT_blend_func_separate,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_clip_volume_hint,
GL_EXT_draw_range_elements, GL_EXT_fog_coord, GL_EXT_multi_draw_arrays,
GL_EXT_packed_pixels, GL_EXT_point_parameters, GL_EXT_rescale_normal,
GL_EXT_secondary_color, GL_EXT_separate_specular_color,
GL_EXT_stencil_wrap, GL_EXT_texgen_reflection, GL_EXT_texture3D,
GL_EXT_texture_compression_s3tc, GL_EXT_texture_cube_map,
GL_EXT_texture_edge_clamp, GL_EXT_texture_env_combine,
GL_EXT_texture_env_dot3, GL_EXT_texture_filter_anisotropic,
GL_EXT_texture_lod_bias, GL_EXT_texture_mirror_clamp,
GL_EXT_texture_object, GL_EXT_texture_rectangle, GL_EXT_vertex_array,
GL_EXT_vertex_shader, GL_HP_occlusion_test, GL_NV_blend_square,
GL_NV_occlusion_query, GL_NV_texgen_reflection, GL_SGI_color_matrix,
GL_SGIS_generate_mipmap, GL_SGIS_texture_border_clamp,
GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod, GL_SUN_multi_draw_arrays
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x23 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 1 0 Slow
0x24 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 1 0 Slow
0x25 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 1 0 Slow
0x26 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 1 0 Slow
0x27 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 1 0 None
0x28 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 1 0 None
0x29 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 1 0 None
0x2a 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 1 0 None
0x2b 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 1 0 Slow
0x2c 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 1 0 Slow
0x2d 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 1 0 Slow
0x2e 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 1 0 Slow
0x2f 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 1 0 None
0x30 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 1 0 None
0x31 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 1 0 None
0x32 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 1 0 None

lord_scarl@linux:~> glxgears
4838 frames in 5.0 seconds = 967.600 FPS
5784 frames in 5.0 seconds = 1156.800 FPS
5772 frames in 5.0 seconds = 1154.400 FPS
5775 frames in 5.0 seconds = 1155.000 FPS
5771 frames in 5.0 seconds = 1154.200 FPS
5786 frames in 5.0 seconds = 1157.200 FPS
5776 frames in 5.0 seconds = 1155.200 FPS
5775 frames in 5.0 seconds = 1155.000 FPS
7285 frames in 5.0 seconds = 1457.000 FPS

lord_scarl@linux:~>
lord_scarl@linux:~> fgl_glxgears
Using GLX_SGIX_pbuffer
632 frames in 5.0 seconds = 126.400 FPS
634 frames in 5.0 seconds = 126.800 FPS
817 frames in 5.0 seconds = 163.400 FPS
795 frames in 5.0 seconds = 159.000 FPS
828 frames in 5.0 seconds = 165.600 FPS
lord_scarl@linux:~> fgl_glxgears
Using GLX_SGIX_pbuffer
lord_scarl@linux:~> lsmod | grep fglrx
fglrx 391596 8
agpgart 33096 2 fglrx,via_agp
lord_scarl@linux:~> lsmod | grep agp
via_agp 9472 1
agpgart 33096 2 fglrx,via_agp


solo los 2 primeros engranes salieron muy lentos, y el cubo me muestra solo el cubo k gira, y en los datos se ve el rendimiento inferior al de Diablorojo, eso si no se si sea por k mi maquina es ya un poco vieja :p o si algo no se instalo bien, Saludos :adios:

PD la maquina es AMD +2000 640 mb ram, Ati radeon 9200, 2 discos de 40 gb

tomeu
31-jul-2006, 16:06
Gracias por la Información. Y en OpenSuse_10.1 también funciona.

Ahora bien, no basta con instalarlo con YaST y reiniciar, además hay que hacer lo siguiente, tras reiniciar:


init 3

sax2 -r -m 0=fglrx

init 5


Por cierto, la versión de fglrx que se instala con el rpm es la 8.26.18, y desde ayer ya sacaron la versión 8.27.10 (los que sufran "versionitis" deberán seguir este manual)

pablogp
07-ago-2006, 13:49
He seguido la guia, pero no lo he conseguido, porque podra ser ¿? y con
lsmod | grep fglrx no sale nada :S



pablo@linux:~> fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.4.1)

pablo@linux:~> glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read,
GLX_SGIS_multisample, GLX_SGIX_hyperpipe, GLX_SGIX_swap_barrier,
GLX_SGIX_fbconfig
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_ATI_pixel_format_float,
GLX_ATI_render_texture
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_multisample
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.4.1)
OpenGL extensions:
GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
GL_EXT_texture_lod_bias

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x23 24 tc 0 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 1 0 None
0x24 24 tc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 1 0 None
0x25 24 tc 0 32 0 r y . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
0x26 24 tc 0 32 0 r . . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
0x27 24 dc 0 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 1 0 None
0x28 24 dc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 1 0 None
0x29 24 dc 0 32 0 r y . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
0x2a 24 dc 0 32 0 r . . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
pablo@linux:~> lsmod | grep fglrx


thx y salu2,


edito:
He hecho lo que a mencionado tomeu en el post anterior, por sigo sin tener aceleracion 3d, lo unico que ahora la casilla de aceleracion 3d en el panel de control de yast (t.grafica y monitor) sale como si tendria,,,,
¿sera por eso de la version de xorg que comentais? como miro la version que tengo ¿?
por cierto tengo la version 10.1 de openSuse, y no he realizado ninguna actualizacion al menos no soy consciente de haberlo hecho :S

DiabloRojo
07-ago-2006, 14:27
He seguido la guia, pero no lo he conseguido, porque podra ser ¿? y con
lsmod | grep fglrx no sale nada :SSi ni sale nada es que parece ser que no es tu driver, que marca y modelo de tarjeta tienes.

pablogp
07-ago-2006, 15:07
es una Asus Radeon 9800XT/TVD

xuo
07-ago-2006, 16:02
Hola, soy nuevo.

Llevo poco tiempo con Suse 10.1 y no controlo casi nada pero bueno.

tengo una ati 9550 y he seguido los pasos de instalacion en la primera pagina pero con esta version de drivers ati-driver-installer-8.27.10-x86.run pero no consigo hacer funcionar el soporte·3D, ahora mismo lo he vuelto a desinstalar.

He comprobado los requisitos de instalacion y los cumplo. Tengo la version 6.9.0 de Xorg

Puede que deba cambiar algo antes de volver a instalar o desisto? :negar:

Si debo comprobar algo antes de comenzar la instalacion me comentais, si no empezare de nuevo y me pedis lo q sea.

Un saludo

DiabloRojo
07-ago-2006, 20:54
es una Asus Radeon 9800XT/TVDEntonces es tu driver, lo raro es que no se ha instalado correctamnete ya que no te sale por medio de "lsmod | grep fglrx" , mira los mensajes del sistema: "dmesg | grep fglrx". Aplicable tambien para xuo.

xuo
08-ago-2006, 00:43
vamos a ver, he vuelto a instalar los drivers.
pego los mensajes de la consola.

______________________________
# sh ./ati-driver-installer-8.27.10-x86.run
Creating directory fglrx-install
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.27.10........................................... .................................................. ...............
==================================================
ATI Technologies Linux Driver Installer/Packager
==================================================
Detected configuration:
Architecture: i686 (32-bit)
X Server: Xorg 6.9.0
Removing temporary directory: fglrx-install

______________________________
# /usr/X11R6/bin/aticonfig --initial
Uninitialised file found, configuring.
generate load 'dri' module
Using /etc/X11/xorg.conf
Saved back-up to /etc/X11/xorg.conf.original-3

______________________________
# /usr/X11R6/bin/aticonfig --overlay-type=Xv
Warning: Option 'VideoOverlay' doesn't affect running session.
Warning: Option 'OpenGLOverlay' doesn't affect running session.
Using /etc/X11/xorg.conf
Saved back-up to /etc/X11/xorg.conf.fglrx-5

_______________________________
# fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.4.1)

________________________________
~> lsmod | grep fglrx
no muestra nada

~> lsmod | grep agp
nvidia_agp 7324 1
agpgart 28976 1 nvidia_agp

~> dmesg | grep fglrx
no muestra nada



Bueno sigo sin compatibilidad 3D, voy a ajustar la resolucion de la pantalla. Espero no haber escrito nada mal pero la resolucion de pantalla es demasiado grande.

Un saludo

xuo
08-ago-2006, 01:04
ya he escrito un post en el que explico los pasos de instalacion, ahora al cambiar la resolucion y reiniciar el equipo no me entra en modo grafico.

al hacer startx me aparece un mensaje como q no detecta ninguna pantalla.

me quedo en windows hasta q me aconsejeis como seguir.

un saludo

DiabloRojo
08-ago-2006, 08:32
# /usr/X11R6/bin/aticonfig --initial
Uninitialised file found, configuring.
generate load 'dri' module No se ha cargado el modulo.
No se como aconsejarte ya que no tengo los mensajes de error de la instalacion, debe estar en /var/log pero no se como se llamara el fichero.

No obstante, puedes usar linux con el driver generico de X para ati, llamado radeon.
sax2 -m 0=radeon

xuo
09-ago-2006, 15:41
gracias DiabloRojo!

he vuelto al modo grafico y ya he dejado todo como en principio sin drivers.

vuelvo a probar si es posible hacerlo funcionar o desisto??

lo de no entrar en modo grafico no me habia pasado hasta ahora tras instalar los drivers.

un saludo

DiabloRojo
09-ago-2006, 22:27
Esperate a la proxima version.

xuo
09-ago-2006, 23:10
ya habia pensado en si el proximo driver me servirá o no :scratchch

de todas formas gracias por la ayuda prestada, en windows me atrevo a meter mano a todo pero en linux aun me falta experiencia y voy poco a poco.

gracias por la ayuda prestada y la futura q seguro llega.

un saludo

pablogp
11-ago-2006, 20:28
pues tampoco me sale nada -_-


pablo@linux:~> su
Contraseña:
linux:/home/pablo # dmesg|grep fglrx
linux:/home/pablo #

el driver que instale es el 8.27.10
¿sera eso de la version del xorg? q por cierto nose cual es la version que tengo que comando hay que poner en la terminal para verlo?
salu2, y thx

randu
11-ago-2006, 21:54
yo tengo el mismo problema que xuo, despues de instalar el driver sigue mostrando el mesa y no el ati,

bueno la verdad pues no se mucho de linux, pero por ahy en un tutorial me dicen que tengo que recompilar e instalar el fglrx kernel module que es eso o como lo hago

DiabloRojo
12-ago-2006, 09:15
Si no se instala el fglrx, mal asunto.

Cuando tenga un tiempo, instalare el nuevo driver de ATI en mi PC y mandare un mensaje diciendo si se ha instalado o no y como se soluciona.

[Apocalipsis]
14-ago-2006, 02:20
bueno yo tengo una duda muy boba , ya llevo mas de 3 meses constantemente tratando de instalar con las versiones que han salido con los requerimientos que han pedido y con sus respectivos comando en muchas compbinaciones de tutoriales pero lo unico que no he hecho y me tiene confundido es algo muy tonto
hay varios packages que se pueden hacer en mi caso con novell suse 10 y estou usando el driver 8.27 que no deja hacer el comando ./ati-driver...... --get.....
la pregunta es:
al tener novell suse 10.0 como hago para saber si es SLED SLED u otra? porque el paquete que siempre se genera es el suse10-ia32 o algo asi pero hay otrso que son sles sled y resto de cosas asi que depronto por ahi estaria haciendo algo mal
creoq ue opensuse y novell suse son algo direfente o no?
alguien que porfa me responda por que es lo unico que necesito para borrar completamente a winbug xp
tengo ati radeon all in wonder 9600 pero no me importa lo de capturar solo la aceleracion

de antemano muchisimas gracias

randu
21-ago-2006, 18:02
']bueno yo tengo una duda muy boba , ya llevo mas de 3 meses constantemente tratando de instalar con las versiones que han salido con los requerimientos que han pedido y con sus respectivos comando en muchas compbinaciones de tutoriales pero lo unico que no he hecho y me tiene confundido es algo muy tonto
hay varios packages que se pueden hacer en mi caso con novell suse 10 y estou usando el driver 8.27 que no deja hacer el comando ./ati-driver...... --get.....
la pregunta es:
al tener novell suse 10.0 como hago para saber si es SLED SLED u otra? porque el paquete que siempre se genera es el suse10-ia32 o algo asi pero hay otrso que son sles sled y resto de cosas asi que depronto por ahi estaria haciendo algo mal
creoq ue opensuse y novell suse son algo direfente o no?
alguien que porfa me responda por que es lo unico que necesito para borrar completamente a winbug xp
tengo ati radeon all in wonder 9600 pero no me importa lo de capturar solo la aceleracion

de antemano muchisimas gracias


bueno en primer lugar el SLED y el SLES es la d indica desktop y la s server al final de las siglas,

una pregunta tu tienen una maquina de 64bits o es de 32, porque si es de 32 es mejor bajar el otro driver el i386 y ese no coloca problemas, eso depende de la arquitectura, y aunque dicen que el de 86_64 funciona para 32 y 64 bits, a veces
saca error y no compila cuando uno trata de hacerlo para 32 bits, a mi me paso,

DiabloRojo
03-sep-2006, 12:20
El manual sigue siendo valido para la version 8.28.8 del driver llamado "ati-driver-installer-8.28.8.run", aunque aviso que ha empeorado los FPS y/o frames de los comandos de evaluacion con respecto a la 8.24.8, ver 1er. post de este tema:

leches@linux-mq7y:~> glxgears
1525 frames in 5.0 seconds = 304.857 FPS
1569 frames in 5.0 seconds = 313.779 FPS
1337 frames in 5.0 seconds = 267.192 FPS
1263 frames in 5.0 seconds = 252.594 FPS
1262 frames in 5.0 seconds = 252.392 FPS
1264 frames in 5.0 seconds = 252.794 FPS
leches@linux-mq7y:~> fgl_glxgears
Using GLX_SGIX_pbuffer
2391 frames in 5.0 seconds = 478.200 FPS
2894 frames in 5.0 seconds = 578.800 FPS
2432 frames in 5.0 seconds = 486.400 FPS
2372 frames in 5.0 seconds = 474.400 FPS
2386 frames in 5.0 seconds = 477.200 FPS
2411 frames in 5.0 seconds = 482.200 FPS

KaLPo
04-sep-2006, 11:29
Al instalar el driver me fastidia el visionado de TV... he instalado mal el river o es normal?

DiabloRojo
04-sep-2006, 17:29
Eso pasa en algunos usuarios, segun he leido por ahi. Prueba usar el VESA si funcione reinstala el driver de ati y si sigue igual, ya lo sabes. Habra que buscar en San Google por si hay una solucion.

Epifumi
05-sep-2006, 23:20
Mirando los valores de Diablorojo y comparandolos con los mios creo que tengo un problema con la aceleracion 2D.


epifumi@linux:~> glxgears
2184 frames in 5.0 seconds = 436.800 FPS
2540 frames in 5.0 seconds = 508.000 FPS
2538 frames in 5.0 seconds = 507.600 FPS
2572 frames in 5.0 seconds = 514.400 FPS
2338 frames in 5.0 seconds = 467.600 FPS
epifumi@linux:~> fgl_glxgears
Using GLX_SGIX_pbuffer
4270 frames in 5.0 seconds = 854.000 FPS
4827 frames in 5.0 seconds = 965.400 FPS
4880 frames in 5.0 seconds = 976.000 FPS
4886 frames in 5.0 seconds = 977.200 FPS
4837 frames in 5.0 seconds = 967.400 FPS
4864 frames in 5.0 seconds = 972.800 FPS


Tengo una Ati X800 GTO con el driver 8.27.10

¿que ocurre?

DiabloRojo
06-sep-2006, 18:20
Ni idea. San Google que te dice.

Epifumi
06-sep-2006, 23:02
Comparando los datos de DiabloRojo con los dos drivers

8.24.8
diablorojo@linux:~> glxgears
16194 frames in 5.0 seconds = 3238.800 FPS
19901 frames in 5.0 seconds = 3980.200 FPS
51285 frames in 5.0 seconds = 10257.000 FPS
56872 frames in 5.0 seconds = 11374.400 FPS

diablorojo@linux:~> fgl_glxgears
Using GLX_SGIX_pbuffer
2547 frames in 5.0 seconds = 509.400 FPS
2871 frames in 5.0 seconds = 574.200 FPS
2871 frames in 5.0 seconds = 574.200 FPS
2862 frames in 5.0 seconds = 572.400 FPS

8.28.8

leches@linux-mq7y:~> glxgears
1525 frames in 5.0 seconds = 304.857 FPS
1569 frames in 5.0 seconds = 313.779 FPS
1337 frames in 5.0 seconds = 267.192 FPS
1263 frames in 5.0 seconds = 252.594 FPS
1262 frames in 5.0 seconds = 252.392 FPS
1264 frames in 5.0 seconds = 252.794 FPS
leches@linux-mq7y:~> fgl_glxgears
Using GLX_SGIX_pbuffer
2391 frames in 5.0 seconds = 478.200 FPS
2894 frames in 5.0 seconds = 578.800 FPS
2432 frames in 5.0 seconds = 486.400 FPS
2372 frames in 5.0 seconds = 474.400 FPS
2386 frames in 5.0 seconds = 477.200 FPS
2411 frames in 5.0 seconds = 482.200 FPS

Y los mios con el 8.27.10

epifumi@linux:~> glxgears
2184 frames in 5.0 seconds = 436.800 FPS
2540 frames in 5.0 seconds = 508.000 FPS
2538 frames in 5.0 seconds = 507.600 FPS
2572 frames in 5.0 seconds = 514.400 FPS
2338 frames in 5.0 seconds = 467.600 FPS
epifumi@linux:~> fgl_glxgears
Using GLX_SGIX_pbuffer
4270 frames in 5.0 seconds = 854.000 FPS
4827 frames in 5.0 seconds = 965.400 FPS
4880 frames in 5.0 seconds = 976.000 FPS
4886 frames in 5.0 seconds = 977.200 FPS
4837 frames in 5.0 seconds = 967.400 FPS
4864 frames in 5.0 seconds = 972.800 FPS

... hay algo que no me cuadra

¿como puede ser que con los 8.24 el valor del glxgears sea 10 veces superior al del 8.28?

Ademas, si comparamos los de DiabloRojo con el 8.28 y los mios con el 8.27 vemos que existe una porporción entre los valores 2D y 3D (casi el doble) mientras que los primeros datos aportados (con los drivers mas viejos) esa proporción es de una sexta parte.

¿hay algun error en los datos?

Otra medidión de los mios dan un resultado parecido al de ayer

epifumi@linux:~> glxgears
2715 frames in 5.0 seconds = 543.000 FPS
2625 frames in 5.0 seconds = 525.000 FPS
2589 frames in 5.0 seconds = 517.800 FPS
2589 frames in 5.0 seconds = 517.800 FPS
2590 frames in 5.0 seconds = 518.000 FPS
2568 frames in 5.0 seconds = 513.600 FPS
epifumi@linux:~> fgl_glxgears
Using GLX_SGIX_pbuffer
4208 frames in 5.0 seconds = 841.600 FPS
4995 frames in 5.0 seconds = 999.000 FPS
5043 frames in 5.0 seconds = 1008.600 FPS
5034 frames in 5.0 seconds = 1006.800 FPS
5006 frames in 5.0 seconds = 1001.200 FPS
5023 frames in 5.0 seconds = 1004.600 FPS

He buscado en google y con una tarjeta algo superior a la mia el glxgears da valores sobre los 10.000 FPS con el 8.24.8.

¿hay algun bug en el valor que aporta glxgears o en los drivers posteriores?

¿Podeis poner vuestros valores de glxgears?

icomputo
17-sep-2006, 18:25
hola que tal.

acabo de instalar kernel-source

pero me sigue saliendo el mimso error.

"Found fglrx primary device section"



saludos
gracias

pakomirlob
18-sep-2006, 18:37
Hola

Después de mucho batallar con la configuración de mi tarjeta ati radeon xpress 200m, por fin la pude configurar, esto lo hice mas o menos hace un mes, nadamas que no había tenido tiempo de poner la solución., Y sin mas preámbulos aquí les comento mi problema y mi solución:

Instalaba el manual de DiabloRojo y todo lo hacia sin ningún problema nadamas que al reiniciar me mandaba una bonita pantalla negra. Y bueno buscándole encontré en un foro que las lap-tops de la marca hp serie zv6000, marcan este mismo problema y se puede solucionar de la siguiente manera:

1.- Reinicias tu pc
2.- Entras al bios
3.- Te metes a la pestaña de Advanced
4.- Cambias la opcion Sideport por Sideport + Uma
5.- le compartes 128 mg o 256mb, según sea el tamaño de tu tarjeta o el de tu memoria ram
6.- Reinicias
7.- listo

Si esto no te funciona entonces cambias el paso 4 por el siguiente:
4.- Cambias la opción Sideport + Uma por Uma

Y continúas con los pasos anteriores.

Creo que también funciona con las lap-top marca Compaq pero la verdad no me consta, espero le sirva a alguien así como a mí.

Bueno ahora les comento un problema que tengo:
Bueno todo lo que batalle con mi tarjeta de aceleración de gráficos fue nadamas por poder instalar el xgl y bueno ya lo he logrado pero me desconfigura la aceleración grafica, es decir funciona pero ya no tengo aceleración grafia.
Cuando pongo el comando glxinfo | more, en la opcion direct rendering: me marca que no y me gasta muchisima memoria ram

Quisiera que alguien que aya configurado una tarjeta similar me ayude para poder tener este fantastico programa y que funcione sin ningun problema, y bueno pasando a otra cosa.
Alguien conoce juegos de accion 3d para suse Linux, para aprobechar mi batalla con la ati?

Saludos a todos y gracias por su ayuda.

korsh
20-sep-2006, 20:34
Hola, a mí también me pasa que, aunque está activada, no tengo aceleración 3D. He probado el fglrxinfo y esto es lo que me pone:

Xlib: connection to ":0.0" refused by server
Xlib: Invalid MIT-MAGIC-COOKIE-1 key
Error: unable to open display :0

Con glxinfo y glxgears me pone:

Error: unable to open display (null)

He estado mirando en los posts y buscando por el foro pero no sé qué tengo que hacer.

Roy
24-sep-2006, 19:19
Hola que tal yo lo he hecho de otra manera, solo agregue la repositorio de ati, por el yast (que gracias al smarth ya funciona :p )

Y me fue bastante bien con los:



zeth@linux:~> fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Radeon X1600 Series Generic
OpenGL version string: 2.0.5879 (8.26.18)

zeth@linux:~> glxgears
13714 frames in 5.0 seconds = 2742.739 FPS
13780 frames in 5.0 seconds = 2755.858 FPS
13778 frames in 5.0 seconds = 2755.572 FPS
zeth@linux:~> fgl_glxgears
Using GLX_SGIX_pbuffer
2763 frames in 5.0 seconds = 552.600 FPS
2777 frames in 5.0 seconds = 555.400 FPS
2775 frames in 5.0 seconds = 555.000 FPS
2773 frames in 5.0 seconds = 554.600 FPS
zeth@linux:~>

Saludos

xuo
27-sep-2006, 00:26
Por fin puedo disfrutar de la aceleracion 3D en mi suse.

Gracias a DiabloRojo por todas las molestias causadas anteriormente y Tomeu por las instrucciones de este post: http://www.forosuse.org/forosuse/showthread.php?t=7944

Al final opte por agregar los repositorios en Yast e instalar x11-video-fglrx y ati-fglrx-kmp, reinicie el equipo y todo estaba perfecto.

Un saludo :adios:

arlick
28-sep-2006, 00:59
hola, supongo que este tema ya esta muy tocado pero tengo una complicacion.

Tras muchos meses e intentos de instalar los drivers de ati lo he conseguido!!!

Gracias DiabloRojo, pero tengo un problema que no se como solucionar.
Cuando miras a ver que modulos se han cargado hay un modulo que no seme carga (o eso creo que es), el "agpgart". (lsmod | grep agp = 'null' )

No se exactamente que es esto, lo he estado buscando en San google pero aunque he encontrado informacion sobre ello, no la he encontrado sobre como cargarlo.

a que se debe??

Ademas:

alvaro@linux:~> fgl_glxgears
Using GLX_SGIX_pbuffer
2644 frames in 5.0 seconds = 528.800 FPS
3203 frames in 5.0 seconds = 640.600 FPS
3199 frames in 5.0 seconds = 639.800 FPS
3193 frames in 5.0 seconds = 638.600 FPS
3172 frames in 5.0 seconds = 634.400 FPS

alvaro@linux:~> glxgears
15394 frames in 5.0 seconds = 3078.283 FPS
15495 frames in 5.0 seconds = 3098.826 FPS
15078 frames in 5.0 seconds = 3015.421 FPS

Me parece que los graficos 2d me van bien, pero los 3d de culo.
Otro problema añadido es que aunque he seguido manuales sobre como instalar xgl no lo he conseguido, esto solo es un dato porque de momento he desistido de seguir intentando instalarlo.

uso radeon x700, amd64, kernel 2.6.16.21.
lo que no se es si tengo bien puestos los drivers de la placa madre, esto puede tener algo que ver??

DiabloRojo
28-sep-2006, 18:21
Y el glxinfo?

icomputo
28-sep-2006, 22:04
Hola de nuevo.

con la novedad que ya no esta instalado de nuevo =S que rarro. :scared:

lo intente instalar otra ves. Se instalo todo bien a la hora de hacer:


linux:/ # /usr/X11R6/bin/aticonfig --initial
Found fglrx primary device section
Nothing to do, terminating.


linux:/ # /usr/X11R6/bin/aticonfig --overlay-type=Xv
Warning: Option 'VideoOverlay' doesn't affect running session.
Warning: Option 'OpenGLOverlay' doesn't affect running session.
Using /etc/X11/xorg.conf
Saved back-up to /etc/X11/xorg.conf.fglrx-5


me salen esos errores lo cual no me deja configurar. :scratchch


por otro lado.

Roy puedes esplicar como lo has hecho?

saludos
gracias.

arlick
29-sep-2006, 17:57
Hola DiabloRojo, ahora no estoy en mi suse asi que no te pudo dar la salida exacta, pero si lo unico que necesitas saber es si el direct rendering esta puesto la respuesta es si.

Otra cosa, por si tal vez ayuda. he probado a desinstalar y reinstalar los drivers un par de veces pero cuando hago: aticonfig --initial me dice que ya existe una seccion con el modulo fglrx.

Lo que quiero es borrar por completo la configuracion del antiguo driver para meter el nuevo desde cero, tambien cuando tenga un rato probare a hacerlo con distintas versiones del driver.

Un saludo y gracias por contestar.

chaparro2001
01-oct-2006, 12:04
buenas de nuevo. veamos e seguido la guia paso a paso para la intalacion de un x1400 y bien: el driver se intala y y todas las pruebas que ponen en la quia son positivas solo que cuando me meto en sax2 me sigue apareciendo la tarjeta grafica como una vesa y sin aceleracion 3d claro esta. que puedo hacer

DiabloRojo
01-oct-2006, 12:50
Da la informacion de los comandos de lsmod de mi 1er post, mas la salida de "dmesg | grep fglrx" y el contenido de /var/log/Xorg.0.log.

chaparro2001
01-oct-2006, 13:20
portatil:/home/chaparro # lsmod
Module Size Used by
michael_mic 6400 1
arc4 5888 1
ieee80211_crypt_tkip 13440 1
aes 31936 1
ieee80211_crypt_ccmp 10624 1
af_packet 28296 2
fglrx 399180 8
xt_pkttype 5760 5
ipt_LOG 9856 16
xt_limit 6528 16
cpufreq_ondemand 10632 2
cpufreq_userspace 8448 0
cpufreq_powersave 5760 0
speedstep_centrino 11184 1
freq_table 8448 1 speedstep_centrino
edd 12484 0
eeprom 10768 0
snd_pcm_oss 47104 0
snd_mixer_oss 20480 1 snd_pcm_oss
snd_seq 53360 0
snd_seq_device 11916 1 snd_seq
button 10640 0
battery 13444 0
ac 8964 0
ip6t_REJECT 8960 3
xt_tcpudp 7040 22
ipt_REJECT 9216 3
xt_state 6016 16
iptable_mangle 6656 0
iptable_nat 11652 0
ip_nat 20268 1 iptable_nat
iptable_filter 6912 1
ip6table_mangle 6272 0
ip_conntrack 49880 3 xt_state,iptable_nat,ip_nat
nfnetlink 10264 2 ip_nat,ip_conntrack
ip_tables 16196 3 iptable_mangle,iptable_nat,iptable_filter
ip6table_filter 6656 1
ip6_tables 17604 2 ip6table_mangle,ip6table_filter
x_tables 16388 10 xt_pkttype,ipt_LOG,xt_limit,ip6t_REJECT,xt_tcpudp, ipt_REJECT,xt_state,iptable_nat,ip_tables,ip6_tabl es
ipv6 242272 15 ip6t_REJECT
apparmor 53144 0
aamatch_pcre 17408 1 apparmor
nls_utf8 6016 1
ntfs 201364 1
loop 19080 0
dm_mod 57936 0
usbhid 44640 0
hw_random 9496 0
ipw3945 173600 1
ohci1394 34224 0
intel_agp 24988 1
agpgart 33352 2 fglrx,intel_agp
snd_hda_intel 21652 5
ieee1394 93880 1 ohci1394
snd_hda_codec 137856 1 snd_hda_intel
i8xx_tco 11032 0
ieee80211 32968 1 ipw3945
ieee80211_crypt 9728 3 ieee80211_crypt_tkip,ieee80211_crypt_ccmp,ieee8021 1
uhci_hcd 32400 0
snd_pcm 86788 4 snd_pcm_oss,snd_hda_intel,snd_hda_codec
snd_timer 25860 3 snd_seq,snd_pcm
snd 57092 16 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_seq_device,s nd_hda_intel,snd_hda_codec,snd_pcm,snd_timer
soundcore 13024 1 snd
snd_page_alloc 13576 2 snd_hda_intel,snd_pcm
firmware_class 13952 1 ipw3945
i2c_i801 12044 0
ehci_hcd 31880 0
i2c_core 24064 2 eeprom,i2c_i801
b44 27148 0
mii 9088 1 b44
usbcore 116612 4 usbhid,uhci_hcd,ehci_hcd
reiserfs 217856 2
fan 8580 0
thermal 17416 0
processor 31208 2 speedstep_centrino,thermal
sr_mod 18596 0
cdrom 36512 1 sr_mod
sg 35996 0
ata_piix 14212 4
libata 69776 1 ata_piix
sd_mod 20352 5
scsi_mod 128008 4 sr_mod,sg,libata,sd_mod


portatil:/home/chaparro # dmesg | grep fglrx
fglrx: module not supported by Novell, setting U taint flag.
fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
[fglrx] Maximum main memory to use for locked dma buffers: 1898 MBytes.
[fglrx] module loaded - fglrx 8.29.6 [Sep 19 2006] on minor 0
[fglrx:drm_parse_option] *ERROR* "agplock" is not a valid option
[fglrx] Maximum main memory to use for locked dma buffers: 1898 MBytes.
[fglrx] total GART = 134217728
[fglrx] free GART = 118226944
[fglrx] max single GART = 118226944
[fglrx] total LFB = 127889408
[fglrx] free LFB = 119697408
[fglrx] max single LFB = 119697408
[fglrx] total Inv = 0
[fglrx] free Inv = 0
[fglrx] max single Inv = 0
[fglrx] total TIM = 0

chaparro2001
01-oct-2006, 13:38
buenas de nuevo, e posteado ya 3 veces oo mismo pero no me aparece no se porque pero bueno..... aqui te dejo de nuevo dos archivos uno con la salida de los comandos y el otro del xorg venga gracias.

DiabloRojo
01-oct-2006, 14:00
[fglrx:drm_parse_option] *ERROR* "agplock" is not a valid option Este es el error, hay que buscarlo en http://www.rage3d.com, date de alta.
Como este http://www.rage3d.com/board/showthread.php?t=33850077 hay mas para mirar.

chaparro2001
01-oct-2006, 15:42
hola de nuevo unas consultillas como puedo comprobar esto:

If a Linux 2.6.11 or newer kernel was built with CONFIG_AGP enabled, the kernel AGP frontend is required to load the fglrx kernel module. To identify whether your kernel was built with CONFIG_AGP enabled, look for CONFIG_AGP=y in the kernel config file, or if the 'agpgart' module loaded

y esto

In order to use the fglrx internal AGP support, you have to make sure that the kernel agpgart support is not active, i.e. it is not compiled into the kernel and the kernel modules are not loaded. If the fglrx kernel module detects that the kernel agpgart support is active, it will automatically use that even if its internal AGP support is requested in order to avoid conflicts that can cause problems under some circumstances.


haber si me podeis echar una manilla y gracias de antemano :)

DiabloRojo
01-oct-2006, 16:40
Eso es para compilar el nuevo kernel, mejor busca la solucion al error por San Google.

chaparro2001
04-oct-2006, 20:18
veamos, tras aver intentado un par de cosas y un problemilla pue e vuelto a instalar todo de nuevo y ahora sale esto:

PORTATIL:/home/chaparro2001 # dmesg | grep fglrx
fglrx: module not supported by Novell, setting U taint flag.
fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERM ANY' taints kernel.
[fglrx] Maximum main memory to use for locked dma buffers: 1898 MBytes.
[fglrx] module loaded - fglrx 8.29.6 [Sep 19 2006] on minor 0
[fglrx] total GART = 134217728
[fglrx] free GART = 118226944
[fglrx] max single GART = 118226944
[fglrx] total LFB = 127889408
[fglrx] free LFB = 119697408
[fglrx] max single LFB = 119697408
[fglrx] total Inv = 0
[fglrx] free Inv = 0
[fglrx] max single Inv = 0
[fglrx] total TIM = 0
PORTATIL:/home/chaparro2001 #

DiabloRojo
05-oct-2006, 17:56
No veo ningun error, en el fichero /var/log/Xorg.0.log ¿hay alguno?.
cat /var/log/Xorg.0.log | grep '(EE)'

juankarlos
05-oct-2006, 19:49
He instalado los controladores tal y como se indica y he seguido todos los pasos, pero al reiniciar, el monitor se apaga. Se que suena raro, pero es así. Se apaga sin mas.
¿A alguien más le pasa, o soy el único que tiene ese problema?

DiabloRojo
06-oct-2006, 19:25
Busca en el foro por frecuencias verticales y horizontales...

alekzander
16-oct-2006, 19:52
(EE) No devices detected.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
at http://wiki.X.Org


No te detecta la tarjeta grafica y aparte la tarjeta es muy vieja, estas seguro de que es el drive adecuado.
yo tengo una portatil compaq armada e-500 PIII 700MHz 256 en RAM con una ATI RAGE Mobility pero no consigo activar la aceleracion 3D con el XP si de hecho una vez ejecute el emulador project64 me gustaria activarla en linux

tomeu
16-oct-2006, 20:28
¿Y tu crees que tu tarjeta admite el driver fglrx?
Linux Driver FAQ (http://mirror.ati.com/products/catalyst/linux.html#1) Alternativos (http://www.ati.com/developer/altoschart.pdf)

chaparro2001
28-oct-2006, 16:13
No veo ningun error, en el fichero /var/log/Xorg.0.log ¿hay alguno?.
cat /var/log/Xorg.0.log | grep '(EE)'

pues no me aparece ningun error; siento el tiempo que a pasado pero esque e estado muy despegado de el portatil por un tiempo :p :p

Lisan Al-Gaib
29-oct-2006, 10:26
despues de buscar por muchas partes que hacer y como hacerle y que buscar. pues di con tu esplicacion gracias...... me funciono todos los pasos que comentaste con algunas variantes que supongo se deben a la version de suse que tengo la 10.1 y algunas actualizaciones que he hecho.

saludos......

Volker
29-oct-2006, 15:24
buenas, e estado siguiendo los pasos y al llegar aqui no se que debo hacer:

Detected version of X does not have a matching 'x690_64a' directory
You may override the detected version using the following syntax:
X_VERSION=<xdir> ./ati-driver-installer-<ver>-<arch>.run [--install]

The following values may be used for <xdir>:
x410 XFree86 4.1.x
x420 XFree86 4.2.x
x430 XFree86 4.3.x
x680 X.Org 6.8.x
x690 X.Org 6.9.x

a ver si alguien me echa un cable, saludos

pakomirlob
23-nov-2006, 23:31
Pues nuevamente yo aqui dando problemas, bueno mi problemaes este:
Lo que pasa es que realice todos los pasos del manuel de diablorojo en SLED 10
y todo la hace sin broncas pero cuando le doy fglrxinfo me sigue dando los datos de vesa, no se que es lo que estoy haciendo mal.
Alguien podria decirme como hacerle.
Se los agradeceria mucho.

DiabloRojo
25-nov-2006, 08:36
Sin datos :confused: Repasa el manual y fijate al final.

icomputo
30-nov-2006, 07:33
Hola que tal.

Eh usado la aceleracion 3D por un tiempo mas o menos 3 meses, desde ese tiempo gracias al manual aqui puesto pude instalarlo, lo que ha resultado que de repente ya no se encuentran los drivers instalados. :molesto:

y tengo que volver hacer todo el protocolo, desistalo los driver y a instalarlos otraves.


alguien le a pasado esto? ahi forma de hacer para que ne se desistanlen?

saludos

gracias.

PD. OpenSuse 10.0 ati radeon 9250.

DiabloRojo
30-nov-2006, 18:18
Cuando se actualiza el kernel hay que volver a instalarlo.

icomputo
01-dic-2006, 00:47
gracias por responder.

bueno lo malo es que no lo eh actulizado =S

:tstress:


saludos

gracias

tomeu
01-dic-2006, 06:03
La pérdida de aceleracion 3D "sin tu hacer nada" solo puede ser por una actualización del kernel, como te dice DR, o en caso de que uses el driver del repo de ATI que el mismo no coincida con la versión del kernel instalada.

Pero ojo que no se ha desinstalado el driver fglrx, sino que ha perdido la configuración en el sistema, luego para volver a instalarlo, ATI recomienda que antes se desinstale el existente.

Y por tu tarjeta, ten en cuenta que ya no te sirven las últimas versiones 8.30 y 8.31; en la página de descarga de ATI, ahora mucho más fácil e interactiva, te dirá cuál puedes ponerte.

Rekeb
08-dic-2006, 20:26
La verdad es que el metodo que ha descrito diablo rojo, funciona de maravilla, al menos hasta la version 10.1 de suse no ha habido ningun problema.

He encontrado esta otra forma de hacerlo:

http://es.opensuse.org/SDB:Instalaci%C3%B3n_de_drivers_ATI_bajo_SuSE_Linu x

salu2

icomputo
17-dic-2006, 02:07
con la novedad que al actualizar a OpenSuse 10.2 trae consigo Xorg 7.2 lo cual
hasta orita no ahi driver se ati =S

malo malo...

:molesto:

Pepe_veraz
21-dic-2006, 19:28
Despues de leer todos los mensajes y estar como dos dias seguidos dandole, al fin lo he conseguido "3d rendering = yes" a todos gracias :)
Última version de drivers ati= 8.32.5 para el ultimo xorg

Saludos.

freckle
03-ene-2007, 01:08
segi apso a paso la gia y me aparece en direct rendering no" y este es el error ek tengo

freckle@linux-freckle:~> cat /var/log/Xorg.0.log | grep '(EE)'
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(EE) AIGLX: DRI module not loaded
freckle@linux-freckle:~> ke puedo hacer??????

versus
04-ene-2007, 20:54
[novato en linux] ....Hola,,poco a poco estoy conociendo mi sistema,,toca aqui y aya,,[solo miro],,y me sale algun para mi estraño,,,tengo una targeta grafica
ATI RADEON X550XT,,pero me sale registrada una X 700 SE,,digo yo que no esta bien esto,,,y que quisas por eso es que no teno el 3D,,,como cambio [arreglo esto]..
Gracias]





Puedo instalar BERYL ??

DiabloRojo
05-ene-2007, 17:50
Hola freckle, dame la salida del otro comando de mi manual.

Hola versus, sigue mi manual a pie de letra y lo de Beryl si puedes instalarlo, busca en el foro.

alberffdez
10-ene-2007, 23:51
Hola,
para todos los desesperados que como yo estábais esperando unos drivers de ATI para el SUSE 10.2 sin hacer un downgrade de la xorg 7.2 a la 7.1. Que sepáis que hoy 10/1/2007 se ha publicado la versión 8.33.6 de los drivers y tal como pone en las Release Notes soporta ya esta versión xorg 7.2 definitiva..
Voy a ir probando que tal rula, ya os contaré.

alberffdez
11-ene-2007, 12:45
Hola,
para todos los desesperados que como yo estábais esperando unos drivers de ATI para el SUSE 10.2 sin hacer un downgrade de la xorg 7.2 a la 7.1. Que sepáis que hoy 10/1/2007 se ha publicado la versión 8.33.6 de los drivers y tal como pone en las Release Notes soporta ya esta versión xorg 7.2 definitiva..
Voy a ir probando que tal rula, ya os contaré.

Que no he podido,no sé si estaré cometiendo algún fallo porque con Suse 10.1 me salió todo a la primera, pero con la 10.2 no hay manera.

randu
11-ene-2007, 16:26
yo si no fui capaz de hacer funcionar la aceleracion a mi tarjeta ati, y lo peor es que tengo un portatil y un compuador de escritorio y ninguno, la tarjeta ati del portatil no tiene aun soporte 3D segun el fabricante, y la del pc grande que es una ati radeon 9250 yo no se que pasa siempre me muestra ese mesa @#$%^&*(

pero no pierdo las esperanzas, je je se que algun dia lo vere funcionando asi me toque comprar otra tarjeta grafica, ja ja ja

icomputo
12-ene-2007, 08:55
alberffdez, no dices para que tajeta es, en mi caso eh checado la pagina, y para la mia que es una ati radeon 9250, me sigue a pareciendo el drivers:


Download Link File Size Version Date Posted Package Includes
ATI Driver Installer 52.7MB 8.28.8 Aug. 18, 2006 Automated installer and Display Drivers for XFree86 4.3 and X.Org 6.7, 6.8, 6.9, 7.0, 7.1


y como dice ahi, solo hasta la vercion 7.1

http://ati.amd.com/support/drivers/linux/linux-radeon-prer200.html


saludos

alberffdez
12-ene-2007, 11:35
Hola sakuragi ,
he vuelto a leer las Release Notes (http://https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/linux_8.28.8.html) , y lo que he visto en requerimientos mínimos es:
Minimum System Requirements
XOrg 6.7, 6.8, 6.9, 7.0, or 7.1; XFree86 version 4.3
De todos modos he buscado lo que me pareció leer hace unos días y no he conseguido encontrar :negar: , venía a decir algo así como que a diferencia de lo drivers anteriores que sólo daban soporte hasta la xorg 7.2 RC2, en esta versión ya son soportados los de la versión definitiva (es decir 7.2).
Repito que creo que lo leí en las RN de ATI, pero ahora por más que lo busco no lo encuentro por ninguna parte, no sé si han modificado el documento, lo leí de otro distinto o simplemente entendí lo que hacía tiempo venía buscando.
Respecto a a tarjeta con la que lo he probado es una Mobility X300, que he verificado que soportan estos drivers.
......
Ya he encontrado lo de la 7.2 en el enlace RSS (http://ati.amd.com/online/rss/atilinuxdriver.rss?OTC-rssfeedlinux) de los drivers de ATI :dedosarri

Linux Proprietary Driver 8.33.6 Release: x86 and x86_64 variants

NEW FEATURES: (1) Xorg 7.2 Support (2) Linux Kernel 2.6.19 Support
ISSUES RESOLVED: (1) Enabling Stereo on a FireGL V5000 no longer results in corruption being noticed on the X-Windows desktop (2) The ATI Control Panel no longer gets installed when running through the Custom Installation and de-selecting the Control Panel component (3) Connecting two display devices and switching the overlay to the secondary display device no longer causes aticonfig to fail (4) Running through the package gerneration installation of the ATI Proprietary Linux driver no longer results in the continue button remaining greyed out when selecting a package to be generated
y en esta otra (https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/linux_8.33.6.html#183503)

X.Org 7.2 Support

This release of the ATI Catalyst™ Linux software driver provides support for the offical X.Org 7.2 release. The previous release (8.32.5) supported the X Org 7.2 RC2 release only.
Lo cual resuelve el asunto de mi nivel de ansiedad que no es tan alto como para imaginarse estas cosas.

De todos modos sospecho que el soporte de esta flamante versión o no está del todo conseguido, o bien con la instalación generando el RPM específico para la distribución no funciona bien, ya que fue como yo lo hice.
En fin... seguiremos esperando / intentándolo / googleandolo .....

Roy
12-ene-2007, 20:39
Hola alberffdez veo que batallando por los drivers de Ati como ya es costumbre (a estas ati), no se si ya lograste instalar el controlador, yo lo he logrado siguiendo los pasos de:

http://en.opensuse.org/ATI_Driver#openSUSE_Linux_10.2_-_fglrx

con los 8.33.6 y me ha hido bastante bien incluso tengo efectos XGL

Lo unico que hice fue Omitir el paso de cambiar el kdm por gdm y guala

Saludos

Roy
13-ene-2007, 02:25
Otra guia que me encontre, funciona 100%, solo que ojo no hagan el comando init 3 para dar el sax2 -r -m 0=fglrx, ya que no regresara a la consola de comandos.

http://en.opensuse.org/Howto/ATI_Driver

Todo lo demas funcion perfecto:



zeth@Alenix:~> fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Radeon X1600 Series Generic
OpenGL version string: 2.0.6286 (8.33.6)


zeth@Alenix:~> glxinfo | more
name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig, GLX_MESA_copy_sub_buffer
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_get_proc_address, GLX_SGI_video_sync, GLX_ARB_multisample,
GLX_ATI_pixel_format_float, GLX_ATI_render_texture
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_multisample
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Radeon X1600 Series Generic
OpenGL version string: 2.0.6286 (8.33.6)
OpenGL extensions:
GL_ARB_multitexture, GL_EXT_texture_env_add, GL_EXT_compiled_vertex_array,
GL_S3_s3tc, GL_ARB_depth_texture, GL_ARB_fragment_program,
GL_ARB_fragment_program_shadow, GL_ARB_fragment_shader,
GL_ARB_multisample, GL_ARB_occlusion_query, GL_ARB_point_parameters,
GL_ARB_point_sprite, GL_ARB_shader_objects, GL_ARB_shading_language_100,
GL_ARB_shadow, GL_ARB_shadow_ambient, GL_ARB_texture_border_clamp,
GL_ARB_texture_compression, GL_ARB_texture_cube_map,
GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
GL_ARB_texture_env_crossbar, GL_ARB_texture_env_dot3,
GL_ARB_texture_float, GL_ARB_texture_mirrored_repeat,
GL_ARB_texture_rectangle, GL_ARB_transpose_matrix, GL_ARB_vertex_blend,
GL_ARB_vertex_buffer_object, GL_ARB_pixel_buffer_object,
GL_ARB_vertex_program, GL_ARB_vertex_shader, GL_ARB_window_pos,
GL_ARB_draw_buffers, GL_ATI_draw_buffers, GL_ATI_element_array,
GL_ATI_envmap_bumpmap, GL_ATI_fragment_shader, GL_ATI_map_object_buffer,
GL_ATI_separate_stencil, GL_ATI_shader_texture_lod,
GL_ATI_texture_compression_3dc, GL_ATI_texture_env_combine3,
GL_ATI_texture_float, GL_ATI_texture_mirror_once,
GL_ATI_vertex_array_object, GL_ATI_vertex_attrib_array_object,
GL_ATI_vertex_streams, GL_ATIX_texture_env_combine3,
GL_ATIX_texture_env_route, GL_ATIX_vertex_shader_output_point_size,
GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color, GL_EXT_blend_func_separate,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_clip_volume_hint,
GL_EXT_draw_range_elements, GL_EXT_fog_coord, GL_EXT_framebuffer_object,
GL_EXT_multi_draw_arrays, GL_EXT_packed_pixels, GL_EXT_point_parameters,
GL_EXT_rescale_normal, GL_EXT_secondary_color,
GL_EXT_separate_specular_color, GL_EXT_shadow_funcs, GL_EXT_stencil_wrap,
GL_EXT_texgen_reflection, GL_EXT_texture3D,
GL_EXT_texture_compression_s3tc, GL_EXT_texture_cube_map,
GL_EXT_texture_edge_clamp, GL_EXT_texture_env_combine,
GL_EXT_texture_env_dot3, GL_EXT_texture_filter_anisotropic,
GL_EXT_texture_lod_bias, GL_EXT_texture_mirror_clamp,
GL_EXT_texture_object, GL_EXT_texture_rectangle, GL_EXT_vertex_array,
GL_EXT_vertex_shader, GL_HP_occlusion_test, GL_NV_blend_square,
GL_NV_occlusion_query, GL_NV_texgen_reflection, GL_SGI_color_matrix,
GL_SGIS_generate_mipmap, GL_SGIS_texture_border_clamp,
GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod, GL_SUN_multi_draw_arrays
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x23 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x24 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x25 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x26 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x27 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 1 0 None
0x28 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 1 0 None
0x29 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 1 0 None
0x2a 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 1 0 None
0x2b 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x2c 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x2d 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x2e 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x2f 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 2 1 None
0x30 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 2 1 None
0x31 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 2 1 None
0x32 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 2 1 None
0x33 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x34 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x35 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x36 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x37 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 4 1 None
0x38 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 4 1 None
0x39 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 4 1 None
0x3a 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 4 1 None
0x3b 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x3c 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x3d 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x3e 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x3f 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 6 1 None
0x40 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 6 1 None
0x41 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 6 1 None
0x42 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 6 1 None
0x43 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x44 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x45 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x46 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x47 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 1 0 None
0x48 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 1 0 None
0x49 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 1 0 None
0x4a 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 1 0 None
0x4b 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x4c 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x4d 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x4e 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x4f 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 2 1 None
0x50 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 2 1 None
0x51 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 2 1 None
0x52 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 2 1 None
0x53 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x54 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x55 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x56 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x57 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 4 1 None
0x58 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 4 1 None
0x59 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 4 1 None
0x5a 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 4 1 None
0x5b 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x5c 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x5d 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x5e 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x5f 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 6 1 None
0x60 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 6 1 None
0x61 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 6 1 None
0x62 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 6 1 None


zeth@Alenix:~> glxgears
634 frames in 5.0 seconds = 126.632 FPS
867 frames in 5.0 seconds = 173.399 FPS
1256 frames in 5.0 seconds = 251.196 FPS
1256 frames in 5.0 seconds = 251.195 FPS
1259 frames in 5.0 seconds = 251.797 FPS


zeth@Alenix:~> fgl_glxgears
Using GLX_SGIX_pbuffer
2586 frames in 5.0 seconds = 517.200 FPS
4934 frames in 5.0 seconds = 986.800 FPS
4551 frames in 5.0 seconds = 910.200 FPS
2794 frames in 5.0 seconds = 558.800 FPS
3095 frames in 5.0 seconds = 619.000 FPS
2838 frames in 5.0 seconds = 567.600 FPS
2799 frames in 5.0 seconds = 559.800 FPS
2782 frames in 5.0 seconds = 556.400 FPS

Ojo que esta Guia recomienda actualizar el Xorg, si lo piensas hacer por YOU, yo lo pensaria 2 veces

alberffdez
15-ene-2007, 12:57
Muchas gracias Roy, en cuanto tenga un rato lo probaré, y ya os contaré los resultados.
A mí se me quedaba "colgado" cuando modificaba la configuración con el sax2, y no podía si quiera iniciar otra sesión para poder reiniciar, sólo podía pegarle el botonazo... y eso duele.

Roy
15-ene-2007, 21:03
Fijate que el unico detalle que le encontrado a ambas guias es que aunque los comandos fglrxinfo y demas te marquen aceleracion grafica de ati, el sistema parese que no lo detecta correctamente porque por ejemplo si le das sysinfo:/ segun recuerdo en el Suse 10.1 te mostraba fglrx con aceleracion 3D, ahora solo marca como desconocido. Aunque te permite ejecutar opciones en 3D (como por ejemplo el Chromium B.S.U) Eso en KDE, en Gnome aunque ya tengas el XGL claramente en las opciones te dice "Que no tienes 3D" y por ende no te deja activarlo (aunque lo hayas activado a la braba con la consola :p )

En fin e buscado algo al respecto pero parase no llamar mucho la atencion y pues realmente si, si tienes 3D funcionando perfectamente que salga el mensaje te vale.

Saludos

Mikage
16-ene-2007, 16:04
Siguiendo esta y cambiando claro esta la version y la tajeta grafica he podido configurar al fin el 3D.

Cada vez que vea a alguien con problemas de los que yo he tenido, le voy a mandar a mirarse la guia. gracias DiabloRojo

EDITO:
el sax2 no me activa el 3dD y las pruebas del tutorial de DIabloRojo me salen asi:


Xlib: extension "XFree86-DRI" missing on display ":0.0".
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9550 Generic
OpenGL version string: 1.2 (2.0.6286 (8.33.6))

14:31 SuSE102:~ > glxinfo | more
Xlib: extension "XFree86-DRI" missing on display ":0.0".
name of display: :0.0
display: :0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_get_proc_address, GLX_SGI_video_sync, GLX_ARB_multisample,
GLX_ATI_pixel_format_float, GLX_ATI_render_texture
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_multisample
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9550 Generic
OpenGL version string: 1.2 (2.0.6286 (8.33.6))
OpenGL extensions:
GL_ARB_multitexture, GL_ARB_texture_border_clamp, GL_ARB_texture_cube_map,
GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
GL_ARB_texture_env_dot3, GL_ARB_transpose_matrix, GL_EXT_abgr,
GL_EXT_blend_color, GL_EXT_blend_minmax, GL_EXT_blend_subtract,
GL_EXT_texture_env_add, GL_EXT_texture_env_combine,
GL_EXT_texture_env_dot3, GL_EXT_texture_lod_bias
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x2c 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 1 0 None
0x2d 24 tc 0 32 0 r . . 8 8 8 8 0 0 0 0 0 0 0 1 0 None
0x2e 32 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 1 0 Ncon
0x2f 32 tc 0 32 0 r . . 8 8 8 8 0 0 0 0 0 0 0 1 0 Ncon
14:31 SuSE102:~ > glxgears
Xlib: extension "XFree86-DRI" missing on display ":0.0".
21 frames in 5.2 seconds = 4.024 FPS
20 frames in 5.1 seconds = 3.932 FPS
19 frames in 5.2 seconds = 3.648 FPS
21 frames in 5.1 seconds = 4.089 FPS
21 frames in 5.3 seconds = 3.995 FPS
14:32 SuSE102:~ > fgl_glxgears
Using GLX_SGIX_pbuffer
Xlib: extension "XFree86-DRI" missing on display ":0.0".
Error: couldn't get fbconfig


Que es eso de Xfree86-dri??
tb os paso mi xorg.conf

/.../
# SaX generated X11 config file
# Created on: 2006-12-31T14:22:46+0100.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "ServerLayout"
Identifier "Layout[all]"
Screen 0 "aticonfig-Screen[0]" 0 0
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
EndSection

Section "Files"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
FontPath "/usr/share/fonts/misc:unscaled"
FontPath "/usr/share/fonts/local"
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/100dpi:unscaled"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/URW"
FontPath "/usr/share/fonts/Speedo"
FontPath "/usr/share/fonts/PEX"
FontPath "/usr/share/fonts/cyrillic"
FontPath "/usr/share/fonts/latin2/misc:unscaled"
FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
FontPath "/usr/share/fonts/latin2/Type1"
FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
FontPath "/usr/share/fonts/baekmuk:unscaled"
FontPath "/usr/share/fonts/japanese:unscaled"
FontPath "/usr/share/fonts/kwintv"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/uni:unscaled"
FontPath "/usr/share/fonts/CID"
FontPath "/usr/share/fonts/ucs/misc:unscaled"
FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/misc:unscaled"
FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/Type1"
FontPath "/usr/share/fonts/misc/sgi:unscaled"
FontPath "/usr/share/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "type1"
Load "freetype"
Load "extmod"
Load "glx"
Load "v4l"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
Option "IgnoreABI" "on"
EndSection

Section "InputDevice"
Identifier "Keyboard[0]"
Driver "kbd"
Option "Protocol" "Standard"
Option "XkbLayout" "es"
Option "XkbModel" "pc102"
Option "XkbRules" "xorg"
EndSection

Section "InputDevice"
Identifier "Mouse[1]"
Driver "mouse"
Option "Buttons" "7"
Option "Device" "/dev/input/mice"
Option "Name" "GenPS/2 Genius Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Modes"
Identifier "Modes[0]"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]"
Driver "fglrx"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]"
Device "aticonfig-Device[0]"
Monitor "aticonfig-Monitor[0]"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
Option "DAMAGE" "false"
EndSection


Y encima de todo el XGL y Beryl funcionan, no con mucha rapidaez pero medio funcionan. ya nose que mas hacerle.Ayuda por favor.

Roy
17-ene-2007, 18:34
Es lo que vengo diciendo hace rato Mikage todos los mandos del shell te muestran que efectivamente el equipo tiene aceleracion 3D pero el sistema dice lo contrario, osea que hay algo instalado como controlador grafico, pero no lo puede detectar correctamente, sin embargo la acelaracion 3d trabaja bien. Para checar eso basta con darle en el konqueror sysinfo:/ y veras que el apartado de adaptador de la pantalla dice:

Controlador: Desconocido

Cuando no deberia ser asi, deberia mostrar el dato: Controlador fglrx con 3D

En Gnome es igual, incluso si vas al panel del sistema y quieres activar el XGL este te dice que no hay aceleracion 3D, sin embargo lo puedes activar a la mala con el comando del shell

Creo que es hora de sacar este problema de la guia y mandarlo a hardware, haber si un moderador puede separar los ultimos temas y mandarlo al foro de hardware con el tema tengo 3D pero el sistema no lo detecta correctamente (ATI)

Saludos

Mikage
18-ene-2007, 16:51
14:31 SuSE102:~ > glxgears
Xlib: extension "XFree86-DRI" missing on display ":0.0".
21 frames in 5.2 seconds = 4.024 FPS
20 frames in 5.1 seconds = 3.932 FPS
19 frames in 5.2 seconds = 3.648 FPS
21 frames in 5.1 seconds = 4.089 FPS
21 frames in 5.3 seconds = 3.995 FPS
14:32 SuSE102:~ > fgl_glxgears
Using GLX_SGIX_pbuffer
Xlib: extension "XFree86-DRI" missing on display ":0.0".
Error: couldn't get fbconfig
mira eso, puuffff 20 FRAMES!! en 5.2 segundos!!!!ke va ke va, como va a estar el 3D puesto? esa es la prueba de 2D y la segunda fgl_glxgears peor, no se inicia y es la prueba 3D, los efectos XGL/Beryl estan pero van muy lentos y las X se bloquea. En sysinfo:/ dice que el controlador es fgrlx y de ati y misa y en Sax2 = solo que cuando le intento activar la casilla del 3D se bloquea. yo que se, esto es muy raro todo. U_U

Epifumi
27-ene-2007, 03:50
A mi, con los ultimos drivers y en SuSE 10.2 con una Ati X800 GTO me salía esto


==================================================
ATI Technologies Linux Driver Installer/Packager
==================================================
Detected configuration:
Architecture: x86_64 (64-bit)
X Server: Unknown X Window
cp: no se puede efectuar `stat' sobre «x710_64a/usr/X11R6/bin/*»: No existe el fichero o el directorio
find: install/usr/bin/fireglcontrolpanel: No existe el fichero o el directorio


SI hago fglrxinfo me dice esto

Xlib: extension "XFree86-DRI" missing on display ":0.0".
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (1.5 Mesa 6.5.1)

Pero investigando por ahi, he conseguido instalarlos y tener aceleración 3D .

Lo primero que he hecho ha sido instalar las kernel-sources, el gcc y, aqui creo que está el kid de la cuestión, instalar los paquetes de desarrollo de XOrg (XOrg-devel).

Despues, como root, he ejecutado el driver


sh ./ati-driver-installer-8.33.6-x86.x86_64.run

He marcado todo automático y cuando ha terminado he hecho


init 3

me he logeado como root y he ejecutado


sax2 -r -m 0=fglrx

He configurado el monitor en el Sax, he hecho init 5 y he reiniciado. Al arrancar de nuevo he comprobado

epifumi@linux-r8r8:~> glxinfo | more
name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig, GLX_MESA_copy_sub_buffer
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_get_proc_address, GLX_SGI_video_sync, GLX_ARB_multisample,
GLX_ATI_pixel_format_float, GLX_ATI_render_texture
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_multisample
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON X800 GTO Generic
OpenGL version string: 2.0.6286 (8.33.6)
OpenGL extensions:
GL_ARB_multitexture, GL_EXT_texture_env_add, GL_EXT_compiled_vertex_array,
GL_S3_s3tc, GL_ARB_depth_texture, GL_ARB_fragment_program,
GL_ARB_fragment_program_shadow, GL_ARB_fragment_shader,
GL_ARB_multisample, GL_ARB_occlusion_query, GL_ARB_point_parameters,
GL_ARB_point_sprite, GL_ARB_shader_objects, GL_ARB_shading_language_100,
GL_ARB_shadow, GL_ARB_shadow_ambient, GL_ARB_texture_border_clamp,
GL_ARB_texture_compression, GL_ARB_texture_cube_map,
GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
GL_ARB_texture_env_crossbar, GL_ARB_texture_env_dot3,
GL_ARB_texture_float, GL_ARB_texture_mirrored_repeat,
GL_ARB_texture_rectangle, GL_ARB_transpose_matrix, GL_ARB_vertex_blend,
GL_ARB_vertex_buffer_object, GL_ARB_pixel_buffer_object,
GL_ARB_vertex_program, GL_ARB_vertex_shader, GL_ARB_window_pos,
GL_ARB_draw_buffers, GL_ATI_draw_buffers, GL_ATI_element_array,
GL_ATI_envmap_bumpmap, GL_ATI_fragment_shader, GL_ATI_map_object_buffer,
GL_ATI_separate_stencil, GL_ATI_texture_compression_3dc,
GL_ATI_texture_env_combine3, GL_ATI_texture_float,
GL_ATI_texture_mirror_once, GL_ATI_vertex_array_object,
GL_ATI_vertex_attrib_array_object, GL_ATI_vertex_streams,
GL_ATIX_texture_env_combine3, GL_ATIX_texture_env_route,
GL_ATIX_vertex_shader_output_point_size, GL_EXT_abgr, GL_EXT_bgra,
GL_EXT_blend_color, GL_EXT_blend_func_separate, GL_EXT_blend_minmax,
GL_EXT_blend_subtract, GL_EXT_clip_volume_hint,
GL_EXT_draw_range_elements, GL_EXT_fog_coord, GL_EXT_framebuffer_object,
GL_EXT_multi_draw_arrays, GL_EXT_packed_pixels, GL_EXT_point_parameters,
GL_EXT_rescale_normal, GL_EXT_secondary_color,
GL_EXT_separate_specular_color, GL_EXT_shadow_funcs, GL_EXT_stencil_wrap,
GL_EXT_texgen_reflection, GL_EXT_texture3D,
GL_EXT_texture_compression_s3tc, GL_EXT_texture_cube_map,
GL_EXT_texture_edge_clamp, GL_EXT_texture_env_combine,
GL_EXT_texture_env_dot3, GL_EXT_texture_filter_anisotropic,
GL_EXT_texture_lod_bias, GL_EXT_texture_mirror_clamp,
GL_EXT_texture_object, GL_EXT_texture_rectangle, GL_EXT_vertex_array,
GL_EXT_vertex_shader, GL_HP_occlusion_test, GL_NV_blend_square,
GL_NV_occlusion_query, GL_NV_texgen_reflection, GL_SGI_color_matrix,
GL_SGIS_generate_mipmap, GL_SGIS_texture_border_clamp,
GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod, GL_SUN_multi_draw_arrays
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x23 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x24 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x25 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x26 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x27 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 1 0 None
0x28 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 1 0 None
0x29 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 1 0 None
0x2a 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 1 0 None
0x2b 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x2c 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x2d 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x2e 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x2f 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 2 1 None
0x30 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 2 1 None
0x31 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 2 1 None
0x32 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 2 1 None
0x33 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x34 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x35 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x36 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x37 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 4 1 None
0x38 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 4 1 None
0x39 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 4 1 None
0x3a 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 4 1 None
0x3b 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x3c 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x3d 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x3e 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x3f 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 6 1 None
0x40 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 6 1 None
0x41 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 6 1 None
0x42 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 6 1 None
0x43 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x44 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x45 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x46 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x47 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 1 0 None
0x48 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 1 0 None
0x49 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 1 0 None
0x4a 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 1 0 None
0x4b 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x4c 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x4d 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x4e 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x4f 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 2 1 None
0x50 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 2 1 None
0x51 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 2 1 None
0x52 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 2 1 None
0x53 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x54 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x55 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x56 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x57 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 4 1 None
0x58 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 4 1 None
0x59 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 4 1 None
0x5a 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 4 1 None
0x5b 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x5c 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 1 0 None
0x5d 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x5e 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 1 0 None
0x5f 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 6 1 None
0x60 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 6 1 None
0x61 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 6 1 None
0x62 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 6 1 None



epifumi@linux-r8r8:~> glxgears
35485 frames in 5.0 seconds = 7096.932 FPS
49763 frames in 5.0 seconds = 9952.498 FPS
42559 frames in 5.0 seconds = 8511.708 FPS
50275 frames in 5.0 seconds = 9997.312 FPS
49160 frames in 5.0 seconds = 9786.999 FPS
42776 frames in 5.0 seconds = 8555.103 FPS
51305 frames in 5.0 seconds = 10260.851 FPS
epifumi@linux-r8r8:~> fgl_glxgears
Using GLX_SGIX_pbuffer
11169 frames in 5.0 seconds = 2233.800 FPS
11199 frames in 5.0 seconds = 2239.800 FPS
11099 frames in 5.0 seconds = 2219.800 FPS
11273 frames in 5.0 seconds = 2254.600 FPS
11118 frames in 5.0 seconds = 2223.600 FPS
11270 frames in 5.0 seconds = 2254.000 FPS
11252 frames in 5.0 seconds = 2250.400 FPS

melkorex
27-ene-2007, 10:02
Amigos de FOROSuSE recurro a ustedes...

Tengo una Shappire Ati Radeon 9600 XT de 256mb eh instalado los drivers todo perfecto pero a la hora del 3d nada!.

datos:

cuando voy a "mi equipo" me dice..

Información de pantalla
Fabricante: ATI Technologies Inc
Modelo: RV350 AR
Controlador: fglrx (sin compatibilidad 3D)

Mi pregunta y lo que mas me intriga saber es lo de la POSIX Shared Memory como se si lo tengo y/o como hago para tenerlo please una mano.

dato: cuando hago los test el test de 2d anda de 10.
dato: cuando hago el test de 3d dice lo siguiente:....


Using GLX_SGIX_pbuffer
Xlib: extension "XFree86-DRI" missing on display ":0.0".
X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 157 (GLX)
Minor opcode of failed request: 5 (X_GLXMakeCurrent)
Serial number of failed request: 30
Current serial number in output stream: 30

arlick
02-feb-2007, 17:59
Hola a todo el mundo, despues de haberlo intentado de todas las formas posibles con suse10.2 he conseguido instalar los drivers.

Primero intente hacerlo como decia Epifuni pero no funciono (no se si esto es determinante).

Luego de reiniciar y dar gracias por que se iniciase de forma normal hice los siguiente:

1) ./ati-driver-installer-8.33.6-x86.x86_64.run --listpkg

Cambio a modo superuser.

2) ./ati-driver-installer-8.33.6-x86.x86_64.run --buildpkg SuSE/SUSE102-AMD64

3) rpm -Uvh fglrx64_7_1_0_SUSE102-8.33.6-1.x86_64.rpm

4) aticonfig --initial

5) aticonfig --overlay-type=Xv

6) Ctrl + Alt + Backspc

Me ha funcionado de forma perfecta:

name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
-------
Ahora probare a jugar a un juego muy bueno de roll, que tiene disponible la version para linux.

El juego se llama Regnum y el enlace es: http://www.regnumonline.com.ar/

Un saludo!!!

arlick
03-feb-2007, 02:44
Que iluso fui.

Ya han pasado unas cuantas horas desde escribi el comentario anterior y a pasado una cosa importante: al reiniciar la pantalla con Ctrl + Alt +Backspc o cuando reinicie el ordenador o cuando he cambiado a sesion de consola haciendo Alt + FX se queda la pantalla negra!!!!

He estado jugando perfectamente (antes de reiniciar), tanto al juego que he mencionado como a los propios juegos en 3d de kde sin problema.

Tambien cuando he tratado de apagar se quedaba bloqueado con la pantalla en negro.

La unica forma que he tenido de solucionarlo ha sido cambiar el fichero generado "/etc/X11/xorg.conf" por el original generico "/etc/X11/xorg.conf.saxsave" (en mi caso).

Hay alguna forma de saber porque falla esto y solucionarlo??

Probare mañana a ver si con el driver instalador tan solo necesito sustuir cuando necesite 3d un fichero por otro, una solucion cutre pero que deberia funcionar, ya os contare.

alberffdez
03-feb-2007, 07:14
Hola Arlick,
no se si lo has escrito todo, pero de esta manera esta manera no le dices a linux que emplee los drivers propietarios para gestionar la pantalla, lo has instalado todo si, pero no los va a utilizar y por lo tanto no tendrás aceleración 3D.
Hace falta la orden a Sax2 para que emplee el driver fglrx, que es justo cuando a mí me da error y se me queda frito el ordenador.

arlick
07-feb-2007, 03:13
Cuando he intentado hacerlo desde el repositorio de ati me dice algo asi como que no se pueden obtener los "headers" del archivo. ¿Que significa exactamente este fallo? ¿Puedo arreglarlo o no es mio? La version que hay puesta es la 3.28.X la ultima vez que lo mire.

No lo he dicho pero uso suse 10.2, amd64, tarjeta ati X700SE (512Mb).


P.D.: es curioso pero si antes usaba una particion de windows para jugar y otra de linux para lo demás ahora uso suse 10.2 para trabajar y suse 10.1 para jugar :p, a ver si arreglo esto y asi podria formatear una gran cantidad de memoria, un saludo!!!

DiabloRojo
07-feb-2007, 10:26
headers corresponde al paquete kernel-source, instalalo desde el cd1 o dvd de OpenSuse.

Mikage
09-feb-2007, 10:57
¿Por que en las notas de la version del driver de ati pone que soporta Xorg 7.2(RC2 me parece) y dice que requisitos del sistema hasta Xorg 7.1, y encima en la pagina de donde bajas los drivers pone:Instalador automático y controladores de pantalla de XFree86 4.3 y X.Org 6.7, 6.8, 6.9, 7.0, 7.1? que pasa ahi?

alberffdez
09-feb-2007, 14:55
¿Por que en las notas de la version del driver de ati pone que soporta Xorg 7.2(RC2 me parece) y dice que requisitos del sistema hasta Xorg 7.1, y encima en la pagina de donde bajas los drivers pone:Instalador automático y controladores de pantalla de XFree86 4.3 y X.Org 6.7, 6.8, 6.9, 7.0, 7.1? que pasa ahi?

Mucho me temo que en realidad 7.2 no está soportado por la última versión del driver de ati, yo intenté instalarlo con la 7.2 RC2 que viene de origen con nuestra OS 10.2, lo intenté con la versión actualizada de xorg 7.2 desde el repositorio oficial. Incluso, leyendo leyendo actualicé sax2 porque a mí me petaba en ese paso y según algunas fuentes el problema podía ser ese.
Por otra parte, aunque yo no programe, me fío más de que el error esté en los drivers que son cerrados y lo pueden leer cuatro gatos a que se encuentre en el propio de linux que es abierto y puede leer quien quiera y pueda.

Además estoy contigo en tu firma "Busca y encontrarás" clara, corta y sencilla, y lo que es más importante NO OFENDE. Este último aspecto es de vital importancia en un sitio colaborativo como es éste foro. Si se pretende que tenga cierto éxito, y debería ser tenido en cuenta por todos sus usuarios de novatillos a ADMINISTRADORES.

Mikage
09-feb-2007, 15:44
yo tambien actualize el sax etc...hice todo lo que me decian, pero nada, no hay solucion exepto esperar al proximo driver--si es que el problema es suyo--o a la OpenSuSE 10.3 que ya mismo sale la 1ª alpha. xDDDD


pero otra cosa, si en las notas de la relase pone soportado?? no significa eso q tienen q funcionar???

DiabloRojo
09-feb-2007, 19:39
Además estoy contigo en tu firma "Busca y encontrarás" clara, corta y sencilla, y lo que es más importante NO OFENDE. Este último aspecto es de vital importancia en un sitio colaborativo como es éste foro. Si se pretende que tenga cierto éxito, y debería ser tenido en cuenta por todos sus usuarios de novatillos a ADMINISTRADORES.Tengo que ser un poco pesado con el tema de buscar aunque llegue a ser ofensivo, asi que he quitado parte de mi firma. ;)

Pero el exito de un foro no se mide por el grado de participacion sino por el grado de soluciones que aporte a la comunidad y donde los aforados aprenden a manejar una distribuccion de Linux.

El aprendizaje mas importante es BUSCAR que es el comienzo de un reto superior: el de ser un experto en algo.

He participado en muchos foros de muchos temas, etc.... siempre que he tomado el camino mas rapido: El de preguntar sin buscar, he encontrado siempre la misma respuesta: BUSCALO en el foro que ya hemos hablado de ello. Ni que decir que las respuestas, unas muy amables otras muy ofensivas, vamos de todos los colores, es decir, de tantos capones que me han dado me he convertido un experto buscador del google, tanto que hasta los amigos me piden que les busque algo cuando no lo encuentra, ni que decir que buscar por un amigo cansa por muy amigo que sea ;)

PD: Proximadamente creare un nuevo manual de instalacion del ultimo driver de ATI, y eso que paso de la aceleracion 3D que ni falta me hace.

EDITADO: Ah, se me olvido decirte que si consigo que los nuevos aforados, a menos 3 de cada 10, aprendan a buscar me dare por satisfecho y que me perdone ser pesado en ello.

alberffdez
09-feb-2007, 19:57
Tengo que ser un poco pesado con el tema de buscar aunque llegue a ser ofensivo, asi que he quitado parte de mi firma. ;)
Me parece muy acertada tu rectificación de la firma y estoy de acuerdo con lo que dices en todos los aspectos, incluso comprendo tu frustración con la gente que lejos de buscar se trata de aprovechar del esfuerzo de los demás, a mí me ocurre lo mismo.
Sólo que me tomo muy en serio las formas.

EDITADO: Ah, se me olvido decirte que si consigo que los nuevos aforados, a menos 3 de cada 10, aprendan a buscar me dare por satisfecho y que me perdone ser pesado en ello.



Como descargo de esto te ofrezco mi colaboración en lo que pueda, así que recopilaré mis experiencias para ir añadiéndolas al foro. De momento mi batallita la sitúo "contra" los rebeldes drivers de ATI, seguiré buscando soluciones.

Mikage
10-feb-2007, 15:43
Muy buena idea, ojala sea una solucion eficaz pues muchos deseamos tener la aceleracion 3D y no sabemos como lograrla a pesar de haber hecho de todo, en mi caso ya lo he dejado de lado, a pesar de que me gustaria, no pienso dedicarle mi vida a ello--ya solo nos falta sacrificar un cordero y ofrecerselo a los dioses...¬¬UUuu-asi se acabaran todos esos post que inundan el foro con el tema.

Edito:
PD:yo tambien me ofrezco para ayudar.

Viskovitz
11-feb-2007, 21:35
Hola a todos, antes de todo presentarme y decir que acabo de llegar a este foro y prácticamente a linux desde hace un par de semanas sólo.

Después de pasarme un par de días preguntándole al señor google he conseguido instalar los drivers originales de ati para mi radeon 9600 y en teoría ha ido todo bien, pero no consigo hacer que funcionen estos en lugar de los que trae suse 10.2, ni con sax2 en la consola ni en modo gráfico.

Por lo que ponéis más arriba ¿se supone que debería esperar a una nueva versión de los drivers estos? Lo pregunto más que nada para aclararme, porque estoy empezando a desesperarme un poco y sería un alivio que fuera cosa de los drivers.


Un saludo a todos.

Mikage
12-feb-2007, 01:32
Hola a todos, antes de todo presentarme y decir que acabo de llegar a este foro y prácticamente a linux desde hace un par de semanas sólo.

Después de pasarme un par de días preguntándole al señor google he conseguido instalar los drivers originales de ati para mi radeon 9600 y en teoría ha ido todo bien, pero no consigo hacer que funcionen estos en lugar de los que trae suse 10.2, ni con sax2 en la consola ni en modo gráfico.

Por lo que ponéis más arriba ¿se supone que debería esperar a una nueva versión de los drivers estos? Lo pregunto más que nada para aclararme, porque estoy empezando a desesperarme un poco y sería un alivio que fuera cosa de los drivers.


Un saludo a todos.
sax -r -m 0=fglrx
creo que era si, pero sera mejor que mires el primer post de este foro, porque es una guia, seguro que alli encuentras lo que necesitas

Viskovitz
12-feb-2007, 21:08
Gracias Mikage, yo lo he hecho con sax2 -r -m 0=fglrx, pero sigue sin funcionar. Me voy a pasar por la página que dice DiabloRojo (www.rage3d.com) a ver si saco algo en claro.


Un saludo y gracias.

Darkored
12-feb-2007, 21:22
Primero me gustaria presentarme,ya que es la primera vez que posteo.
Soy Darkored y me pasaré mucho por aquí ya que es la mejor fuente de información de linux/suse que he encontrado en la red.Soy bastante nuevo en esto y estoy aprendiendo por mis medios...bajandome manuales,leyendo foros como este etc...

Tambien quiero agradecer a DiabloRojo la paciencia y la amabilidad que tiene al ofrecernos su sabiduria en estos temas,jeje.Gracias a él y con las respuestas de otros usuarios he conseguido configurar mi tarjeta gráfica ATI a la perfección.

Por si sirve de experiencia a otros usuarios,mi problema fue que seguí los pasos del manual y no pasaba nada,no me lo detectaba.Con la respuesta de otro usuario llegué a la conclusión: "Me faltaba instalar los paquetes de g++ y kernel-sources". Después de esto volví a instalar y todo genial. Conclusión: "busca y encontrarás ^^"

Nada más,solo que gracias a todos y seguiré leyendo mas cosas de este foro,todas ellas muy interesantes.

PD:Genial el tutorial y como explicas las cosas Diablo :dedosarri

alberffdez
12-feb-2007, 23:48
Primero me gustaria presentarme,ya que es la primera vez que posteo.
Soy Darkored y me pasaré mucho por aquí ya que es la mejor fuente de información de linux/suse que he encontrado en la red.Soy bastante nuevo en esto y estoy aprendiendo por mis medios...bajandome manuales,leyendo foros como este etc...

Tambien quiero agradecer a DiabloRojo la paciencia y la amabilidad que tiene al ofrecernos su sabiduria en estos temas,jeje.Gracias a él y con las respuestas de otros usuarios he conseguido configurar mi tarjeta gráfica ATI a la perfección.

Por si sirve de experiencia a otros usuarios,mi problema fue que seguí los pasos del manual y no pasaba nada,no me lo detectaba.Con la respuesta de otro usuario llegué a la conclusión: "Me faltaba instalar los paquetes de g++ y kernel-sources". Después de esto volví a instalar y todo genial. Conclusión: "busca y encontrarás ^^"

Nada más,solo que gracias a todos y seguiré leyendo mas cosas de este foro,todas ellas muy interesantes.

PD:Genial el tutorial y como explicas las cosas Diablo :dedosarri
Que interesante esto que cuentas ojotes: , me gustaría comprobarlo, ¿de qué repositorio descargaste g++?
Yo la verdad que después de todo lo que he buscado lo único que he encontrado es que con OpenSUSE 10.2 todavía hay que esperar, pero bueno si gracias a esto reducimos la espera bienvenido sea.

Darkored
13-feb-2007, 19:15
Bueno,como soy muy novato y aun no entiendo que es exactamente eso de repositorio :p ,te comentaré paso a paso lo que hice.
-Abrí el yaST2.
-Busqué por "++" porque por g++ no me daba nada.
-Le dije de instalar los siguientes paquetes: "gcc-c++","gcc41-c++" y alguna libreria como "boost" y "compat-libstdc++".
-Luego busqué kernel con el yaST2.
-Le dije de instalar el paquete "kernel-source".
-Reinicié el equipo y volví a seguir todos los pasos del tutorial de DiabloRojo.

No sé si instalé cosas de sobra o que...la cuestión es que al instalar todo eso y volver a hacer el tutorial ya funcionaba y estaba bien configurada.La idea surgió de que otro usuario le daba un error parecido al mio y alguien le recomendó que instalase un compilador de g++ y algo del kernel-source...asi que hice lo mismo.

Espero haberte servido de ayuda.
Saludos!

Mikage
14-feb-2007, 13:42
y todos teneis Xorg 7.2 RC2? O.o!! yo he instalado los paquetes y nada

alberffdez
14-feb-2007, 20:39
Muchas :) gracias Darkored pero eso mismo es lo que ya había hecho y no me sirvió de nada con OpenSUSE 10.2, aunque con la versión 10.1 si me funcionó a la (casi)primera :dedosarri . Por cierto tengo el fijo con un nvidia y ruedan de maravilla :) tanto el soporte 3D como Beryl.
Lo he buscado y rebuscado por internet, he seguido distintas guías, incluída ésta que DiabloRojo hizo con tanto acierto para la versión 8.24 y que ha seguido siendo útil para las posteriores (excepto ésta última con OSS 10.2)
Cambiando de tema;


y todos teneis Xorg 7.2 RC2? O.o!! yo he instalado los paquetes y nada

Yo lo probé primero con la versión 7.2 RC2 y después actualicé a la 7.2 Oficial y en ambas ocasiones falló en el mismo punto:
Al cargar los drivers sax2 el ordenador se quedaba con la pantalla en negro haciendo lecturas a disco duro cada poco tiempo y sin dejar abrir (aparentemente) otra sesión.
Luego tras tener que reiniciar a lo bruto (botonazo y posterior fcsk) presentaba basura y gran lentitud con el interfaz gráfico (para arreglarlo basta con volver a cargar los drivers que lleva suse "sax2 -r -m 0=ati" pero claro sin soporte 3D)

Lo que me niego :dedosabaj a probar es a descender a la 7.1(y lo digo con firmeza pero sin acritud), para eso que actualicen los de ATI (o que abran sus drivers).

Mikage
15-feb-2007, 13:03
Muchas :) gracias Darkored pero eso mismo es lo que ya había hecho y no me sirvió de nada con OpenSUSE 10.2, aunque con la versión 10.1 si me funcionó a la (casi)primera :dedosarri . Por cierto tengo el fijo con un nvidia y ruedan de maravilla :) tanto el soporte 3D como Beryl.
Lo he buscado y rebuscado por internet, he seguido distintas guías, incluída ésta que DiabloRojo hizo con tanto acierto para la versión 8.24 y que ha seguido siendo útil para las posteriores (excepto ésta última con OSS 10.2)
Cambiando de tema;

Yo lo probé primero con la versión 7.2 RC2 y después actualicé a la 7.2 Oficial y en ambas ocasiones falló en el mismo punto:
Al cargar los drivers sax2 el ordenador se quedaba con la pantalla en negro haciendo lecturas a disco duro cada poco tiempo y sin dejar abrir (aparentemente) otra sesión.
Luego tras tener que reiniciar a lo bruto (botonazo y posterior fcsk) presentaba basura y gran lentitud con el interfaz gráfico (para arreglarlo basta con volver a cargar los drivers que lleva suse "sax2 -r -m 0=ati" pero claro sin soporte 3D)

Lo que me niego :dedosabaj a probar es a descender a la 7.1(y lo digo con firmeza pero sin acritud), para eso que actualicen los de ATI (o que abran sus drivers).

Yo lo intente, en realidad no encuentro los paquetes de Xorg 7.1, cogi los de la 6.9 que vienen en SuSE 10.1, pero es horrible, la cantidad de dependecias que tienen las X(normal, y evidente, es el sistema grafico)hacen casi imposible degradar la version de Xorg, podria instalar todos los paquetes, pero es que para eso cojo directamente, e instalo limpiamente la 10.1,total...pero solo de pensar los problemas que me daba me hecho atras. Estos drivers solo soportan hasta la 7.2 RC2 la final no,los drivers no creo que sean liberados--pues contienen secretos para competidores-- y teniendo en cuenta el dia en el que estamos, y que AMD/ATI saca una version por mes...
: D

EDITO: Xorg 7.2 estan soportados, hasta la version final.
X.Org 7.2 Support

This release of the ATI Catalyst™ Linux software driver provides support for the offical X.Org 7.2 release. The previous release (8.32.5) supported the X Org 7.2 RC2 release only.

DiabloRojo
16-feb-2007, 22:24
Lo prometido es deuda ya teneis el NUEVO MANUAL sobre una version superior: Instalar version 8.33.6-x86.x86_64 del driver ATI (http://www.forosuse.org/forosuse/showthread.php?t=11066)

JaG
02-mar-2007, 21:43
lo he posteado mejor en este otro hilo

http://www.forosuse.org/forosuse/showthread.php?t=11210&page=3&pp=10&highlight=9550

Un saludo.

Maggot
16-may-2007, 00:37
hola soy nuevo en el mundo de linux y eleji el suse por que me parece muy atractivo como sistema operarivo.
el asunto que yo con el manual y todo no puedo instalar el driver cuando coloco chmod y el nombre del archivo me dice que no esxiste el archivo y no c que puedo hacer , porfavor si me pueden ayudar


el dirvers que tengo es ati-driver-installer-8.36.5-x86_64.run

ç


Salidos

tomeu
16-may-2007, 11:15
¿Y dónde lo tienes?
El comando 'chmod' es para cambiar las propiedades del archivo, con la variante '+x' se convierte en ejecutable.
chmod +x driver_fglrx.run Si lo haces desde consola verás que luego el archivo ha cambiado de color ;)

- Ve al directorio donde te has bajado el *.run: comando cd /ruta/archivo
- comando ls para ver lo que hay dentro (deberías ver el archivo de color negro)
- chmod +x nombre_archivo.run
- nuevo ls y ahora deberías verlo de color

omashu
24-oct-2007, 05:43
hola tengo opensuse10.3 yo me perdi aqui soy nuevo en suse;

Selecionar el modo automatico o "Automatic" y una vez instalado ejecutar para configurar automaticamente:
Código:

/usr/X11R6/bin/aticonfig --initial /usr/X11R6/bin/aticonfig --overlay-type=Xv

y pues cuando pongo fglrxinfo me sale :

Xlib: extension "XFree86.DRI" mising on display ":0.0"
Violacion del segmento

en que estoy mal

omashu
24-oct-2007, 21:06
oigan yo tengo un par de dudas:
1-porque nunca ponen el comando "SUDO" que no es necesario o que onda?
2-en este tutorial de diablo rojo me atore dond debemos seleccionar el modo automatico
3 al poner el comando glxgears me sale:
Xlib extension "Xfree86-DRI" mising on display :0.0
violacion del segemto

que hice mal? con ese y los comando de ese apartado me sale eso?
ayuda por favor.

eduararley
24-oct-2007, 22:05
Dos cositas:

1. Lo del SUDO es una costumbre ubuntera, que esconde deliberadamente el usuario root (no se porqué, la verdad). En otras distros, desde que ingreasa "su" en consola, eres root, y no necesitas un SUDO ni nada por el estilo
2. Para que los comandos "fglrxinfo" y "glxgears" te funcionen, debes tener una sesión gráfica iniciada.

omashu
26-oct-2007, 04:52
y entonces para que los comando funcionen necesito una secion grafia?
como activo una?
alguien sabe?

omashu
27-oct-2007, 23:35
hola perdon la molestia pero en el tutorial sobre el nuevo driver de ati para la aceleracion 3d hice todo bien excepto por la parte de la seleccion del modo automatico ya que como soy nuevo en open suse no entiendo a qu te refieres con ello?
y pues si pudieses aclarar mi duda te lo agradeceria

Gendeck
28-oct-2007, 20:43
Prueba instalar el driver con este (http://www.forosuse.org/forosuse/showthread.php?t=11066) tutorial