PDA

Ver la Versión Completa : [TUTORIAL] Como hacer funcionar los drivers de ATI...



Huess
12-dic-2005, 05:07
Bueno, para ser un rookie en asuntos de linux, he conseguido un triunfo absoluto tratando de instalar los drivers de ATI...

Ya hablaban sobre que casi funcionan los drivers a excepción de algunas cosillas:

http://www.forosuse.org/forosuse/showthread.php?t=3694

... y me he decidido a zanjar la cuestión, ya que los drivers que traia el SuSE 10.0 por defecto no tenían aceleración 3D, lo cual es una putada.

Solución: modificar el xorg.conf original con parámetros interesantes del xorg.conf generado por fglrxconfig.

Me he puesto ambos ficheros uno al lado del otro, para buscar diferencias, y he añadido lo que me parecía conveniente...

Para empezar debeis bajaros los ficheros necesarios del siguiente link:

https://support.ati.com/ics/support/default.asp?deptID=894&task=knowledge&folderID=300

Ahi seleccionais que quereis drivers para linux, vuestra tarjeta y tipo de máquina, en mi caso, con una Radeon 9550 y un sistema de 32 bits.

Tras navegar un poco, os dará la opción de bajaros el instalador para todas las versiones de X, o de bajaros el rpm específico de vuestro sistema. Con el instalador, el driver se instala correctamente, pero no lo hace para vuestra distribución (no tiene doporte para ninguna de SuSE) y no lo tendreis en YaST. Teneis que bajaros el específico de Xorg (por lo menos en el caso de Suse 10.0, creo que en le resto también)...

Bueno, una buena idea es crearos una carpeta (por ejemplo en /root/) que se llame rpms (o como os de la gana) para meter todos los rpm que os bajeis. Añadiendo esa carpeta a YaST podreis actualizar con facilidad.

Para añadir la carpeta como fuente de YaST, es tan facil como desde konqueror, sobre la carpeta que hayamos creado:

botón derecho -> Acciones -> Add directory as YaST source

El único problema es que cada vez que ejecuteis YaST, si no se ha modificado el contenido de dicha carpeta, os dira que la fuente no está actualizada. Eso se puede evitar desde YaST -> Cambiar fuente de instalación. Vereis que la carpeta que habeis añadido pone Actualizar Activado, y por ello os da el coñazo. Podeis desactivarlo seleccionando la carpeta -> Activar o desactivar actualizaciones. De este modo, cuando metais nuevos rpm's teneis que ir a YaST -> Cambiar fuente de instalación -> Seleccionar carpeta -> Editar -> Actualizar... o no os aparecerán los nuevos ficheros.

Cualquiera de los dos métodos es un coñazo, pero bueno, si lo desactivais, cuando tengais algo nuevo lo actualizais a pelo y así no os da la murga.

Bueno, pues tras añadir la carpeta como fuente de instalación, si desde YaST ejecutais Instalar/desinstalar software, buscais 'fglrx' y os deben aparecer una opcion, el paquete fglrx_6_8_0. Lo seleccionais para instalarlo y le dais a aceptar.

Antes de nada, hay que salvar nuestro xorg.conf para evitar lios si las cosas van mal...

xorg.conf -> xorg.conf.buena

Tras la instalación, teneis que ejecutar /usr/X11R6/bin/fglrxconfig, para que os genere el nuevo xorg.conf que utilice el nuevo driver pero que da problemas con Sax2. Haced de este una copia también:

xorg.conf -> xorg.conf.ati

Ahora volvemos a poner el xorg.conf como estaba al principio, utilizando el fichero xorg.conf.buena ... y lo editais. El aspecto de mi fichero modificado es el siguiente:



# /.../
# SaX generated X11 config file
# Created on: 2005-12-10T12:31:31+0100.
#
# Version: 7.1
# Contact: Marcus Schaefer <sax@suse.de>, 2002
#
# Automatically generated by [ISaX] (7.1)
# PLEASE DO NOT EDIT THIS FILE!
#
Section "Files"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/local"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/URW"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/PEX"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/kwintv"
FontPath "/usr/X11R6/lib/X11/fonts/truetype"
FontPath "/usr/X11R6/lib/X11/fonts/uni:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/CID"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
InputDevices "/dev/ttyS0"
InputDevices "/dev/ttyS1"
InputDevices "/dev/ttyS2"
InputDevices "/dev/ttyS3"
InputDevices "/dev/ttyS4"
InputDevices "/dev/ttyS5"
InputDevices "/dev/ttyS6"
InputDevices "/dev/ttyS7"
InputDevices "/dev/ttyS8"
InputDevices "/dev/psaux"
InputDevices "/dev/logibm"
InputDevices "/dev/sunmouse"
InputDevices "/dev/atibm"
InputDevices "/dev/amigamouse"
InputDevices "/dev/atarimouse"
InputDevices "/dev/inportbm"
InputDevices "/dev/gpmdata"
InputDevices "/dev/mouse"
InputDevices "/dev/usbmouse"
InputDevices "/dev/adbmouse"
InputDevices "/dev/input/mice"
InputDevices "/dev/input/event0"
InputDevices "/dev/pointer0"
InputDevices "/dev/pointer1"
InputDevices "/dev/pointer2"
InputDevices "/dev/pointer3"

# Nuevo .................................................. ...........
RgbPath "/usr/X11R6/lib/X11/rgb"
# Fin nuevo .................................................. ........

EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail"
EndSection

Section "Module"
Load "freetype"
Load "type1"
Load "dbe"
Load "glx"
# Load "extmod" <- ELIMINADO
# Load "v4l" <- ELIMINADO

# Nuevo .................................................. ............
SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension
EndSubSection
Load "dri"
# Fin nuevo .................................................. ........

EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "es"
Option "XkbModel" "pc102"
Option "XkbRules" "xfree86"

# Nuevo .................................................. ...............
Option "AutoRepeat" "500 30"
# Fin nuevo .................................................. ...........

EndSection

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "7"
Option "Device" "/dev/input/mice"
Option "Name" "ImExPS/2 Generic Explorer Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
DisplaySize 380 300
HorizSync 30-83
Identifier "Monitor[0]"
ModelName "LG ELECTRONICS L1915S"
VendorName "GSM"
VertRefresh 50-75
UseModes "Modes[0]"
EndSection

Section "Modes"
Identifier "Modes[0]"
Modeline "1280x1024" 134.72 1280 1320 1456 1696 1024 1025 1028 1068
Modeline "1280x960" 126.27 1280 1368 1504 1728 960 961 964 1001
Modeline "1280x960" 107.32 1280 1360 1496 1712 960 961 964 995
Modeline "1280x800" 104.35 1280 1360 1496 1712 800 801 804 835
Modeline "1280x800" 88.68 1280 1352 1488 1696 800 801 804 830
Modeline "1152x864" 102.08 1152 1224 1352 1552 864 865 868 901
Modeline "1152x864" 86.70 1152 1224 1344 1536 864 865 868 896
Modeline "1280x768" 99.17 1280 1352 1488 1696 768 769 772 801
Modeline "1280x768" 84.35 1280 1344 1480 1680 768 769 772 797
Modeline "1024x768" 79.52 1024 1080 1192 1360 768 769 772 801
Modeline "1024x768" 67.48 1024 1080 1184 1344 768 769 772 797
Modeline "800x600" 47.53 800 840 920 1040 600 601 604 626
Modeline "800x600" 40.19 800 832 912 1024 600 601 604 623
Modeline "768x576" 43.52 768 800 880 992 576 577 580 601
Modeline "768x576" 37.37 768 800 880 992 576 577 580 598
Modeline "640x480" 29.84 640 664 728 816 480 481 484 501
Modeline "640x480" 25.10 640 656 720 800 480 481 484 498
EndSection

Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "800x600" "768x576" "640x480"

# Nuevo .................................................. ................
ViewPort 0 0 # initial origin if mode is smaller than desktop
# Virtual 1280 1024
# Fin nuevo .................................................. ............

EndSubSection
SubSection "Display"
Depth 32
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "800x600" "768x576" "640x480"

# Nuevo .................................................. ................
ViewPort 0 0 # initial origin if mode is smaller than desktop
# Virtual 1280 1024
# Fin nuevo .................................................. ............

EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection

Section "Device"
BoardName "RV350 AS"
BusID "1:0:0"
# Driver "radeon" <- ELIMINADO
Identifier "Device[0]"
Option "usevnc" "no"

# Nuevo .................................................. ......
Driver "fglrx"
# ### generic DRI settings ###
# === disable PnP Monitor ===
#Option "NoDDC"
# === disable/enable XAA/DRI ===
Option "no_accel" "no"
Option "no_dri" "no"
# === misc DRI settings ===
Option "mtrr" "off" # disable DRI mtrr mapper, driver has its own code for mtrr
# ### FireGL DDX driver module specific settings ###
# === Screen Management ===
Option "DesktopSetup" "Single"
Option "ScreenOverlap" "0"
Option "GammaCorrectionI" "0x06419064"
Option "GammaCorrectionII" "0x06419064"
# === OpenGL specific profiles/settings ===
Option "Capabilities" "0x00000000"
Option "CapabilitiesEx" "0x00000000"
# === Video Overlay for the Xv extension ===
Option "VideoOverlay" "on"
# === OpenGL Overlay ===
# Note: When OpenGL Overlay is enabled, Video Overlay
# will be disabled automatically
Option "OpenGLOverlay" "off"
# === Center Mode (Laptops only) ===
Option "CenterMode" "off"
# === Pseudo Color Visuals (8-bit visuals) ===
Option "PseudoColorVisuals" "off"
# === QBS Management ===
Option "Stereo" "off"
Option "StereoSyncEnable" "1"
# === FSAA Management ===
Option "FSAAEnable" "no"
Option "FSAAScale" "1"
Option "FSAADisableGamma" "no"
Option "FSAACustomizeMSPos" "no"
Option "FSAAMSPosX0" "0.000000"
Option "FSAAMSPosY0" "0.000000"
Option "FSAAMSPosX1" "0.000000"
Option "FSAAMSPosY1" "0.000000"
Option "FSAAMSPosX2" "0.000000"
Option "FSAAMSPosY2" "0.000000"
Option "FSAAMSPosX3" "0.000000"
Option "FSAAMSPosY3" "0.000000"
Option "FSAAMSPosX4" "0.000000"
Option "FSAAMSPosY4" "0.000000"
Option "FSAAMSPosX5" "0.000000"
Option "FSAAMSPosY5" "0.000000"
# === Misc Options ===
Option "UseFastTLS" "0"
Option "BlockSignalsOnLock" "on"
Option "UseInternalAGPGART" "no"
Option "ForceGenericCPU" "no"
# Fin nuevo .................................................. ........

Screen 0
VendorName "ATI"
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
EndSection


Bueno, obviamente solo debeis añadir las cosas que aparecen entre


# Nuevo .................

# Fin nuevo ...................

... y eliminar las que pongo <- ELIMINADO.

Hay otra modificacion que es el autorepeat del teclado, que no tiene nada que ver con la ATI pero que me gustó de la config generada...

De todos modos, todo lo que he introducido nuevo lo he sacado del xorg.conf.ati, por lo que os recomiendo que repaseis vuestros ficheros para ver si os genera lo mismo u otra cosa (depende de vuestras respuestas al ejecutar fglrxconfig).

...

Huess
12-dic-2005, 05:08
...

Tras crear vuestro xorg.conf modificado convenientemente, teneis que volver a ejecutar las X, pulsando Ctrl + Alt + Backspace y luego loggeandose y ejecutando startx.

Una vez hecho eso, ejecutais Sax2 para ver vuestra config y tal.

Esta vez todo está en orden, teneis vuestro monitor seleccionado correctamente, al igual que el raton y el teclado. En las opciones de la tarjeta aparecen un mogollón de variables definidas que antes ni aparecían!

Una vez comprobado todo, le damos a aceptar, luego a probar, ajustamos el monitor y guardamos.

Tras esto nos dice que reiniciemos las X (como os he indicado antes) para que surtan efecto los cambios.

Tras todo esto, el Sax2 nos vuelve a modificar el xorg.conf quitando todos los comentarios y dejando solo lo necesario:


# /.../
# SaX generated X11 config file
# Created on: 2005-12-12T03:36:26+0100.
#
# Version: 7.1
# Contact: Marcus Schaefer <sax@suse.de>, 2002
#
# Automatically generated by [ISaX] (7.1)
# PLEASE DO NOT EDIT THIS FILE!
#
Section "Files"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/local"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/URW"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/PEX"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/kwintv"
FontPath "/usr/X11R6/lib/X11/fonts/truetype"
FontPath "/usr/X11R6/lib/X11/fonts/uni:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/CID"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
RgbPath "/usr/X11R6/lib/X11/rgb"
InputDevices "/dev/ttyS0"
InputDevices "/dev/ttyS1"
InputDevices "/dev/ttyS2"
InputDevices "/dev/ttyS3"
InputDevices "/dev/ttyS4"
InputDevices "/dev/ttyS5"
InputDevices "/dev/ttyS6"
InputDevices "/dev/ttyS7"
InputDevices "/dev/ttyS8"
InputDevices "/dev/psaux"
InputDevices "/dev/logibm"
InputDevices "/dev/sunmouse"
InputDevices "/dev/atibm"
InputDevices "/dev/amigamouse"
InputDevices "/dev/atarimouse"
InputDevices "/dev/inportbm"
InputDevices "/dev/gpmdata"
InputDevices "/dev/mouse"
InputDevices "/dev/usbmouse"
InputDevices "/dev/adbmouse"
InputDevices "/dev/input/mice"
InputDevices "/dev/input/event0"
InputDevices "/dev/pointer0"
InputDevices "/dev/pointer1"
InputDevices "/dev/pointer2"
InputDevices "/dev/pointer3"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail"
EndSection

Section "Module"
Load "extmod"
Load "type1"
Load "glx"
Load "freetype"
Load "dbe"
Load "dri"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "AutoRepeat" "500 30"
Option "Protocol" "Standard"
Option "XkbLayout" "es"
Option "XkbModel" "pc102"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "7"
Option "Device" "/dev/input/mice"
Option "Name" "ImExPS/2 Generic Explorer Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
DisplaySize 380 300
HorizSync 30-83
Identifier "Monitor[0]"
ModelName "LG ELECTRONICS L1915S"
VendorName "GSM"
VertRefresh 50-75
UseModes "Modes[0]"
EndSection

Section "Modes"
Identifier "Modes[0]"
Modeline "1280x1024" 134.72 1280 1368 1504 1728 1024 1025 1028 1068
Modeline "1280x960" 126.27 1280 1368 1504 1728 960 961 964 1001
Modeline "1280x960" 107.32 1280 1360 1496 1712 960 961 964 995
Modeline "1280x800" 104.35 1280 1360 1496 1712 800 801 804 835
Modeline "1280x800" 88.68 1280 1352 1488 1696 800 801 804 830
Modeline "1152x864" 102.08 1152 1224 1352 1552 864 865 868 901
Modeline "1152x864" 86.70 1152 1224 1344 1536 864 865 868 896
Modeline "1280x768" 99.17 1280 1352 1488 1696 768 769 772 801
Modeline "1280x768" 84.35 1280 1344 1480 1680 768 769 772 797
Modeline "1024x768" 79.52 1024 1080 1192 1360 768 769 772 801
Modeline "1024x768" 67.48 1024 1080 1184 1344 768 769 772 797
Modeline "800x600" 47.53 800 840 920 1040 600 601 604 626
Modeline "800x600" 40.19 800 832 912 1024 600 601 604 623
Modeline "768x576" 43.52 768 800 880 992 576 577 580 601
Modeline "768x576" 37.37 768 800 880 992 576 577 580 598
Modeline "640x480" 29.84 640 664 728 816 480 481 484 501
Modeline "640x480" 25.10 640 656 720 800 480 481 484 498
EndSection

Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection

Section "Device"
BoardName "RV350 AS"
BusID "1:0:0"
Driver "fglrx"
Identifier "Device[0]"
Option "DesktopSetup" "Single"
Option "FSAADisableGamma" "no"
Option "OpenGLOverlay" "off"
Option "Stereo" "off"
Option "FSAAMSPosX3" "0.000000"
Option "CenterMode" "off"
Option "FSAAMSPosY0" "0.000000"
Option "ScreenOverlap" "0"
Option "mtrr" "off"
Option "FSAAMSPosX4" "0.000000"
Option "FSAAMSPosY1" "0.000000"
Option "IgnoreEDID" "off"
Option "TVHPosAdj" "0"
Option "ForceGenericCPU" "no"
Option "FSAAScale" "1"
Option "FSAAMSPosX5" "0.000000"
Option "FSAAMSPosY2" "0.000000"
Option "FSAAMSPosY3" "0.000000"
Option "GammaCorrectionI" "0x00000000"
Option "no_accel" "no"
Option "FSAAMSPosY4" "0.000000"
Option "FSAACustomizeMSPos" "no"
Option "UseFastTLS" "0"
Option "NoTV" "yes"
Option "FSAAMSPosY5" "0.000000"
Option "BlockSignalsOnLock" "on"
Option "FSAAEnable" "no"
Option "GammaCorrectionII" "0x00000000"
Option "TVHSizeAdj" "0"
Option "VideoOverlay" "on"
Option "TVVPosAdj" "0"
Option "no_dri" "no"
Option "TVColorAdj" "0"
Option "StereoSyncEnable" "1"
Option "TVVSizeAdj" "0"
Option "UseInternalAGPGART" "no"
Option "UseInternalAGPGART" "no"
Option "TVHStartAdj" "0"
Option "PseudoColorVisuals" "off"
Option "usevnc" "no"
Option "FSAAMSPosX0" "0.000000"
Option "Capabilities" "0x00000000"
Option "FSAAMSPosX1" "0.000000"
Option "TVStandard" "NTSC-M"
Option "FSAAMSPosX2" "0.000000"
Screen 0
VendorName "ATI"
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
EndSection


Por último, para probar todo el tema de una vez por todas, ejecutais /usr/X11R6/bin/fgl_glxgears para poder ver unos estupendos engranajes 3D que nos vaticinan el éxito de nuestra operación: Driver ATI actualizado con soporte para 3D y Sax2 completamente funcional...

Un saludo!

Huess
12-dic-2005, 05:23
Ah, bueno, se me olvidaba comentar que tengo SuSE 10.0 (supongo que con el resto si no son excesivamente viejos será igual) y una ATI Radeon 9550 (Club 3D).

Un saludo, me voy pa la piltra.

impala
12-dic-2005, 12:41
Vamos a probarlo, aunque en principio me reconoce la tarjeta con otro nombre, yo tengo una radeon xpress 200M (es un portatil), no sé cual es la tuya ... pero a ver que sale ...

Huess
12-dic-2005, 12:47
Yo os recomiendo que en vez de copiar directamente las lineas que yo le he puesto, trateis de extraer de vuestro fichero xorg.conf las líneas correspondientes por si acaso no son las mismas...

De todos modos, podeis probar lo que querais, mientras que tengais el xorg.conf original para volver a la normalidad...

Un saludo!

cachi
11-mar-2006, 14:52
Ayer estuve probando según tus notas con mi ATI x300 y no funcionó. Ejecuntando el sax2 la resolución no podía cambiarse ni siquiera las frecuencias del monitor. Hice así: Guardé la configuración del xorg original y fui agregando o quitando según el xorg generado al instalar el rpm de ATI. No obstante, la idea, si no entendí mal es hacer un nuevo fichero xorg entre el original y el nuevo de ATI. Volveré a probar y te comento.
Otra cosa respecto a la profundidad de color. ¿Cuando instalás el driver te habilita la produndidad de 32 bits?
Muy buen tutorial. Felicitaciones.
Saludetes.

kordo
13-mar-2006, 19:41
hola :aplausos: :aplausos:
tengo una radeon 9250 que ahora me va de cojones en mi monitor pero en la tv del salon no encuentro la manera de que se vea
ni el GATOS ni el ATITVOUT.... :( ni por supuesto el propio driver de ati me han servido

podeis hecharme una manilla :adios: :

DiabloRojo
13-mar-2006, 19:57
Copia el fichero /etc/X11/xorg.conf por si tienes problemas despues. Como usuario root ejecuta fglrxconfig en un apartado pregunta sobre salida a TV.

omashu
15-oct-2007, 23:59
hola yo tengo una ati radeon xpress200m y no puedo configurarla podrian ayudarme?
se que "impala" tiene una = (creo) ayuda por favor
aunq cabe destacar q yo cuento con la version opensue10.3
creen que alla alguna diferencia?

eduararley
21-oct-2007, 08:12
http://en.opensuse.org/ATI_Radeon_Xpress