PDA

Ver la Versión Completa : Problema con Apache



CGSHBL
15-nov-2004, 14:10
Hola a todos!

He instalado Apache desde YaST, sin problemas, pero a la hora de copiar un archivo en la carpeta /srv/www/htdocs, me dice que "Acceso denegado No se pudo escribir en /srv/www/htdocs/nombre del archivo.php3.

Por otra parte cuando trato de entrar en http://localhost , sale lo siguiente:

¡Acceso prohibido!

Usted no tiene permiso para accesar a la dirección solicitada. Existe la posibilidad de que el directorio este protegido contra lectura o que no exista la documentación requerida.

Por favor contacte con el webmaster en caso de que usted crea que existe un error en el servidor.
Error 403
localhost
Mon Nov 15 08:51:19 2004
Apache/2.0.50 (Linux/SUSE)

Que tengo que hacer?
la verdad, estoy recien incursionando en linux, y es la primera vez que estoy instalando el servidor para hacer pruebas con SPIP y MAMBO. esa es la razon, no quiero subir al dominio sin saber antes como funciona y aprender mas antes de hacerlo publico.

Gracias a todos :aplausos:

benysar
15-nov-2004, 14:26
Hola a todos!

He instalado Apache desde YaST, sin problemas, pero a la hora de copiar un archivo en la carpeta /srv/www/htdocs, me dice que "Acceso denegado No se pudo escribir en /srv/www/htdocs/nombre del archivo.php3.


Has de escribir en esa carpeta siendo root, es decir....cualquier cosa que pongas dentro has de ser root


Por otra parte cuando trato de entrar en http://localhost , sale lo siguiente:

¡Acceso prohibido!

Usted no tiene permiso para accesar a la dirección solicitada. Existe la posibilidad de que el directorio este protegido contra lectura o que no exista la documentación requerida.


Exactamente...comprueba los permisos para esa carpeta. eso lo puedes hacer si abres un explorador como root, y botón derecho sobre la carpeta. comprueba que en la pestaña permisos la seción "otros y "grupo" tienen los permisos de "pueden visualizar el contenido"

Dudu678
16-nov-2004, 18:23
Aprovecho para decir que a mí me dice que fue rechazada la conexión... Tengo el firewall abierto.

Elmer
13-feb-2005, 02:49
Sobre apache, yo lo he istalado des de YaST tambien pero cuando voy a http://localhost , no me funciona... da el error de que no se puedo encontrar el sito o algo asi es como si no estubiera instalado el servidor.
:(

Kaisermart
13-feb-2005, 11:54
Ya somos cuatro que nos pasa lo mismo. :) :)

Saludos

riven
13-feb-2005, 12:10
Yo para montaros Apache, Mysql, Perl, PHP y demas os recomiendo que useis un programa como Xampp, lo podreis descargar desde aqui (http://www.apachefriends.org/en/xampp-linux.html); en cuanto a los permisos de escritura probad a cambiar los permisos de la carpeta que os intererese, haciendo:


riven@linux:~> su
Password:
linux:/home/riven # chmod -Rf 777 /ruta_servidor/carpeta


con esto dareis permiso de escritura a a la carpeta y todo lo que haya incluido en ella.

un saludo.

Kaisermart
13-feb-2005, 17:32
40 megas de nada. Menos mal que parece ser que tiene todo y la instalación solo es descomprimir. a ver que tal se porta.

Saludos

Elmer
14-feb-2005, 17:31
gracias por el enlace
lo instale y me salio todo bien :)

riven
14-feb-2005, 17:50
gracias por el enlace
lo instale y me salio todo bien :)

Me alegra verte por aqui. :) espero que disfrutes con SuSE y en breve hayas dejado a un lado el mundo oscuro. :dedosarri
por cierto, hay que agradecer en parte el funcionamiento del portal a este señor, jejeje, ademas de que la traduccion al español es suya, asi si hay quejas que vayan dirigidas a el. :p

anata
04-jul-2007, 02:03
Antes de responder me disculpo si el tema es muy viejo, pero como tuve el mismo problema voy a dar la solución que encontré.

Parece que el problema reside en los permisos, en /srv/www/htdocs , como no quiero entrar siempre como "root" porque aun soy nuevo en linux, pues me fui a YaST Seguridad y Usuarios, Gestionar Usuarios, ahi marque mi usuario y le di Editar, lo añadi al grupo "root".

Luego tuve que entrar en session de usuario (no di con otra manera de hacerlo) y cambie los permisos de la carpeta /srv/www/htdocs , le cambie el permiso al grupo, le puse ,"Se puede visualizar y Modificar el contenido", cerré sesión root y volví a mi usuario.

Probe guardando un archivo info.php en la carpeta y asi lo hizo, probe en el navegador http://localhost/info.php y lo corrió normal. luego probe http://localhost/ y para mi sorpresa me volvio a salir que no tenia permisos, lo cual me parecio extraño, cambie el nombre de info.php a index.php y volvi a http://localhost/ y corrio el archivo sin problemas.


Sobre apache, yo lo he istalado des de YaST tambien pero cuando voy a http://localhost , no me funciona... da el error de que no se puedo encontrar el sito o algo asi es como si no estubiera instalado el servidor.

Tienes que inicializar el servicio en el YaST, Sistema, Editor de Niveles de Ejecucion, ahi busca Apache2 y activalo, si instalaste MySQL tambien activalo.

Salu2, espero les sirva.

gama_blind
10-jul-2007, 07:59
Tengo un problema con el PHP cuando intent accesar desde el navegador me da opcion de guardar el archivo index.php


Alguien sabe como solucionarlo, el apache ya me funciona bien...

alhernandezs
03-oct-2007, 16:07
Al paracer no esta reconociendo ese tipo de archivo y ese cuando ocurre es que el php no esta instalado
Verifica que php este instalado.

alhernandezs
03-oct-2007, 16:11
Tal vez sea un poco tarde para mi respuesta, pero entrego a ustedes la solucion que encontre para mi problema ya que me presentaba Error 403 no tiene permiso para ver....
Bueno solo lo que toca hacer es modificar el archivo httpd.conf en donde dice
<directory>
.
options indexes.
..

eso fue todo ya tenia acceso.

Aclaro que en algunos casos debes buscar httpd-default.conf ya que si se realiza la instalacion con el yast los archivos de configuracion se reparten por no se que razon