PDA

Ver la Versión Completa : Actualización de seguridad de Samba 3



chuzo
12-nov-2004, 23:21
Las versiones no actualizadas de Samba son susceptibles a un ataque de denegación de servicio que permite que un atacante remoto consuma una gran cantidad de recursos, especialmente CPU. Con la suficiente insistencia, el servidor SAMBA puede quedar inaccesible para el resto de usuarios.

Samba es una implementación Unix "Open Source" del protocolo SMB/NetBIOS, utilizada para la compartición de archivos e impresora en entornos Windows. Gracias a este programa, se puede lograr que máquinas Unix y Windows convivan amigablemente en una red local, compartiendo recursos comunes. Incluso es factible utilizar un servidor Samba para, por ejemplo, actuar como controlador de un dominio Microsoft Windows.

La vulnerabilidad reside en la gestión de máscaras de nombre de ficheros, y es explotable por cualquier usuario remoto con acceso al servidor SAMBA.

Hispasec recomienda a todos los administradores de sistemas SAMBA que actualicen cuanto antes a la versión 3.0.8, especialmente si el servidor es accesible a usuarios no confiables. Es de destacar que existen dos versiones 3.0.8 publicadas, la primera de las cuales contiene varios errores en la documentación y en los permisos. Si ha descargado Samba 3.0.8 antes del 9 de Noviembre, deberá descargar la versión actualizada.

Más información: HispaSec (http://www.hispasec.com/unaaldia/2211)
Samba (http://www.samba.org/samba/)
Security Notice -- CVE CAN-2004-0930 (http://www.samba.org/samba/news/#security_3.0.8)
CAN-2004-0930: Potential Remote Denial of Service Vulnerability in Samba 3.0.x <= 3.0.7 (http://www.samba.org/samba/security/CAN-2004-0930.html)

Un saludo :adios: