PDA

Ver la Versión Completa : ¿desactivar firewall para acceder a la red local?



birraboy
03-ene-2006, 10:44
Saludos compañeros!
Tengo un ordenador el que utilizo frecuentemente con suse 10 instalado y en mi red local dispongo tambien de otros pc windows, cuando iba a acceder a mi red local me bloqueaba avisandome de que había algún tipo de firewall que intervenía, para poder acceder a la red local he tenido que desactivar el firewall pero esta practica no me gusta. ¿Sabrías decirme de que manera configurar el firewall para poder acceder a mi red local sin tener que desactivar por completo el firewall?.
Muchas gracias!

kilops
03-ene-2006, 14:43
no tienes que desactivar el firewall,samba el firewall ya permite a samba el acceso.postea tu archivo smb.conf.
salu2

birraboy
04-ene-2006, 09:59
Gracias Kilops por las molestias!. Te adjunto mi configuración del archívo smb.conf, no obstante te comento que toda la red la he configurado por yast, y que en la configuración que te envio de samba no coincede con el nombre de mi grupo de trabajo, aunque mi red está 100% operativa siempre y cuando tenga el firewall desactivado.

smb.conf:


# smb.conf is the main Samba configuration file. You find a full commented
# version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
# samba-doc package is installed.
# Date: 2005-11-11
[global]
workgroup = TUX-NET
printing = cups
printcap name = cups
printcap cache time = 750
cups options = raw
map to guest = Bad User
include = /etc/samba/dhcp.conf
logon path = \\%L\profiles\.msprofile
logon home = \\%L\%U\.9xprofile
logon drive = P:
[homes]
comment = Home Directories
valid users = %S
browseable = No
read only = No
inherit acls = Yes
[profiles]
comment = Network Profiles Service
path = %H
read only = No
store dos attributes = Yes
create mask = 0600
directory mask = 0700
[users]
comment = All users
path = /home
read only = No
inherit acls = Yes
veto files = /aquota.user/groups/shares/
[groups]
comment = All groups
path = /home/groups
read only = No
inherit acls = Yes
[printers]
comment = All Printers
path = /var/tmp
printable = Yes
create mask = 0600
browseable = No
[print$]
comment = Printer Drivers
path = /var/lib/samba/drivers
write list = @ntadmin root
force group = ntadmin
create mask = 0664
directory mask = 0775

kilops
04-ene-2006, 15:40
smb.conf is the main Samba configuration file. You find a full commented
# version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
# samba-doc package is installed.
# Date: 2005-11-11
[global]
workgroup = TUX-NET
printcap name = cups
cups options = raw
map to guest = Bad User
include = /etc/samba/dhcp.conf
logon path = \\%L\profiles\.msprofile
logon home = \\%L\%U\.9xprofile
logon drive = P:
add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
domain master = no
security = share
restrict anonymous = no
preferred master = no
max protocol = NT
ldap ssl = No
server signing = Auto
guest ok = yes

este es mi rchivo smb.conf i me funciona perfectamente con el firewall!prueba de añadir lo que te falta a tu confuguracion!saludos

birraboy
05-ene-2006, 12:17
Nada de nada, sigue sin funcionar aún así, es curioso, accediendo al firewall mediante yast me doy cuenta que el firewall en la zona externa no tiene ningún servidor activado, en la zona interna no actua el cortafuegos y en la zona desmilitarizada tampoco tengo nada. ¿Es correcta esta configuración?. Gracias por las molestias.

kilops
05-ene-2006, 16:26
buenas,yo tengo en el apartado de servicios autorizados del firewall "servidor samba" ,pero se no lo puse manualmente,se autorizo solo quando configure samba.
prueba de volver a cargar la configuracion samba a ver que tal.
Tambien modifique en el centro de control>internet red>samba los parametros de "compartir archivos" ,supongo que tambien ya lo hiciste.
si aun i asi no te funciona,instala con el apt-get los paquetes smbclient,smbfs,y samba i luego instalate smb4k que es un scaner de redes i podras montar los directorios que quieras compartir.
salu2