PDA

Ver la Versión Completa : configurar vsftpd en SuSE



birraboy
26-dic-2005, 13:39
Saludos!
Mi problema viene al intentar iniciar el servicio vsftpd, os comento, he configurado el archívo vsftpd.conf siguiendo este manual:
http://www.linuxparatodos.net/geeklog/staticpages/index.php?page=09-como-vsftpd

una vez configurado tengo que iniciar el servicio vsftpd pero no encuentro el comando para hacerlo ya que pongo
/sbin/service vfstpd start
y no lo reconoce. ¿alguna sugerencia?

DiabloRojo
26-dic-2005, 14:24
yum -y install vsftpd
/sbin/service vfstpd startEsto se refiere a Fedora Core o Red Hat.
En Suse, hay que localizar el comando vfstpd con "whereis vfstpd" o similar, donde tiene que haber un script de arranque en "/etc/init.d", por lo tanto el equivalente sera "/etc/init.d/vfstpd start"

noxious
31-dic-2005, 12:39
también deberás activarlo si está desabilitado, edita el fichero /etc/xinetd/vsftpd y en la linea disable=yes pon no, por supuesto el xinetd debe estar corriendo, rcxinetd start.


# default: off
# description:
# The vsftpd FTP server serves FTP connections. It uses
# normal, unencrypted usernames and passwords for authentication.
# vsftpd is designed to be secure.
service ftp
{
socket_type = stream
protocol = tcp
wait = no
user = root
server = /usr/sbin/vsftpd
# server_args =
# log_on_success += DURATION USERID
# log_on_failure += USERID
# nice = 10
disable = no
}

birraboy
13-ene-2006, 11:15
ya esta solucionado muchas gracias!!
Como lo puedo configurar para que arranque al inicio??
y como configuro el firewall para que no me relentice tanto el acceso al ftp.

Espero me ayudeis en mis problemas. Gracias!

DiabloRojo
13-ene-2006, 21:09
Abre el puerto 21 que es el predestinado para ftp. Sobre como arrancar al principio, metelo en /etc/init.d y crea un enlace simbolico tipo K* en rc.d5 y otro S* o utiliza el gestor de servicios de Yast, estoy en XP.

carla
03-jul-2006, 18:33
Hola mi nombre es carla , soy nueva en linux-suse y quiero solicitar ayuda urgente, envio lo que tengo si alguien puede ayudarme. porfavor.
No es con usuarios fantasma

configuracion es esta: vsftpd.conf

write_enable=yes
dirmessage_enable=YES
ftpd_banner="Bienvenidos al servidor "
local_enable=YES
local_umask=022
chroot_local_user=YES
chroot_list_enable=YES
chroot_list_file=/etc/vsftpd/vsftpd.chroot_list
local_max_rate=7200
max_per_ip=3
anonymous_enable=NO
anon_world_readable_only=YES
anon_max_rate=7200
max_clients=3
syslog_enable=YES
log_ftp_protocol=YES
setproctitle_enable=YES
connect_from_port_20=YES
pam_service_name=vsftpd
listen=YES


/etc/xinetd.d/vsftpd

# default: off
# description:
# The vsftpd FTP server serves FTP connections. It uses
# normal, unencrypted usernames and passwords for authentication.
# vsftpd is designed to be secure.
#
# NOTE: This file contains the configuration for xinetd to start vsftpd.
# the configuration file for vsftp itself is in /etc/vsftpd.conf
service ftp
{
# server_args =
# log_on_success += DURATION USERID
# log_on_failure += USERID
nice = 10
socket_type = stream
protocol = tcp
wait = no
user = root
server = /usr/sbin/vsftpd
disable = no
}

cuando lo ejecuto me aparece..

linux:~ # /etc/init.d/xinetd start
Starting INET services. (xinetd) done
linux:~ # /usr/sbin/vsftpd
500 OOPS: missing value in config file for: has an effect if the above global write enable is activated. Also, you will
linux:~ # ftp localhost
Trying 127.0.0.1...
Connected to localhost.
500 OOPS: missing value in config file for: has an effect if the above global write enable is activated. Also, you will

no se que tengo erroneo si alguien me puede acarar esto porfavor escribrme es urgente tu respuesta.

DiabloRojo
04-jul-2006, 18:16
No utilizo vsftpd. Mirate esto: http://www.google.es/search?q=500+OOPS%3A+missing+value+in+config+file+ for%3A+has+an+effect+if+the+above+global+write+ena ble+is+activated.+Also%2C+you+will&start=0&ie=utf-8&oe=utf-8&client=firefox-a&rls=org.mozilla:es-ES:official

carla
05-jul-2006, 22:30
gracias te agradezco mucho que hayas leido mi publicacion.

Yedi
22-jul-2006, 21:55
Hola segui los paso que dio diablo para iniciar el ftp pero el problema es q ya ck el archivo de init.d y no viene el vfstpd, normalmente inicio el mysql en KSysV, pero tampoco esta ahi ya he iniciado el xinetd y cambie el archivo q inidica pero nada al dar el comando me indica lo siguiente:
/etc/init.d/vfstpd start
bash: /etc/init.d/vfstpd: No such file or directory

pero al dar ftp localhost

ftp localhost
Trying 127.0.0.1...
Connected to localhost.
220 "Bienvenido al FTP"
Name (localhost:root):

por lo q me imagino q solo falta iniciar el servicio, pero no le hayo como ¿?
Agradeceria mucho su ayuda :)

DiabloRojo
23-jul-2006, 08:35
Comprueba que lo tengas instalado: "ls -al /etc/init.d/vfstpd*".