PDA

Ver la Versión Completa : recuperar grub despues de haber instalado windows



annubis
26-sep-2011, 03:45
Hola.
Parace que hay muchas personas que se desesperan por tener instalado linux y despues de haber instalado windows ya no pueden recuperar el grub.

La receta es facil y sencilla:

Metemos nuestro dvd de instalación de opensuse, ahí elegimos rescue system.

una vez que arrancamos en rescue y nos aparece el bash de la terminal.

Le ponemos root en el login (no nos pide contraseña),

- escribimos grub

grub>root (hd0,1) (la primera parte del parentesis es el disco primario y la segunda parte es la particion donde esta.

grub>setup (hd0) 'reactivamos' el grub

grub>quit

rescue# reboot

A mi me acaba de funcionar despues de haber instalado windows 7.

saludos

Holmes
26-sep-2011, 14:00
hola annubis, muy bueno la receta para recuperar el grub después de haber instalado windows. creó que va a ayudar muchos usuarios que quieren instalar windows.

Saludos...

vlw fwi, Holmes :)

jesusx
26-sep-2011, 22:32
Gracias!! Fácil y rápido, para quien use window$ claro...
Salu2:adios:

oscarpoio
20-nov-2011, 22:54
Faltaría decir que una vez recuperado se puede poner "bonito" volviendo a crearon desde yast

navarrete
22-nov-2011, 15:52
Hola: Lo que sucede es que Windog cree que es lo único que exite en el mundo y alrededores, y cambia la partición activa (donde esta el grub) a la partición "c", por tanto hay que volver a activar la partición donde se encuentra Grub. Yo utilizo "SystemRescue", es un live CD con mucha opciones e interfaz gráfica con la cual ejecuto Gparted para activar la partición donde se encuentra Grub.

Astro
22-sep-2013, 19:52
A mi me paso lo contrario, instale OpenSUSE 12.3 y ahora solo me arranca directamente, entre a ver mis particiones desde Linux y ahí sigue la de windous solo que en el grub no me aparece, alguna solución? soy ultra novato :D

enae
25-sep-2013, 09:58
A mi me paso lo contrario, instale OpenSUSE 12.3 y ahora solo me arranca directamente, entre a ver mis particiones desde Linux y ahí sigue la de windous solo que en el grub no me aparece, alguna solución? soy ultra novato :D
Hola Astro, seguramente instalaste y dejaste activada la casilla de verificación de inicio automático
paso 1.
ve a inicio, en buscar tipea user > gestión de usuarios y grupos > se abrirá yaST2 > opciones avanzadas > desmarca las casillas correspondientes.
paso 2
por si el grub esta desconfigurado:
abre la pizarrina (terminal) y tipea

sudo /usr/sbin/grub2-mkconfig -o /boot/grub2/grub.cfg