PDA

Ver la Versión Completa : Solución temporal: nVidia drivers 260.19.29 y Amarok 2



Eternal_Sin
31-ene-2011, 05:01
Después de hurgar mucho he encontrado algo al menos temporal.
Mi configuración hardware y software viene a ser

Intel Core2Dúo T7250 @2Ghz
nVidia GeForce 9200M
Amarok 2.30 y 2.40 (con los dos crasheaba al arrancar)
KDE 4.4.4 (Stable)
Qt 4.6
OpenSuSE 11.3 x86
nVidia 260.19.29 instalado a través de One Click Install desde la página oficial de opensuse

Links de interés

nVidia Drivers: http://midsofts.com/archives/nvidia-256-53-linux-display-driver.html
Post en inglés: http://forums.opensuse.org/english/get-technical-help-here/multimedia/448737-opensuse-11-3-amarok-crashes-startup.html
Post de este mismo foro en español: http://www.forosuse.org/forosuse/showthread.php?p=134653

Bien. Tras bastante navegar, probar distintas versiones y trastear con librerías, no estoy seguro de si el daño ha sido irreparable para mi camaleoncito pero ya tengo música que es algo pelea:

Según parece trae un poco de cabeza a la comunidad de KDE y no es para menos. Este problema se me ha dado utilizando el paquete

nvidia-gfxG02-kmp-default 260.19.29
x11-video-nvidiaG02 260.19.29

Software necesario:
gcc
kernel-devel
Los drivers de nvidia, una versión anterior, link del que utilizo al principio del post

1º Desinstalar

nvidia-gfxG02-kmp-default 260.19.29
x11-video-nvidiaG02 260.19.29

Se puede hacer perfectamente con yast, supongo que eso no tengo que explicarlo (o con zypper :P)

2º Abrir una terminal y como root cambiar a init 3
root@eternalpc ~ $ init 3 <- Pequeño ejemplo gráfico para los muy nuevos :P

Nos logueamos como root y navegamos hasta la carpeta donde tengamos los drivers descargados (en formato .sh o .run)

3º Ejecutar el fichero descargado con sh
root@eternalpc ~ $ sh NVIDIA-Linux-x86-256.53.run

Está en inglés, así que le damos al primer campo "Acept", es el acuerdo de licencia

3.1º Si está nouveau instalado, le decís al programa cuando os lo ofrezca que queréis añadir una entrada a la blacklist para deshabilitar el nouveau. Hasta que no hagáis esto o desinstaléis el paquete manualmente no os dejará continuar. Sea como sea, después de solucionar ese problemita habrá que reiniciar, tras lo cuál, habrá que abrir una terminal para volver a hacer todo lo del init 3 para delante

4º Reiniciar sistema

5º Disfrutar :B

sieg84
02-mar-2011, 07:48
con el kernel 2.6.37 aparece no build nvidia kernel con el driver 256, con el 260 se instalaba, pero no arrancaba KDE4. toco volver al kernel 2.6.34 y el driver 256.

xisco
02-mar-2011, 10:29
Nada pues que no han arreglado los problemas, yo me volvi a la 256 y ahi me he quedado, ademas me guarde los rpm :) si alguien los quiere los puedo subir a algun sitio.

Salu2

caligulaelsanto
03-mar-2011, 06:42
esta visto que esto no se va a solucionar parece, ademas no anda virtualbox