PDA

Ver la Versión Completa : falla la instalacion de virtualbox guest additions



ramses_17
01-ene-2011, 05:39
sistema huesped: opensuse 11.2 instalado desde la iso DVD
sistema anfitrion de 32 bits
virtualbox 3.2.10

no podia instalar los DKMS desde el yast2 por lo que tuve que descargarlo desde la siguiente direccion:

http://software.opensuse.org/ymp/isv:dell:community/suse11.2-x86_64/dkms.ymp

al instalarlo me dio el siguiente error al correr el archivo .run del cd de virtualboxguestadditions

linux-c0i4:/media/VBOXADDITIONS_3. # ./VBoxLinuxAdditions-x86.run
Verifying archive integrity... All good.
Uncompressing VirtualBox 3.2.10 Guest Additions for Linux.........
VirtualBox Guest Additions installer
Removing installed version 3.2.10 of VirtualBox Guest Additions...
tar: Tamaño del registro = 8 bloques
Uninstalling old VirtualBox DKMS kernel modules done
Building the VirtualBox Guest Additions kernel modules failed
Your system does not seem to be set up to build kernel modules.
Look at /var/log/vboxadd-install.log to find out what went wrong. Once you have corrected it, you can
run

/etc/init.d/vboxadd setup

to build them.
Doing non-kernel setup of the Guest Additions done
Installing the Window System drivers
Installing X.Org Server 1.6 modules done
Setting up the Window System to use the Guest Additions done
You may need to restart the hal service and the Window System (or just restart
the guest system) to enable the Guest Additions.

Installing graphics libraries and desktop services components done
linux-c0i4:/media/VBOXADDITIONS_3. #

es obvio que la instalacion fallo, asi que despues de googlear unos dias, lo que pude averiguar fue la recomendacion de la instalacion de algunos paquetes.

y los paquetes a instalar son:

linux-c0i4:~ # zypper install kernel-PAE-devel.i686
Loading repository data...
Reading installed packages...
'kernel-PAE-devel.i686' not found.
Resolving package dependencies...

Nothing to do.
linux-c0i4:~ # zypper install kernel-devel-$(uname -r)
Loading repository data...
Reading installed packages...
'kernel-devel-2.6.31.5-0.1-default' not found.
Resolving package dependencies...

Nothing to do.
linux-c0i4:~ # zypper install kernel-headers kernel-devel gcc
Loading repository data...
Reading installed packages...
'linux-kernel-headers' providing 'kernel-headers' is already installed.
'kernel-devel' not found.
'gcc' is already installed.
No update candidate for 'gcc'.
Resolving package dependencies...

Nothing to do.
linux-c0i4:~ # zypper install kernel-source kernel-syms
Loading repository data...
Reading installed packages...
'kernel-source' is already installed.
No update candidate for 'kernel-source'.
'kernel-syms' is already installed.
No update candidate for 'kernel-syms'.
Resolving package dependencies...

Nothing to do.
linux-c0i4:~ # zypper install linux-headers-$(uname -r)
Loading repository data...
Reading installed packages...
'linux-headers-2.6.31.5-0.1-default' not found.
Resolving package dependencies...

Nothing to do.
linux-c0i4:~ #

estoy atorado ya no se que hacer. :confused:

espero alguien me pueda ayudar.

sin mas por el momento me despido no sin antes desearles un FELIZ 2011

jesusx
01-ene-2011, 08:54
Hola, entra como root en una consola y ejecuta: /etc/init.d/vboxadd setup
Salu2:adios:

ramses_17
02-ene-2011, 04:20
boyka@linux-c0i4:~> su -
Contraseña:
linux-c0i4:~ # /etc/init.d/vboxadd setup
Uninstalling old VirtualBox DKMS kernel modules done
Building the VirtualBox Guest Additions kernel modules failed
Your system does not seem to be set up to build kernel modules.
Look at /var/log/vboxadd-install.log to find out what went wrong. Once you have corrected it, you can
run

/etc/init.d/vboxadd setup

to build them.
Doing non-kernel setup of the Guest Additions done
linux-c0i4:~ #

alguna otra idea :confused:

jesusx
02-ene-2011, 08:55
Hola, lee lo que pone en /var/log/vboxadd-install.log adjuntalo o pégalo pues ahí esta escrito el problema. Salu2:adios:

caligulaelsanto
03-ene-2011, 05:41
no me queda claro usas la version de oracle??
la actual es la version 4
tu problema puede ser en principio
usas gráfica nvidia y driver propietario?? si es asi no funciona ,deberás usar noveau
lo siguiente debes tener instalado kernel-sources,gcc,make

estos son los errores típicos en estos días

ramses_17
03-ene-2011, 08:55
hola, si es la version de oracle
version 3.2.10 r66523
en cuanto a mis dispositivos de la maquina:
[boyka@localhost ~]$ lspcidrake
8139too : Realtek Semiconductor Co., Ltd.|RTL-8139/8139C/8139C+ [NETWORK_ETHERNET]
ath_pci : Atheros Communications Inc.|AR242x 802.11abg Wireless PCI Express Adapter [NETWORK_ETHERNET]
i2c_i801 : Intel Corporation|82801H (ICH8 Family) SMBus Controller [SERIAL_SMBUS]
ahci : Intel Corporation|82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller [STORAGE_SATA]
ata_piix : Intel Corporation|82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller [STORAGE_IDE]
iTCO_wdt : Intel Corporation|82801HEM (ICH8M) LPC Interface Controller [BRIDGE_ISA]
unknown : Intel Corporation|82801 Mobile PCI Bridge [BRIDGE_PCI]
ehci_hcd : Intel Corporation|82801H (ICH8 Family) USB2 EHCI Controller #1 [SERIAL_USB]
uhci_hcd : Intel Corporation|82801H (ICH8 Family) USB UHCI Controller #3 [SERIAL_USB]
uhci_hcd : Intel Corporation|82801H (ICH8 Family) USB UHCI Controller #2 [SERIAL_USB]
uhci_hcd : Intel Corporation|82801H (ICH8 Family) USB UHCI Controller #1 [SERIAL_USB]
shpchp : Intel Corporation|82801H (ICH8 Family) PCI Express Port 1 [BRIDGE_PCI]
snd_hda_intel : Intel Corporation|82801H (ICH8 Family) HD Audio Controller
unknown : Intel Corporation|Mobile GM965/GL960 Integrated Graphics Controller [DISPLAY_OTHER]
Card:Intel 810 and later: Intel Corporation|Mobile GM965/GL960 Integrated Graphics Controller [DISPLAY_VGA]
intel_agp : Intel Corporation|Mobile PM965/GM965/GL960 Memory Controller Hub [BRIDGE_HOST]
hub : Linux 2.6.29.1-desktop586-4mnb ehci_hcd|EHCI Host Controller [Hub|Unused|Full speed (or root) hub]
rtl8187 : Manufacturer_Realtek_RTL8187_|RTL8187_Wireless
usb_storage : Generic|USB2.0-CRW [Mass Storage|SCSI|Bulk (Zip)]
uvcvideo : Chicony Electronics Co., Ltd.|CNF7041 [Video|Video Control]
hub : Linux 2.6.29.1-desktop586-4mnb uhci_hcd|UHCI Host Controller [Hub|Unused|Full speed (or root) hub]
hub : Linux 2.6.29.1-desktop586-4mnb uhci_hcd|UHCI Host Controller [Hub|Unused|Full speed (or root) hub]
hub : Linux 2.6.29.1-desktop586-4mnb uhci_hcd|UHCI Host Controller [Hub|Unused|Full speed (or root) hub]
usbhid : Logitech|USB Optical Mouse [Human Interface Device|Boot Interface Subclass|Mouse]
[boyka@localhost ~]$

linux-c0i4:~ # zypper install kernel-sources gcc make
Loading repository data...
Reading installed packages...
'kernel-sources' not found.
'gcc' is already installed.
No update candidate for 'gcc'.
'make' is already installed.
No update candidate for 'make'.
Resolving package dependencies...

Nothing to do.
linux-c0i4:~ #

ramses_17
03-ene-2011, 09:07
jesusx mira este es el contenido del archivo. kwrite /var/log/vboxadd-install.log

Uninstalling modules from DKMS
removing old DKMS module vboxguest version 3.2.10

------------------------------
Deleting module version: 3.2.10
completely from the DKMS tree.
------------------------------
Done.
Makefile:25: Warning: using /usr/src/linux as the source directory of your Linux kernel. If this is not correct, specify KERN_DIR=<directory> and run Make again.
grep: /usr/src/linux/include/linux/version.h: No such file or directory
make KBUILD_VERBOSE=1 -C /usr/src/linux SUBDIRS=/tmp/vbox.0 SRCROOT=/tmp/vbox.0 modules
test -e include/linux/autoconf.h -a -e include/config/auto.conf || ( \
echo; \
echo " ERROR: Kernel configuration is invalid."; \
echo " include/linux/autoconf.h or include/config/auto.conf are missing."; \
echo " Run 'make oldconfig && make prepare' on kernel src to fix it."; \
echo; \
/bin/false)

ERROR: Kernel configuration is invalid.
include/linux/autoconf.h or include/config/auto.conf are missing.
Run 'make oldconfig && make prepare' on kernel src to fix it.

mkdir -p /tmp/vbox.0/.tmp_versions ; rm -f /tmp/vbox.0/.tmp_versions/*
make -f scripts/Makefile.build obj=/tmp/vbox.0
/tmp/vbox.0/Makefile:25: Warning: using /usr/src/linux as the source directory of your Linux kernel. If this is not correct, specify KERN_DIR=<directory> and run Make again.
grep: /usr/src/linux/include/linux/version.h: No such file or directory
gcc -Wp,-MD,/tmp/vbox.0/.test.o.d -nostdinc -isystem /usr/lib/gcc/i586-suse-linux/4.4/include -Iinclude -I/usr/src/linux-2.6.31.14-0.4/arch/x86/include -include include/linux/autoconf.h -D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration -Wno-format-security -fno-delete-null-pointer-checks -O2 -m64 -mno-red-zone -mcmodel=kernel -maccumulate-outgoing-args -DCONFIG_AS_CFI_SIGNAL_FRAME=1 -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -fomit-frame-pointer -I/usr/src/linux/include -I/tmp/vbox.0/ -I/tmp/vbox.0/include -I/tmp/vbox.0/r0drv/linux -D__KERNEL__ -DMODULE -DRT_OS_LINUX -DIN_RING0 -D_X86_ -DIN_RT_R0 -DIN_SUP_R0 -DVBGL_VBOXGUEST -DVBGL_HGCM -DVBOX_WITH_HGCM -DMODULE -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD_STR(test)" -D"KBUILD_MODNAME=KBUILD_STR(vboxadd_test)" -c -o /tmp/vbox.0/test.o /tmp/vbox.0/test.c
/tmp/vbox.0/test.c:1: error: code model 'kernel' not supported in the 32 bit mode
/tmp/vbox.0/test.c:1: sorry, unimplemented: 64-bit mode not compiled in
make[2]: *** [/tmp/vbox.0/test.o] Error 1
make[1]: *** [_module_/tmp/vbox.0] Error 2
make: *** [vboxadd_test] Error 2
Attempting to install using DKMS

Creating symlink /var/lib/dkms/vboxguest/3.2.10/source ->
/usr/src/vboxguest-3.2.10

DKMS: add Completed.

Error! Your kernel source for kernel 2.6.31.5-0.1-default cannot be found at
/lib/modules/2.6.31.5-0.1-default/build or /lib/modules/2.6.31.5-0.1-default/source.
You can use the --kernelsourcedir option to tell DKMS where it's located.
Failed to install using DKMS, attempting to install without
Creating user for the Guest Additions.
Creating udev rule for the Guest Additions kernel module.

:)

caligulaelsanto
03-ene-2011, 16:50
linux-c0i4:~ # zypper install kernel-sources gcc make
Loading repository data...
Reading installed packages...
'kernel-sources' not found.
'gcc' is already installed.
No update candidate for 'gcc'.
'make' is already installed.
No update candidate for 'make'.
Resolving package dependencies...


no tienes kernel sources según veo ,alguno me corregirá si no es así

búscalo en yast

jcsl
03-ene-2011, 17:03
Hola.

El nombre del paquete es kernel-source y no kernel-sources. Con openSUSE 11.3 creo que ya no es necesario instalarlo para compilar módulos, con el kernel-devel más el kernel-X-devel (X = default, desktop, pae, ...) es suficiente (al menos yo no lo necesito para compilar el controlador de la tarjeta de TV y el de NVIDIA).

Edito: te aconsejaría que usaras YaST en vez de zypper. Es más visual y sencillo si no se está experimentado. Y pega la salida de


rpm -qa | grep "kernel\|gcc\|make\|syms" | sort

para ver qué te falta por instalar. Otra cosa, he visto que usas el comando lspcidrake que no es de openSUSE. ¿Estás usando Madriva?

Un saludo.

ramses_17
03-ene-2011, 22:45
lo se, pero caligulaelsanto me puso kernel-sources, crei que asi lo llamaban al paquete aqui, si ves en el post original viene una orden donde pongo kernel-source kernel-syms.
pego el resultado del comando que me has dado:

linux-c0i4:~ # rpm -qa | grep "kernel\|gcc\|make\|syms" | sort
automake-1.11-6.2.i586
gcc-4.4-4.2.i586
gcc44-4.4.1_20090817-2.3.4.i586
kernel-debug-devel-2.6.31.14-0.4.1.i586
kernel-default-2.6.31.5-0.1.1.i586
kernel-default-devel-2.6.31.14-0.4.1.i586
kernel-desktop-devel-2.6.31.14-0.4.1.i586
kernel-pae-devel-2.6.31.14-0.4.1.i586
kernel-source-2.6.31.14-0.4.1.noarch
kernel-syms-2.6.31.14-0.4.1.i586
kernel-xen-devel-2.6.31.14-0.4.1.i586
libgcc44-4.4.1_20090817-2.3.4.i586
libstlport_gcc4-4.6.2-3.1.i586
linux-kernel-headers-2.6.31-3.4.noarch
make-3.81-130.2.i586
linux-c0i4:~ #

respondiendo tambien a lo de lspcidrake, si estoy usando mandriva como sistema base, uso la verison 2009.1

salu2

jesusx
03-ene-2011, 23:52
Hola,el kernel-source-2.6.31.14-0.4.1.noarch no se asocia con el kernel-default-2.6.31.5-0.1.1.i586
Ahi esta el problema. Instala el kernel-source-2.6.31.5-0.1.1.¡586
Salu2:adios:

caligulaelsanto
04-ene-2011, 01:17
si perdón se me escapo una "s"

no se tu caso pero yo uso 11.3 kde4 32 bits
lo único que pongo es el kernel-source, y lo que mencione a continuación
lo demás jamas

saludos

DiabloRojo
04-ene-2011, 11:13
linux-c0i4:~ # rpm -qa | grep "kernel\|gcc\|make\|syms" | sort
automake-1.11-6.2.i586
gcc-4.4-4.2.i586
gcc44-4.4.1_20090817-2.3.4.i586
kernel-debug-devel-2.6.31.14-0.4.1.i586
kernel-default-2.6.31.5-0.1.1.i586
kernel-default-devel-2.6.31.14-0.4.1.i586
kernel-desktop-devel-2.6.31.14-0.4.1.i586
kernel-pae-devel-2.6.31.14-0.4.1.i586
kernel-source-2.6.31.14-0.4.1.noarch
kernel-syms-2.6.31.14-0.4.1.i586
kernel-xen-devel-2.6.31.14-0.4.1.i586
libgcc44-4.4.1_20090817-2.3.4.i586
libstlport_gcc4-4.6.2-3.1.i586
linux-kernel-headers-2.6.31-3.4.noarch
make-3.81-130.2.i586Tienes un cacao de kernels, de versiones y ¿de procedencias de kernels?. ¿como lo obtienes: por repositorios o descarga directa?

Lo marcado en rojo y en negrita te sobra, intenta borrarlos.

Y lo marcado en azul y negrita SON distintas versiones, fíjate en los números, he intenta poner las mismas versiones, esto es lo que causa tu problema. Y el amigo jesusx te ha dicho otro fallo marcado en verde y negrita.

¿De donde sale lo marcado en marrón y negrita?.

Compara las versiones de mis kernel, son la misma versión y numeración y por eso tengo nulo conflicto en VirtualBox:

rpm -qa | grep kernel | sort
kernel-default-2.6.34.7-0.5.1.i586
kernel-default-devel-2.6.34.7-0.5.1.i586
kernel-devel-2.6.34.7-0.5.1.noarch
kernel-firmware-20100617-2.2.noarch
kernel-source-2.6.34.7-0.5.1.noarch

ramses_17
05-ene-2011, 06:53
ya le quite algunas cosas y asi me ha quedado, el problema es que no puedo instalar el kernel que me recomienda jesux

linux-uq9o:~ # rpm -aq | grep "kernel\|gcc\|make\|syms" | sort
kernel-default-2.6.31.5-0.1.1.i586
libgcc44-4.4.1_20090817-2.3.4.i586
linux-uq9o:~ # zypper install kernel-source-2.6.31.5-0.1-¡586
Loading repository data...
Reading installed packages...
'kernel-source-2.6.31.5-0.1-¡586' not found.
Resolving package dependencies...

Nothing to do.
linux-uq9o:~ #

incluso lo he intentado instalar desde el yast pero no me aparece esa version del kernel. e incluso ya active algunos repositorios. son lo que se agregaron durante la instalacion de opensuse
¿alguien sabe por que? o ¿me faltaran repositorios?

davmont
05-ene-2011, 09:42
el kernel source no tiene arquitectura... comprueba con zypper se kernel-source ;)

un saludo :adios:

DiabloRojo
05-ene-2011, 16:26
linux-uq9o:~ # rpm -aq | grep "kernel\|gcc\|make\|syms" | sort
kernel-default-2.6.31.5-0.1.1.i586
libgcc44-4.4.1_20090817-2.3.4.i586:confused::confused::confused: ¿Donde esta make, automake, gcc, etc... que tenias y estaban correctos?

Se instala SIN el nº de la version:
zypper install kernel-source
zypper install kernel-default-devel

Sobre los repositorios, no sabemos cuales tienes, con "zypper lr -u" y danos su salida.

Aprendete y estudiate esta GUÍA mía: GUIA de Repositorios de openSUSE: Manejo y Funcionamiento (http://www.forosuse.org/forosuse/showthread.php?t=23559)

ramses_17
06-ene-2011, 14:12
boyka@linux-uq9o:~> su -
Contraseña:
linux-uq9o:~ # zypper install automake gcc libgcc make kernel-source kernel-default-devel
Retrieving repository 'Actualizaciones para openSUSE 11.2-0' metadata [done]
Building repository 'Actualizaciones para openSUSE 11.2-0' cache [done]
Loading repository data...
Reading installed packages...
'libgcc44' providing 'libgcc' is already installed.
Resolving package dependencies...

The following NEW packages are going to be installed:
autoconf automake gcc gcc44 glibc-devel kernel-default-devel kernel-source
linux-kernel-headers m4 make

10 new packages to install.
Overall download size: 83.4 MiB. After the operation, additional 374.3 MiB
will be used.
Continue? [y/n/?] (y): y
Retrieving package linux-kernel-headers-2.6.31-3.4.noarch (1/10), 726.0 KiB (2.6 MiB unpacked)
Retrieving: linux-kernel-headers-2.6.31-3.4.noarch.rpm [done (33.2 KiB/s)]
Installing: linux-kernel-headers-2.6.31-3.4 [done]
Additional rpm output:
post linux-kernel-headers-2.6.31-3.4 /var/tmp/rpm-tmp.u14GJl 1


Retrieving package make-3.81-130.2.i586 (2/10), 353.0 KiB (979.0 KiB unpacked)
Retrieving: make-3.81-130.2.i586.rpm [done (68.6 KiB/s)]
Installing: make-3.81-130.2 [done]
Retrieving package m4-1.4.13-2.2.i586 (3/10), 245.0 KiB (457.0 KiB unpacked)
Retrieving: m4-1.4.13-2.2.i586.rpm [done (33.2 KiB/s)]
Installing: m4-1.4.13-2.2 [done]
Retrieving package kernel-source-2.6.31.14-0.6.1.noarch (4/10), 67.4 MiB (333.9 MiB unpacked)
Retrieving: kernel-source-2.6.31.14-0.6.1.noarch.rpm [done (133.9 KiB/s)]
Installing: kernel-source-2.6.31.14-0.6.1 [done]
Retrieving package autoconf-2.63-5.2.i586 (5/10), 688.0 KiB (1.9 MiB unpacked)
Retrieving: autoconf-2.63-5.2.i586.rpm [done (12.9 KiB/s)]
Installing: autoconf-2.63-5.2 [done]
Retrieving package kernel-default-devel-2.6.31.14-0.6.1.i586 (6/10), 6.2 MiB (6.5 MiB unpacked)
Retrieving: kernel-default-devel-2.6.31.14-0.6.1.i586.rpm [done (89.0 KiB/s)]
Installing: kernel-default-devel-2.6.31.14-0.6.1 [done]
Retrieving package glibc-devel-2.10.1-10.9.1.i686 (7/10), 4.4 MiB (20.2 MiB unpacked)
Retrieving: glibc-devel-2.10.1-10.9.1.i686.rpm [done (75.8 KiB/s)]
Installing: glibc-devel-2.10.1-10.9.1 [done]
Retrieving package gcc44-4.4.1_20090817-2.3.4.i586 (8/10), 2.8 MiB (6.0 MiB unpacked)
Retrieving: gcc44-4.4.1_20090817-2.3.4.i586.rpm [done (94.5 KiB/s)]
Installing: gcc44-4.4.1_20090817-2.3.4 [done]
Retrieving package automake-1.11-6.2.i586 (9/10), 670.0 KiB (1.7 MiB unpacked)
Retrieving: automake-1.11-6.2.i586.rpm [done (37.1 KiB/s)]
Installing: automake-1.11-6.2 [done]
Retrieving package gcc-4.4-4.2.i586 (10/10), 6.0 KiB (0 B unpacked)
Retrieving: gcc-4.4-4.2.i586.rpm [done (0 B/s)]
Installing: gcc-4.4-4.2 [done]
linux-uq9o:~ # zypper lr -u
# | Alias | Name | Enabled | Refresh | URI
--+-------------------------------------+--------------------------------------+---------+---------+----------------------------------------------------------------
1 | http-download.opensuse.org-d9fa6ffc | Actualizaciones para openSUSE 11.2-0 | Yes | Yes | http://download.opensuse.org/update/11.2/
2 | openSUSE 11.2-0 | openSUSE 11.2-0 | Yes | No | cd:///
3 | repo-debug | openSUSE-11.2-Debug | Yes | Yes | http://download.opensuse.org/debug/distribution/11.2/repo/oss/
4 | repo-non-oss | openSUSE-11.2-Non-Oss | Yes | Yes | http://download.opensuse.org/distribution/11.2/repo/non-oss/
5 | repo-oss | openSUSE-11.2-Oss | Yes | Yes | http://download.opensuse.org/distribution/11.2/repo/oss/
6 | repo-source | openSUSE-11.2-Source | Yes | Yes | http://download.opensuse.org/source/distribution/11.2/repo/oss/
linux-uq9o:~ #
linux-uq9o:/media # sh VBoxLinuxAdditions-x86.run
Verifying archive integrity... All good.
Uncompressing VirtualBox 3.2.10 Guest Additions for Linux.........
VirtualBox Guest Additions installer
You appear to have a version of the VBoxGuestAdditions software
on your system which was installed from a different source or using a
different type of installer. If you installed it from a package from your
Linux distribution or if it is a default part of the system then we strongly
recommend that you cancel this installation and remove it properly before
installing this version. If this is simply an older or a damaged
installation you may safely proceed.

Do you wish to continue anyway? [yes or no]
no

Cancelling installation.
linux-uq9o:/media #

jcsl
06-ene-2011, 15:52
Hola.

automake no hace falta y, si no recuerdo mal, también hay que instalar pam-devel además del resto de cosas pero para compilar VirtualBox y supongo que también para compilar las Guest Additions, no para instalar las Guest Additions.

¿No hay una opción en los menús de VirtualBox que sirve precisamente para instalar las Guest Additions? Recuerdo que yo lo hacía así, y no tenía que instalar nada porque el mismo programa se encargaba de descargarlas e instalarlas desde la página de Oracle para VirtualBox. Aunque hace tiempo que no instalo VirtualBox y quizás no fuera así.

De todos modos, el último error que te indica viene a decir que ya tienes instaladas unas Guest Additions pero con una versión anterior a la que tiene el VirtualBox actualmente instalado. Eliminalas y reintenta la instalación.

Un saludo.

ramses_17
07-ene-2011, 09:16
he instalado los paquetes de virtualbox relacionados con la misma version de mi kernel
linux-uq9o:/media # uname -a
Linux linux-uq9o 2.6.31.5-0.1-default #1 SMP 2009-10-26 15:49:03 +0100 i686 i686 i386 GNU/Linux
linux-uq9o:/media # rpm -aq | grep virtualbox
virtualbox-ose-guest-tools-debuginfo-3.0.6-9.10.4.i586
virtualbox-ose-kmp-pae-debuginfo-3.0.6_2.6.31.5_0.1-9.10.4.i586
virtualbox-ose-kmp-default-debuginfo-3.0.6_2.6.31.5_0.1-9.10.4.i586
virtualbox-ose-kmp-debug-debuginfo-3.0.6_2.6.31.5_0.1-9.10.4.i586
xorg-x11-driver-virtualbox-ose-debuginfo-3.0.6-9.10.4.i586
linux-uq9o:/media # sh VBoxLinuxAdditions-x86.run
Verifying archive integrity... All good.
Uncompressing VirtualBox 3.2.10 Guest Additions for Linux.........
VirtualBox Guest Additions installer
Removing installed version 3.2.10 of VirtualBox Guest Additions...
tar: Tamaño del registro = 8 bloques
Uninstalling old VirtualBox DKMS kernel modules done
Building the VirtualBox Guest Additions kernel modules failed
Your system does not seem to be set up to build kernel modules.
Look at /var/log/vboxadd-install.log to find out what went wrong. Once you have corrected it, you can
run

/etc/init.d/vboxadd setup

to build them.
Doing non-kernel setup of the Guest Additions done
Installing the Window System drivers
Installing X.Org Server 1.6 modules done
Setting up the Window System to use the Guest Additions done
You may need to restart the hal service and the Window System (or just restart
the guest system) to enable the Guest Additions.

Installing graphics libraries and desktop services components done
linux-uq9o:/media #

y ahora que podra ser?

DiabloRojo
07-ene-2011, 10:22
Sigues teniendo el problema del kernel, dinos lo que dice "rpm -aq | grep "kernel\|gcc\|make\|syms" | sort"

jcsl
07-ene-2011, 11:04
Hola.

¿Pero has probado a instalarlas desde el menú o no?


http://ubuntu-tutorials.com/wp-content/uploads/2010/06/virtualbox-install-guest-additions.jpg

Un saludo.

ramses_17
08-ene-2011, 09:52
linux-uq9o:/media # rpm -aq | grep "kernel\|gcc\|make\|syms" | sort
automake-1.11-6.2.i586
gcc-4.4-4.2.i586
gcc44-4.4.1_20090817-2.3.4.i586
kernel-default-2.6.31.5-0.1.1.i586
kernel-default-devel-2.6.31.14-0.6.1.i586
kernel-source-2.6.31.14-0.6.1.noarch
libgcc44-4.4.1_20090817-2.3.4.i586
linux-kernel-headers-2.6.31-3.4.noarch
make-3.81-130.2.i586
linux-uq9o:/media #

DiabloRojo
08-ene-2011, 10:32
kernel-default-2.6.31.5-0.1.1.i586
kernel-default-devel-2.6.31.14-0.6.1.i586
kernel-source-2.6.31.14-0.6.1.noarchEl kernel-default NO tiene la misma versión o numeración 2.6.31.5-0.1.1 que los paquetes kernel-default-devel y kernel-source que es la 2.6.31.14-0.6.1 puedes hacerlo desde Yast->Software->Instalar/desinstalar, en la pestaña "Versiones" debajo del cuadro de los paquetes, ver imagen de abajo.

Y, ademas, para instalar la VirtualBox Guest Additions se hace dentro de la aplicación, tal y como te lo explica jcsl.

http://i56.tinypic.com/wl3v4n.jpg

ramses_17
20-ene-2011, 22:10
hola. antes que nada disculpen por la tardanza para responder, he tenido unos problemas personales que he tenido que atender.

ami no me aparecen el kernel default-devel, ni el kernel devel

http://img17.imageshack.us/img17/5057/susep.png (http://img17.imageshack.us/i/susep.png/)

Uploaded with ImageShack.us (http://imageshack.us)

espero me puedan seguir ayudando.

intente instalar los guest additions desde el menu de la ventana, abri el yast, estaban por ser descargados. pero despues vi que el sistema yast2 abortaba la descarga alegando que era muy lento, y despues aparecio un mensaje que decia error 2 no se que es lo que este pasando o si sea normal.

viendo que los otros kernels no aparecen en la lista siento que a lo mejor es por la falta de algun repositorio, que yo tenga que cargar como se hace en mandriva con easy urpmi.
crei que venian cargados por default en el sistema al igual que ubuntu.
la verdad estoy muy perdido, alguien que me pueda ayudar?? :)

DiabloRojo
21-ene-2011, 09:56
Ese paquete kernel-default-devel esta en el repositorio OSS, añádelo, refréscalo e instalarlo. Mas información: GUIA de Repositorios de openSUSE: Manejo y Funcionamiento (http://www.forosuse.org/forosuse/showthread.php?t=23559)