PDA

Ver la Versión Completa : servidor de correo en linux



annubis
11-ago-2005, 23:36
Ya estoy de los nervios, estoy intentando instalar un servidor de correo en linux usando como base la documentacion que hay por ahi sobre ello usando postfix, courier, cyrus-sasl, squirrelmail y mysql pero no hay forma porque han usado sistema debian y hay muchas cosas que en suse no aparecen y no hay forma de que el squirrelmail pueda reconocer a los usuarios.

Alguno sabe o ha podido instalar esto mismo en suse o en su defecto alguna forma de instalar un servidor de correo en suse usando squirrelmail y no morir en el intento?.

Gracias

mabs
12-ago-2005, 08:22
Q problemas tienes?? SI usas postfix+ courier + squirrelmail que problemas te da. Deja para mas tarde el cyrus y el mysql. Re cuerda que squirrelmail funciona solo con IMAP....

annubis
12-ago-2005, 09:40
Gracias por contestar.
Principalmente sino uso mysql, como hago para que el squirrel me reconozca entonces los usuarios, si son los que vienen en el sistema tampoco me los reconoce.

mabs
12-ago-2005, 10:07
Los del sistema te los tiene que reconocer sin problemas, solo que tienes que activar la opcion de cram-md5... y sino tambien puedes tener los usuarios en un servidor LDAP. El MySQL solo es opcional.
Saludos.

annubis
12-ago-2005, 21:31
Bueno algo voy consiguiendo, el problema que tngo ahora es con el squirrel, cuando meto o no meto un usuario y el doy a login, me sale que no encuentra db.php, he buscado con el kfind a ver si esta por algun sitio y no, tengo instalado php4 en casi todas sus facetas y me sigue dando el mismo error.

alguna sugerencia? :scratchch

annubis
14-ago-2005, 21:40
Alguna idea apañeros de como solucionar el tema del db.php?

mabs
16-ago-2005, 08:20
Has instalado el mod de php de apache???

annubis
17-ago-2005, 02:31
gracias por contestar mabs, si tengo isntalado el apache_mod_php4, aunque he revisado otros mods y php4,
el error que me sale exacto es:

Warning: main(DB.php): failed to open stream: No such file or directory in /srv/www/htdocs/squirrelmail/functions/db_prefs.php on line 35

Fatal error: main(): Failed opening required 'DB.php' (include_path='.:') in /srv/www/htdocs/squirrelmail/functions/db_prefs.php on line 35

eso me sale cuando meto cualquier usuario, exista o no y luego al darle al login

:chillando :chillando :chillando

ayudita?

mabs
17-ago-2005, 08:39
Yo el fichero db_prefs.php si que lo tengo en el directorio functions. Otra cosa, has desactivado el uso de bases de datos en el squirrelmail???????? Porque ese error parece ser debido a que busca una base de datos....

annubis
17-ago-2005, 13:40
Si, tambien tengo el db_prefs.php en funtions. Estoy usando el mysql, postfix y el squirrel de momento.

El postfix esta funcionando perfectamente porque he usado el postfixadmin, he enlazado la base de datos creada con mysql con el squirrel en database y parece que esta bien puesta.

LA cosa es, si desactivo (que nose como hacerlo, supongo que dejando en blanco database del squirrel) las bases de datos en el squirrel el mysql ya no me servira para nada?

gracias de nuevo

mabs
17-ago-2005, 14:21
Claro que no te servira para nada, pero por lo menos podras probar de donde vienen los problemas, y si es del mysql, empezar a investigar por ahi...

Saludos.

annubis
17-ago-2005, 14:23
Bueno algo hemos hecho, encontre por fin DB.php y estaba en usr/share/php, ahi esta lo que se necesita ahora no me da error, lo unico que no me valida el usuario: usuario invalido o contraseña erronea, conectado a la base de datos esta en config pero...

mabs
18-ago-2005, 09:05
Postea el /var/log/mail.log y el /var/log/messages en el momento que intentas loguearte....

annubis
18-ago-2005, 20:55
Gracias mabs, voy a reinstalar el suse de nuevo para repetir todos los pasos:
Apache, mysql, postfix y squirrelmail y php4 completo a ver que sale, ya posteo el resultado, si al final conseguimos que funcione con tu ayuda, hago unas capturas y si se puede poner como manual para otros estupendo.

ya te cuento

annubis
21-ago-2005, 15:14
Bueno ya instale lo necesario, parece ser que ahora el squirrel me da error

Error connecting to IMAP server: tls://stargate.
115 : Operation now in progress

la verdad es que ya nose donde mirar, si configuro el kmail con el servicio imap me diceq ue esta ok, que tiene conexion segura tls, pero al hacer un login me da error en contraseña.

nose que hago mal :chillando :chillando :chillando

mabs
22-ago-2005, 08:38
Prueba con el manual q te adjunto... Eso si, yo lo hice con LDAP... pero la configurqacion de courier te vendra bien.

annubis
22-ago-2005, 21:25
gracias mabs, nose como agradecertelo. Voy a ver si lo pruebo en condiciones.

Una cosita. las contraseñas encriptadas qe aparecen en {CRYPT} de donde salen o como se meten ahi.

Lo que tu me mandas y el squirrel tiene que funcionar estupendamente no?.

Me baje el phpldapadmin para investigar pero ciertamente tampoco me deja conectar al servidor ldap, error, problema de servidores?, incluso metiendo la ip no me deja.

gracias otra vez por las molestias causadas de verdad :)

mabs
23-ago-2005, 09:09
Ese tipo de contraseñas se crean con el comando :
slappasswd -h {CRYPT}
Y todo funciona muy bien, lo tengo puesto en varios servidores.
EL phpadmin ni lo utilices. Tu sigues el manual... compruebas que por telnet te va bien y luego agregas el squirrell. En el squirrell lo unico que tienes que modificar es la configuracion del servidore LDAP.