PDA

Ver la Versión Completa : Compartir internet con windows



pepotis
01-ago-2005, 19:46
Veréis, el problema es el siguiente: Mi ordenador está coectado a un cable modem por eth1, y a la vez, está conectado a otro PC (con windows) por eth0, con mi suse linux 9.0 lo había podido configurar todo perfectamente, pero ahora me he pasado a 9.3 y no sé como hacerlo, os comento lo que he hecho hasta ahora:
-A la targeta local (eth0) le he asignado la ip 192.168.0.1 con la máscara de subred 255.255.255.0
-En windows he asignado a la targeta de red la dirección 192.168.0.2, la misma máscara de subred, mi ip como puerta de enlace y en los DNS los que utiliza mi servidor

La red local está bien montada, ya que veo los archivos de ambos por samba, pero no sé que coño pasa con Internet. He provado a desactivar el firewall sin resultados. Por favor ayúdenme!!

NOTA: En 9.0 el truco de la configuración estaba en el firewall, pero aquí me encuentro que en el YAST todas las opciones del firewall son diferentes!

DiabloRojo
01-ago-2005, 20:00
Creo que te falta activar la casilla de enrutamiento, busca en el foro.

impala
01-ago-2005, 20:19
probá con esto desde consola:

echo 1 > /proc/sys/net/ipv4/ip_forward

Despues de hacer esto deberias salir andando.
Si es asi, tendrías que crear un script (y darle permisos de ejecución) y ponerlo para que se ejecute con cada inicio en el archivo /etc/rc.d/boot.local (creo que era esta la ruta) ya que lo que te dije que ejecutaras se perderá al reiniciar la PC.
Saludos y contá si te sirvió ...

pepotis
01-ago-2005, 20:21
No me funciona ese comando... Yo se que se puede hacer, y cre que desde el cortafuegos, por lo mens es como lo hice en la 9.0. Por favor, ayúdenme :chillando

chuzo
01-ago-2005, 20:46
Activando el firewall con las opciones correspondientes te debe funcionar sin problemas ... DiabloRojo ya te ponía la opción concreta:


Creo que te falta activar la casilla de enrutamiento, busca en el foro.

pepotis
01-ago-2005, 20:47
Bueno, gracias al post de vigle101he logrado arreglarlo, ¿El truco? Marcar la casilla enmascarar redes. ¿Alguien me puede explicar qué significa eso y por qué se me ha solucionado el problema al marcarlo? Es que a mí me gusta entender lo que hago... Por eso me he pasado a Linux... Muchas gracias por vuestra ayuda!

impala
01-ago-2005, 22:28
El enmascaramiento significa que los paquetes que salen a internet enviados desde pc´s pertenecientes a tu LAN salen con la IP pública del gateway y, obviamente, no con la propia de la red local. A eso se le llama enmascaramiento.
De todas formas, acá podés leer cómo hacer rápidamente lo que pedías pero desde consola con el firewall iptables.
Iptables y NAT para vagos (http://bulma.net/body.phtml?nIdNoticia=1522)

Otra cosa, lo de marcar la casilla que dijiste es lo mismo que lo que te habia puesto arriba:

echo > 1 /proc/sys/net/ipv4/ip_forward

te lo comento para que sepas como hacerlo por consola.
Saludos

pepotis
02-ago-2005, 11:50
Muchísimas gracias impala, ahora ya me siento mejor, jeje, de todas formas tu comando de consola no me funciono... :scratchch Pero bueno, lo importante es que ya he solucionado el problema y además se cómo

impala
02-ago-2005, 15:46
Perdón, corregí el link del IPTABLES y NAT para vagos ya que habia puesto un link de otra cosa ...
Por las dudas, lo dejo aca tambien Iptables y NAT para vagos (http://bulma.net/body.phtml?nIdNoticia=1522)

Si querés mas sobre IPTABLES podés mirar en la página www.pello.info en la que hay unos manuales muy buenos y muy claros.

Saludos y espero que te sirva.

JK0
13-ago-2005, 06:39
hola!

Soy un poco nuevo en linux y tengo exactamente el mismo problema, en suse 9.3, pero no he podido solucionarlo, por que no entiendo algunas cosas en los post anteriores....
alguien podria explicarme con mas detenimiento por favor? :S

Gracias

impala
13-ago-2005, 15:10
JK0: cuales son puntualmente las cosas que no entendiste ? De todas formas te recomiendo que leas el NAT para vagos que puse arriba ... pero preguntá lo q haga falta.