PDA

Ver la Versión Completa : Vulnerabilidad en Adobe Acrobat Reader para versiones Unix



chuzo
07-jul-2005, 00:24
http://www.adobe.com/images/logo.gif

Descubierta una vulnerabilidad en Adobe Reader 5.0.9 y 5.0.10 para plataformas Linux, Solaris, IBM-AIX y HP-UX que podría ser aprovechada por un atacante para ejecutar código arbitrario de forma remota.

El desbordamiento de buffer explotable se localiza en la función UnixAppOpenFilePerform(), utilizada por Adobe Reader cuando abre archivos PDF que contienen la etiqueta /Filespec.

A efectos prácticos, un atacante podría diseñar un PDF que, al intentar ser visualizado por una versión de Adobe Reader vulnerable, ejecutara código arbitrario con los mismos privilegios que el usuario local. El atacante podría hacer llegar a la víctima el PDF malicioso a través de una página web, adjunto en un e-mail, o con cualquier otra estrategia.

Para corregir la vulnerabilidad, los usuarios de Adobe Reader 5.0.9 o 5.0.10 para Linux o Solaris deberán actualizar a la versión 7.0, mientras que los usuarios de plataformas IBM-AIX o HP-UX deberán actualizar a la versión 5.0.11.

Todas las actualizaciones están disponibles a través de la dirección: http://www.adobe.com/products/acrobat/readstep2.html

Más Información:

Buffer overflow vulnerability in Adobe Reader (Linux, Solaris, HP-UX, IBM-AIX) (http://www.adobe.com/support/techdocs/329083.html)

Adobe Adobe Reader UnixAppOpenFilePerform() Buffer Overflow Vulnerability (http://www.idefense.com/application/poi/display?id=279&type=vulnerabilities)

Fuente:

Vulnerabilidad en Adobe Acrobat Reader para versiones Unix - Hispasec - Una al día 06/07/2005 (http://www.hispasec.com/unaaldia/2447)