Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Técnica > Internet, Redes y Wireless


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

[Solventado] Conexiòn DHCP a internet imposible de resolver en linux
  #1  
Antiguo 16-oct-2006, 08:24
Avatar de Arkantos_cero
Arkantos_cero Arkantos_cero está desconectado
Habitual
 
Fecha de Ingreso: 04-septiembre-2006
Ubicación: /home/los_teques
Mensajes: 107
Agradecimientos: 2
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 12
Arkantos_cero está en el buen camino
Angry [Solventado] Conexiòn DHCP a internet imposible de resolver en linux

CONEXIÓN DHCP A INTERNET IMPOSIBLE DE RESOLVER EN LINUX
Introducción:

Acudo a ustedes, experimentados usuarios, después de haber intentado y leido minuciosamente la gran cantidad de threads sobre el tema. No les he escrito antes, intentando minimizar y encerrar la falla. Pero mi orgullo de Geek y profesional de la informática està herido, con la impotencia que Linux no permita un proceso que bajo Windows es sumamente sencillo.
Tratarè de evitar, pues, mis expresiones de molestia e impotencia que me ha creado intentar pasarme al mundo linux, y sobre toda las cosas, haber elegido SuSe como distribución para iniciarme. Asì, nótese que soy newbie entonces en linux, sin embargo me he documentado y créanme, les escribo con un libro de iniciación en linux en la mano. Tratarè de indicar en orden cronológico lo que he realizado a ver si detectan algún error por omisión que estè causando esta falla, o si de lo contrario, soy el ùnico que posee el deshonor de no poder conectarse vìa ethernet y dhcp en el mundo linux.



Resumen:
Imposibilidad de conectarse a Internet con mi configuración de red actual, y tambièn con la anterior, hacia Internet, con diagnòstico correcto de la NIC.
Conexión a Internet perfecta y sin configuración necesaria bajo Windows XP, con la misma configuración y la anterior tambièn.


Descripciòn de la Red
Es una red domèstica, muy sencilla en realidad, interfaz de red Ethernet, UTP5.
Del proveedor de Internet, cantv.net, llega la conexión vìa ADSL hacia un mòdem-router marca Starbridge ADSL EU, en simple modo Bridge. El mismo posee dos interfaces de salida: Ethernet y USB, esta ultima interfaz sin soporte para linux.
En la interfax Ethernet està conectado un switch D-Link DES-1008D 10/100 Fast Ethernet.
En un puerto està conectado el mòdem y en otros dos, sòlo dos PC`s, una ejecuta SuSE Linux 10.0 y Win XP Profesional, y la otra ejecuta sòlo WIN XP Profesional.
El ISP, entonces, entrega las direcciones IP vìa DHCP.
Importante: Bajo esta configuración, Windows detectò automáticamente y me conectò hacia internet, sin yo tener que realizar nada.






Antecedentes:
En mi primer contacto con el mundo linux, no tenìa el switch arriba descrito. Asì que la conexión era directa desde el mòdem hacia la PC. Bajo esa configuración primitiva, Probè SuSe 10.1 y, aunque no detectò la conexión en el setup, en el segundo reinicio tipiee ifconfig y voila!, tuve conexión.

Luego de eso, me vì obligado a comprar un dispositivo de red porque no puedo dejar sin servicio a la otra PC, la cual està alejada y usa ethernet. A la misma yo le robaba su puerto ethernet del mòdem para las pruebas con linux, ya que originalmente y bajo windows me conectaba vìa USB, la cual como describì arriba, no està soportado (otra traba) en linux.


Mi sorpresa y molestia es mayor cuando, luego de haber desembolsado el dinero, conecto mi switch de la forma descrita y no tengo conexión en linux, ni siquiera agarra las direcciones IP de cantv.net, cuando probándolo con Windows funciona de las mil maravillas.

Procedo entonces a retirar el switch. Vuelvo a mi configuración de red anterior, la misma que minutos antes funcionaba en linux y sorpresa: NO HAY CONEXIÓN. Hasta el sol de hoy, màs nunca. No importaba que detuviera y reiniciara el servicio, que reiniciara la pc (como si de win 98 se tratara), la detección de las IP`s se fuè a la dimension desconocida del kernel.
Volví a colocar el switch.


Instalè la versión anterior de Linux, la 10.0, y no conectò en el setup, y como era de esperarse, tampoco una vez instalado. Retirè el switch, mismo estatus.

Todo esto validando con la otra computadora, y con la misma bajo XP, que existiera conexión a Internet.




Borrè en la imagen con efecto gaussiano intencionalmente la direccion IP y la direccion Fìsica por cuestiones de seguridad.
Acciones Tomadas:
Con el fin de evitar el tìpico comentario de respuesta que he leido en los threads del foro cuando comentan una falla seria (“Mètete en YaST y coloca la conexión por dhcp,” como si uno no hubiese intentado lo obvio), intentarè ser lo màs cronológico posible en las soluciones intentadas.

Acciòn 1:
Verifico que haya link en el switch. En el botteo de linux hace par de parapadeos, y luego el led se queda fijo.


Verifico las opciones en YaST:

Desde dispositivos de red / Tarjeta de red:
Aparece tarjeta de red : Biostar Microtech Intl MCP51 Ethernet Controller
EN Direccion IP aparece: DHCP
Al darle “Editar”:
Mètodo de activaciòn: Configuracion automàtica de direcciones IP (Por DHCP)




Pasarela Predeterminada: En Blanco
Tabla de enrutado: Sin seleccionar y en blanco
Activar reenvio de IP : Sin seleccionar
Detalles del Hardware:






Opciones del cliente DHCP: Solicitar Respuesta Broadcast : Sin Seleccionar Identificador de cliente DHCP:En blanco
Nombre de ordenador para el envìo: AUTO
Configuracion Detallada de NIC: MTU: En blanco
Activacion del dispositivo: Durante el arranque
Controlada por usuario: Desactivado
Firewall desactivado.
Direcciones adicionales: En blanco


Verifico lo que dice el comando ifconfig:
desktop:~ # ifconfig
eth0 Link encap:Ethernet HWaddr 00:E0:4C:E5:27:02
inet6 addr: fe80::2e0:4cff:fee5:2702/64 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1087 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:36 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:75973 (74.1 Kb) TX bytes:0 (0.0 b)
Interrupt:233 Base address:0xc000


lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:206 errors:0 dropped:0 overruns:0 frame:0
TX packets:206 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:15058 (14.7 Kb) TX bytes:15058 (14.7 Kb)



Nòtese que no aparece la direccion IP.

Verifico el comando route:



desktop:~ # route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
loopback * 255.0.0.0 U 0 0 0 lo


Obviamente intento navegar y no abre pàgina.

Acciòn 2:

Reinicio la configuracion de la red, usando:
/etc/init.d/network stop (Enter)
/etc/init.d/network start (Enter)


desktop:~ # /etc/init.d/network stop
Shutting down network interfaces:
eth0 device: nVidia Corporation MCP51 Ethernet Controller (rev a1)
eth0 configuration: eth-id-00:e0:4c:e5:27:02 done
Shutting down service network . . . . . . . . . . . . . done.

desktop:~ # /etc/init.d/network start
Hint: you may set mandatory devices in /etc/sysconfig/network/config
Setting up network interfaces:
lo
lo IP address: 127.0.0.1/8 done
eth0 device: nVidia Corporation MCP51 Ethernet Controller (rev a1)
eth0 configuration: eth-id-00:e0:4c:e5:27:02
eth0 (DHCP) . . . . . no IP address yet... backgrounding.
waiting
Setting up service network . . . . . . . . . . . . . . done.

Por el mensaje “waiting” puedo presumir que no fùe capaz de resolver DHCP. Al hacer ifconfig se repite la informaciòn arriba descrita. No hay conexión.

Accion 3:
Leì entonces que era necesario colocar la puerta de enlace. Eso resultarìa muy curioso para mi tipo de conexión tan sencilla, ya que dicha puerta de enlace està en el NRP de mi ISP, no en mi modem, ya que dicho modem no esta funcionando como router, es un simple bridge, por lo tanto no posee direccion IP asignada. Aùn asì, hago un ipconfig/all desde windows, y la puerta de enlace que me arroja cantv.net, la cual es 201.209.64.1 (Nòtese entonces q es una IP publica), la coloco donde dice “Pasarela predeterminada” en YaST. Lo demàs lo dejo idèntico como estaba.
Si hago un ifconfig, un route, o reinicio la configuracion de red, obtengo el mismo resultado arriba descrito. No hay conexión.


Accion 4:
Leì entonces que lo único que tienìa que hacer es configurar mi NIC con los mismos valores que utilizo en otro sistema operativo (ip, puerta de enlace, máscara de red y servidores dns). A esta altura me pregunto, “¿Y es que acaso Linux no acepta autoconfiguracion?” Sin embargo me trago la incredulidad y procedo a colocar en YaST TODO lo que veo en el ipconfig que me arrojò Windows. Aunque serìa una contradicciòn porque en Windows nada de esto yo lo coloco, el S.O. detecta todo sòlo por DCHP.
Favor ver la imagen:
http://mipagina.cantv.net/andrezrodr...ocacionips.png
Nòtese que en nombre de dominio, aparece ese nombre: site, el cual no se porque, ni a que se refiere, ni aparece en el ipconfig de windows.
¿Que querrà Linux con eso? Sin embargo lo dejo ya que ustedes son los expertos.

No encontrè donde colocar la IP del servidor DHCP.
Muy bien, hago un ifconfig y obviamente obtengo la direcciòn IP que acabo de colocar. Sin embargo al intentar navegar, no ingresa a pàgina alguna. El switch hace par de parpadeos aislados. Si le hago un ping a los DNS de cantv, obtengo Destinaton Host Unreachable. (Todo esto me parece lògico porque estoy forzando a linux a usar una IP, en vez de obtener una del servidor DHCP)

Acciòn 5:
Elimino la configuraciòn utilizada en Acciòn 4, y la configuro nuevamente como Acciòn 1.
Utilizo desde consola la opcion /etc/init.d/network restart-all-dhcp-clients

desktop:~ # /etc/init.d/network restart-all-dhcp-clients
Shutting down network interfaces:
eth0 device: nVidia Corporation MCP51 Ethernet Controller (rev a1)
eth0 configuration: eth-id-00:e0:4c:e5:27:02 done
Hint: you may set mandatory devices in /etc/sysconfig/network/config
Setting up network interfaces:
eth0 device: nVidia Corporation MCP51 Ethernet Controller (rev a1)
eth0 configuration: eth-id-00:e0:4c:e5:27:02
eth0 (DHCP) . . . . . no IP address yet... backgrounding.
waiting

Accion 6:
Cualquiera pensarìa entonces que el switch tiene algun tipo de “Incompatibilidad” con linux (algo que creo debe ser ilògico, ya que es un dispositivo capa 2 en el modelo OSI). Asì que procedo a quitarlo. Coloco la configuraciòn de red como la describo en los Antecedentes (leer arriba). Reinicio el computador.
Al arrancar linux aparece esta joyita, ver imagen:

http://mipagina.cantv.net/andrezrodr.../5Netdamon.png
Ejecuto lo indicado en Acciòn 2. Mismo resultado allì descrito.
¿Que pasò con el demonio de red?

Accion 7:
Voy a YaST y procedo a cambiar el nombre de mi PC. Hago esto para descartar que el servidor DHCP no pueda resolver el mismo nombre de Host con S.O, diferentes.
Mismo resultado.




Accion 8:
Leì que si se usa DHCP :“Debería introducir el nombre del host como la asignó el proveedor en el campo dhclient_hostname_option en el apartado Sistema -> Editor para Sysconfig -> etc de Yast2.”
“La opción dhclient_modify_resolv_conf tiene que estar configurada en yes".

En primer lugar, mi proveedor cantv.net NO otorga ningun nombre de Host. Uno coloca el que sea y el NRP lo resuelve. Sin embargo , voy a la ruta indicada y noto que esta colocado el string “AUTO” , el cual es el valor predeterminado. Coloco el nuevo nombre del PC, el cual concuerda con el que coloquè en Acciòn 7.La opcion dhclient_modify_resolv_conf la consigo configurada en Yes, la dejo asì.
Reinicio el PC
Obtengo el mismo resultado.

Continùa.....
__________________
Antes de preguntarles, SI , SI busquè en Google y SI busquè en el foro....
Datos si necesito de su ayuda:
Athlon 64 3000+
Biostar T Series, Chip NVidia Geforce 6100 (NIC interna)
1 GB Ram, Dual Channel
BFG NVIDIA 8500GT 512Mb
SuSE Linux 11.1 64Bits, Win XP Professional Edition
compiz-fusion CORRIENDO!

Última edición por Arkantos_cero; 31-jul-2007 a las 16:24 Razón: Siguiendo las nuevas suigerencias del moderador.
Responder Citando
Acciòn 9, lo ùltimo
  #2  
Antiguo 16-oct-2006, 08:30
Avatar de Arkantos_cero
Arkantos_cero Arkantos_cero está desconectado
Habitual
 
Fecha de Ingreso: 04-septiembre-2006
Ubicación: /home/los_teques
Mensajes: 107
Agradecimientos: 2
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 12
Arkantos_cero está en el buen camino
Red face Acciòn 9, lo ùltimo

Accion 9:
Noto que el mensaje del Damon ahora continùa.
Parece haber empeorado el problema.
Retorno a la configuraciòn establecida en Acciòn 1. Elimino los valores colocados en Acciòn 8.


Golpeo mi saco de boxeo hasta quedar exausto. Un trago de Wiskey, bien largo. Hago un largo jalòn a mi cigarrillo, buscando las respuestas en el humo.


Redacto algunas crìticas a linux en el foro y, finalmente, escribo este thread.


Preguntas al aire:
  • ¿Que falta por intentar?
  • ¿Influye el nombre “site” en el dominio como causa de la falla?
  • ¿Que le pasò al demonio de red?
  • ¿Tiene esta falla soluciòn?
Preguntas opcionales.
Entiendo que hay que ser un verdadero erudito para responder las cuestiones siguientes, por eso sòlo las dejo como opcionales.

  • ¿Linux es siempre asì de cojonudo para todo?
  • ¿Si hacer una labor tan sencilla como detectar una conexion a Internet es tan dificil, hacer labores complejas como NAT o establecer DMZ resultan un verdadero infierno?
  • ¿Por qué al regresar a una configuración que funcionaba en Linux, ahora no funciona?
  • ¿Porque funciona esta configuracion en Windows a la perfeccion y en Linux no funciona de forma alguna?
Algunos enlaces intentados de este foro consultados:
Realmente intentè mucahs de las cosas indicadas acà en todo el foro, de hecho varias de las "Acciones" son por ello. sin embargo se pueden considerar tambièn estos enlaces como referencia


Aspectos a mejorar de Linux, se menciona el DHCP
http://www.forosuse.org/forosuse/sho...2&page=2&pp=40


Lo indicado en la Accion 4, lo cual no resultò:
http://www.forosuse.org/forosuse/sho...light=Conexion


Estarè agradecido enormemente. Muchas gracias por su tiempo en leer este RETO, y gracias por asumir este RETO quien lo asuma.
__________________
Antes de preguntarles, SI , SI busquè en Google y SI busquè en el foro....
Datos si necesito de su ayuda:
Athlon 64 3000+
Biostar T Series, Chip NVidia Geforce 6100 (NIC interna)
1 GB Ram, Dual Channel
BFG NVIDIA 8500GT 512Mb
SuSE Linux 11.1 64Bits, Win XP Professional Edition
compiz-fusion CORRIENDO!
Responder Citando
  #3  
Antiguo 16-oct-2006, 18:11
Avatar de keops
keops keops está desconectado
Miembro Junior
 
Fecha de Ingreso: 19-diciembre-2005
Ubicación: Mallorca
Mensajes: 600
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 12
keops está en el buen camino
Hola,

Visto tu mensaje, y el gráfico de tu instalación, al primer vistazo de ese gráfico, diria que lo que necesitas es un router no un switch.
Para ponerte un ejemplo, tengo en casa una red de tres ordenadores a traves de un router y todos tienen salida a internet. El esquema es el tuyo, cambiando el switch por un router.
Pero puedo equivocarme, espera otra respuesta de los foristas.

Suerte.

Salu2.
__________________
SuSE 11.3 - KDE
The Time Of CHOICE, Time Of Freedom
Responder Citando
  #4  
Antiguo 16-oct-2006, 18:24
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.480
Agradecimientos: 563
Agradecido 2.416 Veces en 1.627 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Cita:
Iniciado por Arkantos_cero
Pasarela Predeterminada: En Blanco
201.209.64.1

Aunque la ip de XP es publica, tambien le puedes meterla. Nunca he configurado redes con IPs publicas.
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
  #5  
Antiguo 16-oct-2006, 19:16
pequejuan
Invitado
 
Mensajes: n/a
Thumbs up

Estimado Amigo SuSEro:

La conexion a internet que utilizas es una conexion con DHCP, via PPPoe o PPPoa, ya que eso es critico para tu configuracion si ip fija la conexion que dispones es solo acceso a internet con tu Swicht y si quieres hacer nat con algun servicio lo tienes que promover con el route de acceso a internet, si no es asi y solo quieres acceso a internet con tus maquinas tienes que ver si tu conexion te pide user y pass de conexion de esa forma estarias por PPPoe lo cual puedes tener problemas con el user ya que algunas empresa usan un tema llamado access mac, lo cual te registra la mac de tu tarjeta de red junto con tu usuario y para que no hagan mal uso de esos user solo te permite conectar con el pc que registraste primero con tu user, para cambiar de equipo o cambiar de tarjeta de red tienes que contactarte con tu ISP y solicitar la limpieza de mac. de esa forma solo un pc puedes conectar, si quieres los 2 tienes que usar un route con pppoe para que el route te valida y desde el router compartes tu acceso a internet.

espero te sirva
saludos
pequeño Juan
Responder Citando
  #6  
Antiguo 16-oct-2006, 19:37
RedDwarf RedDwarf está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 11-mayo-2006
Versión: openSUSE 12.1
Mensajes: 1.531
Agradecimientos: 0
Agradecido 29 Veces en 26 Mensajes
Poder de Credibilidad: 13
RedDwarf está en el buen camino
Como ya dije mi experiencia en DHCPs es escasa (creía recordar que había que indicar el servidor DHCP, que no funcionaba por broadcast...). Pero lo que se me ocurre:

- Tu ISP te permite tener mas de una IP? Imagino que no es el caso, pero es posible que todas las pruebas se hayan hecho con la maquina Windows encendida? Lo digo por si la otra máquina consigue una IP, y cuando la Linux lo intenta el ISP te deniega una segunda IP.

- Lo de "Pasarela Predeterminada: En Blanco" la verdad es que me parece que es algo para comentar en bugzilla.
Entiendo que el servidor DHCP también te puede asignar una pasarela predeterminada. Así que al igual que en la configuración de los DNS existe la opción "Actualizar servidores de nombres y lista de búsqueda via DHCP", en la configuración de el enrutádo debería existir una opción "Actualizar pasarela predeterminada via DHCP". Tal y como está ahora es como mínimo confuso.

Llegados a este punto yo entiendo que puede existir alguna incompatibilidad entre el cliente DHCP de Linux y el servidor DHCP de tu ISP. Tu ISP funciona por DHCP, que es un protocolo bien definido, y Linux entiende DHCP... no hay mucho margen de error, y tú ya has probado todo. O el cliente de Linux o el servidor de DHCP deben tener algún pequeño error en la implementación del protocolo.
Así que nos vamos a la configuración detallada del DHCP vía sysconfig. Mirando por encima las opciones:
- DHCLIENT_BIN: Por lo visto existen dos clientes DHCP, lo mismo el otro no tiene problemas con tu ISP.
- DHCLIENT_DEBUG: Activandolo lo mismo aclaramos algo
- DHCLIENT_SET_DEFAULT_ROUTE: Esto es la "pasarela predeterminada". Genial, la coge por DHCP, pero en la configuración gráfica ya hemos comentado antes que no dice nada... definitivamente a bugzilla.
- DHCLIENT_HOSTNAME_OPTION: Entiendo por la descripcción que dejarlo en AUTO es lo mñas lógico. Aunque si miras el archivo /etc/HOSTNAME verás que dice que tu hostname es desktop.site. Lo de "site" en general no te va a influir en nada, pero que esté en tu hostname lo mismo es un problema (sinceramente, no lo creo).
- DHCLIENT_UDP_CHECKSUM: Está es el tipo de cosa que puede dar incompatibilidades entre Windows y Linux. No se exactamente que hace, pero entiendo que verifica si los paquetes que llegan del servidor són correctos. Si Windows no lo verifica y el servidor DHCP de tu ISP calcula un checksum incorrecto, es posible que tu ISP este enviando paquetes "dañados" que Windows acepta y Linux no. Por si acaso yo probaría a desactivarlo.


Si no consigues nada deberías intentar usar el Ethereal. Si no lo conoces, te captura el tráfico de la red. El tráfico capturado se puede guardar a disco, suele ocupar mucho espacio pero es muy comprimíble... en un .tar.bz2 no suele ocupar demasiado. Así que si no lo entiendes puedes colgarlo en el foro o en bugzilla para que se pueda hacer un mejor diagnostico.
Viendo de primera mano la negociación entre el cliente y el servidor DHCP en Windows (Ethereal funciona en Windows y Linux) y en Linux podremos ver exactamente donde falla, aunque confio en que las trazas de DHCLIENT_DEBUG sean suficiente.
Responder Citando
  #7  
Antiguo 16-oct-2006, 19:38
Avatar de ShakaGoldSaint
ShakaGoldSaint ShakaGoldSaint está desconectado
Habitual
 
Fecha de Ingreso: 17-junio-2006
Ubicación: /home/eleazar
Versión: Ubuntu Fiesta Fawn!
Mensajes: 337
Agradecimientos: 0
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 12
ShakaGoldSaint está en el buen camino
Enviar un mensaje por MSN a ShakaGoldSaint


[NoobComment]
Pos yo le puse cantv.net al nombre del dominio y no tuve que periquear mas nada

Yo acá tengo modem aba --> hub --> Dos PCs
[/NoobComment]
__________________
(\__/) Este es Conejo.
(='.'=) Copia a Conejo en tu firma y
(")_(") ayudale en sus planes de dominacion mundial.
Responder Citando
Comienzo de aplicacion de sugerencias
  #8  
Antiguo 19-oct-2006, 00:55
Avatar de Arkantos_cero
Arkantos_cero Arkantos_cero está desconectado
Habitual
 
Fecha de Ingreso: 04-septiembre-2006
Ubicación: /home/los_teques
Mensajes: 107
Agradecimientos: 2
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 12
Arkantos_cero está en el buen camino
Post Comienzo de aplicacion de sugerencias

Wow!
Puedo hablar mal de Linux, pero nunca lo harìa de esta comunidad SuSera.
Gracias por su valioso tiempo.
Comenzarè a atacar la falla en el orden de arriba hacia abajo.


Cita:
Iniciado por keops
Hola,

Visto tu mensaje, y el gráfico de tu instalación, al primer vistazo de ese gráfico, diria que lo que necesitas es un router no un switch.
Salu2.
Muchas gracias Keops por leer mi post.
La sugerencia de colocar un router, lamentablente no explica el hecho de que sin el mismo, funcione la red y el internet bajo windows. Incluso, bajo ese esquema que puedes visualizar, yo puedo hacer que ambas màquinas se vean como una LAN y transfiera informacion entre ellas (bajo windows, usando las ip`s 201.x.x.x, claro està).
Ahora, quizà sepas explicar porque necesito un router para linux, y eso explique porque si funcione en windows ?.... dejo la pregunta abierta

Cita:
Iniciado por DiabloRojo
201.209.64.1

Aunque la ip de XP es publica, tambien le puedes meterla. Nunca he configurado redes con IPs publicas.

Gracias Moderador por leer el post. Lo que recomiendas es lo que describì en la "Accion 3". Es decir, ya lo intentè antes de escribir el thread. Acà tienes el proceso y el resultado, a ver tu opiniòn.


Cita:
Iniciado por Arkantos_cero

Accion 3:
Leì entonces que era necesario colocar la puerta de enlace. Eso resultarìa muy curioso para mi tipo de conexión tan sencilla, ya que dicha puerta de enlace està en el NRP de mi ISP, no en mi modem, ya que dicho modem no esta funcionando como router, es un simple bridge, por lo tanto no posee direccion IP asignada. Aùn asì, hago un ipconfig/all desde windows, y la puerta de enlace que me arroja cantv.net, la cual es 201.209.64.1 (Nòtese entonces q es una IP publica), la coloco donde dice “Pasarela predeterminada” en YaST. Lo demàs lo dejo idèntico como estaba.
Si hago un ifconfig, un route, o reinicio la configuracion de red, obtengo el mismo resultado arriba descrito. No hay conexión.

Cita:
Iniciado por pequejuan
La conexion a internet que utilizas es una conexion con DHCP, via PPPoe o PPPoa, (...) ip fija la conexion que dispones es solo acceso a internet con tu Swicht y si quieres hacer nat con algun servicio lo tienes que promover con el route de acceso a internet, si no es asi y solo quieres acceso a internet con tus maquinas tienes que ver si tu conexion te pide user y pass de conexion de esa forma estarias por PPPoe (...) para cambiar de equipo o cambiar de tarjeta de red tienes que contactarte con tu ISP y solicitar la limpieza de mac. de esa forma solo un pc puedes conectar(...)
Pequeño Juan, gracias por leer el post.
Confiezo que tuve q leer varias veces tu post, y acà vamos:

Mi conexiòn a internet, acà en Venezuela, es DSL asìncrona (ADSL), banda ancha. NO requiere nombre de usuario ni contraseña. NO deseo hacer NAT. Como explique, es una conexion a Internet bastante sencilla. Es un plan de 512 Kbps, lo cual me permite MÀS de dos màquinas... en realidad (trabaje en el ISP por un tiempito) el servidor de cantv no es muy bueno frenando a las màquinas que estèn de màs.

Me explico mejor: el servidor dhcp de cantv.net, aunque tengas un plan limitado de 256 Kbps (el cual permite solo 2 maquinas) no es capaz de negarle una IP a una tercera o cuarta màquina que se pegue con un hub. Claro que irìas lentìsimo, pero lo permite. O por lo menos hasta que me fuì de cantv.

Sin embargo me diste dos ideas.

Idea 1: Si el servidor DHCP de cantv.net me està negando una tercera IP Adress..... (con lo cual estarìan desacatando mi contrato de 512 kbps)
Entonces al yo pedirle una tercera direccion IP desde windows, diferente, deberìa fallar en la respuesta.
Idea 2: Si la cuestion es que està registrada mi mac adress con windows en el servidor DHCP, al liberar esa IP (haciendo ipconfig/release) y conectando windows con U.S.B. (la cual tiene otra mac adress "virtual") y conectando linux vìa ethernet, deberìa tener conexiòn.

Accion 10:
Los valores en linux estàn configurados segùn "Accion 1"
Desconecto las dos pc`s de internet, de esta forma:
Apago una de ellas.
Aplico ipconfig/release desde windows en la otra (que posee linux)
Desactivo mi conexiòn ethernet desde windows en la misma.
Conecto cable USB, monto TCP/IP en esa conexiòn, y listo, el servior DHCP le da una direcciòn IP de inmediato.
Compruebo MAC ADRESS: Es diferente por supesto a la mac adress de ethernet.
CONCLUSION 1: cantv.net es capaz de darle IP a una tercera MAC ADRESS diferente, por lo menos si estàn desconectadas las otras dos.
Reinicio en Linux, con ethernet conectado.
Compruebo conexiòn : Negativo.
Realizo "Accion 5" y obtengo los mismos valores (
eth0 (DHCP) . . . . . no IP address yet... backgrounding. waiting)

Accion 11:
Decido comprobar si cantv.net es capaz de darme TRES IP Adress a la vez.
Enciendo el otro PC, verifico que tenga conexiòn.
En el pc con conexion USB, le acivo la conexiòn Ethernet y le pido un ip mediante ip/relaese.
Resultado:
Tengo una PC con DOS IPAdress y una con la suya. Total: Tres IP Adress diferentes.
CONCLUSION 2: cantv.net puede darme màs de dos direcciones IP.


Esta es una de las computadoras, la otra posee conexiòn tambien.
No comprendo, (ustedes quizà son màs expertos en redes). Si yo libero, desde una PC una direccion IP, supongo que en el servidor DHCP esa "lease" o "licencia" o "concesion" como la llama windows, queda liberada para esa mac adress. ¿Porque al yo pedirsela nuevamente desde linux no me la da? ¿Porque al pedirsela desde Windows si me la da?

Se me agotò el tiempo por hoy. En conclusiòn, no pude conectarme con linux con las primeras sugerencias tomadas en cuenta. Por supuesto si algo he hecho mal no està de màs escucharlos. Apenas pueda, intentarè con las demàs sugerencias. Gracias por su valioso tiempo.



__________________
Antes de preguntarles, SI , SI busquè en Google y SI busquè en el foro....
Datos si necesito de su ayuda:
Athlon 64 3000+
Biostar T Series, Chip NVidia Geforce 6100 (NIC interna)
1 GB Ram, Dual Channel
BFG NVIDIA 8500GT 512Mb
SuSE Linux 11.1 64Bits, Win XP Professional Edition
compiz-fusion CORRIENDO!
Responder Citando
  #9  
Antiguo 19-oct-2006, 16:42
RedDwarf RedDwarf está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 11-mayo-2006
Versión: openSUSE 12.1
Mensajes: 1.531
Agradecimientos: 0
Agradecido 29 Veces en 26 Mensajes
Poder de Credibilidad: 13
RedDwarf está en el buen camino
Cita:
Iniciado por Arkantos_cero
Incluso, bajo ese esquema que puedes visualizar, yo puedo hacer que ambas màquinas se vean como una LAN y transfiera informacion entre ellas (bajo windows, usando las ip`s 201.x.x.x, claro està).
Imagino que también puedes hacer que la maquina Linux (corriendo Linux) y la Windows se vean, no? Aunque sea usando IPs estáticas. No vaya a ser que el problema sea que la tarjeta de red falla o no sea compatible con Linux.

p.d. Por que Windows dice "DHCP habiliado.....: No"?
Responder Citando
creo q es facil
  #10  
Antiguo 19-oct-2006, 16:58
morcillaking
Invitado
 
Mensajes: n/a
creo q es facil

hermano q mas, yo tambien uso cantv.net y la he configurado en mas de una distribucion es mas en mas de una makina...


mi solucion evidente es.

1 colocar cantv.net (nombre del dominio)
2 colocar dhcp (tipo de conexion)
3colocar los dns de cantv.net en la configuracionde suse q es el q te da problemas serian 200.44.32.12, 200.44.32.13(servidor de nombres)
con eso NO deberias rener problemas el hecho q conecte con guindos ya es suficiente para saber q no es problema de la conexion si no de configuracion de suse.

nada es imposible.

Última edición por morcillaking; 19-oct-2006 a las 17:29
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Los 12 mitos sobre linux penguin_1989 El Contubernio 79 02-oct-2010 23:21
Problemas Wifi USB de Telefonica blaster Internet, Redes y Wireless 10 18-nov-2006 00:02
Problema con red en SuSE 9.0 Pro arandaedgar Internet, Redes y Wireless 6 16-oct-2006 02:52
TV ATI (All in Wonder) en Suse 10.0 vmannarelli Hardware 25 12-may-2006 03:40
Suse 10 se cuelga al arrancar el escritorio goordel Hardware 6 14-mar-2006 18:21



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 19:28.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba