Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona OpenSUSE > Hardware


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Problemas con tarjeta gráfica Nvidia.
  #1  
Antiguo 21-jul-2006, 11:53
tumerudi tumerudi está desconectado
Aforado
 
Fecha de Ingreso: 10-agosto-2005
Mensajes: 23
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
tumerudi está en el buen camino
Angry Problemas con tarjeta gráfica Nvidia.

Hola a tod@s!

Veréis, tengo un portátil Toshiba Intel Centrino Pro M10, creo que no me salto nada del nombre del modelo, y tiene una tarjeta gráfica Nvidia Geforce 420. Y tengo dos problemas, el primero es un error que me trae bastante de cabeza y el segundo es menos importante para mí.

El caso es que se ve de maravilla, incluyendo fotos, vídeos y juegos (he jugado alguna vez al GL-117) pero tengo un grave problema desde que lo instalé y no he sabido solucionar.

Os cuento: cuando estoy un rato sin utilizar el ordenador, salta el salvapantallas y si lo dejo un poco más la pantalla se apaga, como si fuera por el ahorro de energía (no lo sé seguro) y una vez en ese estado no hay forma de que se vuelva a encender, ni moviendo el ratón, ni tocando las teclas propias de los portátiles para ajuste del monitor (que sí que funcionan cuando está encendida la pantalla) ni nada de nada...

Imaginaos el cabreo que me produce este problema, porque si tengo un documento a medio hacer lo pierdo al no poder guardarlo, he de decir que cuando me ocurre este problema sólo veo como solución apagar el ordenador con el botón de apagado. También decir que constantemente tengo que estar pendiente de hacer alguna actividad en el ordenador para que no se dé este problema. Otra cosa que he probado es hacer varias combinaciones jugando con el control de energía y el salvapantallas, llegándome a pasar lo mismo incluso en el caso de desactivar ambas opciones. Hasta llegué a intentar modificar hace mucho un fichero que se encuentra en "/etc/X11/XF86org.conf" o similar, porque buscando en Google encontré que para cualquier ajuste debía modificar ese archivo, lo intenté pero no supe realizar cambios.

Utilizo SuSE 10.0, con la versión 10.1 compilé los drivers de Nvidia con "tiny-nvidia-installer" y al final no me dejó arrancar el ordenador, por lo que volví a la versión 10.0, con la cual estoy muy contento, también porque me manejo bastante mejor con ella para mi uso personal. Es en esta versión donde instalé los drivers de Nvidia como aconsejaba el YaST, viéndose notablemente mejor la pantalla con esta configuración.

El segundo problema es de la salida de televisión, que después de mucho romperme la cabeza he comprobado que me funciona cuando no está el servidor X (no sé si dice así) funcionando. Lo he probado con SuSE, Ubuntu, Kubuntu y unas cuantas más. El caso es que sólo me funciona bien cuando activo la salida de televisión y en este modo apago el ordenador, pasando de rayas en la televisión a lo que realmente muestra el ordenador. He de deciros que he utilizado "nvtv", "ial" o en su caso "fnfx", ambos son incompatibles.

Espero no haberme extendido mucho.

Muchas gracias!!

Última edición por tumerudi; 21-jul-2006 a las 12:06
Responder Citando
  #2  
Antiguo 21-jul-2006, 12:39
Avatar de anuljade
anuljade anuljade está desconectado
Miembro Junior
 
Fecha de Ingreso: 28-mayo-2005
Mensajes: 380
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 13
anuljade está en el buen camino
Enviar un mensaje por ICQ a anuljade Enviar un mensaje por AIM a anuljade Enviar un mensaje por MSN a anuljade Enviar un mensaje por Yahoo  a anuljade
Hola...

el problema de la tarjeta gráfica, siempre te ha pasado, o ha sido a raiz de "modificar" algo?

tienes activada la aceleración 3D?; compruebalo:

glxinfo | grep direct


Puedes tener acceso a algún archivo "Xorg.x.log" (en /var/log) para ver que dice?

Puedes probar un par de cosas:

1.- edita el archivo xorg.conf (en /etc/X11) y cambia donde pone "nvidia" por "nv"

Código:
Section "Device"
	Driver		"nvidia"
y reinicia las X a ver que pasa. Haz copia del archivo por si acaso.

2.- Reinstalar la tarjeta tuya otra vez desde sax2:

Código:
ctrl+alt+f1 (te logeas como root)

init 3

sax2 (configuras tu tarjeta)

init 5 (a ver que pasa)
Por cierto, que tipo de configuración tienes como tarjeta?

En cuanto a lo de la salida de tv, mirate en éste foro, en la sección de manuales se encuentra uno referente a lo que quieres.

Bueno ya contarás...
__________________
Salu2
"Conocer la verdad duele, pero es sin duda una acción altamente saludable y liberadora"
Mons. Juan José Gerardi y Conedera (Guatemala)
Esperando instalar nuevo SUSE || KDE ??|| X.Org ?? ||

Última edición por anuljade; 21-jul-2006 a las 12:53
Responder Citando
  #3  
Antiguo 21-jul-2006, 13:15
tumerudi tumerudi está desconectado
Aforado
 
Fecha de Ingreso: 10-agosto-2005
Mensajes: 23
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
tumerudi está en el buen camino
En primer lugar, te agradezco la respuesta, anuljade, he de decir que siempre me ha ocurrido este problema en SuSE 10.0, eso es lo más raro...

Ahora que reinstalé la versión 10.0 después de pasar por la 10.1 me sigue pasando lo mismo incluso después de no haber tocado absolutamente nada, ni siquiera la configuración del salvapantallas. Es muy extraño...

Voy a realizar los pasos que me has aconsejado, tardaré un rato supongo, así que más tarde podré exponer los resultados.

Muchísimas gracias!!!
Responder Citando
  #4  
Antiguo 21-jul-2006, 18:19
tumerudi tumerudi está desconectado
Aforado
 
Fecha de Ingreso: 10-agosto-2005
Mensajes: 23
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
tumerudi está en el buen camino
Lo he conseguido!!

Ahora me funciona con eso de cambiar el driver en /etc/X11/xorg.conf, lo primero que me dijiste!

Me he dado cuenta de que hay salvapantallas que no me van, pero me da igual, obviamente, se ven fotos y eso es lo que más cuenta para mí, así que ya está!!

Ahora, cuando se apaga la pantalla, le doy al ratón y se vuelve a encender!

En serio, muchísimas gracias!!
Responder Citando
  #5  
Antiguo 23-jul-2006, 14:08
Avatar de anuljade
anuljade anuljade está desconectado
Miembro Junior
 
Fecha de Ingreso: 28-mayo-2005
Mensajes: 380
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 13
anuljade está en el buen camino
Enviar un mensaje por ICQ a anuljade Enviar un mensaje por AIM a anuljade Enviar un mensaje por MSN a anuljade Enviar un mensaje por Yahoo  a anuljade
Hola...

jajajaj... me alegro mucho de que hayas conseguido tu propósito.

En cuanto al tema de que haya algunos salvapantallanas que no puedas ver, seguramete se deba a que son aceleración 3D que tú, ahora, no tienes. Es un "mal" menor que en muchos casoso es incluso reconmendable.

Bueno... lo dicho

P.D.
Pernoda el retraso en resonder, pero el curro... ya sabes

[Editado]
donde pongo "son aceleración 3D" quiero decir que son salvapantallas que usan OpenGL, osea aceleración 3D.
__________________
Salu2
"Conocer la verdad duele, pero es sin duda una acción altamente saludable y liberadora"
Mons. Juan José Gerardi y Conedera (Guatemala)
Esperando instalar nuevo SUSE || KDE ??|| X.Org ?? ||

Última edición por anuljade; 24-jul-2006 a las 14:36
Responder Citando
  #6  
Antiguo 24-jul-2006, 01:00
Zyndarius
Invitado
 
Mensajes: n/a
Yo que el hubiera investigado como desactivar todo tipo de reserva energetica que implique la desactivacion del display en pantalla, ademas de eliminar los salvapantallas.

Yo no cambiaria aceleracion 3d por nada, sobre todo cuando cuesta un mundo hacerla funcionar sin problemas TT
Responder Citando
  #7  
Antiguo 24-jul-2006, 14:41
Avatar de anuljade
anuljade anuljade está desconectado
Miembro Junior
 
Fecha de Ingreso: 28-mayo-2005
Mensajes: 380
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 13
anuljade está en el buen camino
Enviar un mensaje por ICQ a anuljade Enviar un mensaje por AIM a anuljade Enviar un mensaje por MSN a anuljade Enviar un mensaje por Yahoo  a anuljade
Hola...

no soy el más apropiado para contestarte, pero lo que si te digo es que no puedes anteponer tus necesidades a las de los demás. Lo que significa que lo que es "necesario" para ti no lo es para otra persona.

No te has planteado que para él puede ser más importante tener salvapantallas o ahorro de energía que tener 3D?.

Como has podido leer, para tumerudi, lo que más le importaba era poder ver fotos. Si desactivando la 3D cumple su objetivo...
__________________
Salu2
"Conocer la verdad duele, pero es sin duda una acción altamente saludable y liberadora"
Mons. Juan José Gerardi y Conedera (Guatemala)
Esperando instalar nuevo SUSE || KDE ??|| X.Org ?? ||
Responder Citando
  #8  
Antiguo 25-jul-2006, 17:25
cellfer
Invitado
 
Mensajes: n/a
Muy buenas compañeros, les comeno que soy muy nuevo en esto de Linux y acabo de instalar en mi portatil Satellite Pro 4600 y les cuento que solo me inicia en 800 x 600 pixeles y no asi en toda la pantalla ya intente cambiar pero solo hay estas dos opciones 800 x 600 y 640 x 480

Yo quiero que me salga en toda la pantalla y no puedo , alguien sabe como hacer que este Linux trabaje en toda la pantalla a 1024 pixeles?

Por favor una ayudita.
Responder Citando
  #9  
Antiguo 25-jul-2006, 18:38
Avatar de anuljade
anuljade anuljade está desconectado
Miembro Junior
 
Fecha de Ingreso: 28-mayo-2005
Mensajes: 380
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 13
anuljade está en el buen camino
Enviar un mensaje por ICQ a anuljade Enviar un mensaje por AIM a anuljade Enviar un mensaje por MSN a anuljade Enviar un mensaje por Yahoo  a anuljade
Hola...

puedes hacerlo "a pelo", editando el archivo "xorg.conf" y añadiendo más resoluciones en la sección metamodes, o... puedes reconfigurar tu tarjeta con sax:

Cita:
ctrl+alt+f1 (te logeas como root)

init 3

sax2 (configuras tu tarjeta; en éste caso miras las resoluciones)

init 5 (a ver que pasa)
__________________
Salu2
"Conocer la verdad duele, pero es sin duda una acción altamente saludable y liberadora"
Mons. Juan José Gerardi y Conedera (Guatemala)
Esperando instalar nuevo SUSE || KDE ??|| X.Org ?? ||
Responder Citando
  #10  
Antiguo 28-jul-2006, 13:12
tumerudi tumerudi está desconectado
Aforado
 
Fecha de Ingreso: 10-agosto-2005
Mensajes: 23
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
tumerudi está en el buen camino
Hola a todos!

He estado fuera de mi domicilio y por eso no he tenido la posibilidad de responder tan fácilmente. Celifer, cuando se hacen actualizaciones con el YaST, a mí me aparecía una opción para bajarse los drivers de Nvidia, aunque no sé si tu ordenador en concreto utilizará esa tarjeta gráfica. Quizá con los drivers actualizados consigas esa configuración de pantalla, no lo sé seguro, pero tienes más posibilidades...

Al resto les doy las gracias por haberme ayudado, y también os digo que voy a probar lo de la salida de televisión que me han aconsejado en BandaAncha.st, me han dicho cosas interesantes con respecto a la salida de televisión. Voy a pelearme con ello, y en cuanto tenga resultados satisfactorios os lo comento!

Un saludo!!!

Última edición por tumerudi; 28-jul-2006 a las 13:17
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Como instalar lo driver para tu tarjeta NVIDIA maldito71 FAQs, Manuales y Tutoriales 25 23-sep-2007 20:16
Linux Desktop multiples rock General OpenSUSE 20 03-dic-2006 20:02
Problema con tarjeta gráfica nueva Wild_bull Hardware 6 05-mar-2006 09:41
Problemas con configuración de NVidia en SuSE 9.3 Pro reynierpm Hardware 8 24-jun-2005 22:09
Problemas con la tarjeta de Sonido druidas Hardware 17 19-ago-2004 17:55



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 16:32.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba