Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Técnica > Internet, Redes y Wireless


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Problemas Wifi USB de Telefonica
  #1  
Antiguo 29-ene-2006, 01:23
blaster blaster está desconectado
Habitual
 
Fecha de Ingreso: 29-enero-2006
Mensajes: 108
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 12
blaster está en el buen camino
Problemas Wifi USB de Telefonica

He contratado Imagenio, y como el router esta en el otro extremo de la casa, Telefonica me ha puesto un WIFI USB (fabricado por Amper). Con Ruindow$ funciona correctamente, pero con OpenSUSE 10.0, no lo he conseguido.

He probado con ndiswrapper, me detecta el hard y el dispositivo, pero al hacer modprobe ndiswrapper el terminal se me bloquea.

Me mirado el messages, y me aparecen los siguientes mensajes:

Jan 15 01:44:47 linux kernel: usb 4-3: new high speed USB device using ehci_hcd and address 4
Jan 15 01:45:33 linux kernel: ndiswrapper: module not supported by Novell, setting U taint flag.
Jan 15 01:45:33 linux kernel: ndiswrapper version 1.2 loaded (preempt=no,smp=no)
Jan 15 01:45:33 linux kernel: ndiswrapper: driver prisma02 (Red Inalámbrica Local,03/26/2004, 1.0.0.4) loaded
Jan 15 01:45:33 linux kernel: Unable to handle kernel NULL pointer dereference at virtual address 00000020
Jan 15 01:45:33 linux kernel: printing eip:
Jan 15 01:45:33 linux kernel: c01f8896
Jan 15 01:45:33 linux kernel: *pde = 00000000
Jan 15 01:45:33 linux kernel: Oops: 0000 [#1]
Jan 15 01:45:33 linux kernel: Modules linked in: ndiswrapper nvidia ipt_pkttype ipt_LOG ipt_limit hfsplus subfs speedstep_lib freq_table snd_seq_dummy snd_pcm_oss snd_mixer_oss snd_seq snd_seq_device af_packet button battery ac ppp_generic slhc edd joydev ip6t_REJECT ipt_REJECT ipt_state iptable_mangle iptable_nat iptable_filter ip6table_mangle ip_conntrack ip_tables usbhid ip6table_filter ip6_tables ipv6 bttv video_buf firmware_class i2c_algo_bit v4l2_common btcx_risc ivtv_tveeprom videodev 8139too ehci_hcd mii ohci_hcd usbcore snd_intel8x0 snd_ac97_codec snd_ac97_bus snd_pcm snd_timer snd soundcore i2c_sis96x i2c_core generic sis_agp agpgart snd_page_alloc pci_hotplug parport_pc lp parport nls_iso8859_1 nls_cp437 vfat fat nls_utf8 ntfs dm_mod reiserfs ide_cd cdrom fan thermal processor sis5513 ide_disk ide_core
Jan 15 01:45:33 linux kernel: CPU: 0
Jan 15 01:45:33 linux kernel: EIP: 0060:[<c01f8896>] Tainted: P U VLI
Jan 15 01:45:33 linux kernel: EFLAGS: 00010202 (2.6.13-15.7-default)
Jan 15 01:45:33 linux kernel: EIP is at pci_set_master+0x6/0x60
Jan 15 01:45:33 linux kernel: eax: 00000000 ebx: d289f302 ecx: d2941dca edx: 00000000
Jan 15 01:45:33 linux kernel: esi: f6d22220 edi: 000003e8 ebp: 00000000 esp: d2941dc8
Jan 15 01:45:33 linux kernel: ds: 007b es: 007b ss: 0068
Jan 15 01:45:33 linux kernel: Process loadndisdriver (pid: 7537, threadinfo=d2940000 task=f7e48a40)
Jan 15 01:45:33 linux kernel: Stack: 00000000 d289f302 f947a858 f6c35680 00000000 f6d44928 d2941e04 f94b5959
Jan 15 01:45:33 linux kernel: f5237600 f6d44800 00000000 000003e8 00000005 f6d44800 000003e8 d2941e34
Jan 15 01:45:33 linux kernel: f94a1c25 f6d44800 00000008 00000005 00000000 00000000 f94b984a f6d44800
Jan 15 01:45:33 linux kernel: Call Trace:
Jan 15 01:45:33 linux kernel: [<f947a858>] NdisMSetAttributesEx+0x1b8/0x1f0 [ndiswrapper]
Jan 15 01:45:33 linux kernel: [<f946d667>] miniport_init+0x57/0x60 [ndiswrapper]
Jan 15 01:45:33 linux kernel: [<f9472bb6>] ndiswrapper_add_usb_device+0x96/0x1b0 [ndiswrapper]
Jan 15 01:45:33 linux kernel: [<f9472c12>] ndiswrapper_add_usb_device+0xf2/0x1b0 [ndiswrapper]
Jan 15 01:45:33 linux kernel: [<c0255f00>] __driver_attach+0x0/0x40
Jan 15 01:45:33 linux kernel: [<f92fd06a>] usb_probe_interface+0x4a/0x60 [usbcore]
Jan 15 01:45:33 linux kernel: [<c0255e3f>] driver_probe_device+0x2f/0x90
Jan 15 01:45:33 linux kernel: [<c0255f39>] __driver_attach+0x39/0x40
Jan 15 01:45:33 linux kernel: [<c02556a8>] bus_for_each_dev+0x38/0x60
Jan 15 01:45:34 linux kernel: [<c0255f51>] driver_attach+0x11/0x20
Jan 15 01:45:34 linux kernel: [<c0255f00>] __driver_attach+0x0/0x40
Jan 15 01:45:34 linux kernel: [<c0255aaa>] bus_add_driver+0x5a/0xa0
Jan 15 01:45:34 linux kernel: [<f92fd12d>] usb_register+0x4d/0xa0 [usbcore]
Jan 15 01:45:34 linux kernel: [<f9473f2b>] register_devices+0x3cb/0x5b0 [ndiswrapper]
Jan 15 01:45:34 linux kernel: [<f9474110>] wrapper_ioctl+0x0/0xb0 [ndiswrapper]
Jan 15 01:45:34 linux kernel: [<f9474161>] wrapper_ioctl+0x51/0xb0 [ndiswrapper]
Jan 15 01:45:34 linux kernel: [<f9474110>] wrapper_ioctl+0x0/0xb0 [ndiswrapper]
Jan 15 01:45:34 linux kernel: [<c0169a9e>] do_ioctl+0x4e/0x60
Jan 15 01:45:34 linux kernel: [<c0169baf>] vfs_ioctl+0x4f/0x1c0
Jan 15 01:45:34 linux kernel: [<c0169d57>] sys_ioctl+0x37/0x70
Jan 15 01:45:34 linux kernel: [<c0102d1b>] sysenter_past_esp+0x54/0x79
Jan 15 01:45:34 linux kernel: Code: ff 89 da 89 f8 4b e8 aa fd ff ff 39 f3 75 f2 b8 f0 ff ff ff eb e2 eb 0d 90 90 90 90 90 90 90 90 90 90 90 90 90 53 51 8d 4c 24 02 <8b> 50 20 89 c3 8b 40 10 51 b9 04 00 00 00 e8 87 df ff ff 66 8b
Jan 15 01:45:34 linux kernel: <3>ndiswrapper (wrapper_init:1531): loadndiswrapper failed (11); check system log for messages from 'loadndisdriver'
Jan 15 01:45:34 linux kernel: usbcore: deregistering driver ndiswrapper


¿Alguien ha conseguido hacerlo funcionar?

P.D: Creo que el chipset que lleva es de Intersil (09aa:1000).

Gracias,
Responder Citando
  #2  
Antiguo 26-may-2006, 14:13
Bunghi
Invitado
 
Mensajes: n/a
Hola.

Antes también tenía Imagenio, y se de que adaptador USB estás hablando, yo lo tenía hasta que, al ver que no consigo configurarlo en linux, me he pasado al cable, lo más seguro del mundo. Si puedes, tira un cable desde el router, que supongo que esta al lado de la tele, hasta tu ordenador, todo es más fácil.

Yo también lo probé con ndiswrapper pero sin éxito.

Suerte!
Responder Citando
  #3  
Antiguo 31-may-2006, 12:32
MAW
Invitado
 
Mensajes: n/a
Buenas tardes, el USB es un Senao NL-3054 UB5, a mi me funciona con Ndiswrappper en Suse 10.0
Instala Ndiswrapper con YAST
graba el archivo donde viene el driver de Win desde el cd a una carpeta
como root:
teclea Ndiswrapper -m
cd /(indica el camino hasta la carpeta donde esta el driver)
Ndiswrapper -i prisma02.inf
Ndiswrapper -d 09aa:1000 prisma02
modprobe Ndiswrapper
Despues abre Yast-dispositivos de red-tarjetas de red
añadir:
dispositivo inalambrico y en la casilla de abajo (a la izquierda, no me acuerdo el nombre) pones Ndiswrapper, siguiente
dhcp (o la ip que quieras para el adaptador)
ESSID y clave del wifi (igual que Win, si esta encriptado)
Aceptar
Al salir de Yast empezo a lucir el led y navegaba (RECUERDA NO CONECTARTE A INTERNET COMO ROOT EN NINGUN CASO).

Creo que era todo lo que hice y me funciono, espero que te funcione a ti tambien.
Responder Citando
  #4  
Antiguo 05-jun-2006, 09:42
AdrIsma4
Invitado
 
Mensajes: n/a
Buenas se que me estoy metiendo en chaleco de 11 balas, pero esque me interesa esto de Linux, y da la casualidad que la distro que tengo es SUSE 10.0 y resulta que el tema que aqui se trata es mi principal problema.

1º Alguien me podria explicar de manera sencilla como hago todo eso?¿
2º Resulta que hace poco que empece con Linux y resulta que manejarlo degamos que se poco (Nivel de conociemiento: Bajo)
3º Espero que me ayudeis, por que yo solo no estoy seguro.
Responder Citando
  #5  
Antiguo 05-jun-2006, 16:44
blaster blaster está desconectado
Habitual
 
Fecha de Ingreso: 29-enero-2006
Mensajes: 108
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 12
blaster está en el buen camino
Buenas.

Hice varios intentos como el que comentas MAW, pero siempre conseguia lo mismo que aparece en el primer post.

Como vi que pasaba el tiempo y no me contestaba nadie probe DRIVERLOADER de LINUXANT y funcionó a la primera, el problema es que este es de pago (20 e+/-) y sólo te deja un mes de prueba.

BUNGHI, el problema es que el router está en el extremo opuesto de la casa, y no tengo por donde pasar el cable de una forma permanente. Ahora lo que hago es tirar el cable (25 mts) y cuando termino tengo que recogerlo, porque sino tengo bronca.
Responder Citando
  #6  
Antiguo 14-nov-2006, 11:16
balrog
Invitado
 
Mensajes: n/a
Hola

He hecho lo que comenta MAW, pero no me funciona...

No me da errores en ningun sitio.

He probado ejecutando #/usr/sbin/iwconfig# y me dice que no hay dispositivos inalambricos

Tambien he probado con el wlasistant y nada.

A ver si me podeis hechar una mano.

Gracias por adelantado.
Responder Citando
  #7  
Antiguo 14-nov-2006, 12:46
balrog
Invitado
 
Mensajes: n/a
He estado mirando por el foro y he probado a ejecutar ifconfig, iwconfig y route.

El resultado:

###

ifconfig

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:102 errors:0 dropped:0 overruns:0 frame:0
TX packets:102 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:6908 (6.7 Kb) TX bytes:6908 (6.7 Kb)

iwconfig

lo no wireless extensions.

eth0 no wireless extensions.

sit0 no wireless extensions.

route

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
loopback * 255.0.0.0 U 0 0 0 lo

###

Aunque no se lo que significa la mitad de lo que pone si se que mi inalambrico USB no sale por ningun lado

¿Que puedo hacer?

Gracias.
Responder Citando
  #8  
Antiguo 14-nov-2006, 17:44
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.470
Agradecimientos: 563
Agradecido 2.415 Veces en 1.626 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
nuestro maestro kilops: http://www.forosuse.org/forosuse/showthread.php?t=9286
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
  #9  
Antiguo 16-nov-2006, 16:47
balrog
Invitado
 
Mensajes: n/a
Cita:
Iniciado por DiabloRojo
Gracias DiabloRojo, pero ya lo conocía.

Lo malo de ese post es que solo habla de tarjetas pci y no dice como hacer que funcionen.

Yo tengo un adaptador USB inalambrico, asi que los comandos #lspci -vv, #hwinfo --netcard, #cardctl ident y #pccardctl ident no me dicen nada de mi USB, eso sin tener en cuenta que el último ni siquiera existe en mi linux, SUSE 10.1.

Movido por la desesperacion teclee #lsusb -vv, comando que ni siquiera sabia que existiera y me dijo que marca y modelo es mi Adaptador USB, pero no me dice el chipset.

Aun asi he intentado, ya que es de la marca SparkLan y en el modelo aparece la mencion 802.11g, a instalar los controladores de chipset "Ralink", y tampoco ha funcionado.

A ver si alguien tiene el mismo Adaptador USB Inalambrico de telefonica que yo y me dice algo.

La otra solucion es comprarme una tarjeta PCI que funcione con SUSE 10.1, si es que hay alguna.
Responder Citando
  #10  
Antiguo 16-nov-2006, 18:38
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.470
Agradecimientos: 563
Agradecido 2.415 Veces en 1.626 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Mirate esto: http://linux-wless.passys.nl/query_p...dname=Sparklan

Si el modelo es el mismo, veras que tu driver es el rt2570, instala el cvs de http://rt2x00.serialmonkey.com/ sino el rt73, son los modelos USB, ya que rt2500 y rt61 son para pcmcia y pci.

Siempre te quedara el ndiswrapper.
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Problemas configurando red wifi Mr.Mitnick Internet, Redes y Wireless 2 02-abr-2007 22:02
Problemas de asignación de tarjetas Wifi KRONENSURF Hardware 4 07-may-2006 23:05
Problemas WIFI...Por favor ayuda KRONENSURF Hardware 8 18-nov-2005 22:04
Problemas WiFi PRISM2 Raiser Hardware 5 13-oct-2005 19:33
Problemas Wifi suse 9.3 redrum-sbd Hardware 3 21-sep-2005 23:48



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 09:13.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba