Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Técnica > Internet, Redes y Wireless


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Wifi se desconecta permanentemente (SOLUCIONADO)
  #1  
Antiguo 25-mar-2018, 21:45
janopi janopi está desconectado
Aforado
 
Fecha de Ingreso: 25-marzo-2018
Versión: Tumbleweed
Mensajes: 16
Agradecimientos: 0
Agradecido 2 Veces en 2 Mensajes
Poder de Credibilidad: 0
janopi está en el buen camino
Wifi se desconecta permanentemente (SOLUCIONADO)

Estimados:
Abro esto como tema nuevo porque revisé los similares y no es lo mismo. Les cuento. Desde hace un par de años hasta ayer tenía Leap (42.3), pero me decidí a migrar a Tumbleweed. Seguí las recomendaciones oficiales y las de victorchk en su blog. Todo bien, salvo que al final me preguntó por un error sobre unas fuentes y al ponerle que reintentara se estancó el proceso así que tuve que reiniciar. Espero que no haya afectado el dup (sospecho que tuvo que ver con el problema que paso a explicar).
Voy al punto: me reconoce la red wifi, se conecta bien pero se desconecta a ratos. Eso me ha traido problemas con algunas descargas y quisiera solucionarlo porque no me da como para reinstalar desde cero o cambiar de distro. Con Leap no falló nunca y es un notebook, así que me da la impresión que no aplica el fallo de otros casos que revisé en que se atribuía a lo viejo de las tarjetas o a problemas con el router.

Esto es lo que me arrojaron algunos de los comandos que están en los manuales de Diablorojo (pego lo que entendí que se pedía. Si está mal, completo o lo cambio):

f@linux-8ld8:~> /usr/bin/lsusb
Bus 002 Device 003: ID 05c8:0348 Cheng Uei Precision Industry Co., Ltd (Foxlink)
Bus 002 Device 006: ID 12d1:2608 Huawei Technologies Co., Ltd.
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

f@linux-8ld8:~> /sbin/lspci -nnk
01:00.0 Network controller [0280]: Ralink corp. RT5390R 802.11bgn PCIe Wireless Network Adapter [1814:539b]
Subsystem: Hewlett-Packard Company Device [103c:18ed]
Kernel driver in use: rt2800pci
Kernel modules: rt2800pci
02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5229 PCI Express Card Reader [10ec:5229] (rev 01)
Subsystem: Hewlett-Packard Company Device [103c:1854]
Kernel driver in use: rtsx_pci
Kernel modules: rtsx_pci
08:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL810xE PCI Express Fast Ethernet controller [10ec:8136]
(rev 05)
Subsystem: Hewlett-Packard Company Device [103c:1854]
Kernel driver in use: r8169
Kernel modules: r8169

f@linux-8ld8:~> dmesg | grep firmware
[ 0.033542] Spectre V2 : Enabling Restricted Speculation for firmware calls
[ 42.414115] ieee80211 phy0: rt2x00lib_request_firmware: Info - Loading firmware file 'rt2860.bin'
[ 42.505166] ieee80211 phy0: rt2x00lib_request_firmware: Info - Firmware detected - version: 0.40


f@linux-8ld8:~> /usr/sbin/hwinfo --netcard
17: PCI 800.0: 0200 Ethernet controller
[Created at pci.378]
Unique ID: rBUF._uvd6zDH8OF
Parent ID: Z7uZ.qfZRT4S2tx8
SysFS ID: /devices/pci0000:00/0000:00:1c.3/0000:08:00.0
SysFS BusID: 0000:08:00.0
Hardware Class: network
Device Name: "Hanksville 10/100 Lan Connection"
Model: "Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller"
Vendor: pci 0x10ec "Realtek Semiconductor Co., Ltd."
Device: pci 0x8136 "RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller"
SubVendor: pci 0x103c "Hewlett-Packard Company"
SubDevice: pci 0x1854
Revision: 0x05
Driver: "r8169"
Driver Modules: "r8169"
Device File: eth0
I/O Ports: 0x2000-0x20ff (rw)
Memory Range: 0xc2404000-0xc2404fff (ro,non-prefetchable)
Memory Range: 0xc2400000-0xc2403fff (ro,non-prefetchable)
IRQ: 28 (no events)
HW Address: 78:e3:b5:80:ac:27
Permanent HW Address: 78:e3:b5:80:ac:27
Link detected: no
Module Alias: "pci:v000010ECd00008136sv0000103Csd00001854bc02sc0 0i00"
Driver Info #0:
Driver Status: r8169 is active
Driver Activation Cmd: "modprobe r8169"
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #6 (PCI bridge)

19: PCI 100.0: 0282 WLAN controller
[Created at pci.378]
Unique ID: y9sn.hpc6i7AhJhC
Parent ID: z8Q3.kAvxafkpie6
SysFS ID: /devices/pci0000:00/0000:00:1c.0/0000:01:00.0
SysFS BusID: 0000:01:00.0
Hardware Class: network
Device Name: "Ralink RT5390R 802.11bgn 1x1 Wi-Fi Adapter"
Model: "Ralink RT5390R 802.11bgn PCIe Wireless Network Adapter"
Vendor: pci 0x1814 "Ralink corp."
Device: pci 0x539b "RT5390R 802.11bgn PCIe Wireless Network Adapter"
SubVendor: pci 0x103c "Hewlett-Packard Company"
SubDevice: pci 0x18ed
Driver: "rt2800pci"
Driver Modules: "rt2800pci"
Device File: wlan0
Features: WLAN
Memory Range: 0xc2500000-0xc250ffff (rw,non-prefetchable)
IRQ: 16 (193281 events)
HW Address: 08:3e:8e:80:19:8e
Permanent HW Address: 08:3e:8e:80:19:8e
Link detected: yes
WLAN channels: 1 2 3 4 5 6 7 8 9 10 11
WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462
WLAN encryption modes: WEP40 WEP104 TKIP CCMP
WLAN authentication modes: open sharedkey wpa-psk wpa-eap
Module Alias: "pci:v00001814d0000539Bsv0000103Csd000018EDbc02sc8 0i00"
Driver Info #0:
Driver Status: rt2800pci is active
Driver Activation Cmd: "modprobe rt2800pci"
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #14 (PCI bridge)

f@linux-8ld8:~> lsmod | grep rt2800pci
rt2800pci 16384 0
rt2800mmio 16384 1 rt2800pci
rt2800lib 122880 2 rt2800mmio,rt2800pci
rt2x00pci 16384 1 rt2800pci
rt2x00mmio 16384 2 rt2800mmio,rt2800pci
rt2x00lib 57344 5 rt2800lib,rt2x00pci,rt2800mmio,rt2x00mmio,rt2800pc i
eeprom_93cx6 16384 1 rt2800pci

f@linux-8ld8:~> sudo /usr/sbin/iwlist scan
[sudo] password for root:
wlan0 Scan completed :
Cell 01 - Address: E8:ED:05:F3:39:70
Channel:11
Frequency:2.462 GHz (Channel 11)
Quality=39/70 Signal level=-71 dBm
Encryption keyn
ESSID:"Blia"
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
18 Mb/s; 36 Mb/s; 54 Mb/s
Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
Mode:Master
Extra:tsf=0000016243d3c531
Extra: Last beacon: 192ms ago
IE: Unknown: 0006416D656C6961
IE: Unknown: 010882848B961224486C
IE: Unknown: 03010B
IE: Unknown: 2A0104
IE: Unknown: 32040C183060
IE: Unknown: 2D1A6C0017FFFF000000000000000000000000000000000000 000000
IE: Unknown: 3D160B000500000000000000000000000000000000000000
IE: Unknown: 3E0100
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
IE: Unknown: DD180050F2020101800003A5000027A4000042435E0062322F 00
IE: Unknown: 0B05060018127A
IE: Unknown: 7F0101
IE: Unknown: DD07000C4303000000
IE: Unknown: 0706555320010B10

eth0 Interface doesn't support scanning.

lo Interface doesn't support scanning.


No se si me falten más comandos, pero mi impresión es que se puede deber a algo como lo que dicen en este foro:

https://www.adslayuda.com/foro/topic...-con-opensuse/

Pero entiendo que opensuse ya no incorpora ifconfig, route y otros comandos, así que no pude probar las soluciones que sugieren ahí.

Les agradecería mucho la ayuda para arreglar el problema y que todo vuelva a funcionar correctamente.

Saludos y muchas gracias!

Última edición por janopi; 13-abr-2018 a las 15:00
Responder Citando
  #2  
Antiguo 26-mar-2018, 03:37
bialera bialera está desconectado
Aforado
 
Fecha de Ingreso: 08-julio-2012
Versión: 12.3
Mensajes: 23
Agradecimientos: 0
Agradecido 10 Veces en 7 Mensajes
Poder de Credibilidad: 0
bialera está en el buen camino
Channel:11
Frequency:2.462 GHz (Channel 11)
Quality=39/70 Signal level=-71 dBm

En el momento en que se ejecutó el scan el nivel de señal no era bueno y ademas hay que tener en cuenta que la señal y el ruido fluctúan. A puro sentimiento trataría de tener por lo menos -65 dbm

Tambien hay que tener en cuenta la actividad que hay en un momento dado en el canal 11.
Responder Citando
  #3  
Antiguo 26-mar-2018, 10:10
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.892
Agradecimientos: 620
Agradecido 2.647 Veces en 1.794 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Bienvenido al foro @janopi, vemos que es tu 1er. mensaje en el foro. Estamos encantados de que te hayas dado de alta, como queremos ayudarte en tu desempeño en el foro tenemos unas normas del foro donde aprenderás cosas útiles como aportar datos, hacer preguntas, como buscar, etc... Es como una guía o navaja suiza para los novatos. Para evitarte futuros problemas en el foro fíjate lo que dice resaltado y en negrita la norma 5 sobre el objetivo primordial del foro y, sobre todo, la norma 7 de escribir claro y nítido para entendernos.

Por los comandos que reportas, aparentemente esta bien. La tarjeta detectada, cargado su driver y el firmware. Todo bien, salvo lo que dice bialera, una señal débil puede ser que tiene conflicto con otras señales en el mismo canal 11. Para saber eso, instala Wifi Analyzer en tu móvil con android y mira los canales, fijate en la 1ª imagen a la derecha del video.

Los comandos de abajo son muy útiles. Usa Quotes para separarlo http://www.forosuse.org/forosuse/misc.php?do=bbcode
/sbin/ifconfig
/usr/sbin/iwconfig'
/sbin/route -n
cat /etc/resolv.conf
host google.com
ping -c 4 172.217.16.238
/sbin/ethtool -i wlan0


Seguramente que cuando tengas conexión, las salidas de los comandos de arriba estaran correctos, pero cuando pierdas la señal, inmediatamente ejecuta el comando de abajo y reportarlo a foro, nos dará información de la caída.
dmesg | tail

Como eres nuevo, preséntate en la sección de Presentaciones y si tienes tiempo libre, acuérdate de leer las normas.
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

Última edición por DiabloRojo; 26-mar-2018 a las 10:19
Responder Citando
  #4  
Antiguo 26-mar-2018, 15:04
janopi janopi está desconectado
Aforado
 
Fecha de Ingreso: 25-marzo-2018
Versión: Tumbleweed
Mensajes: 16
Agradecimientos: 0
Agradecido 2 Veces en 2 Mensajes
Poder de Credibilidad: 0
janopi está en el buen camino
Estimados Bialera y Diablorojo. Parto por agradecerles su respuesta. Lo que dice Bialera es cierto. La señal es relativamente débil, pero no creo que sea la causa del problema porque nunca antes se comportó así ni con este notebook ni con otros equipos (otro notebook con Chakra, otro con MX y un PC con Pop os). Coincide mucho con el cambio de Leap a Tumbleweed.
Por lo que comenta Diablorojo, no habría problemas de software ni hardware. Voy a probar con Wifi Analyzer a ver qué pasa. Pero lo curioso es que ahora estoy monitoreando las señales de wifi y poniendo radios online y no ha habido fallos. No sé por qué será. Quizás una actualización que hice ayer. En fin. Seguiré monitoreando para ver si vuelve el fallo y les cuento. Si no, tendría que dar por cerrado el tema.
Respecto a las normas, las voy a revisar. Espero no haberme saltado ninguna, y si lo hice, fue sin querer queriendo
Muchas gracias, amigos, que sin estos espacios de ayuda todo sería más difícil.
Responder Citando
  #5  
Antiguo 27-mar-2018, 03:56
bialera bialera está desconectado
Aforado
 
Fecha de Ingreso: 08-julio-2012
Versión: 12.3
Mensajes: 23
Agradecimientos: 0
Agradecido 10 Veces en 7 Mensajes
Poder de Credibilidad: 0
bialera está en el buen camino
Una característica propia de la transmisión wireless es justamente la inestabilidad. Dependes de todo, incluso del comportamiento del vecindario.

Si el resto de los equipos tuvieran HW idéntico, niveles de señal (y ruido) idénticos, estuvieran muy cercanos entre si (geometría) y los estuvieras observando exactamente al mismo tiempo...

Por otra parte las diferencias de nivel entre los componentes de TW y Leap son pequeños y operan sobre un tema trillado. El nucleo?

Yo he observado black outs de señal dificiles de explicar, probablemente debidos a interferencias.

A la hora de probar, una idea sería arrancar "un algo" en modo live, pero hay que probar mucho y en condiciones diferentes. Vale la pena?

Un gran saludo a todos.
Responder Citando
  #6  
Antiguo 28-mar-2018, 16:11
janopi janopi está desconectado
Aforado
 
Fecha de Ingreso: 25-marzo-2018
Versión: Tumbleweed
Mensajes: 16
Agradecimientos: 0
Agradecido 2 Veces en 2 Mensajes
Poder de Credibilidad: 0
janopi está en el buen camino
Gracias Bilera. Es verdad. No vale la pena. Además que se arregló. Ya no se cae. Lo estuve monitoreando con radios on-line y la señal está constante. Me gustaría saber qué cambió en la configuración de los paquetes, etc., como para que sirviera a otros usuarios, pero la verdad no sé qué pasó. Lo tendré que dar por solucionado (?).
Muchas gracias por su ayuda!
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
El wifi deja de funcionar arbitrariamente después de un tiempo usándolo thirthree Internet, Redes y Wireless 5 15-ene-2016 20:40
Wifi se desconecta al cerrar tapa de notebook danielc Internet, Redes y Wireless 1 25-dic-2014 09:38
Wifi se desconecta Mercader24 Internet, Redes y Wireless 7 12-jul-2014 15:26
Wifi se Desconecta y relentiza Notebook suenatremendo Internet, Redes y Wireless 7 22-dic-2013 18:00
wifi se desconecta continuamente ale_82 Internet, Redes y Wireless 1 28-jun-2011 11:17



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 09:05.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba