Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona OpenSUSE > Instalación y Actualizaciones


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Inicio "traslado" a opensuse, alguna duda de cómo...
  #1  
Antiguo 06-nov-2017, 12:55
Wonder Wonder está desconectado
Aforado
 
Fecha de Ingreso: 07-agosto-2014
Versión: Leap 42.3
Mensajes: 95
Agradecimientos: 51
Agradecido 2 Veces en 2 Mensajes
Poder de Credibilidad: 4
Wonder está en el buen camino
Inicio "traslado" a opensuse, alguna duda de cómo...

Hola,
Antes de nada, disuclpas si no esta en el foro correspondiente, y el título, es poco "aclarador"...

El caso es que, me he planteado muy seriamente el cambio a opensuse, vengo de los derivados de debian (mint, maui, kde neon...) y bien, pero ya hacía tiempo, de hecho, hará algo más de un año hice un "intento" en el portátil y por distintas causas, se quedó en intento.

Ahora, con más tiempo, si quiero hacer el cambio, primero en el portátil y luego en el pc de trabajo.

Tras leer por el foro, google y demás, creo que la mayoría de dudas las tengo resueltas (o eso creo) pero hay alguna que no logro sacar...

Este finde, puse en portátil tumbleweed (por delante de leap) y creo que en portátil bien pero en pc...tengo driver nvidia y querré poner el privativo. Lo usaré al 100%? No lo creo, pero "necesito" ponerlo, aunque luego lo quite (ya se sabe, aquello de probar/romper/aprender...).

Por el momento en el portátil voy defendiéndome, añadí repositorio packman, pero he leído por ahí que luego hay que cambiar los paquetes a ese repositorio.
Esa es mi primera duda, no se que ni cómo... tras buscar no logré encontrar.
Por cierto, se me añadió con prioridad 99, igual que los demás, no se si es correcto.

No se si esta bien porque, hice búsqueda de dos programas que suelo usar, como audacity y openshot, del primero, me apareció la misma versión que antes de añadir este repositorio (y hace poco han sacado una nueva versión), y sobre el segundo, seguía sin aparecer.
Así que, o lo añadí mal, o no estan estos programas..

Las actualizaciones de kernel, son automáticas o hay algún modo gráfico para seleccionar el deseado?

De momento, depuro esas dudas y luego prosigo.

Gracias por adelantado.

Saludos!
__________________

Última edición por Wonder; 06-nov-2017 a las 12:58
Responder Citando
  #2  
Antiguo 06-nov-2017, 14:40
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.545
Agradecimientos: 566
Agradecido 2.446 Veces en 1.652 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Son muchas preguntas. Intentare responderte a la mayoría de ellas por el orden que lo planteas.

1.- Nvidia. Busca en el foro algun tema de Nvidia que haya respondido el compañero @Krovikan donde ha dejado una guía de pasos para instalarlo.

2.- Repositorios. Hay una guía mía de ellos (hay un apartado donde explica como pasar todos los paquetes a un repositorio en concreto) y un tema especial donde me das los repositorios y te digo si están bien o no. En principio, Packman siempre con prioridad 70 y el resto a 99, cuanto mas bajo es el numero mas prioridad tiene el repositorio.

3.- Aplicaciones. Audacity esta en el repo Packman y openshot esta en el repo multimedia:apps. Procura no añadir repositorios por el método de 1 Click Install.

4.- Kernel. las actualizaciones son automáticas, las puedes seleccionar en el Grub (opciones avanzadas) si la ultima version te da problemas.
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a DiabloRojo Por Este Mensaje:
Wonder (07-nov-2017)
  #3  
Antiguo 06-nov-2017, 17:27
Wonder Wonder está desconectado
Aforado
 
Fecha de Ingreso: 07-agosto-2014
Versión: Leap 42.3
Mensajes: 95
Agradecimientos: 51
Agradecido 2 Veces en 2 Mensajes
Poder de Credibilidad: 4
Wonder está en el buen camino
Cita:
Iniciado por DiabloRojo Ver Mensaje
Son muchas preguntas. Intentare responderte a la mayoría de ellas por el orden que lo planteas.
Gracias DiabloRojo por las indicaciones, y pensé que había posteado menos dudas...
Cita:
1.- Nvidia. Busca en el foro algun tema de Nvidia que haya respondido el compañero @Krovikan donde ha dejado una guía de pasos para instalarlo.
Ok, he visto incluso en la portada de este site (acabo de verlo), que hay una nueva opción para driver nvidia. No se si será mejor Leap en el pc con el tema del privativo de nvidia, pero creo que no, como comenté antes, probar/romper/aprender...

Cita:
2.- Repositorios. Hay una guía mía de ellos (hay un apartado donde explica como pasar todos los paquetes a un repositorio en concreto) y un tema especial donde me das los repositorios y te digo si están bien o no. En principio, Packman siempre con prioridad 70 y el resto a 99, cuanto mas bajo es el numero mas prioridad tiene el repositorio.
Me lo miro con calma y el apartado dónde explica como pasar todos los paquetes de un repositorio a otro, pero sobre esto, mi duda: Cual es el motivo de ello, que beneficio se tiene así? (por preguntarlo de algún modo) puedo aprender a hacer ese cambio, pero desconozco el "porque".

Cita:
3.- Aplicaciones. Audacity esta en el repo Packman y openshot esta en el repo multimedia:apps. Procura no añadir repositorios por el método de 1 Click Install.
Ok, gracias por el consejo, no añadir repositorios por método 1 Click Install.
De momento, solo he añadido 3, el de packman (el completo) uno de kde graphics (aún no he visto cosas nuevas o mejoras) y el que me indicas aquí de multimedia apps.
Audacity, el tema es que hace poco sacarón versión nueva y aún no esta dicha versión, supongo que es cuestión de esperar. Openshot, vi que tiene sus 2 versiones, pero la última, la que uso, la qt-openshot, ya me dió un error de dependencia, pero con eso, ya me pelearé más adelante.
Packman lo tengo en prioridad 70, pero este añadido, en que la que viene por defecto, la 99, no se si también debo bajarla...


Cita:
4.- Kernel. las actualizaciones son automáticas, las puedes seleccionar en el Grub (opciones avanzadas) si la ultima version te da problemas.
Ok, en ese caso es parecido a por defecto el sistema que uso en mi actual distro, son automáticas, pero también existe una opción, visual, dónde puedes elegir que otros kernels instalar / eliminar (por ejemplo, el nuevo 4.11, que aunque no es LTS da la opción para instalación).
Yo soy de los que solo dejo instaladas 2 versiones, la voy actualizando, pero dejo instaladas 2, la actual y otra anterior que sepa que me funcionó.
En este caso, aquí, se van añadiendo las versiones? Se pueden desinstalar las antiguas para liberar espacio por ejemplo?

De nuevo, gracias!!
__________________
Responder Citando
  #4  
Antiguo 06-nov-2017, 19:59
Avatar de Krovikan
Krovikan Krovikan está desconectado
Miembro Junior
 
Fecha de Ingreso: 16-noviembre-2010
Ubicación: Delante del ordenador
Versión: Leap 42.3
Mensajes: 476
Agradecimientos: 173
Agradecido 101 Veces en 86 Mensajes
Poder de Credibilidad: 8
Krovikan está en el buen camino
Te recomiendo este post que te enlazo para los drivers Nvidia:

http://www.forosuse.org/forosuse/sho...4&postcount=20

Packman se pone por defecto porque es donde está todo lo que no se puede meter en una distro por problemas de licencias y etc. Es el repo multimedia (aparte de otras cosas) por excelencia.

Por ejemplo, no es lo mismo el audacity que viene en la distro al audacity del repo Packman (igual para k3b, vlc, etc). Los de la distro están capados para hacer ciertas cosas (por eso de las licencias) y el de Packman, no.


Saludos
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a Krovikan Por Este Mensaje:
Wonder (07-nov-2017)
  #5  
Antiguo 07-nov-2017, 13:02
Wonder Wonder está desconectado
Aforado
 
Fecha de Ingreso: 07-agosto-2014
Versión: Leap 42.3
Mensajes: 95
Agradecimientos: 51
Agradecido 2 Veces en 2 Mensajes
Poder de Credibilidad: 4
Wonder está en el buen camino
Cita:
Iniciado por DiabloRojo Ver Mensaje
...
2.- Repositorios. Hay una guía mía de ellos (hay un apartado donde explica como pasar todos los paquetes a un repositorio en concreto) y un tema especial donde me das los repositorios y te digo si están bien o no. En principio, Packman siempre con prioridad 70 y el resto a 99, cuanto mas bajo es el numero mas prioridad tiene el repositorio.
Creo haberlo hecho, al no especificar "pasar paquetes a un repositorio" dudaba que punto era, de toda la guía que me indicas, al leerla, creo que es esta: Cómo actualizar los paquetes de un repositorio desde Yast
Si es esa, lo hice.
Al hacerlo vi que se pasaban los paquetes al nuevo repositorio, en este caso packman, pero me pareció ver que solo eran los instalados.
Ahora, mi duda, si a partir de ahora, busco un paquete que esta en repositorio oficial y el de packman, se instalará desde packman?
No me dió la impresión que todos los paquetes se cambiasen a packman, solo los que ya tengo instalados.


Cita:
Iniciado por Krovikan Ver Mensaje
Te recomiendo este post que te enlazo para los drivers Nvidia:

http://www.forosuse.org/forosuse/sho...4&postcount=20

Packman se pone por defecto porque es donde está todo lo que no se puede meter en una distro por problemas de licencias y etc. Es el repo multimedia (aparte de otras cosas) por excelencia.

Por ejemplo, no es lo mismo el audacity que viene en la distro al audacity del repo Packman (igual para k3b, vlc, etc). Los de la distro están capados para hacer ciertas cosas (por eso de las licencias) y el de Packman, no.


Saludos
Gracias Krovikan por la aclaración,
Con el ejemplo de audacity, resueltas dudas sobre ello.

Lo del driver nvidia, lo estoy dejando para lo último, solo tengo nvidia en el pc sobremesa, primero "pruebo" en el portátil, cuando cambie el pc tengo que tener el resto de dudas resueltas, en el pc, si que no puedo quedarme "sin sistema" que es el que uso como principal

Hice lo del repo esta mañana, desde ayer tarde hasta hoy, el portátil hizo extraños, llegué a pensar que quizás tendría que reinstalar.

Al abrir yast, cuando me pidió contraseña se quedó colgado casi un minuto, y luego se quedó literalmente bloqueado cuando fui a abrir instalar/desinstalar soft.

Tuve que reiniciar con botón de power, y a partir de ahí...una carpeta podia tardar 30 segundos en abrirse (tengo ssd, por lo que suele ir ligero) pero abrir menú o yast (si llegaba) se bloqueaba portátil.

En modo depuración, conseguía hacer algo más, pero se volvía a bloquear al acceder al menú o a yast si llegaba...

Esta mañana, primer encendido otra vez igual, luego, en el segundo bien, vi que no estaba correctamente configurado touchpad y ratón, reconfiguré.
Lleva toda la mañana ya bien... (espero fuese eso, no me había pasado nunca).

Gracias y un saludo!!
__________________
Responder Citando
  #6  
Antiguo 07-nov-2017, 16:39
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.545
Agradecimientos: 566
Agradecido 2.446 Veces en 1.652 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Cita:
Iniciado por Wonder Ver Mensaje
Cual es el motivo de ello, que beneficio se tiene así? (por preguntarlo de algún modo) puedo aprender a hacer ese cambio, pero desconozco el "porque".
...
Yo soy de los que solo dejo instaladas 2 versiones, la voy actualizando, pero dejo instaladas 2, la actual y otra anterior que sepa que me funcionó.
En este caso, aquí, se van añadiendo las versiones? Se pueden desinstalar las antiguas para liberar espacio por ejemplo?
1.- Tal como te cuenta @Krovikan, Packman es el repositorios fundamental y sus paquetes son mas prioritarios para instalar.
2.- Sobre los kernels, tendrás varias versiones instaladas, lo puedes mirar con el comando de abajo, cada vez que instales automaticamente una versión se ira eliminando la mas antigua.
zypper se -si kernel

Cita:
Iniciado por Wonder Ver Mensaje
Ahora, mi duda, si a partir de ahora, busco un paquete que esta en repositorio oficial y el de packman, se instalará desde packman?
No me dió la impresión que todos los paquetes se cambiasen a packman, solo los que ya tengo instalados.
Si, si tiene mas prioridad el de Packman.

Lee esto, en especial el pto. 13: Guía básica de openSUSE Leap para recién llegados a GNU/Linux.
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a DiabloRojo Por Este Mensaje:
Wonder (07-nov-2017)
  #7  
Antiguo 07-nov-2017, 19:37
Wonder Wonder está desconectado
Aforado
 
Fecha de Ingreso: 07-agosto-2014
Versión: Leap 42.3
Mensajes: 95
Agradecimientos: 51
Agradecido 2 Veces en 2 Mensajes
Poder de Credibilidad: 4
Wonder está en el buen camino
Cita:
Iniciado por DiabloRojo Ver Mensaje
1.- Tal como te cuenta @Krovikan, Packman es el repositorios fundamental y sus paquetes son mas prioritarios para instalar.
Si, tras leer su post, entendí ese aspecto, thanks to all!

Cita:
2.- Sobre los kernels, tendrás varias versiones instaladas, lo puedes mirar con el comando de abajo, cada vez que instales automaticamente una versión se ira eliminando la mas antigua.
zypper se -si kernel
Ok, perfect. Si cada vez que instale uno automáticamente una versión se ira eliminando la más antigua, es bueno eso.
Pero me gusta mirarlo y ver.
Aparecen en el listado de updates?

Miré la guía que, en especial, el punto 13 que es el tema códecs y repo packman, y justo este cambio, efectivamente, así lo hice (había visto anteriormente la guía tuya y había seguido esas mismas indicaciones), solventa mi duda de si hice el cambio de paquetes correctamente

De momento, voy tirando, me habéis aclarado muchísimo en este hilo, mis principales dudas.
Ahora a seguir en el portátil para luego cambiar el pc.

El driver nvidia, vi que es instalación manual, en uno de los anteriores distros también lo instalé en modo manual, pero esto no lo haré hasta que no ponga opensuse en el pc, que es dónde tengo nvidia, por ello, lo demás primero en portátil.

Gracias y un saludo!!!
__________________
Responder Citando
  #8  
Antiguo 08-nov-2017, 11:50
Avatar de DanielVE
DanielVE DanielVE está desconectado
Aforado
 
Fecha de Ingreso: 07-noviembre-2017
Versión: Última estable en hw legado.
Mensajes: 51
Agradecimientos: 3
Agradecido 12 Veces en 12 Mensajes
Poder de Credibilidad: 1
DanielVE está en el buen camino
Demasiadas preguntas para un solo tema y se fundamenta en que los lectores necesitamos repasar una y otra vez tu comentario para no olvidar nada.

Básicamente, hasta hace bien poco, si se requería utilizar controladores privativos, no se recomendaba Tumbleweed (TW) para usuarios no experimentados ya que existía un lapso de tiempo en la disponibilidad de nuevas versiones de estos controladores con cada iteración de TW, esto es, podías acabar en la situación de tener un sistema no arrancable gráficamente y con la necesidad de compilar tus propios drivers desde las fuentes.

Tienes más info aquí.

Esto parece haberse solucionado recientemente con la creación de un repo dedicado. Tienes un hilo en portada y creo que VictorHck tiene información detallada en su blog. En cualquier caso, si es una máquina de uso prioritario, manejaría este asunto con cautela; recuerda que Linux viene sin garantías.

Sobre los repos, si no me equivoco 99 es el valor por defecto para la prioridad de los repositorios y puedes modificarla a conveniencia para priorizar las instalaciones y actualizaciones de paquetes según su proveedor (repo); también puedes elegir el proveedor manualmente en el momento de la instalación de un paquete. Este aspecto es importante si no quieres sucumbir a lo que llamamos infierno de las dependencias y que suele o solía ser más pronunciado en distros basadas en RPM, aunque nadie te asegura la salvación en las basadas en DEB.

El problema del infierno de las dependencias se presenta principalmente al añadir multitud de repos, a veces incompatibles entre ellos, a veces ajenos a OpenSUSE y de dudosa seguridad, y de esta manera mezclar paquetería sin llevar una minuciosa gestión de los repos. En definitiva puedes acabar con un sistema inservible.

Las actualizaciones del núcleo Linux se instalan automáticamente y ya que no uso OpenSUSE regularmente desde hace tiempo, no puedo asegurar si se van purgando automáticamente los núcleos antiguos o hay que hacerlo manualmente, lo que es seguro es que siempre dispones de la versión anterior en caso de necesitarlo, ¡y de las fantásticas snapshots con Btrfs!

Saludos.

Ya que acabas de caer en OpenSUSE, te dejo esta lectura inicial recomendada aquí.

Última edición por DanielVE; 08-nov-2017 a las 12:07 Razón: Añado +info.
Responder Citando
  #9  
Antiguo 08-nov-2017, 13:48
Wonder Wonder está desconectado
Aforado
 
Fecha de Ingreso: 07-agosto-2014
Versión: Leap 42.3
Mensajes: 95
Agradecimientos: 51
Agradecido 2 Veces en 2 Mensajes
Poder de Credibilidad: 4
Wonder está en el buen camino
Cita:
Iniciado por DanielVE Ver Mensaje
Demasiadas preguntas para un solo tema y se fundamenta en que los lectores necesitamos repasar una y otra vez tu comentario para no olvidar nada.
Tienes razón, aunque de inicio, pensé que era "leve"...

Cita:
Básicamente, hasta hace bien poco, si se requería utilizar controladores privativos, no se recomendaba Tumbleweed (TW) para usuarios no experimentados ya que existía un lapso de tiempo en la disponibilidad de nuevas versiones de estos controladores con cada iteración de TW, esto es, podías acabar en la situación de tener un sistema no arrancable gráficamente y con la necesidad de compilar tus propios drivers desde las fuentes.

Tienes más info aquí.

Esto parece haberse solucionado recientemente con la creación de un repo dedicado. Tienes un hilo en portada y creo que VictorHck tiene información detallada en su blog. En cualquier caso, si es una máquina de uso prioritario, manejaría este asunto con cautela; recuerda que Linux viene sin garantías.
Gracias por el hilo.
Me va quedando claro que, con TW la cosa era más complicadilla, aunque últimamente mejoró. He visto tanto la opción de instalación manual, o a través de repo, como el que indicas.

Cita:
Sobre los repos, si no me equivoco 99 es el valor por defecto para la prioridad de los repositorios y puedes modificarla a conveniencia para priorizar las instalaciones y actualizaciones de paquetes según su proveedor (repo); también puedes elegir el proveedor manualmente en el momento de la instalación de un paquete. Este aspecto es importante si no quieres sucumbir a lo que llamamos infierno de las dependencias y que suele o solía ser más pronunciado en distros basadas en RPM, aunque nadie te asegura la salvación en las basadas en DEB.
OK
Si, el 99 por defecto, bajar a 70 lo hice con packman.
Ayyy, se el "infierno de dependencias" que nombras, me sucedió alguna vez en deb, pero de eso hace mucho...

Cita:
El problema del infierno de las dependencias se presenta principalmente al añadir multitud de repos, a veces incompatibles entre ellos, a veces ajenos a OpenSUSE y de dudosa seguridad, y de esta manera mezclar paquetería sin llevar una minuciosa gestión de los repos. En definitiva puedes acabar con un sistema inservible.
Gracias

Cita:
Las actualizaciones del núcleo Linux se instalan automáticamente y ya que no uso OpenSUSE regularmente desde hace tiempo, no puedo asegurar si se van purgando automáticamente los núcleos antiguos o hay que hacerlo manualmente, lo que es seguro es que siempre dispones de la versión anterior en caso de necesitarlo, ¡y de las fantásticas snapshots con Btrfs!
Si se purgan automáticamente bien, si se debe hacer a mano, no problem.
Y los snapshots son nuevos para mi en Btrfs, eso es un campo nuevo para mi, pero mejor, en otro hilo

Cita:
Ya que acabas de caer en OpenSUSE, te dejo esta lectura inicial recomendada aquí.
Lo miro

Grcias y un saludo!!
__________________
Responder Citando
  #10  
Antiguo 13-nov-2017, 13:26
Avatar de DanielVE
DanielVE DanielVE está desconectado
Aforado
 
Fecha de Ingreso: 07-noviembre-2017
Versión: Última estable en hw legado.
Mensajes: 51
Agradecimientos: 3
Agradecido 12 Veces en 12 Mensajes
Poder de Credibilidad: 1
DanielVE está en el buen camino
Thumbs up

FYI. Acabo encontrarme con esto:

Cita:
purge-kernels.service - Purge old kernels
Loaded: loaded (/usr/lib/systemd/system/purge-kernels.service; enabled; vendor preset: enabled)
Active: inactive (dead)
Condition: start condition failed at Mon 2017-11-13 09:10:14 CET; 3h 11min ago
ConditionPathExists=/boot/do_purge_kernels was not met
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a DanielVE Por Este Mensaje:
Wonder (13-nov-2017)
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
openSUSE 11.2 con Samba Guia Ilustrada easgs FAQs, Manuales y Tutoriales 24 29-ene-2015 16:32
Tumbleweed repos... goro Instalación y Actualizaciones 11 03-ene-2014 16:55
Como conseguir instalar opensuse 12.3 en un equipo con windows 8 y tener dual boot oscarpoio FAQs, Manuales y Tutoriales 13 14-dic-2013 12:50
Intalando agente NRPE en suseserver 10 64bits prubilar Seguridad y Servidores 4 27-abr-2012 19:40
Después de instalar suse 11.2 no funciona red local amungar Internet, Redes y Wireless 15 21-nov-2009 09:52



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 00:13.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba