Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > Software


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Problema en glxgears con Bumblebee/Nvidia
  #1  
Antiguo 18-sep-2017, 21:05
J_VM J_VM está desconectado
Habitual
 
Fecha de Ingreso: 22-septiembre-2013
Versión: Tumbleweed
Mensajes: 222
Agradecimientos: 32
Agradecido 19 Veces en 17 Mensajes
Poder de Credibilidad: 5
J_VM está en el buen camino
Problema en glxgears con Bumblebee/Nvidia

Hola a todos, hace tiempo que me pasa esto, a ver si me podéis decir qué pasa. Tengo opensuse 42.2 con tarjeta intel/Nvidia, así que uso bumblebee para cambiar de una a otra. Probando glxgears

Código:
> optirun glxgears
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  154 (GLX)
  Minor opcode of failed request:  24 (X_GLXCreateNewContext)
  Value in failed request:  0x0
  Serial number of failed request:  22
  Current serial number in output stream:  23
Y no llega a ejecutarse, se cierra. Esto me pasa con todas las glx**** (gears, spheres, info). En cambio si lanzo cualquier programa, por ejemplo okular, va bien.

Saludos!!

Have a lot of fun!!
Responder Citando
  #2  
Antiguo 18-sep-2017, 21:54
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.586
Agradecimientos: 569
Agradecido 2.475 Veces en 1.673 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
¿Tienes aceleración 3D?, ejecuta el comando de abajo, como ves en la salida dice que si:

Cita:
glxinfo | grep "direct rendering"
direct rendering: Yes
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
  #3  
Antiguo 19-sep-2017, 09:47
J_VM J_VM está desconectado
Habitual
 
Fecha de Ingreso: 22-septiembre-2013
Versión: Tumbleweed
Mensajes: 222
Agradecimientos: 32
Agradecido 19 Veces en 17 Mensajes
Poder de Credibilidad: 5
J_VM está en el buen camino


Código:
> glxinfo | grep "direct rendering"
direct rendering: Yes
EDIT:
Me acabo de dar cuenta que parece un problema de permisos. Con

Código:
kdesu optriun glxgears
Sí que funciona.

glxspheres da un error pero se ejecuta bien igualmente

Código:
> kdesu optirun glxspheres
QXcbConnection: XCB error: 3 (BadWindow), sequence: 583, resource id: 31457432, major code: 40 (TranslateCoords), minor code: 0

glxinfo solo da esto:
Código:
> kdesu optirun glxinfo
QXcbConnection: XCB error: 3 (BadWindow), sequence: 587, resource id: 31457439, major code: 40 (TranslateCoords), minor code: 0

Por lo que veo en internet estos errores anteriores son por estar ejecutando con permisos de root...

Última edición por J_VM; 19-sep-2017 a las 10:05 Razón: Más información
Responder Citando
  #4  
Antiguo 19-sep-2017, 10:33
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.586
Agradecimientos: 569
Agradecido 2.475 Veces en 1.673 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
optriun esta asociado a las tarjetas Nvidia. Parece que has dado con el comando correcto.
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
  #5  
Antiguo 19-sep-2017, 13:09
J_VM J_VM está desconectado
Habitual
 
Fecha de Ingreso: 22-septiembre-2013
Versión: Tumbleweed
Mensajes: 222
Agradecimientos: 32
Agradecido 19 Veces en 17 Mensajes
Poder de Credibilidad: 5
J_VM está en el buen camino
pero deberia funcionar sin root (sin kdesu). De hecho glxinfo no va bien de ninguna de las dos maneras...

EDITO: solucionado! Resulta que no me había añadido al grupo video

sudo usermod -aG video username

Creo que eso debería añadirse en el tutorial de aquí . En una versión anterior creo que sí que estaba.

Have a lot of fun!

Última edición por J_VM; 20-sep-2017 a las 09:53
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
ntfs, problema accediendo a directorio NestorAcevedo Hardware 1 23-jul-2010 19:00
Problema con Video Intel 82845G sescalad Hardware 4 23-jul-2010 17:51
problema con Driver ATI head777 Software 13 02-sep-2007 18:07
Problema al acceder a carpeta con kde aleromar Escritorios: KDE, Gnome, otros... 5 09-mar-2007 01:27
Problema con audio Clufis Multimedia 4 19-sep-2005 13:18



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 20:41.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba