Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > Multimedia


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

[Solucionado] Openshot no se abre
  #1  
Antiguo 16-nov-2017, 01:49
Wonder Wonder está desconectado
Habitual
 
Fecha de Ingreso: 07-agosto-2014
Versión: Leap 42.3
Mensajes: 149
Agradecimientos: 87
Agradecido 5 Veces en 5 Mensajes
Poder de Credibilidad: 4
Wonder está en el buen camino
[Solucionado] Openshot no se abre

Hola.

Si esta cuestión debiese ir a foro openshot, sorrys, pero no se si el error es por aplicación o sistema...

Hace poco instalé openshot-qt, a través de repositorio multimedia:
https://download.opensuse.org/reposi...timedia:/apps/

Cierto es que, al ir a instalarlo me pidió, primero python3-openshot y luego libopenshot13, ya que sino, no se podía instalar el paquete openshot.

Una vez instalado todo, tiro a arrancar y cuando clicko, sale abajo en el panel como la ventana de openshot que va a iniciarse, pero poquitos segundos después desaparece y no inicia.
Eliminé la carpeta que crea de config.

A través de konsola, esto es lo que obtengo:
Código:
wonder@localhost:~> openshot-qt
Loaded modules from installed directory: /usr/lib/python3.6/site-packages/openshot_qt
      launch:INFO ------------------------------------------------
      launch:INFO    OpenShot (version 2.4.0)
      launch:INFO ------------------------------------------------
         app:INFO openshot-qt version: 2.4.0
         app:INFO libopenshot version: 0.1.8
         app:INFO platform: Linux-4.13.12-1-default-x86_64-with-glibc2.3.4
         app:INFO processor: x86_64
         app:INFO machine: x86_64
         app:INFO python version: 3.6.3
         app:INFO qt5 version: 5.9.2
         app:INFO pyqt5 version: 5.9
      logger:ERROR Traceback (most recent call last):
      logger:ERROR   File "/usr/bin/openshot-qt", line 11, in <module>
      logger:ERROR load_entry_point('openshot-qt==2.4.0', 'gui_scripts', 'openshot-qt')()
      logger:ERROR   File "/usr/lib/python3.6/site-packages/openshot_qt/launch.py", line 69, in main
      logger:ERROR app = OpenShotApp(sys.argv)
      logger:ERROR   File "/usr/lib/python3.6/site-packages/openshot_qt/classes/app.py", line 91, in __init__
      logger:ERROR from classes import exceptions
      logger:ERROR   File "/usr/lib/python3.6/site-packages/openshot_qt/classes/exceptions.py", line 30, in <module>
      logger:ERROR from classes.metrics import track_exception_stacktrace
      logger:ERROR   File "/usr/lib/python3.6/site-packages/openshot_qt/classes/metrics.py", line 30, in <module>
      logger:ERROR import requests
      logger:ERROR ModuleNotFoundError
      logger:ERROR :
      logger:ERROR No module named 'requests'
No se muy bien por dónde viene el fallo...

Saludos!
__________________

Última edición por Wonder; 16-nov-2017 a las 13:00
Responder Citando
  #2  
Antiguo 16-nov-2017, 09:19
Avatar de DanielVE
DanielVE DanielVE está desconectado
Aforado
 
Fecha de Ingreso: 07-noviembre-2017
Versión: Última estable en hw legado.
Mensajes: 57
Agradecimientos: 3
Agradecido 13 Veces en 13 Mensajes
Poder de Credibilidad: 1
DanielVE está en el buen camino
Es un problema en el guión de Python, si estás usando TW es normal que se rompan cosas de una semana para otra y se arreglen del mismo modo, ni siquiera OpenQA es perfecto. Si es importante, abriría un bug en Bugzilla.
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a DanielVE Por Este Mensaje:
Wonder (16-nov-2017)
  #3  
Antiguo 16-nov-2017, 10:17
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.586
Agradecimientos: 569
Agradecido 2.475 Veces en 1.673 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Cita:
Iniciado por Wonder Ver Mensaje
logger:ERROR import requests
logger:ERROR ModuleNotFoundError
logger:ERROR :
logger:ERROR No module named 'requests'
Los mensajes de error son muy claros, necesitas instalar el modulo requests del Python, que es un lenguaje de programación muy dependiente de las librerías de desarrollo.
Si usas Python 2.x es el paquete python-requests, si utilizas Python 3.x es el paquete python3-requests.

Saludos.
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a DiabloRojo Por Este Mensaje:
Wonder (16-nov-2017)
  #4  
Antiguo 16-nov-2017, 11:12
Avatar de DanielVE
DanielVE DanielVE está desconectado
Aforado
 
Fecha de Ingreso: 07-noviembre-2017
Versión: Última estable en hw legado.
Mensajes: 57
Agradecimientos: 3
Agradecido 13 Veces en 13 Mensajes
Poder de Credibilidad: 1
DanielVE está en el buen camino
Cita:
Iniciado por DiabloRojo Ver Mensaje
Los mensajes de error son muy claros, necesitas instalar el modulo requests del Python, que es un lenguaje de programación muy dependiente de las librerías de desarrollo.
Si usas Python 2.x es el paquete python-requests, si utilizas Python 3.x es el paquete python3-requests.

Saludos.
DiabloRojo tiene toda la razón.

Claro, la pregunta es, porqué OpenShot no lo requiere como dependencia ya que actualmente, en una instalación por defecto el paquete sólo es proporcionado por system-config-printer. Alguien debería lanzar un informe de fallo, pienso.
Responder Citando
  #5  
Antiguo 16-nov-2017, 11:30
Wonder Wonder está desconectado
Habitual
 
Fecha de Ingreso: 07-agosto-2014
Versión: Leap 42.3
Mensajes: 149
Agradecimientos: 87
Agradecido 5 Veces en 5 Mensajes
Poder de Credibilidad: 4
Wonder está en el buen camino
Cita:
Iniciado por DanielVE Ver Mensaje
Es un problema en el guión de Python, si estás usando TW es normal que se rompan cosas de una semana para otra y se arreglen del mismo modo, ni siquiera OpenQA es perfecto. Si es importante, abriría un bug en Bugzilla.
Intuía era relacionado con Python, pero no llego a ver o saber exactamente qué...
Efectivamente estoy usando TW, lo instalé hace unos días para hacer la migración de mi actual sistema a suse, lo instalé en portátil primero para luego migrar sobremesa, que es con el que trabajo más.
Me estoy dando cuenta de ello, TW no cesa de actualizar prácticamente cada día muchos muchos paquetes. Me gusta tener KDE actualizado, pero el resto de cosas empezaba a pensar lo que comentas, hoy funciona, mañana quizás no, pasado seguramente si...
Así que estoy planteándome cambiar a Leap, pero eso seria otro hilo...

Cita:
Iniciado por DiabloRojo Ver Mensaje
Los mensajes de error son muy claros, necesitas instalar el modulo requests del Python, que es un lenguaje de programación muy dependiente de las librerías de desarrollo.
Si usas Python 2.x es el paquete python-requests, si utilizas Python 3.x es el paquete python3-requests.

Saludos.
Gracias Diablo,
Como comentaba, veía que era algo de python pero no se sacar el qué exactamente, que paquete requería, lo leí varias veces pero nada...
He instalado el que mencionas (uso python3) y perfecto, solucionado, gracias!!!

Cita:
Iniciado por DanielVE Ver Mensaje
DiabloRojo tiene toda la razón.

Claro, la pregunta es, porqué OpenShot no lo requiere como dependencia ya que actualmente, en una instalación por defecto el paquete sólo es proporcionado por system-config-printer. Alguien debería lanzar un informe de fallo, pienso.
Correcto, en ningún momento me saltó como dependencia, así como los otros dos paquetes mencionados anteriormente si me los indicó al ir a instalar, este no lo indicó para nada.
Miraré de lanzar el informe de fallo.

Gracias y saludos!
__________________
Responder Citando
  #6  
Antiguo 16-nov-2017, 14:57
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.586
Agradecimientos: 569
Agradecido 2.475 Veces en 1.673 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Cita:
Iniciado por DanielVE Ver Mensaje
Claro, la pregunta es, porqué OpenShot no lo requiere como dependencia ya que actualmente, en una instalación por defecto el paquete sólo es proporcionado por system-config-printer. Alguien debería lanzar un informe de fallo, pienso.
Cita:
Iniciado por Wonder Ver Mensaje
Correcto, en ningún momento me saltó como dependencia, así como los otros dos paquetes mencionados anteriormente si me los indicó al ir a instalar, este no lo indicó para nada.
Miraré de lanzar el informe de fallo.
Si, hay que informar del fallo, de que el creador del paquete openshot debe añadir esa dependencia, pero por otro lado entiendo que pase el problema.
Python es muy pijotero, el core (núcleo) viene pelado de librerías, las librerías esenciales solo trabaja en un aspecto y hay librerías que tiene que incluir otras librerías para que funcionen. Las aplicaciones tienen que incluir muchísimas librerías y encima las librerías cambia de funcionalidad en cada version. Vamos un lió, a mi me ha pasado esto que cuento con las aplicaciones que usan Python.
Conociendo ese problema, es muy fácil solucionarlo ya que cuando falta un modulo de una librería, la aplicación informa de ello.
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a DiabloRojo Por Este Mensaje:
Wonder (16-nov-2017)
  #7  
Antiguo 16-nov-2017, 15:11
Wonder Wonder está desconectado
Habitual
 
Fecha de Ingreso: 07-agosto-2014
Versión: Leap 42.3
Mensajes: 149
Agradecimientos: 87
Agradecido 5 Veces en 5 Mensajes
Poder de Credibilidad: 4
Wonder está en el buen camino
Gracias por la aclaración Diablo,
Voy a intentar informar del fallo, pero no entendía porque, unas dependencias si me las solicitó, y esta en cambio no (de hecho no sabía que estaba faltando un paquete como dependencia).

Lo dicho, gracias.
__________________
Responder Citando
  #8  
Antiguo 27-nov-2017, 15:23
Wonder Wonder está desconectado
Habitual
 
Fecha de Ingreso: 07-agosto-2014
Versión: Leap 42.3
Mensajes: 149
Agradecimientos: 87
Agradecido 5 Veces en 5 Mensajes
Poder de Credibilidad: 4
Wonder está en el buen camino
Tan solo añadir que, iba a informar del fallo, pero como en el sobremesa instalé Leap (y no se si es por ese motivo) no me ha cantado nada, ni durante la instalación, ni a la hora de abrir el programa. Fue todo perfecto sin "cantarme" nada...

No obstante, como sucedió en TW, sería bueno informar indicando que fue en TW...

Saludos!
__________________
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Thunderbird no abre enlaces http... susemex Software 1 11-nov-2014 09:45
problemas con openshot ZackM77 Software 3 13-feb-2012 12:24
Programa no abre. Jose Quesada Software 1 23-feb-2011 18:19
Instalar OpenShot (Editor de video) hurior Software 4 26-nov-2009 23:47
la barra de lugares no abre los acceso con nautilus dahool Escritorios: KDE, Gnome, otros... 1 09-jul-2008 19:56



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 13:56.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba