Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona OpenSUSE > Instalación y Actualizaciones


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

[REINSTALACIÓN] No puedo instalar desde el Menú Install/Remove software ni desde YaST
  #1  
Antiguo 25-jul-2017, 12:32
Xnake Xnake está desconectado
Aforado
 
Fecha de Ingreso: 12-septiembre-2014
Versión: Tumbleweed x86_64
Mensajes: 24
Agradecimientos: 15
Agradecido 4 Veces en 4 Mensajes
Poder de Credibilidad: 0
Xnake está en el buen camino
Red face [REINSTALACIÓN] No puedo instalar desde el Menú Install/Remove software ni desde YaST

Ayer comprobé e instalé 209 actualizaciones que tenía en openSUSE Tumbleweed x86_64, y todo fue bien hasta que al llegar al final de la instalación dio un error de fallo de dependencia de un paquete y esas actualizaciones seguían apareciendo como pendientes.

Como no me eliminaba esas actualizaciones ni encontraba a qué paquete le fallaban las dependencias, hice un pkcon repair (que me dio un error que no recuerdo) y posteriormente zypper dup, que me instaló 8 actualizaciones (creo recordar), entre las que se encontraba el kernel, sin problemas.

Reinicié y arrancó sin problemas ni actualizaciones pendientes. Mi problema surge cuando quise instalar un lector RSS diferente a Akregator porque se cae hace tiempo y aún no hay solución, para lo que voy a "Install/Remove Software" en Favoritos, me pide la contraseña de root y no pasa nada. Lo mismo si lo lanzo desde YaST o uso YaST 1-Click Install.

Hoy monitoricé los logs al realizar esa operación y veo que el servicio snapper da un error de directorio no encontrado:

2017-07-25 12:13:23 MIL libsnapper(12619) snapperd.cc(main):275 - Requesting DBus name
2017-07-25 12:13:23 MIL libsnapper(12619) snapperd.cc(main):279 - Loading snapper configs
2017-07-25 12:13:23 MIL libsnapper(12619) Snapper.cc(getConfigs):269 - Snapper get-configs
2017-07-25 12:13:23 MIL libsnapper(12619) Snapper.cc(getConfigs):270 - libsnapper version 0.5.0
2017-07-25 12:13:23 MIL libsnapper(12619) AsciiFile.cc(reload):114 - loading file /etc/sysconfig/snapper
2017-07-25 12:13:23 MIL libsnapper(12619) AsciiFile.cc(getValue):235 - key:SNAPPER_CONFIGS value:root
2017-07-25 12:13:23 MIL libsnapper(12619) AsciiFile.cc(reload):114 - loading file /etc/snapper/configs/root
2017-07-25 12:13:23 MIL libsnapper(12619) AsciiFile.cc(getValue):235 - key:SUBVOLUME value:/
2017-07-25 12:13:23 MIL libsnapper(12619) AsciiFile.cc(getValue):235 - key:ALLOW_USERS value:
2017-07-25 12:13:23 MIL libsnapper(12619) AsciiFile.cc(getValue):235 - key:ALLOW_GROUPS value:
2017-07-25 12:13:23 MIL libsnapper(12619) snapperd.cc(main):283 - Listening for method calls and signals
2017-07-25 12:13:23 MIL libsnapper(12619) Snapper.cc(Snapper):91 - Snapper constructor
2017-07-25 12:13:23 MIL libsnapper(12619) Snapper.cc(Snapper):92 - libsnapper version 0.5.0
2017-07-25 12:13:23 MIL libsnapper(12619) Snapper.cc(Snapper):93 - config_name:root disable_filters:false
2017-07-25 12:13:23 MIL libsnapper(12619) AsciiFile.cc(reload):114 - loading file /etc/snapper/configs/root
2017-07-25 12:13:23 MIL libsnapper(12619) AsciiFile.cc(getValue):235 - key:SUBVOLUME value:/
2017-07-25 12:13:23 MIL libsnapper(12619) AsciiFile.cc(getValue):235 - key:FSTYPE value:btrfs
2017-07-25 12:13:23 MIL libsnapper(12619) AsciiFile.cc(getValue):235 - key:QGROUP value:1/0
2017-07-25 12:13:23 MIL libsnapper(12619) AsciiFile.cc(getValue):235 - key:SYNC_ACL value:no
2017-07-25 12:13:23 MIL libsnapper(12619) Snapper.cc(Snapper):125 - subvolume:/ filesystem:btrfs
2017-07-25 12:13:23 MIL libsnapper(12619) Snapper.cc(loadIgnorePatterns):174 - number of ignore patterns:8
2017-07-25 12:13:23 MIL libsnapper(12619) Snapshot.cc(read):245 - found 44 snapshots
2017-07-25 12:13:23 WAR libsnapper(12619) FileUtils.cc(SDir):88 - THROW: open failed path://.snapshots errno:2 (No such file or directory)
2017-07-25 12:13:23 MIL libsnapper(12619) SystemCmd.cc(SystemCmd):46 - constructor SystemCmd:"/usr/lib/snapper/plugins/grub --refresh"
2017-07-25 12:13:23 MIL libsnapper(12619) SystemCmd.cc(execute):82 - SystemCmd Executing:"/usr/lib/snapper/plugins/grub --refresh"
2017-07-25 12:13:25 MIL libsnapper(12619) SystemCmd.cc(doExecute):267 - stopwatch 1.614464s for "/usr/lib/snapper/plugins/grub --refresh"
2017-07-25 12:13:25 MIL libsnapper(12619) SystemCmd.cc(doExecute):287 - system() Returns:0
2017-07-25 12:13:25 WAR libsnapper(12619) FileUtils.cc(SDir):88 - THROW: open failed path://.snapshots errno:2 (No such file or directory)
2017-07-25 12:13:25 MIL libsnapper(12619) SystemCmd.cc(SystemCmd):46 - constructor SystemCmd:"/usr/lib/snapper/plugins/grub --refresh"
2017-07-25 12:13:25 MIL libsnapper(12619) SystemCmd.cc(execute):82 - SystemCmd Executing:"/usr/lib/snapper/plugins/grub --refresh"
2017-07-25 12:13:27 MIL libsnapper(12619) SystemCmd.cc(doExecute):267 - stopwatch 1.569445s for "/usr/lib/snapper/plugins/grub --refresh"
2017-07-25 12:13:27 MIL libsnapper(12619) SystemCmd.cc(doExecute):287 - system() Returns:0
2017-07-25 12:13:27 MIL libsnapper(12619) AsciiFile.cc(getValue):235 - key:BACKGROUND_COMPARISON value:yes
2017-07-25 12:13:27 MIL libsnapper(12619) Comparison.cc(Comparison):57 - num1:328 num2:329
2017-07-25 12:13:27 MIL libsnapper(12619) Comparison.cc(load):163 - num1:328 num2:329
2017-07-25 12:13:27 MIL libsnapper(12619) Comparison.cc(create):138 - num1:328 num2:329
2017-07-25 12:13:27 MIL libsnapper(12619) Btrfs.cc(cmpDirs):1385 - special btrfs cmpDirs
2017-07-25 12:13:27 MIL libsnapper(12619) Btrfs.cc(process):1356 - dir1:'//.snapshots/328/snapshot' dir2:'//.snapshots/329/snapshot'
2017-07-25 12:13:27 MIL libsnapper(12619) Btrfs.cc(cmpDirs):1397 - stopwatch 0.000344s for comparing directories
2017-07-25 12:13:27 MIL libsnapper(12619) Comparison.cc(create):156 - found 0 lines
2017-07-25 12:13:27 MIL libsnapper(12619) Comparison.cc(save):221 - num1:328 num2:329
2017-07-25 12:13:57 MIL libsnapper(12619) Snapper.cc(~Snapper):136 - Snapper destructor
2017-07-25 12:14:27 MIL libsnapper(12619) snapperd.cc(main):287 - Exiting


La instalación desde línea de comandos con zypper install me dio un error de "Failed to cache rpm database (1)", pero tras un rpm --rebuilddb funciona sin problemas.

Supongo que el problema es del servicio Snapper y/o btrfs.

¿Alguna idea de qué probar/mirar?

Última edición por Xnake; 26-jul-2017 a las 16:59 Razón: Cambio del título
Responder Citando
  #2  
Antiguo 25-jul-2017, 13:26
J_VM J_VM está desconectado
Habitual
 
Fecha de Ingreso: 22-septiembre-2013
Versión: Tumbleweed
Mensajes: 222
Agradecimientos: 32
Agradecido 19 Veces en 17 Mensajes
Poder de Credibilidad: 5
J_VM está en el buen camino
Comprueba si tienes el disco lleno, a ver si va a ser eso. Lo puedes hacer con
Código:
df -h
Responder Citando
  #3  
Antiguo 25-jul-2017, 16:18
Xnake Xnake está desconectado
Aforado
 
Fecha de Ingreso: 12-septiembre-2014
Versión: Tumbleweed x86_64
Mensajes: 24
Agradecimientos: 15
Agradecido 4 Veces en 4 Mensajes
Poder de Credibilidad: 0
Xnake está en el buen camino
Gracias por la respuesta. Tengo espacio libre de sobra en / (12GB).

Comparé el /etc/sysconfig/snapper de un portátil con Tumbleweed que me deja instalar sin problemas:

## Path: System/Snapper
## Type: string
## Default: ""
# List of snapper configurations.
SNAPPER_CONFIGS=""


con el que tengo en el PC:

## Path: System/Snapper
## Type: string
## Default: ""
# List of snapper configurations.
SNAPPER_CONFIGS="root"


Edité el del PC y le quité el parámetro root para dejarlo como el otro y renombré /etc/snapper/configs/root a /etc/snapper/configs/root.MAL. Reinicié el PC y sigue igual. Ahora el /var/log/snapper.log, al lanzar Install/Remove Sofware aparece lo mismo que en el portátil:

2017-07-25 16:06:37 MIL libsnapper(2790) snapperd.cc(main):275 - Requesting DBus name
2017-07-25 16:06:37 MIL libsnapper(2790) snapperd.cc(main):279 - Loading snapper configs
2017-07-25 16:06:37 MIL libsnapper(2790) Snapper.cc(getConfigs):269 - Snapper get-configs
2017-07-25 16:06:37 MIL libsnapper(2790) Snapper.cc(getConfigs):270 - libsnapper version 0.5.0
2017-07-25 16:06:37 MIL libsnapper(2790) AsciiFile.cc(reload):114 - loading file /etc/sysconfig/snapper
2017-07-25 16:06:37 MIL libsnapper(2790) AsciiFile.cc(getValue):235 - key:SNAPPER_CONFIGS value:
2017-07-25 16:06:37 MIL libsnapper(2790) snapperd.cc(main):283 - Listening for method calls and signals
2017-07-25 16:06:37 WAR libsnapper(2790) Client.cc(dispatch):1550 - CAUGHT: unknown config
2017-07-25 16:06:37 WAR libsnapper(2790) Client.cc(dispatch):1550 - CAUGHT: unknown config
2017-07-25 16:07:37 MIL libsnapper(2790) snapperd.cc(main):287 - Exiting


Pero no va.

Comprobé que ambos accesos directos lanzan el mismo comando.

Última edición por Xnake; 25-jul-2017 a las 16:22 Razón: Añadir información
Responder Citando
  #4  
Antiguo 25-jul-2017, 17:03
Xnake Xnake está desconectado
Aforado
 
Fecha de Ingreso: 12-septiembre-2014
Versión: Tumbleweed x86_64
Mensajes: 24
Agradecimientos: 15
Agradecido 4 Veces en 4 Mensajes
Poder de Credibilidad: 0
Xnake está en el buen camino
Tras instalar 97 actualizaciones pendientes y reiniciar el PC, el problema es más grave de lo que pensaba: Puedo lanzar YaST, pero al intentar lanzar cualquier acceso directo dentro del YaST, no arranca, y en /var/log/snapper.log aparece una línea WAR libsnapper(2790) Client.cc(dispatch):1550 - CAUGHT: unknown config por cada elemento de YaST que intento arrancar.
Responder Citando
  #5  
Antiguo 25-jul-2017, 17:07
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.480
Agradecimientos: 563
Agradecido 2.416 Veces en 1.627 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Prueba un script para limpiar snapshots, lo tienes en este mensaje: http://www.forosuse.org/forosuse/sho...3&postcount=19

Por cierto, no escribas mensajes consecutivos en un corto periodo de tiempo porque no facilitas la lectura.
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a DiabloRojo Por Este Mensaje:
Xnake (26-jul-2017)
  #6  
Antiguo 26-jul-2017, 10:57
Xnake Xnake está desconectado
Aforado
 
Fecha de Ingreso: 12-septiembre-2014
Versión: Tumbleweed x86_64
Mensajes: 24
Agradecimientos: 15
Agradecido 4 Veces en 4 Mensajes
Poder de Credibilidad: 0
Xnake está en el buen camino
Cita:
Iniciado por DiabloRojo Ver Mensaje
Prueba un script para limpiar snapshots, lo tienes en este mensaje: http://www.forosuse.org/forosuse/sho...3&postcount=19
Tras lanzar /etc/cron.weekly/btrfs-balance y no haber nuevas líneas que indicasen actividad en /var/log/snapper.log tras más de cuatro horas y media, maté los procesos asociados a /etc/cron.weekly/btrfs-balance (procesos hijos primero y procesos padre después).

Probé a borrar los snapshots con snapper delete 1-400 (el último tenía nº 345) y me dio error. Ejecuté snapper delete 200-345 y borró dichos snapshots. El snapshot 1 no me lo dejó borrar (y alguno más que no recuerdo).

Parece que btrfs y yo no nos queremos ("no eres tú, soy yo" ), y al reniciar el PC me volvió a dar errores de los subvolúmenes y no arrancaba el sistema.

Arranqué con el sistema de rescate de una imagen de Tumbleweed de Mayo que tenía en el portátil y probé con btrfs check --repair /dev/sdb2 y me lanzó un montón de mensajes que no me daba tiempo a ver, pero que parece que había corregido varias cosas, hasta que llegó a checking fs roots y tras un tiempo generaba un core dump (no recuerdo con qué).

Total, que el sistema ahora no arranca, por lo que he descargado la imagen 20170724 de Tumbleweed y probaré a actualizar, y si no sirve, tocará reinstalar.

EDIT: Tras seguir probando opciones con btrfs y no conseguir recuperar la partición raíz y fallar tanto la Actualización como la Instalación de Tumbleweed en el 75% al buscar los discos duros, arranqué en modo Rescate y ejecuté mkfs.btrfs -f /dev/sdb2 para tener esa partición limpia. Reinicié, pude instalar sin problemas (desactivé las instantáneas/snapshots) en / y ahora estoy reinstalando los programas que me faltan.

Cita:
Iniciado por DiabloRojo Ver Mensaje
Por cierto, no escribas mensajes consecutivos en un corto periodo de tiempo porque no facilitas la lectura.
Perdón.

Lo hice porque me pareció que era pertinente cronológicamente al haber hecho nuevas pruebas y darme cuenta de nuevos problemas asociados (YaST no lanzaba ninguno de los complementos instalados).


PD: El portátil no me vale como referencia porque no usa snapshots (no me había dado cuenta durante las pruebas). Lo había instalado con una versión "normal" de openSUSE (no recuerdo si 13.2 o Leap 42.1) porque Tumbleweed no me dejaba cifrar /home en la instalación, y posteriormente migré a Tumbleweed.

Última edición por Xnake; 26-jul-2017 a las 16:58
Responder Citando
  #7  
Antiguo 26-jul-2017, 18:18
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.480
Agradecimientos: 563
Agradecido 2.416 Veces en 1.627 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Parece que se ha solucionado, me alegro.
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
Respuesta

Marcadores

Etiquetas
btrfs, snapper, yast


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
No puedo cambiar idioma opensuse 12.1 Miguerus General OpenSUSE 7 26-jun-2012 17:30
no puedo instalar con yast suse 11 kde 4.1.3 caligulaelsanto Software 4 24-feb-2009 14:56
no puedo instalar paquetes con yast francesc Software 6 07-dic-2007 09:02
Todo lo necesario para empezar con SUSE 10.0 maldito71 General OpenSUSE 4 18-abr-2007 08:25
Problema al Instalar con Yast SeFirOt Software 6 09-dic-2005 21:42



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 06:51.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba