Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > Software


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Systemd-coredump [solucionado]
  #1  
Antiguo 15-jun-2017, 15:06
Avatar de Krovikan
Krovikan Krovikan está desconectado
Miembro Junior
 
Fecha de Ingreso: 16-noviembre-2010
Ubicación: Delante del ordenador
Versión: Leap 42.3
Mensajes: 475
Agradecimientos: 172
Agradecido 99 Veces en 84 Mensajes
Poder de Credibilidad: 8
Krovikan está en el buen camino
Systemd-coredump [solucionado]

Hola:

De repente me está fallando un programa y en lugar de cerrarse, se queda abierto suspendido en disco (según KSysguard) y así se queda por resto de los días.

Hasta que vi que systemd-coredump se activa y ocupa toda la CPU. Así que quiero desactivar el coredump que no necesito para nada (creo yo).

He probado la opción 2 de está página https://linux-audit.com/understand-a...work-on-linux/

EDIT: Solución

Copiad las órdenes que pongo o si lo haceis desde el enlace de arriba sustituid las comillas torcidas por las comillas de MAYS+2 (las de siempre).

Hacerlo todo en root con su en lugar de sudo.

Código:
echo "ulimit -c 0 > /dev/null 2>&1" > /etc/profile.d/disable-coredumps.sh
Código:
echo "fs.suid_dumpable=0" >> /etc/sysctl.conf
Código:
sysctl -p

Saludos

Última edición por Krovikan; 16-jun-2017 a las 14:41 Razón: Ortografía
Responder Citando
  #2  
Antiguo 15-jun-2017, 17:13
Avatar de karlggest
karlggest karlggest está desconectado
Moderador
 
Fecha de Ingreso: 07-febrero-2007
Ubicación: Ourense
Versión: Leap 42.3
Mensajes: 8.190
Agradecimientos: 42
Agradecido 1.249 Veces en 920 Mensajes
Poder de Credibilidad: 19
karlggest está en el buen camino
Hola.

La redirección consta de dos partes, cada una de las cuales a su vez puede incluir redirecciones, etc.

Los comandos lo que hacen es insertar redirecciones en ficheros ejecutables. Las comillas lo que hacen es indicar que lo entrecomillado es una cadena de texto sin importar los caracteres incluidos. Hasta aquí bien, ¿no?

Lo que indica bash es que la redirección es ambigua, o dicho de otro modo, que no sabe interpretar qué forma parte y qué no de la redirección.

Si ejecutas simplemente:
Código:
echo “ulimit  -c 0 > /dev/null 2>&1”
Obtendrás el error que te indicaba también antes:
Código:
echo “ulimit -c 0 > /dev/null  2>&1”
bash: 1”: redireccionamento ambigüo
(De paso felicidades a quien puso una diéresis donde no se usa )

Fíjate que pone 1" después de bash: eso es lo que no acaba de entender bash. La explicación corta es que no sabe si la cadena acaba ahí o no (y es que la cadena tiene más redirecciones). Añade un espacio entre el 1 y el " y se ejecutará correctamente:
Código:
echo “ulimit -c 0 > /dev/null 2>&1 ”
Por cierto, lo que hace esa redirección es que no se muestre por consola la salida del comando ulimit -c 0

Salud!!
__________________
http://sementedotempo.blogspot.com/

-Si lo creen unos pocos, es un delirio; si son muchos los creyentes, es una religión
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a karlggest Por Este Mensaje:
Krovikan (15-jun-2017)
  #3  
Antiguo 15-jun-2017, 20:12
Avatar de Krovikan
Krovikan Krovikan está desconectado
Miembro Junior
 
Fecha de Ingreso: 16-noviembre-2010
Ubicación: Delante del ordenador
Versión: Leap 42.3
Mensajes: 475
Agradecimientos: 172
Agradecido 99 Veces en 84 Mensajes
Poder de Credibilidad: 8
Krovikan está en el buen camino
Gracias por responder.

El comando no creaba el archivo disable-coredumps.sh así que lo he tecleado con su ya que sudo no hacia nada (ni pedirme pass).

Código:
krovikan@linux:/etc> echo “ulimit -c 0 > /dev/null 2>&1 ” > /etc/profile.d/disable-coredumps.sh
krovikan@linux:/etc> ^C
krovikan@linux:/etc>  cd /etc/profile.d
krovikan@linux:/etc/profile.d> sudo echo “ulimit -c 0 > /dev/null 2>&1 ” > /etc/profile.d/disable-coredumps.sh
krovikan@linux:/etc/profile.d> su
Contraseña: 
linux:/etc/profile.d # echo “ulimit -c 0 > /dev/null 2>&1 ” > /etc/profile.d/disable-coredumps.sh
linux:/etc/profile.d # exit
exit
krovikan@linux:/etc/profile.d> cat /etc/profile.d/disable-coredumps.sh 
“ulimit -c 0 ”
La 2ª parte no he podido completarla. He tenido que volver a usar su porque sudo no tenía permiso (ni me pedía pass)

Código:
sudo echo “fs.suid_dumpable=0” >> /etc/sysctl.conf
bash: /etc/sysctl.conf: Permiso denegado
krovikan@linux:/etc/profile.d> su
Contraseña: 
linux:/etc/profile.d # echo “fs.suid_dumpable=0” >> /etc/sysctl.conf
linux:/etc/profile.d # sysctl -p
net.ipv4.ip_forward = 0
net.ipv6.conf.all.forwarding = 0
sysctl: cannot stat /proc/sys/“fs/suid_dumpable: No existe el fichero o el directorio
EDIT: Remirando el comando, veo que el echo escribió algo en /etc/sysctl.conf. Así que he ido a mirar ese archivo y veo esto:

Cita:
cat /etc/sysctl.conf
####
#
# /etc/sysctl.conf is meant for local sysctl settings
#
# sysctl reads settings from the following locations:
# /boot/sysctl.conf-<kernelversion>
# /lib/sysctl.d/*.conf
# /usr/lib/sysctl.d/*.conf
# /usr/local/lib/sysctl.d/*.conf
# /etc/sysctl.d/*.conf
# /run/sysctl.d/*.conf
# /etc/sysctl.conf
#
# To disable or override a distribution provided file just place a
# file with the same name in /etc/sysctl.d/
#
# See sysctl.conf(5), sysctl.d(5) and sysctl(8) for more information
#
####

# net.ipv6.conf.all.disable_ipv6 = 1
# net.ipv6.conf.all.disable_ipv6 = 1
net.ipv4.ip_forward = 0
net.ipv6.conf.all.forwarding = 0
“fs.suid_dumpable=0”
Ha escrito la última línea. ¿Igual el único error es que tenga " al principio y al final?
Si funciona, creo que con eso desactivo el systemd-coredump según la URL que puse en el primer post.


Saludos

Última edición por Krovikan; 15-jun-2017 a las 22:55 Razón: Info
Responder Citando
  #4  
Antiguo 16-jun-2017, 02:25
Avatar de karlggest
karlggest karlggest está desconectado
Moderador
 
Fecha de Ingreso: 07-febrero-2007
Ubicación: Ourense
Versión: Leap 42.3
Mensajes: 8.190
Agradecimientos: 42
Agradecido 1.249 Veces en 920 Mensajes
Poder de Credibilidad: 19
karlggest está en el buen camino
Hola.

Sí, también en los scripts anteriores borra las comillas. Así ulimits <opciones> y no "ulimits <opciones>".

Vale, ya lo tengo, supongo que lo has copiado de algún lado. Fíjate en las comillas. Las comillas no son rectas "", sino invertidas
Código:
linux:/tmp # echo "ulimit -c 0 > /dev/null 2>&1 " > /etc/profile.d/disable-coredumps.sh
linux:/tmp # cat /etc/profile.d/disable-coredumps.sh 
ulimit -c 0 > /dev/null 2>&1 
linux:/tmp # echo ulimit -c 0 > /dev/null 2>&1  > /etc/profile.d/disable-coredumps.sh
linux:/tmp # cat /etc/profile.d/disable-coredumps.sh 
ulimit -c 0 
linux:/tmp #
Con las comillas rectas no es necesario el espacio detrás del 1, pero tampoco molesta como puedes apreciar. Además, el fichero se crea si no existe.

Una cosa más. En una redirección, cada lado del redirector es Un comando. Si aplicas sudo a una parte... no lo estarás haciendo en la otra Así que si no tienes permisos para abrir o modificar el fichero de turno, no funcionará.

Salud!!
__________________
http://sementedotempo.blogspot.com/

-Si lo creen unos pocos, es un delirio; si son muchos los creyentes, es una religión
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a karlggest Por Este Mensaje:
Krovikan (16-jun-2017)
  #5  
Antiguo 16-jun-2017, 03:30
Avatar de Krovikan
Krovikan Krovikan está desconectado
Miembro Junior
 
Fecha de Ingreso: 16-noviembre-2010
Ubicación: Delante del ordenador
Versión: Leap 42.3
Mensajes: 475
Agradecimientos: 172
Agradecido 99 Veces en 84 Mensajes
Poder de Credibilidad: 8
Krovikan está en el buen camino
Ahora no tengo claro cual es el contenido exacto de los ficheros.

No sé si ha de tener el disable-coredumps.sh ulimit -c -0 o ulimit -c -0 > /dev/null 2>&1 o ulimit -c -0 solamente pero con comillas de algún tipo o no. Estoy hecho un lio.

Lo mismo me pasa con el /etc/sysctl.conf. No sé si ha de tener fs.suid_dumpable=0 con comillas de algún tipo o sin.

Es info que he sacado de https://linux-audit.com/understand-a...work-on-linux/ tras googlear un poco. Sección Disable core dumps, alternativa 2.


Saludos
Responder Citando
  #6  
Antiguo 16-jun-2017, 13:32
Avatar de karlggest
karlggest karlggest está desconectado
Moderador
 
Fecha de Ingreso: 07-febrero-2007
Ubicación: Ourense
Versión: Leap 42.3
Mensajes: 8.190
Agradecimientos: 42
Agradecido 1.249 Veces en 920 Mensajes
Poder de Credibilidad: 19
karlggest está en el buen camino
Hola.

Elimina las líneas que has añadido y ejecuta los comandos pero cambia las comillas por las normales (may+2)

Salud!!
__________________
http://sementedotempo.blogspot.com/

-Si lo creen unos pocos, es un delirio; si son muchos los creyentes, es una religión
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a karlggest Por Este Mensaje:
Krovikan (16-jun-2017)
  #7  
Antiguo 16-jun-2017, 14:42
Avatar de Krovikan
Krovikan Krovikan está desconectado
Miembro Junior
 
Fecha de Ingreso: 16-noviembre-2010
Ubicación: Delante del ordenador
Versión: Leap 42.3
Mensajes: 475
Agradecimientos: 172
Agradecido 99 Veces en 84 Mensajes
Poder de Credibilidad: 8
Krovikan está en el buen camino
Muchas gracias.

Cogía a lo que nunca han programado y usan '' (bajo el interrogante) en lugar de " (mays+2) y les daba. XDD

Ahora sí. Me han metido lo necesario. He ejecutado el sysctl -p y sin problemas.

No sé si será casualidad o no, pero he ejecutado el programa que me ponía en marcha el coredump y se ha ejecutado bien. Ni se ha suspendido en disco, ni se ha puesto en marcha el systemd-coredump ocupando toda la CPU en lugar de terminar el programa ni nada.

Todo bien.


Saludos y gracias de nuevo

PD: He editado el primer post con la solución y puesto el tag [SOLUCIONADO] después del título.
Responder Citando
  #8  
Antiguo 27-jul-2017, 22:23
Avatar de Invisuu
Invisuu Invisuu está desconectado
Aforado
 
Fecha de Ingreso: 05-octubre-2012
Ubicación: Carmen, CAMP, Mexico
Versión: 42.3 GNOME
Mensajes: 76
Agradecimientos: 45
Agradecido 29 Veces en 22 Mensajes
Poder de Credibilidad: 6
Invisuu está en el buen camino
Cita:
Iniciado por Krovikan Ver Mensaje
Muchas gracias.

Cogía a lo que nunca han programado y usan '' (bajo el interrogante) en lugar de " (mays+2) y les daba. XDD

Ahora sí. Me han metido lo necesario. He ejecutado el sysctl -p y sin problemas.

No sé si será casualidad o no, pero he ejecutado el programa que me ponía en marcha el coredump y se ha ejecutado bien. Ni se ha suspendido en disco, ni se ha puesto en marcha el systemd-coredump ocupando toda la CPU en lugar de terminar el programa ni nada.

Todo bien.


Saludos y gracias de nuevo

PD: He editado el primer post con la solución y puesto el tag [SOLUCIONADO] después del título.

¿Aplicaste desde la opción 1?

Que ando hecho un lío con esto. Instalé leap 42.3 y este problema de los coredumps no deja de azotar mi equipo.

Ya he probado lo que mencionas pero se siguen disparando los coredumps gracias a tracker.

Igual estuve revisando esto y esto y, según mi muy limitado conocimiento en el tema, en en esencia es lo mismo.

Estimados moderadores ¿creen necesario que abra un nuevo post con el tema?
Responder Citando
  #9  
Antiguo 28-jul-2017, 00:28
Avatar de Krovikan
Krovikan Krovikan está desconectado
Miembro Junior
 
Fecha de Ingreso: 16-noviembre-2010
Ubicación: Delante del ordenador
Versión: Leap 42.3
Mensajes: 475
Agradecimientos: 172
Agradecido 99 Veces en 84 Mensajes
Poder de Credibilidad: 8
Krovikan está en el buen camino
Hice el método 2 de la web que menciono en mi primer post.

Antes de llevarlo a cabo lee mi solución para que no caigas en el error de las comillas con apóstrofes que usaron en esa web de forma errónea.

Y recuerda no usar sudo. Su, contraseña y a meter comandos.


Saludos
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a Krovikan Por Este Mensaje:
Invisuu (28-jul-2017)
Systemd-coredump
  #10  
Antiguo 14-oct-2017, 22:35
Avatar de aldebaran
aldebaran aldebaran está desconectado
Aforado
 
Fecha de Ingreso: 04-junio-2013
Ubicación: Madrid
Versión: 42.3 GNOME
Mensajes: 48
Agradecimientos: 9
Agradecido 2 Veces en 2 Mensajes
Poder de Credibilidad: 0
aldebaran está en el buen camino
Systemd-coredump

Buenas noches,
me ha pasado lo mismo estos días con mi versión Leap 42.3, no se si será normal pero ya me veia instalando nuevamente y sin saber la causa del problema.

Creo que no es muy normal que un proceso de archivado se lleve el 100% del CPU dejando la máquina sin operativa alguna
__________________
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
No puedo arrancar con opensuse 13.2 catlib Software 9 28-oct-2015 21:46
acerca de systemd armando La cafetería 8 22-ago-2014 16:01
[Wiki] Systemd VampirD Colaboración wiki opensuse 7 24-ago-2013 22:22
[Wiki] Systemd VampirD Colaboración wiki opensuse 0 14-sep-2012 21:52
sistema no inicia con systemd pero con systemV inicia normalmente arag Software 2 14-sep-2012 18:31



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 15:56.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba