Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona OpenSUSE > Instalación y Actualizaciones


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Arranque dual de windows 10 y OpenSuse 42.1 con Uefi [solucionado]
  #1  
Antiguo 18-ene-2016, 23:35
Avatar de Jotape
Jotape Jotape está desconectado
Aforado
 
Fecha de Ingreso: 10-septiembre-2009
Ubicación: Santiago de Chile
Versión: Open SUSE Tumbleweed
Mensajes: 48
Agradecimientos: 27
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 0
Jotape está en el buen camino
Arranque dual de windows 10 y OpenSuse 42.1 con Uefi [solucionado]

Estimados Amigos... Logré solucionar mi problema gracias a la ayuda tanto en sugerencias como en experiencias compartidas, incontables búsquedas en google y youtube, hasta que analizando todo llegué a la conclusión que los drivers de mi laptop no estaban en la versión 42.1 Leap y mucho menos en las versiones anteriores. Eso me daba problemas para arrancar openSUSE específicamente la tarjeta gráfica nVidia Geforce GTX 950M y la tarjeta WiFi produciendo el congelamiento a los segundos de haber iniciado... Después de quebrarme la cabeza y ver que muchas soluciones que encontraba en internet no aplicaban en mi Laptop HP Pavilion Gaming 15-AK002LA se me ocurrió bajar openSUSE Tumbleweed porque como esta versión se está renovando siempre; lo grabé en un pendrive con ImageWhriter, instalo y ¡¡¡EUREKA!!! me llevé la gran sorpresa que reconoció todo el hardware de mi Laptop
arrancó sin problemas y problema solucionado... lo único que el GRUB no se inicia en forma automática sino que pulsando F9, pero con eso me basta y me sobra ... Bueno este problema también ha quedado resuelto y estaba relacionado a un error mío de no considerar que en el bios no bastaba sólo colocar que arrancara desde el HDD donde se encontraban los sistemas operativos y sus booteos sino que además en la opción de HDD se encontraba un submenu para elegir que sistema debería arrancar por defecto. Ahí se elige "arranque de opensuse tumbleweed con arranque seguro" ya que en este inicio se encuentra GRUB.... yyyyyy.... Problema Resuelto.... ahora mi laptop al encenderlo inicia con GRUB 2 UEFI

Gracias a todos los que me ayudaron con sus concejos, sugerencias y experiencias que me guiaron a encontrar la solución a mi problema...

Saludos Cordiales


"Estimados junto con saludarlos y desearles lo mejor para este año 2016, les doy a conocer mis dudas haber si me pueden encaminar. Antes que todo, les comento que ya he buscado en google además de aquí, en este sitio, pero no encuentro lo que necesito o más bien dicho no lo entiendo... normalmente yo soluciono mis problemas que se me presentan pero esta vez lo consulto acá.

Compré recientemente un Notebook HP Paviliion Gaming que en su bios trae el famoso UEFI y partida segura. Este notebook venía con windows 10 Home con toda la basura que traen los pc que vienen con sistema incluido. Bueno, después de desintalar muchos programas inútiles incluyendo el antivirus McAfi que relentizaba todo el sistema, hice las particiones necesarias para instalar Opensuse 42.1 y sorpresa no aparece Grub... intenté arrancarlo eligiendo el boot correspondiente pero al cargar OpenSuse se iban generando errores y al final se reiniciaba y arrancaba windows 10 home.... Como no estaba contento tampoco con esta versión de window, la 10 Home ya que yo tenía la 10 Pro, eliminé todas las particiones incluyendo las recovery que traía el notebook e instalé windows 10 Pro limpio y particionando el disco la mitad para win 10 y la otra mitad para OpenSuse 42.1 Leap... y ahí estoy en este momento, con la partición lista para OpenSuse... a todo esto en mi laptop anterior que era un samsung con i5 primera generación, ram 8 gb y tarjeta dedicada nVidia de 1 gb, corria muy bien esta versión nueva de Opensuse con win 10 pro dual... el HP que me compré es i7 sexta generación 8 gb de ram tarjeta nVidia geoforce gtx 950 m de 4 gb además que viene con Uefi y partida segura... ¿alguna sugerencia que me puedan dar?...
Saludos a todos y quedo atento a sus comentarios"

Última edición por Jotape; 18-may-2016 a las 07:09 Razón: Solucionado
Responder Citando
  #2  
Antiguo 19-ene-2016, 02:00
Avatar de susemex
susemex susemex está desconectado
Miembro Junior
 
Fecha de Ingreso: 13-junio-2014
Ubicación: Veracruz, Ver.
Versión: Leap 42.3
Mensajes: 559
Agradecimientos: 475
Agradecido 93 Veces en 71 Mensajes
Poder de Credibilidad: 4
susemex está en el buen camino
Por lo que nos comentas, al parecer quieres instalar Leap 42.1 en tu HP i7, es correcto? Si es así, dinos qué tipo de particiones has creado (si es que ya lo hiciste) para openSUSE en la mitad del disco duro.
__________________
Saludines,
Isabel.
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a susemex Por Este Mensaje:
Jotape (19-ene-2016)
  #3  
Antiguo 19-ene-2016, 04:21
Avatar de Jotape
Jotape Jotape está desconectado
Aforado
 
Fecha de Ingreso: 10-septiembre-2009
Ubicación: Santiago de Chile
Versión: Open SUSE Tumbleweed
Mensajes: 48
Agradecimientos: 27
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 0
Jotape está en el buen camino
Hola Susemex, gracias por responder.
Así es... hace años que utilizo el arranque dual en laptops que he tenido y cada vez que lo renuevo por uno nuevo no había tenido problemas hasta que me compré este que es un HP Pavilion Gaming que tiene el sistema UEFI y arranque seguro el cual me ha traído problemas para lograr que funcione grub2-efi... este lo compré por sus grandes recursos que tiene para trabajar en gráfica... ahora ya tengo instalado Opensuse Leap pero arranca con errores y además tengo que presionar F9 para elegir que boot empleo pero como te decía arranca con errores y además se congela...
Ahora la partición que hice fue la mitad del disco duro para Opensuse que lo instalé por defecto...

Los tutoriales o experiencias que han tenido otras personas para hacer que funciones el Grub no los he entendido ya que al leerlos me doy cuenta que son muy diferentes o muy antiguos que no aplican a lo que yo veo en mi computador...

Saludos
Responder Citando
  #4  
Antiguo 19-ene-2016, 04:25
Avatar de susemex
susemex susemex está desconectado
Miembro Junior
 
Fecha de Ingreso: 13-junio-2014
Ubicación: Veracruz, Ver.
Versión: Leap 42.3
Mensajes: 559
Agradecimientos: 475
Agradecido 93 Veces en 71 Mensajes
Poder de Credibilidad: 4
susemex está en el buen camino
Si nos mandaras unos pantallazos de los errores que te aparecen en pantalla, sería muy bueno para poder ayudarte.
Lo más seguro es que tengas que ingresar al BIOS de tu sistema y habilitar el Boot mode en Legacy.
__________________
Saludines,
Isabel.
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a susemex Por Este Mensaje:
Jotape (19-ene-2016)
  #5  
Antiguo 19-ene-2016, 05:44
Avatar de Jotape
Jotape Jotape está desconectado
Aforado
 
Fecha de Ingreso: 10-septiembre-2009
Ubicación: Santiago de Chile
Versión: Open SUSE Tumbleweed
Mensajes: 48
Agradecimientos: 27
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 0
Jotape está en el buen camino
Un poco dificil hacer una captura de pantalla ya que los errores los muestra cuando está cargando mostrando sólo texto pasando muy rápido ahora uno de los errores que muestra aparece noveau en una larga lista además de otras cosas

El modo Legacy no lo encuantro excepto en protocolo de arranque de red y sale como "IPv4 (legacy)"... retiro lo dicho, ya lo encontré, era compatibilidad heredada y estaba activada es decir en modo Legacy... al desactivar esta compatibilidad se activa Uefi y el arranque seguro...

Última edición por Jotape; 19-ene-2016 a las 06:32
Responder Citando
  #6  
Antiguo 19-ene-2016, 06:51
Avatar de susemex
susemex susemex está desconectado
Miembro Junior
 
Fecha de Ingreso: 13-junio-2014
Ubicación: Veracruz, Ver.
Versión: Leap 42.3
Mensajes: 559
Agradecimientos: 475
Agradecido 93 Veces en 71 Mensajes
Poder de Credibilidad: 4
susemex está en el buen camino
Trata de iniciar el sistema con un CD Live de openSUSE. Te dejo un link con las imágenes para que descargues una Live y la grabes para iniciar el sistema:

http://download.opensuse.org/distribution/13.2/iso/

Acá las instrucciones para crear un Live USB: https://es.opensuse.org/SDB:Live_USB_stick

PD.- Vamos, muchachos, lo más entendidos del tema salgan al rescate también!
__________________
Saludines,
Isabel.
Responder Citando
Los Siguientes 2 Usuarios Han Dado las Gracias a susemex Por Este Mensaje:
Jotape (19-ene-2016), testeoelas (02-feb-2016)
  #7  
Antiguo 19-ene-2016, 14:52
Avatar de Jotape
Jotape Jotape está desconectado
Aforado
 
Fecha de Ingreso: 10-septiembre-2009
Ubicación: Santiago de Chile
Versión: Open SUSE Tumbleweed
Mensajes: 48
Agradecimientos: 27
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 0
Jotape está en el buen camino
Muchas gracias... ha salido dura la pelea he tratado de diferentes formas para que aparezca grub y no hay caso y al iniciar presionando F9 y eligiendo el booteo correspondiente a OpenSuse, este arranca con una infinidad de errores que cuando ya esta abierto se cuelga... jamás me había pasado desde que utilizo OpenSuse desde el 2009... y necesito que sea partida dual ya que trabajo en grafica con Windows y los archivos que me envían mis clientes vienen casi exclusivamente con Illustrator... OpenSuse lo uso para mis movimientos financieros de transferencias y pagos de cuentas, esto por la seguridad que posee, además que me encanta su estilo y este último lo encuentro Genial...
Responder Citando
  #8  
Antiguo 19-ene-2016, 17:03
Avatar de NestorAcevedo
NestorAcevedo NestorAcevedo está desconectado
Habitual
 
Fecha de Ingreso: 25-agosto-2008
Ubicación: Bogotá D.C, Colombia
Versión: Tumbleweed
Mensajes: 240
Agradecimientos: 9
Agradecido 12 Veces en 10 Mensajes
Poder de Credibilidad: 10
NestorAcevedo está en el buen camino
Cuando se trata de uefi, openSUSE en el momento de instalar el cargador el detecta si es o no uefi y por defecto cuando es uefi el deja la opción de instalar el grub en uefi pero para que sea completo se debe montar la partición que contiene el cargador (en general es la primera de la lista) en /boot/efi. Se me hizo raro que tuviera que entrar con F9 a seleccionar openSUSE y eso pasa cuando no se instala el cargador en la partición uefi (cosa que me pasó la primera vez que instalé Leap)

En cuanto a los errores del noveau es correspondiente a gráficos de nvidia que deduzco es la tarjeta gráfica que tiene ese equipo.
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a NestorAcevedo Por Este Mensaje:
Jotape (19-ene-2016)
  #9  
Antiguo 19-ene-2016, 18:35
Avatar de Jotape
Jotape Jotape está desconectado
Aforado
 
Fecha de Ingreso: 10-septiembre-2009
Ubicación: Santiago de Chile
Versión: Open SUSE Tumbleweed
Mensajes: 48
Agradecimientos: 27
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 0
Jotape está en el buen camino
Gracias NestorAcevedo... mira, lo instalé por defecto incluso la misma instalación de OpenSuse Leap desactivó el arranque seguro y colocó uefi en modo legacy en que a mi me dice "compatibilidad heredada"... me arranca por F9 y ahí me muestra el grub2-efi pero arroja tantos errores que al final cuando OpenSuse está abierto y entre un par de segundos a algunos minutos se cuelga y tengo que apagar mi laptop a la fuerza... no entiendo como salir de eso ya que las explicaciones que he logrado encontrar en google no aplican a mi sistema o no he sabido como aplicarlas... antes cuando tenía un laptop Samsung que lo compré en el 2010 nunca tuve ese problema y todo funcionaba como seda tanto con Windows 7 ultimate como con Windows 10 pro en arranque dual con todas las versiones anteriores de opensuse lo que si a veces tenía algún problemilla con el wifi pero era un detalle arreglable, sin embargo esto del famoso uefi me ha tenido con dolor de cabeza...

y eso de montar grub en /boot/efi... mmmm, creo que no lo entiendo y lo más probable es que me estoy ahogando en un vaso con agua

Última edición por Jotape; 19-ene-2016 a las 18:38
Responder Citando
  #10  
Antiguo 19-ene-2016, 22:50
karlitozebc karlitozebc está desconectado
Aforado
 
Fecha de Ingreso: 06-noviembre-2015
Ubicación: Bogota, Colombia
Versión: 42.1
Mensajes: 28
Agradecimientos: 22
Agradecido 10 Veces en 6 Mensajes
Poder de Credibilidad: 0
karlitozebc está en el buen camino
Cita:
Iniciado por Jotape Ver Mensaje
Gracias NestorAcevedo... mira, lo instalé por defecto incluso la misma instalación de OpenSuse Leap desactivó el arranque seguro y colocó uefi en modo legacy en que a mi me dice "compatibilidad heredada"... me arranca por F9 y ahí me muestra el grub2-efi pero arroja tantos errores que al final cuando OpenSuse está abierto y entre un par de segundos a algunos minutos se cuelga y tengo que apagar mi laptop a la fuerza... no entiendo como salir de eso ya que las explicaciones que he logrado encontrar en google no aplican a mi sistema o no he sabido como aplicarlas... antes cuando tenía un laptop Samsung que lo compré en el 2010 nunca tuve ese problema y todo funcionaba como seda tanto con Windows 7 ultimate como con Windows 10 pro en arranque dual con todas las versiones anteriores de opensuse lo que si a veces tenía algún problemilla con el wifi pero era un detalle arreglable, sin embargo esto del famoso uefi me ha tenido con dolor de cabeza...

y eso de montar grub en /boot/efi... mmmm, creo que no lo entiendo y lo más probable es que me estoy ahogando en un vaso con agua
Hola, ha intenado ver si hay alguna opcion en la BIOS que diga algo como UEFI WINDOWS / OTHER SYSTEM ?, en caso que si la tenga, coloquela en OTHER SYSTEM, tambien desactive en la BIOS el "Arranque Rapido" en caso que lo tenga.

Tambien puede intentar formatear el disco duro antes de la instalacion, utilizando GPARTED (si tiene algun livecd de alguna distro como Ubuntu, etc), elinima todas las particiones incluso las pequeñas (UEFI - Recovery), y particiona desde el mismo Gparted el disco duro (particion para windows, y particion para Opesuse, instale promero windows y despues Opensuse, y "verifique" que cuando opensuse le muestra la tabla de particiones donde se va a instalar, el GRUB quede en la raiz del disco duro y no en la particion de opensuse.

No he intentado instalar win 10 junto a ningun linux, pero si lo hice con win 8 y linux y nunca tube problema para que funcionaran juntos bien.

Ojala algo le sirva, y cualquier cosa mas que recuerde y crea que le pueda servir, la publicare aqui.
__________________
OpenSuse Leap 42.1 kde plasma / OSX Yosemite 10.10.5 / Win 7
MoBo: ASUS H81M-C
Ram: 8Gb
Procesador: Intel i3-4130, 3.4Ghz
Video: Nvidia GeForce GT 610 de 2 Gb

Responder Citando
El Siguiente Usuario Ha Dado las Gracias a karlitozebc Por Este Mensaje:
Jotape (19-ene-2016)
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Otro "The following 48 package updates will NOT be installed" al actualizar openSUSE moshpirit Software 12 01-mar-2015 23:39
No aparece el dual boot (windows 7 y opensuse 12.3) [solucionado] Germanlokura Instalación y Actualizaciones 15 10-dic-2014 19:52
KDEInit no pudo lanzar «/usr/bin/xdg-su». jes_sus50 Escritorios: KDE, Gnome, otros... 14 02-dic-2012 12:02
Ubuntu (Interno) y openSUSE (externo) [SOLUCIONADO] sensei.juba Hardware 8 09-abr-2011 23:17
Windows Vista beta 2 vs Suse 10.1 (Apreciaciones) Jersoncito El Contubernio 42 25-feb-2007 06:26



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 22:37.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba