Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona OpenSUSE > Hardware


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Webcam GENIUS EYE 110
  #1  
Antiguo 05-may-2015, 14:42
Avatar de jhonny_ese
jhonny_ese jhonny_ese está desconectado
Habitual
 
Fecha de Ingreso: 13-agosto-2008
Ubicación: Vargas - Venezuela
Versión: Leap 42.1
Mensajes: 107
Agradecimientos: 6
Agradecido 4 Veces en 4 Mensajes
Poder de Credibilidad: 10
jhonny_ese está en el buen camino
Webcam GENIUS EYE 110

Hola qué tal?. Mi openSuSE me reconoce la cámara Genius EYE110 como una CIF Single Chip, el comando "lsusb" coo una Pixart , todo parece perfecto , peeero..
ejecuto el programa webcamoid, aparece mi webcam CIF Single Chip, y no se ve nada. Al tomar foto se cierra el programa.
Ejecuté desde consola, y al cerrarse me presenta el siguiente mensaje:

"[video4linux2,v4l2 @ 0x16664e0] Cannot find a proper format for codec 'none' (id 0), pixel format 'none' (id -1)
Assertion *codec_id != AV_CODEC_ID_NONE failed at libavdevice/v4l2.c:811
Abortado"

Ideas?

RESUELTO

Última edición por jhonny_ese; 12-may-2015 a las 11:26 Razón: RESUELTO
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a jhonny_ese Por Este Mensaje:
mikrios (07-may-2015)
  #2  
Antiguo 07-may-2015, 15:31
lauser lauser está desconectado
Aforado
 
Fecha de Ingreso: 24-enero-2012
Versión: 13.2
Mensajes: 5
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
lauser está en el buen camino
Esta claro que falta o esta corrupta la libreria http://sourceforge.net/p/mplayer-ww/...vdevice/v4l2.c
__________________
<<---SoloLinux.es--->>
Responder Citando
  #3  
Antiguo 07-may-2015, 23:06
Avatar de mikrios
mikrios mikrios está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.530
Agradecimientos: 1.911
Agradecido 1.402 Veces en 1.175 Mensajes
Poder de Credibilidad: 9
mikrios llegará a ser famoso muy pronto
Hola:

Aunque te parezca raro, en yast hardware lo puede reconocer como un determinado dispositivo, pero a lo mejor por consola lo ve como otro.

Ya me ha pasado con eso, pero no se si uno da la información del fabricante (que muestra el plug and play del usb) y otro el chip de hardware.

Desconocía ese programa o plasmoide, para kde, normalmente no he tenido mucha suerte con las que tengo en casa y he tenido que utilizar programas de gnome en kde, uno que me funciono bien era el Cheese.

Aunque sea Genius EYE110, puede llevar el chip de otros fabricantes de hardware .

Tengo tres modelos de dispositivo usb con chip de web cam, 2 son microscopios usb y el último es un adaptador para una lupa bifocal marca Narita, en los tres no he tenido mucha suerte con el tema de los drivers y si usa la base de datos de Digikam, pues mucho menos; pero aquellos programas que tienen otro tipo de identificación (por ejemplo el cheese), suelen funcionar bien (bueno a veces tiene pequeños problemas )

Gracias por comentar el tema jhonny_ese, si no fuera por que lo ha añadido en el foro, no me hubiese enterado de webcamoid .

Edito:
Ya probé uno de ellos y va ok .

Código:
Bus 001 Device 004: ID eb1a:130a eMPIA Technology, Inc.


Haber si tengo suerte con los otros .

Por cierto el programa que me baje es para tumblewwed (me baje el devel también) :
Código:
X79-PRO:~ # zypper se -si webcamoid
Loading repository data...
Reading installed packages...

S | Name                     | Type    | Version      | Arch   | Repository
--+--------------------------+---------+--------------+--------+-----------
i | plasmoid-webcamoid       | package | 5.0.0b2-1.20 | x86_64 | packman   
i | plasmoid-webcamoid-devel | package | 5.0.0b2-1.20 | x86_64 | packman
Edito:
El adaptador de la lupa bifocal no va y el otro dispositivo usb, tampoco va :
Código:
Bus 001 Device 003: ID 05e1:0500 Syntek Semiconductor Co., Ltd DC-112X Webcam
Pero tengo la duda, por que volví a probar el primero que si funcionaba, y ahora tampoco me funciona , se que me dio algunos errores posteriores en kde, una vez que desconecte el 1º .
En fin lo veo algo inestable, quizás el cheese de mejores resultados .

Edito:
Los errores que dio fueron sobre plasma, tuve que reiniciar algunos archivos de configuración en /home/frank/.kde4/share/config/ (para dejar las cosas como estaban antes)
Los archivos renombrados son estos : plasma-desktoprc-1, khotkeysrc-1, plasma-desktop-appletsrc-1, kglobalshortcutsrc-1, gtkrc-1 y gtkrc-2.0-1 y el de la aplicación solo mantiene la configuración del programa, mientras en los otros realiza algunos cambios (webcamoidrc) ; y me parece que también modifico este : phonondevicesrc

El añadido fue al final y es :
Código:
[VideoDevice_/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.5/1-1.5:1.0/video4linux/video0]
cardName=Digital Microscope
deleted=false
deviceNumber=-1
hotpluggable=true
iconName=camera-web
index=-145
initialPreference=50
isAdvanced=false

[VideoDevice_/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.6/1-1.6:1.0/video4linux/video0]
cardName=PC Camera
deleted=false
deviceNumber=-1
hotpluggable=true
iconName=camera-web
index=-16
initialPreference=50
isAdvanced=false
Creo que al final lo voy a quitar.

Saludos cordiales

Última edición por mikrios; 08-may-2015 a las 01:00 Razón: añadir
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a mikrios Por Este Mensaje:
jhonny_ese (12-may-2015)
  #4  
Antiguo 08-may-2015, 03:34
Avatar de soyasi
soyasi soyasi está desconectado
Miembro Senior
 
Fecha de Ingreso: 26-julio-2005
Ubicación: Atlántida
Versión: leap 42.1
Mensajes: 850
Agradecimientos: 187
Agradecido 323 Veces en 221 Mensajes
Poder de Credibilidad: 13
soyasi está en el buen camino
con esa cámara o chip, el programa que mejor te irá es xawtv.

Lo tienes en los repos

Prueba y ya me dirás

Webcamoide con esa cámara se te cierra y te reinicia KDE, ya lo puse hace tiempo en conocimiento de hipersayanX, si quieres probar la ultima versión y compilarla la tienes aqui



nota: si haces un lsusb probablemente te aparecerá esto
Cita:
Bus 004 Device 002: ID 093a:2468 Pixart Imaging, Inc. SoC PC-Camera
"The gspca driver framework was added to the mainline linux-kernel in 2.6.27, so openSUSE already contains the drivers for most gspca-devices since version 11.1"

Vamos que el kernel ya lo tiene integrado desde la versión 11.1 de opensuse

si consultas esta pagina probablemente la encontraras.


Cita:
mars 093a:050f Mars-Semi Pc-Camera
mr97310a 093a:010e All known CIF cams with this ID
mr97310a 093a:010f All known VGA cams with this ID
pac207 093a:2460 Qtec Webcam 100
pac207 093a:2461 HP Webcam
pac207 093a:2463 Philips SPC 220 NC
pac207 093a:2464 Labtec Webcam 1200
pac207 093a:2468 Webcam WB-1400T
pac207 093a:2470 Genius GF112
pac207 093a:2471 Genius VideoCam ge111
pac207 093a:2472 Genius VideoCam ge110
pac207 093a:2474 Genius iLook 111
pac207 093a:2476 Genius e-Messenger 112
pac7311 093a:2600 PAC7311 Typhoon
pac7311 093a:2601 Philips SPC 610 NC
pac7311 093a:2603 Philips SPC 500 NC
pac7311 093a:2608 Trust WB-3300p
pac7311 093a:260e Gigaware VGA PC Camera, Trust WB-3350p, SIGMA cam 2350
pac7311 093a:260f SnakeCam
pac7302 093a:2620 Apollo AC-905
pac7302 093a:2621 PAC731x
pac7302 093a:2622 Genius Eye 312
pac7302 093a:2624 PAC7302
pac7302 093a:2625 Genius iSlim 310
pac7302 093a:2626 Labtec 2200
pac7302 093a:2627 Genius FaceCam 300
pac7302 093a:2628 Genius iLook 300
pac7302 093a:2629 Genious iSlim 300
pac7302 093a:262a Webcam 300k
pac7302 093a:262c Philips SPC 230 NC
__________________
--
hkp://subkeys.pgp.net
GNU/Linux Opensuse leap 42.1 x86_64
Linux Registered User #391410



(http://linuxcounter.net/)

Última edición por soyasi; 08-may-2015 a las 04:07
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a soyasi Por Este Mensaje:
jhonny_ese (12-may-2015)
  #5  
Antiguo 08-may-2015, 11:28
Avatar de jhonny_ese
jhonny_ese jhonny_ese está desconectado
Habitual
 
Fecha de Ingreso: 13-agosto-2008
Ubicación: Vargas - Venezuela
Versión: Leap 42.1
Mensajes: 107
Agradecimientos: 6
Agradecido 4 Veces en 4 Mensajes
Poder de Credibilidad: 10
jhonny_ese está en el buen camino
Gracias.
lauser: no consigo esa librería en mi sistema. Cómo la añado?. YaST no me la consigue.
soyasi: el lsusb sólo me dice
Bus 004 Device 005: ID 093a:2472 Pixart Imaging, Inc.
y con el xawtv tampoco se capta nada.
mikrios: en realidad, no me gusta mucho mezclar librerías de KDE y GNOME. Voy a llevar la cámara a alguien que use ruindo$ a ver si es que la cámara está mal.
Será que no trabaja bien en sistemas de 64 bits? Es el que yo uso.
De todas maneras no la uso mucho, pero me molesta tener algo que no vaya bien en este OS que me gusta tanto.
Responder Citando
  #6  
Antiguo 08-may-2015, 12:42
Avatar de mikrios
mikrios mikrios está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.530
Agradecimientos: 1.911
Agradecido 1.402 Veces en 1.175 Mensajes
Poder de Credibilidad: 9
mikrios llegará a ser famoso muy pronto
Hola:

Has puesto en yast requiere o proporciona :

Según el enlace que dejaron hace mención a :
Código:
X79-PRO:~ # zypper se -s  libavdevice 
Loading repository data...
Reading installed packages...

S | Name                          | Type    | Version     | Arch   | Repository            
--+-------------------------------+---------+-------------+--------+-----------------------
  | libavdevice52                 | package | 0.7.16-3.12 | x86_64 | packman               
  | libavdevice52                 | package | 0.7.16-3.12 | i586   | packman               
  | libavdevice56                 | package | 2.6.2-1.1   | x86_64 | packman               
  | libavdevice56                 | package | 2.6.2-1.1   | i586   | packman               
  | libavdevice56                 | package | 2.6.2-1.1   | x86_64 | repo-oss              
  | libavdevice56                 | package | 2.6.2-1.1   | i586   | repo-oss              
  | libavdevice52-debuginfo       | package | 0.7.16-3.12 | x86_64 | packman               
  | libavdevice52-debuginfo       | package | 0.7.16-3.12 | i586   | packman               
  | libavdevice56-debuginfo       | package | 2.6.2-1.1   | x86_64 | packman               
  | libavdevice56-debuginfo       | package | 2.6.2-1.1   | i586   | packman               
  | libavdevice56-debuginfo       | package | 2.6.2-1.1   | x86_64 | repo-debug            
  | libavdevice56-debuginfo       | package | 2.6.2-1.1   | x86_64 | tumbleweed/repo/debug/
  | libavdevice56-debuginfo       | package | 2.6.2-1.1   | i586   | repo-debug            
  | libavdevice56-debuginfo       | package | 2.6.2-1.1   | i586   | tumbleweed/repo/debug/
  | libavdevice56-debuginfo-32bit | package | 2.6.2-1.1   | x86_64 | packman               
  | libavdevice52-debuginfo-32bit | package | 0.7.16-3.12 | x86_64 | packman               
  | libavdevice52-32bit           | package | 0.7.16-3.12 | x86_64 | packman               
  | libavdevice56-32bit           | package | 2.6.2-1.1   | x86_64 | packman               
  | libavdevice-libav55-debuginfo | package | 11.3-1.1    | x86_64 | repo-debug            
  | libavdevice-libav55-debuginfo | package | 11.3-1.1    | x86_64 | tumbleweed/repo/debug/
  | libavdevice-libav55-debuginfo | package | 11.3-1.1    | i586   | repo-debug            
  | libavdevice-libav55-debuginfo | package | 11.3-1.1    | i586   | tumbleweed/repo/debug/
  | libavdevice-devel             | package | 2.6.2-1.1   | x86_64 | repo-oss              
  | libavdevice-devel             | package | 2.6.2-1.1   | i586   | repo-oss              
  | libavdevice-libav-devel       | package | 11.3-1.1    | x86_64 | repo-oss              
  | libavdevice-libav-devel       | package | 11.3-1.1    | i586   | repo-oss              
  | libavdevice-libav55           | package | 11.3-1.1    | x86_64 | repo-oss              
  | libavdevice-libav55           | package | 11.3-1.1    | i586   | repo-oss

Y en todo caso para openSUSE sería :
Código:
X79-PRO:~ # zypper se -s  libv4l2
Loading repository data...
Reading installed packages...

S | Name                        | Type    | Version   | Arch   | Repository            
--+-----------------------------+---------+-----------+--------+-----------------------
  | libv4l2-0-debuginfo         | package | 1.6.2-2.1 | x86_64 | repo-debug            
  | libv4l2-0-debuginfo         | package | 1.6.2-2.1 | x86_64 | tumbleweed/repo/debug/
  | libv4l2-0-debuginfo         | package | 1.6.2-2.1 | i586   | repo-debug            
  | libv4l2-0-debuginfo         | package | 1.6.2-2.1 | i586   | tumbleweed/repo/debug/
  | libv4l2rds0-debuginfo       | package | 1.6.2-2.1 | x86_64 | repo-debug            
  | libv4l2rds0-debuginfo       | package | 1.6.2-2.1 | x86_64 | tumbleweed/repo/debug/
  | libv4l2rds0-debuginfo       | package | 1.6.2-2.1 | i586   | repo-debug            
  | libv4l2rds0-debuginfo       | package | 1.6.2-2.1 | i586   | tumbleweed/repo/debug/
  | libv4l2-0-debuginfo-32bit   | package | 1.6.2-2.1 | x86_64 | repo-debug            
  | libv4l2-0-debuginfo-32bit   | package | 1.6.2-2.1 | x86_64 | tumbleweed/repo/debug/
  | libv4l2rds0-debuginfo-32bit | package | 1.6.2-2.1 | x86_64 | repo-debug            
  | libv4l2rds0-debuginfo-32bit | package | 1.6.2-2.1 | x86_64 | tumbleweed/repo/debug/
i | libv4l2-0                   | package | 1.6.2-2.1 | x86_64 | repo-oss              
v | libv4l2-0                   | package | 1.6.2-2.1 | i586   | repo-oss              
  | libv4l2rds0                 | package | 1.6.2-2.1 | x86_64 | repo-oss              
  | libv4l2rds0                 | package | 1.6.2-2.1 | i586   | repo-oss              
  | libv4l2-0-32bit             | package | 1.6.2-2.1 | x86_64 | repo-oss              
  | libv4l2rds0-32bit           | package | 1.6.2-2.1 | x86_64 | repo-oss
o sea : libv4l2-0 .

Bueno hay programas que corren bien tanto los de kde como en gnome, tengo kde y también veo que me instala algo de gnome (actualmente no estoy probando en este equipo nada de gnome) , por lo cual si no hay problemas de dependencias, por lo menos a mi no me importa.

No creo que tenga nada que ver lo de 32bit o 64bit ; si tienes un 64bit puede ejecutar también 32bit (de hecho los drivers de una impresora que tengo son de 32bit, porque no encontré para 64bit) .

Casi todos los micros que hay son ya de 64bit y no solo es por lo del direccionamiento de la memoria ram, si no por las instrucciones de la cpu y sus registros (aunque perfectamente pueden ejecutar las de 32bit para abajo ) .

Eso de molestar creo que le pueda pasar a la mayoría, hay mucho hardware que no tiene drivers para linux y lo mismo pasa con algunas aplicaciones que no puedan ejecutar o trabajar en linux (ya bien por que el fabricante no quiere y solo lo hacen para win y mac , no se también veras que algunos fabricantes se pasan por la piedra a M$ y hacen drivers de win que no están certificados por M$ ) .

Ese programa que comenta soyasi era uno de los que había probado (creo que el mencionado por mi y el que comenta soyasi eran los únicos que iban bien,después había otro, pero el programa era comercial y era para usar cámaras de vigilancia ) .

Saludos cordiales

Última edición por mikrios; 08-may-2015 a las 12:42 Razón: corregir
Responder Citando
Gracias
  #7  
Antiguo 08-may-2015, 14:11
Avatar de jhonny_ese
jhonny_ese jhonny_ese está desconectado
Habitual
 
Fecha de Ingreso: 13-agosto-2008
Ubicación: Vargas - Venezuela
Versión: Leap 42.1
Mensajes: 107
Agradecimientos: 6
Agradecido 4 Veces en 4 Mensajes
Poder de Credibilidad: 10
jhonny_ese está en el buen camino
Gracias

Ok. Al regresar a casa vuelvo a intentarlos. Ya he decubierto que en este mundo de linux, lo importante es la paciencia. Siempre hay una luz al final del tunel.
Responder Citando
  #8  
Antiguo 08-may-2015, 17:10
Avatar de soyasi
soyasi soyasi está desconectado
Miembro Senior
 
Fecha de Ingreso: 26-julio-2005
Ubicación: Atlántida
Versión: leap 42.1
Mensajes: 850
Agradecimientos: 187
Agradecido 323 Veces en 221 Mensajes
Poder de Credibilidad: 13
soyasi está en el buen camino
si no te la reconoce directamente xawtv, prueba a lanzarla desde consola de la siguiente forma:

en 64 bits
Código:
LD_PRELOAD=/usr/lib64/libv4l/v4l1compat.so xawtv
en 32 bits
Código:
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so xawtv
tu cámara
Código:
Bus 004 Device 005: ID 093a:2472 Pixart Imaging, Inc.
esta relacionada en la página que te dí, con lo cual el driver esta ya incluido.
Solo que esta con otro nombre
Código:
pac207	093a:2472	Genius VideoCam ge110
.



Nota: donde he puesto xawtv puedes cambiarlo por webcamoid, es decir
Código:
LD_PRELOAD=/usr/lib64/libv4l/v4l1compat.so webcamoid
o el programa que quieras usar, debería de funcionar correctamente.
__________________
--
hkp://subkeys.pgp.net
GNU/Linux Opensuse leap 42.1 x86_64
Linux Registered User #391410



(http://linuxcounter.net/)

Última edición por soyasi; 08-may-2015 a las 17:36
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a soyasi Por Este Mensaje:
mikrios (08-may-2015)
  #9  
Antiguo 12-may-2015, 11:24
Avatar de jhonny_ese
jhonny_ese jhonny_ese está desconectado
Habitual
 
Fecha de Ingreso: 13-agosto-2008
Ubicación: Vargas - Venezuela
Versión: Leap 42.1
Mensajes: 107
Agradecimientos: 6
Agradecido 4 Veces en 4 Mensajes
Poder de Credibilidad: 10
jhonny_ese está en el buen camino
Gracias a todos.
xawtv me va. Aunque debo decir que la resolución de esta cámara es asquerosa, Intentaré regalarme otra (si mi mujer me deja, ja,ja!)
Responder Citando
Respuesta

Marcadores

Etiquetas
genius, opensuse 13.2, webcam, webcamioid


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
problema al instalar webcam genius islim 310 compueasy Hardware 5 21-jul-2010 00:44
instalacion de webcam genius eye 310 BLACKOTZIN Hardware 2 08-dic-2008 04:06
Webcam Genius Model: videoCam GF112 guspasslike Hardware 1 26-mar-2007 11:24
ayuda con webcam genius trek roberttg Hardware 5 23-mar-2007 01:02
Webcam Genius NB y suse lince Hardware 4 30-ago-2005 19:56



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 12:06.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba