Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > General OpenSUSE


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Yast abre pero no funciona ( solucionado )
  #1  
Antiguo 21-feb-2015, 19:29
Avatar de enae
enae enae esta en línea ahora
Habitual
 
Fecha de Ingreso: 06-agosto-2013
Ubicación: / Home
Versión: Tumbleweed
Mensajes: 111
Agradecimientos: 85
Agradecido 24 Veces en 22 Mensajes
Poder de Credibilidad: 5
enae está en el buen camino
Yast abre pero no funciona ( solucionado )

Hola a toda la comunidad, llevo toda la tarde intentando solucionar el problema pero no lo consigo, si lo abro desde la consola y selecciono algo, me arroja esto en la consola,
Cita:
dynamic:/home/kdesuse # yast2
Run command: /sbin/yast2 repositories &
terminate called after throwing an instance of 'YUIPluginException'
what(): Couldn't load plug-in qt
YaST got signal 6 at YCP file /usr/share/YaST2/modules/Wizard.rb:817
/sbin/yast2: línea 378: 5221 Abortado $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS
Run command: /sbin/yast2 sw_single &
terminate called after throwing an instance of 'YUIPluginException'
what(): Couldn't load plug-in qt
YaST got signal 6 at YCP file /usr/share/YaST2/modules/Wizard.rb:817
/sbin/yast2: línea 378: 5247 Abortado $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS
Run command: /sbin/yast2 system_settings &
terminate called after throwing an instance of 'YUIPluginException'
what(): Couldn't load plug-in qt
YaST got signal 6 at YCP file /usr/share/YaST2/modules/Wizard.rb:817
/sbin/yast2: línea 378: 5271 Abortado $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS
espero alguien me abra una lucecita.
salu2
__________________

Última edición por enae; 23-feb-2015 a las 09:14
Responder Citando
  #2  
Antiguo 21-feb-2015, 19:53
Avatar de mikrios
mikrios mikrios esta en línea ahora
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.526
Agradecimientos: 1.909
Agradecido 1.400 Veces en 1.175 Mensajes
Poder de Credibilidad: 9
mikrios llegará a ser famoso muy pronto
Hola:

Pues debes tener algún conflicto con algo (puede ser de ruby, aunque no me suenan esos errores,cuando pruebo isos) .

Lo mas parecido que encontré es esto del forum, pero en esa época , yast creo que no usaba ruby .
Tampoco se si lo solucionaron .

"https://forums.opensuse.org/showthread.php/394564-YaST-got-signal-6-at-YCP"

y del foro de hace años esto : "http://www.forosuse.org/forosuse/archive/index.php/t-18867.html"

Si es por ruby, has ejecutado yast desde consola (no yast2 si no yast) ? .

Mira de reinstalar yast haber si se soluciona.

Saludos cordiales
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a mikrios Por Este Mensaje:
enae (23-feb-2015)
  #3  
Antiguo 21-feb-2015, 22:44
Avatar de enae
enae enae esta en línea ahora
Habitual
 
Fecha de Ingreso: 06-agosto-2013
Ubicación: / Home
Versión: Tumbleweed
Mensajes: 111
Agradecimientos: 85
Agradecido 24 Veces en 22 Mensajes
Poder de Credibilidad: 5
enae está en el buen camino
Hola, al solicitar yast solo, arroja esto:


Código PHP:
dynamic:/home/kdesuse # yast
terminate called after throwing an instance of 'YUIPluginException'
  
what():  Couldn't load plug-in ncurses
YaST got signal 6 at YCP file /usr/share/YaST2/clients/menu.rb:193
/sbin/yast: línea 378:  1663 Abortado                $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_A 
salu2
__________________
Responder Citando
  #4  
Antiguo 22-feb-2015, 01:15
Avatar de soyasi
soyasi soyasi está desconectado
Miembro Senior
 
Fecha de Ingreso: 26-julio-2005
Ubicación: Atlántida
Versión: leap 42.1
Mensajes: 850
Agradecimientos: 187
Agradecido 323 Veces en 221 Mensajes
Poder de Credibilidad: 13
soyasi está en el buen camino
yo solo he encontrado esto, pero no me arroja mucha luz tampoco.
__________________
--
hkp://subkeys.pgp.net
GNU/Linux Opensuse leap 42.1 x86_64
Linux Registered User #391410



(http://linuxcounter.net/)
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a soyasi Por Este Mensaje:
enae (23-feb-2015)
  #5  
Antiguo 22-feb-2015, 02:42
Avatar de mikrios
mikrios mikrios esta en línea ahora
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.526
Agradecimientos: 1.909
Agradecido 1.400 Veces en 1.175 Mensajes
Poder de Credibilidad: 9
mikrios llegará a ser famoso muy pronto
Hola:

Yast tiene un entorno gráfico distinto a Yast2 (aunque cuando lo ejecutas muestra arriba yast2 menú ) .

He observado cuando hago pruebas que ha veces se cerraban aplicaciones de yast2 o el conjunto completo, pero si funcionaba yast desde consola, donde podías hacer lo mismo y sin problemas (en algunos de los casos, me indicaban que los fallos de yast2 era algo relacionado con ruby ) .

Las pruebas las hacia con factory cuando aún estaba en desarrollo y me ayudaba de herramientas como strace (ejemplo strace yast )

Pero cuando afecta a los 2 creo que sea algo común y que afecta a la funcionalidad de él ( y por lo que veo casi coinciden los dos logs) .

El enlace de soyasi es mas reciente y en el log que tu has puesto hace mención a que no puede cargar plug in en qt y en el de yast un plug in ncurses , aunque las lineas son distintas en los enlaces, pueden que estén relacionados (me supongo que están continuamente reescribiendo el código y estas cambien debido a las actualizaciones, pero en la versión que tu tienes coinciden en ambos yast en la linea 378 y uno de ellos no veo que haga una llamada a qt ) .

No se si el reinstalar yast2 por completo solucione el problema y las dependencias que pudiesen tener, pienso no se que opinaran, de hacerlo a través de zypper y no desde la pagina de descargas, debido a las actualizaciones que han habido; hay distintos módulos que no coinciden con el paquete que proporciona el enlace de descargas "http://software.opensuse.org/package/yast2" .

Por lo menos en mi versión aparecen estos :
Código:
X79-PRO:~ # zypper se -si yast2
Loading repository data...
Reading installed packages...

S | Name                          | Type    | Version      | Arch   | Repository       
--+-------------------------------+---------+--------------+--------+------------------
i | yast2-printer                 | package | 3.1.2-2.2    | x86_64 | repo-oss         
i | patterns-openSUSE-yast2_basis | package | 20150105-3.1 | x86_64 | repo-oss         
i | yast2                         | package | 3.1.121-1.1  | x86_64 | repo-oss         
i | yast2-bootloader              | package | 3.1.120-1.1  | x86_64 | repo-oss         
i | yast2-control-center          | package | 3.1.5-1.2    | x86_64 | repo-oss         
i | yast2-control-center-qt       | package | 3.1.5-1.2    | x86_64 | repo-oss         
i | yast2-core                    | package | 3.1.15-1.2   | x86_64 | repo-oss         
i | yast2-country                 | package | 3.1.18-1.1   | x86_64 | repo-oss         
i | yast2-country-data            | package | 3.1.18-1.1   | x86_64 | repo-oss         
i | yast2-hardware-detection      | package | 3.1.5-1.2    | x86_64 | repo-oss         
i | yast2-ldap                    | package | 3.1.13-1.2   | x86_64 | repo-oss         
i | yast2-network                 | package | 3.1.113-1.2  | x86_64 | repo-oss         
i | yast2-nis-client              | package | 3.1.12-1.1   | x86_64 | repo-oss         
i | yast2-packager                | package | 3.1.62-1.1   | x86_64 | repo-oss         
i | yast2-perl-bindings           | package | 3.1.2-3.3    | x86_64 | repo-oss         
i | yast2-pkg-bindings            | package | 3.1.21-1.1   | x86_64 | repo-oss         
i | yast2-ruby-bindings           | package | 3.1.28-1.1   | x86_64 | repo-oss         
i | yast2-scanner                 | package | 3.1.2-2.2    | x86_64 | repo-oss         
i | yast2-slp                     | package | 3.1.7-1.9    | x86_64 | (System Packages)
i | yast2-snapper                 | package | 3.1.5-1.3    | x86_64 | repo-oss         
i | yast2-sound                   | package | 3.1.7-1.1    | x86_64 | repo-oss         
i | yast2-storage                 | package | 3.1.52-1.1   | x86_64 | repo-oss         
i | yast2-transfer                | package | 3.1.1-4.1    | x86_64 | repo-oss         
i | yast2-tune                    | package | 3.1.6-2.2    | x86_64 | repo-oss         
i | yast2-update                  | package | 3.1.27-1.1   | x86_64 | repo-oss         
i | yast2-users                   | package | 3.1.36-1.2   | x86_64 | repo-oss         
i | yast2-vm                      | package | 3.1.21-1.2   | x86_64 | repo-oss         
i | yast2-x11                     | package | 3.1.3-3.2    | x86_64 | repo-oss         
i | yast2-xml                     | package | 3.1.1-3.3    | x86_64 | repo-oss         
i | yast2-ycp-ui-bindings         | package | 3.1.7-3.3    | x86_64 | repo-oss         
i | autoyast2-installation        | package | 3.1.72-3.1   | noarch | repo-oss         
i | yast2-add-on                  | package | 3.1.10-1.2   | noarch | repo-oss         
i | yast2-apparmor                | package | 3.1.3-1.1    | noarch | repo-oss         
i | yast2-branding-openSUSE       | package | 3.1.32-1.1   | noarch | repo-oss         
i | yast2-firewall                | package | 3.1.3-1.2    | noarch | repo-oss         
i | yast2-inetd                   | package | 3.1.10-1.2   | noarch | repo-oss         
i | yast2-inetd-doc               | package | 3.1.10-1.2   | noarch | repo-oss         
i | yast2-installation            | package | 3.1.132-1.1  | noarch | repo-oss         
i | yast2-iscsi-client            | package | 3.1.21-1.1   | noarch | repo-oss         
i | yast2-mail                    | package | 3.1.5-1.2    | noarch | repo-oss         
i | yast2-metapackage-handler     | package | 3.1.4-1.1    | noarch | repo-oss         
i | yast2-nfs-client              | package | 3.1.13-1.2   | noarch | repo-oss         
i | yast2-nfs-common              | package | 3.1.8-1.2    | noarch | repo-oss         
i | yast2-ntp-client              | package | 3.1.13-1.2   | noarch | repo-oss         
i | yast2-online-update           | package | 3.1.11-1.1   | noarch | repo-oss         
i | yast2-online-update-frontend  | package | 3.1.11-1.1   | noarch | repo-oss         
i | yast2-pam                     | package | 3.1.1-3.3    | noarch | repo-oss         
i | yast2-proxy                   | package | 3.1.3-1.1    | noarch | repo-oss         
i | yast2-qt-branding-openSUSE    | package | 13.2-10.40   | noarch | repo-oss         
i | yast2-samba-client            | package | 3.1.15-2.2   | noarch | repo-oss         
i | yast2-samba-server            | package | 3.1.12-2.2   | noarch | repo-oss         
i | yast2-security                | package | 3.1.8-1.2    | noarch | repo-oss         
i | yast2-services-manager        | package | 3.1.39-2.1   | noarch | repo-oss         
i | yast2-sudo                    | package | 3.1.2-1.1    | noarch | repo-oss         
i | yast2-sysconfig               | package | 3.1.2-1.2    | noarch | repo-oss         
i | yast2-trans-es                | package | 3.1.0-9.1    | noarch | (System Packages)
i | yast2-trans-stats             | package | 2.19.0-17.2  | noarch | repo-oss         
i | yast2_basis                   | pattern | 20150105-3.1 | x86_64 | repo-oss
Es decir mejor hacer un zypper in yast*

También tener en cuenta que estás con tumbleweed y si has elegido btrfs, tienes también la posibilidad de arrancar de una instantánea anterior ( snapshots ) ; la cual podría descartar algún problema de actualizaciones o operaciones que se pudiesen haber hecho con anterioridad (lo que no recuerdo si las opciones de estas son solo de lectura ).

Otra posibilidad si se ve que una instantánea funciona, es restaurarla desde una terminal tty (se que mas o menos puede ser fácil, pero no se me ha dado el caso, por lo cual no tengo mucha experiencia hacerlo desde ese modo , pero es ejecutar por ejemplo snapper list (para hacer un listado de ellas) y snapper mount nº de instantánea (ejemplo: snapper mount 34 ; de todas formas si arrancas bien con una ya sabes cual es la que funciona ) .

Saludos cordiales
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a mikrios Por Este Mensaje:
enae (23-feb-2015)
  #6  
Antiguo 22-feb-2015, 09:20
Avatar de enae
enae enae esta en línea ahora
Habitual
 
Fecha de Ingreso: 06-agosto-2013
Ubicación: / Home
Versión: Tumbleweed
Mensajes: 111
Agradecimientos: 85
Agradecido 24 Veces en 22 Mensajes
Poder de Credibilidad: 5
enae está en el buen camino
Hola, zypper in yast* arroja lo siguiente:
Código PHP:
dynamic:/home/kdesuse # zypper in yast*
PackageKit está bloqueando la ejecución de zypperEsto sucede si tiene un applet de actualización u otro administrador de software utilizando PackageKit.
¿Solicitar a PackageKit interrumpir el proceso y salir? [si/no] (no): si
PackageKit se encuentra en ejecución 
(probablemente ocupado).
¿Reintentar? [si/no] (no): si
Obteniendo los datos del repositorio
...
Leyendo los paquetes instalados...
El paquete 'yast2-mouse' que proporciona 'yast*' ya está instalado.
El paquete 'yast2-mouse' no se encuentra en los repositoriosNo se puede reinstalaractualizaro desactualizar.
Resolviendo dependencias...

Problemayast2-update-3.1.23-1.7.x86_64 requiere yast2-pkg-bindings >= 3.1.14pero este requisito no puede cumplirse
  proveedores no instalables
yast2-pkg-bindings-3.1.20-1.1.i586[openSUSE Current oss]
                   
yast2-pkg-bindings-3.1.20-1.1.x86_64[openSUSE Current oss]
                   
yast2-pkg-bindings-3.1.20-6.1.i586[openSUSE Current update]
                   
yast2-pkg-bindings-3.1.20-6.1.x86_64[openSUSE Current update]
 
Solución 1Se realizarán las siguientes acciones:
  
desinstalación de libyui-ncurses-pkg5-2.44.4-2.1.5.x86_64
  desinstalación de libyui
-qt-pkg5-2.42.13-2.4.1.x86_64
 Solución 2
no instalar yast2-update-3.1.23-1.7.x86_64
 Solución 3
no instalar yast2-update-3.1.23-1.7.x86_64
 Solución 4
romper yast2-update-3.1.23-1.7.x86_64 ignorando algunas de sus dependencias

Elija la solución usando 
'1'o cancele usando 'c' [1/2/3/4/c] (c): 
en cuanto al sistema de archivos, todavía esta en ext4.

y edito para añadir esto:
Código:
Cita:
dynamic:/home/kdesuse # zypper se -si yast2 Obteniendo los datos del repositorio... Leyendo los paquetes instalados... E | Nombre | Tipo | Versión | Arquitectura | Repositorio --+-------------------------------+----------+---------------+--------------+------------------------ i | autoyast2-installation | paquete | 3.0.8-5.1 | noarch | (Paquetes del sistema) i | patterns-openSUSE-yast2_basis | paquete | 20141007-5.1 | x86_64 | openSUSE Current update i | yast2 | paquete | 3.0.14-17.1 | x86_64 | (Paquetes del sistema) i | yast2-add-on | paquete | 3.0.3-4.1 | noarch | (Paquetes del sistema) i | yast2-apparmor | paquete | 3.0.1-2.1.4 | noarch | (Paquetes del sistema) i | yast2-backup | paquete | 3.0.0-2.1.4 | noarch | (Paquetes del sistema) i | yast2-bootloader | paquete | 3.0.3-2.1.3 | x86_64 | (Paquetes del sistema) i | yast2-branding-openSUSE | paquete | 3.1.31-2.1 | noarch | openSUSE Current oss i | yast2-control-center | paquete | 3.1.3-2.1.4 | x86_64 | openSUSE Current oss i | yast2-control-center-qt | paquete | 3.1.3-2.1.4 | x86_64 | openSUSE Current oss i | yast2-core | paquete | 3.0.3-1.1 | x86_64 | (Paquetes del sistema) i | yast2-country | paquete | 3.0.2-1.1 | x86_64 | (Paquetes del sistema) i | yast2-country-data | paquete | 3.1.13.1-4.1 | x86_64 | openSUSE Current update i | yast2-firewall | paquete | 3.1.1-3.1.10 | noarch | openSUSE Current oss i | yast2-hardware-detection | paquete | 3.0.1-2.1.3 | x86_64 | (Paquetes del sistema) i | yast2-inetd | paquete | 3.1.9-1.2 | noarch | openSUSE Current oss i | yast2-inetd-doc | paquete | 3.1.9-1.2 | noarch | openSUSE Current oss i | yast2-installation | paquete | 3.0.8-1.1 | noarch | (Paquetes del sistema) i | yast2-irda | paquete | 2.23.0-2.1.2 | noarch | (Paquetes del sistema) i | yast2-iscsi-client | paquete | 3.1.17-1.4 | noarch | openSUSE Current oss i | yast2-kerberos-client | paquete | 3.0.0-2.1.4 | noarch | (Paquetes del sistema) i | yast2-ldap | paquete | 3.0.1-2.1.3 | x86_64 | (Paquetes del sistema) i | yast2-ldap-client | paquete | 3.0.2-2.4.1 | noarch | (Paquetes del sistema) i | yast2-mail | paquete | 3.1.4-1.4 | noarch | openSUSE Current oss i | yast2-metapackage-handler | paquete | 3.1.3-2.1.4 | noarch | openSUSE Current oss i | yast2-mouse | paquete | 2.21.0-7.1.2 | x86_64 | (Paquetes del sistema) i | yast2-network | paquete | 3.0.9-10.2 | x86_64 | (Paquetes del sistema) i | yast2-nfs-client | paquete | 3.1.9-1.9 | noarch | openSUSE Current oss i | yast2-nfs-common | paquete | 3.1.7-2.1.10 | noarch | openSUSE Current oss i | yast2-nis-client | paquete | 3.0.1-2.4.3 | x86_64 | (Paquetes del sistema) i | yast2-ntp-client | paquete | 3.0.1-7.1 | noarch | (Paquetes del sistema) i | yast2-online-update | paquete | 3.0.0-2.1.4 | noarch | (Paquetes del sistema) i | yast2-online-update-frontend | paquete | 3.1.7-1.7 | noarch | openSUSE Current oss i | yast2-packager | paquete | 3.0.8-1.1 | x86_64 | (Paquetes del sistema) i | yast2-pam | paquete | 3.1.1-2.1.10 | noarch | openSUSE Current oss i | yast2-perl-bindings | paquete | 3.0.1-3.1 | x86_64 | (Paquetes del sistema) i | yast2-pkg-bindings | paquete | 3.0.3-8.1 | x86_64 | (Paquetes del sistema) i | yast2-printer | paquete | 3.1.1.1-2.4.1 | x86_64 | openSUSE Current update i | yast2-proxy | paquete | 3.1.2-1.1 | noarch | openSUSE Current oss i | yast2-qt-branding-openSUSE | paquete | 13.2-3.6.1 | noarch | openSUSE Current oss i | yast2-restore | paquete | 3.0.0-2.1.4 | noarch | (Paquetes del sistema) i | yast2-ruby-bindings | paquete | 3.1.24-1.1 | x86_64 | openSUSE Current oss i | yast2-runlevel | paquete | 3.0.1-1.1 | noarch | (Paquetes del sistema) i | yast2-samba-client | paquete | 3.0.1-3.1 | noarch | (Paquetes del sistema) i | yast2-samba-server | paquete | 3.0.2-2.1.4 | noarch | (Paquetes del sistema) i | yast2-scanner | paquete | 3.1.1.1-2.4.1 | x86_64 | openSUSE Current update i | yast2-security | paquete | 3.1.4-2.1.8 | noarch | openSUSE Current oss i | yast2-services-manager | paquete | 0.0.11-3.4.1 | noarch | (Paquetes del sistema) i | yast2-slp | paquete | 3.0.2-1.1 | x86_64 | (Paquetes del sistema) i | yast2-sound | paquete | 3.0.3-1.1 | x86_64 | (Paquetes del sistema) i | yast2-storage | paquete | 3.0.9-4.2 | x86_64 | (Paquetes del sistema) i | yast2-sudo | paquete | 3.1.1-2.1.9 | noarch | openSUSE Current oss i | yast2-sysconfig | paquete | 3.1.1-2.1.10 | noarch | openSUSE Current oss i | yast2-trans-es | paquete | 3.1.0-9.1 | noarch | openSUSE Current update i | yast2-trans-stats | paquete | 2.19.0-16.1.3 | noarch | openSUSE Current oss i | yast2-transfer | paquete | 3.0.1-2.1.3 | x86_64 | (Paquetes del sistema) i | yast2-tune | paquete | 3.1.5-2.1.10 | x86_64 | openSUSE Current oss i | yast2-tv | paquete | 2.21.4-7.1.2 | noarch | (Paquetes del sistema) i | yast2-update | paquete | 3.0.4-2.1.4 | x86_64 | (Paquetes del sistema) i | yast2-users | paquete | 3.0.1-2.1.4 | x86_64 | (Paquetes del sistema) i | yast2-vm | paquete | 3.1.18-2.1.9 | x86_64 | openSUSE Current oss i | yast2-x11 | paquete | 3.1.3-2.1.2 | x86_64 | openSUSE Current oss i | yast2-xml | paquete | 3.0.0-2.1.2 | x86_64 | (Paquetes del sistema) i | yast2-ycp-ui-bindings | paquete | 3.1.7-2.1.3 | x86_64 | openSUSE Current oss
salu2
__________________

Última edición por enae; 22-feb-2015 a las 09:30 Razón: mas info
Responder Citando
  #7  
Antiguo 22-feb-2015, 19:31
Avatar de mikrios
mikrios mikrios esta en línea ahora
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.526
Agradecimientos: 1.909
Agradecido 1.400 Veces en 1.175 Mensajes
Poder de Credibilidad: 9
mikrios llegará a ser famoso muy pronto
Hola:

Bueno con raíz ext4, me supongo que lo de restauración no esta disponible .

Veo que los módulos de yast los tienes con distintas versiones, casi todas deberían estar a 3.1 (no se porque a ti no te salen si tienes la misma versión ) .

¿has cambiado los repositorios a tumbleweed? , o has dejado por defecto los que instala ; ten en cuenta que hay un fecha limite (no se si es para este mes o el que viene deben estar pasados a tumbleweed todos ellos ) .

Si lo has hecho, por que no se han actualizado (que puedes averiguar de /var/log/YaST2/ los archivos de y2log , en el caso que también los tengas los y2changes, y con algunas comprobaciones se crea una carpeta de solverTestcase, el problema es que al no funcionar yast, no puedas hacerlo desde la aplicación de instalar software ) .

No se que riesgo pueda suponer el actualizar todo yast2 , pero a través de un dup.

Si fuese mi caso primero intento averiguar que fue lo que provoco el fallo (mirando en /var/log/ ) y también si existe algún problema detectado en el bugzilla, forum etc , ademas de los errores que me arrojen de la consola y del strace .

Segundo comprobaría las dependencias ( zypper ve o un zypper ve -D ) , se que en muchos de los casos , va a dar lo mismo que pudiera dar el instalador de soft de yast2 (es decir que las dependencias están ok. ) .

También usaría un zypper wp (actualmente se cambia por zypper se --provides --match-exact ) ; pero cambiando las opciones miraría lo que tengo de yast2 con un simple zypper se -si o zypper se -i --provides yast2 .

Creo que con eso obtengo todo lo relacionado con Yast (incluido las librerías afectadas ncurses y las qt , que están implicadas en ambos yast) :

Código:
X79-PRO:~ # zypper se -si  --provides yast2          
Loading repository data...
Reading installed packages...

S | Name                          | Type    | Version      | Arch   | Repository       
--+-------------------------------+---------+--------------+--------+------------------
i | yast2-printer                 | package | 3.1.2-2.2    | x86_64 | repo-oss         
i | libyui-ncurses-pkg6           | package | 2.46.2-1.2   | x86_64 | repo-oss         
i | libyui-ncurses6               | package | 2.46.8-1.2   | x86_64 | repo-oss         
i | libyui-qt-graph6              | package | 2.44.3-1.2   | x86_64 | repo-oss         
i | libyui-qt-pkg6                | package | 2.44.8-1.2   | x86_64 | repo-oss         
i | libyui-qt6                    | package | 2.46.17-1.1  | x86_64 | repo-oss         
i | libyui6                       | package | 3.1.5-1.3    | x86_64 | repo-oss         
i | libzypp                       | package | 14.34.0-1.2  | x86_64 | repo-oss         
i | openSUSE-release              | package | 20150216-1.2 | x86_64 | (System Packages)
i | patterns-openSUSE-yast2_basis | package | 20150105-3.1 | x86_64 | repo-oss         
i | yast2                         | package | 3.1.121-1.1  | x86_64 | repo-oss         
i | yast2-bootloader              | package | 3.1.120-1.1  | x86_64 | repo-oss         
i | yast2-control-center          | package | 3.1.5-1.2    | x86_64 | repo-oss         
i | yast2-control-center-qt       | package | 3.1.5-1.2    | x86_64 | repo-oss         
i | yast2-core                    | package | 3.1.15-1.2   | x86_64 | repo-oss         
i | yast2-country                 | package | 3.1.18-1.1   | x86_64 | repo-oss         
i | yast2-country-data            | package | 3.1.18-1.1   | x86_64 | repo-oss         
i | yast2-hardware-detection      | package | 3.1.5-1.2    | x86_64 | repo-oss         
i | yast2-ldap                    | package | 3.1.13-1.2   | x86_64 | repo-oss         
i | yast2-network                 | package | 3.1.113-1.2  | x86_64 | repo-oss         
i | yast2-nis-client              | package | 3.1.12-1.1   | x86_64 | repo-oss         
i | yast2-packager                | package | 3.1.62-1.1   | x86_64 | repo-oss         
i | yast2-perl-bindings           | package | 3.1.2-3.3    | x86_64 | repo-oss         
i | yast2-pkg-bindings            | package | 3.1.21-1.1   | x86_64 | repo-oss         
i | yast2-ruby-bindings           | package | 3.1.28-1.1   | x86_64 | repo-oss         
i | yast2-scanner                 | package | 3.1.2-2.2    | x86_64 | repo-oss         
i | yast2-slp                     | package | 3.1.7-1.9    | x86_64 | (System Packages)
i | yast2-snapper                 | package | 3.1.5-1.3    | x86_64 | repo-oss         
i | yast2-sound                   | package | 3.1.7-1.1    | x86_64 | repo-oss         
i | yast2-storage                 | package | 3.1.52-1.1   | x86_64 | repo-oss         
i | yast2-transfer                | package | 3.1.1-4.1    | x86_64 | repo-oss         
i | yast2-tune                    | package | 3.1.6-2.2    | x86_64 | repo-oss         
i | yast2-update                  | package | 3.1.27-1.1   | x86_64 | repo-oss         
i | yast2-users                   | package | 3.1.36-1.2   | x86_64 | repo-oss         
i | yast2-vm                      | package | 3.1.21-1.2   | x86_64 | repo-oss         
i | yast2-x11                     | package | 3.1.3-3.2    | x86_64 | repo-oss         
i | yast2-xml                     | package | 3.1.1-3.3    | x86_64 | repo-oss         
i | yast2-ycp-ui-bindings         | package | 3.1.7-3.3    | x86_64 | repo-oss         
i | autoyast2-installation        | package | 3.1.72-3.1   | noarch | repo-oss         
i | yast2-add-on                  | package | 3.1.10-1.2   | noarch | repo-oss         
i | yast2-apparmor                | package | 3.1.3-1.1    | noarch | repo-oss         
i | yast2-branding-openSUSE       | package | 3.1.32-1.1   | noarch | repo-oss         
i | yast2-firewall                | package | 3.1.3-1.2    | noarch | repo-oss         
i | yast2-inetd                   | package | 3.1.10-1.2   | noarch | repo-oss         
i | yast2-inetd-doc               | package | 3.1.10-1.2   | noarch | repo-oss         
i | yast2-installation            | package | 3.1.132-1.1  | noarch | repo-oss         
i | yast2-iscsi-client            | package | 3.1.21-1.1   | noarch | repo-oss         
i | yast2-mail                    | package | 3.1.5-1.2    | noarch | repo-oss         
i | yast2-metapackage-handler     | package | 3.1.4-1.1    | noarch | repo-oss         
i | yast2-nfs-client              | package | 3.1.13-1.2   | noarch | repo-oss         
i | yast2-nfs-common              | package | 3.1.8-1.2    | noarch | repo-oss         
i | yast2-ntp-client              | package | 3.1.13-1.2   | noarch | repo-oss         
i | yast2-online-update           | package | 3.1.11-1.1   | noarch | repo-oss         
i | yast2-online-update-frontend  | package | 3.1.11-1.1   | noarch | repo-oss         
i | yast2-pam                     | package | 3.1.1-3.3    | noarch | repo-oss         
i | yast2-proxy                   | package | 3.1.3-1.1    | noarch | repo-oss         
i | yast2-qt-branding-openSUSE    | package | 13.2-10.40   | noarch | repo-oss         
i | yast2-samba-client            | package | 3.1.15-2.2   | noarch | repo-oss         
i | yast2-samba-server            | package | 3.1.12-2.2   | noarch | repo-oss         
i | yast2-security                | package | 3.1.8-1.2    | noarch | repo-oss         
i | yast2-services-manager        | package | 3.1.39-2.1   | noarch | repo-oss         
i | yast2-sudo                    | package | 3.1.2-1.1    | noarch | repo-oss         
i | yast2-sysconfig               | package | 3.1.2-1.2    | noarch | repo-oss         
i | yast2-trans-es                | package | 3.1.0-9.1    | noarch | (System Packages)
i | yast2-trans-stats             | package | 2.19.0-17.2  | noarch | repo-oss         
i | yast2_basis                   | pattern | 20150105-3.1 | x86_64 | repo-oss
Seguido repito la misma operación pero sin la opción de -i (por lo cual veo las instaladas y las demás, compruebo si hay versiones superiores etc . (con la opción -s veo de que proveedor es ) .

Hecho esas comprobaciones, ya sería correr el riesgo de actualizar, instalar o forzar una instalación, ya sea general o individual (dependiendo si he detectado un problema en una de sus partes, vamos lo que en yast a veces sale de color rojo ) .

Ahí aplicaría un zypper in yast* o si eso no va un zypper up yast2 o algo por el estilo, y si quiero pues un zypper dup (pero ojo añadiendo sus opciones de los repositorios) y si no tendría que cuidarme bien de tener los repositorios de forma correcta (ya que si no podría hacer un desastre ) .

Mis repositorios mas o menos son estos :
Código:
X79-PRO:~ # zypper lr -p
#  | Alias                                 | Name                                  | Enabled | Refresh | Priority
---+---------------------------------------+---------------------------------------+---------+---------+---------
 1 | Education/openSUSE_Tumbleweed         | Education/openSUSE_Tumbleweed         | Yes     | Yes     |   99    
 2 | KDE:/Extra                            | KDE:/Extra                            | Yes     | Yes     |   99    
 3 | Kernel:/stable/standard               | Kernel:/stable/standard               | Yes     | Yes     |   90    
 4 | Printing/openSUSE_Tumbleweed          | Printing/openSUSE_Tumbleweed          | Yes     | Yes     |   99    
 5 | SUSEStudio/openSUSE_Tumbleweed        | SUSEStudio/openSUSE_Tumbleweed        | Yes     | Yes     |   99    
 6 | VirtualBox_Tumbleweed                 | VirtualBox_Tumbleweed                 | Yes     | Yes     |   99    
 7 | Virtualization/Kernel_stable_standard | Virtualization/Kernel_stable_standard | Yes     | Yes     |   90    
 8 | http-download.opensuse.org-c3996aea   | devel:tools                           | Yes     | Yes     |   99    
 9 | packman                               | packman                               | Yes     | Yes     |   70    
10 | repo-debug                            | repo-debug                            | Yes     | Yes     |   99    
11 | repo-non-oss                          | repo-non-oss                          | Yes     | Yes     |   99    
12 | repo-oss                              | repo-oss                              | Yes     | Yes     |   99    
13 | repo-src-non-oss                      | repo-src-non-oss                      | No      | Yes     |   99    
14 | repo-src-oss                          | repo-src-oss                          | No      | Yes     |   99    
15 | tumbleweed/repo/debug/                | tumbleweed/repo/debug/                | Yes     | Yes     |   99
No se si se puede hacer lo mismo que up , (por ejemplo un zypper dup yast) , pero por lo menos me preocuparía de tener los repos principales de la distribución con una prioridad mas alta, en el caso de hacer un dup (algo de lo que tengo duda, es si dup tiene en cuenta la prioridad, si es así cambiaría los non-oss y oss a un nº mas bajo ( bajo ===> prioridad mas alta) .

Todo eso es lo que me plantearía para resolver ese problema, que incluso a veces he tenido algunos similares y no he tenido que hacer absolutamente nada (una posterior actualización lo resolvió ) .

Es un poco lioso, no se que opinaran los demás , pero (por ahora no uses el dup) prueba con el zypper up yast2 (se que había una forma de forzar la actualización , creo que sin usar el dup, pero ahora no me acuerdo ) .

También si no te importa dar la lista de los repositorios zypper lr -u -p y ver un poco como tienes el yast con zypper se -si --provides yast2 .

No si la opción que en principio, había descartado de "http://software.opensuse.org/package/yast2", podría solucionar el problema (como tenía duda, prefiero consultarlo con alguien mas experto) .

Saludos cordiales

Última edición por mikrios; 22-feb-2015 a las 20:50 Razón: corregir
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a mikrios Por Este Mensaje:
enae (23-feb-2015)
  #8  
Antiguo 23-feb-2015, 01:23
Avatar de enae
enae enae esta en línea ahora
Habitual
 
Fecha de Ingreso: 06-agosto-2013
Ubicación: / Home
Versión: Tumbleweed
Mensajes: 111
Agradecimientos: 85
Agradecido 24 Veces en 22 Mensajes
Poder de Credibilidad: 5
enae está en el buen camino
Hola,
los dos comandos de consola arrojan el siguiente registro,

Código:
dynamic:/home/kdesuse # zypper se -si  --provides yast2 
Obteniendo los datos del repositorio...
Leyendo los paquetes instalados...

E | Nombre                        | Tipo     | Versión        | Arquitectura | Repositorio            
--+-------------------------------+----------+----------------+--------------+------------------------
i | autoyast2-installation        | paquete  | 3.0.8-5.1      | noarch       | (Paquetes del sistema) 
i | libstorage4                   | paquete  | 2.24.8-3.1     | x86_64       | (Paquetes del sistema) 
i | libyui-ncurses-pkg5           | paquete  | 2.44.4-2.1.5   | x86_64       | (Paquetes del sistema) 
i | libyui-ncurses4               | paquete  | 2.43.3.1-1.5.1 | x86_64       | (Paquetes del sistema) 
i | libyui-ncurses5               | paquete  | 2.44.1-2.1.4   | x86_64       | (Paquetes del sistema) 
i | libyui-qt-graph5              | paquete  | 2.42.7-2.2.1   | x86_64       | (Paquetes del sistema) 
i | libyui-qt-pkg5                | paquete  | 2.42.13-2.4.1  | x86_64       | (Paquetes del sistema) 
i | libyui-qt4                    | paquete  | 2.42.5-1.1.1   | x86_64       | (Paquetes del sistema) 
i | libyui-qt5                    | paquete  | 2.43.5-2.1.4   | x86_64       | (Paquetes del sistema) 
i | libyui4                       | paquete  | 2.42.6-1.1.1   | x86_64       | (Paquetes del sistema) 
i | libyui5                       | paquete  | 3.0.10-2.1.4   | x86_64       | (Paquetes del sistema) 
i | libyui6                       | paquete  | 3.1.4-1.8      | x86_64       | openSUSE Current oss   
i | libzypp                       | paquete  | 13.10.4-23.1   | x86_64       | (Paquetes del sistema) 
i | openSUSE-release              | paquete  | 13.1-1.10      | x86_64       | (Paquetes del sistema) 
i | patterns-openSUSE-yast2_basis | paquete  | 20141007-5.1   | x86_64       | openSUSE Current update
i | yast2                         | paquete  | 3.0.14-17.1    | x86_64       | (Paquetes del sistema) 
i | yast2-add-on                  | paquete  | 3.0.3-4.1      | noarch       | (Paquetes del sistema) 
i | yast2-apparmor                | paquete  | 3.0.1-2.1.4    | noarch       | (Paquetes del sistema) 
i | yast2-backup                  | paquete  | 3.0.0-2.1.4    | noarch       | (Paquetes del sistema) 
i | yast2-bootloader              | paquete  | 3.0.3-2.1.3    | x86_64       | (Paquetes del sistema) 
i | yast2-branding-openSUSE       | paquete  | 3.1.31-2.1     | noarch       | openSUSE Current oss   
i | yast2-control-center          | paquete  | 3.1.3-2.1.4    | x86_64       | openSUSE Current oss   
i | yast2-control-center-qt       | paquete  | 3.1.3-2.1.4    | x86_64       | openSUSE Current oss   
i | yast2-core                    | paquete  | 3.0.3-1.1      | x86_64       | (Paquetes del sistema) 
i | yast2-country                 | paquete  | 3.0.2-1.1      | x86_64       | (Paquetes del sistema) 
i | yast2-country-data            | paquete  | 3.1.13.1-4.1   | x86_64       | openSUSE Current update
i | yast2-firewall                | paquete  | 3.1.1-3.1.10   | noarch       | openSUSE Current oss   
i | yast2-hardware-detection      | paquete  | 3.0.1-2.1.3    | x86_64       | (Paquetes del sistema) 
i | yast2-inetd                   | paquete  | 3.1.9-1.2      | noarch       | openSUSE Current oss   
i | yast2-inetd-doc               | paquete  | 3.1.9-1.2      | noarch       | openSUSE Current oss   
i | yast2-installation            | paquete  | 3.0.8-1.1      | noarch       | (Paquetes del sistema) 
i | yast2-irda                    | paquete  | 2.23.0-2.1.2   | noarch       | (Paquetes del sistema) 
i | yast2-iscsi-client            | paquete  | 3.1.17-1.4     | noarch       | openSUSE Current oss   
i | yast2-kerberos-client         | paquete  | 3.0.0-2.1.4    | noarch       | (Paquetes del sistema) 
i | yast2-ldap                    | paquete  | 3.0.1-2.1.3    | x86_64       | (Paquetes del sistema) 
i | yast2-ldap-client             | paquete  | 3.0.2-2.4.1    | noarch       | (Paquetes del sistema) 
i | yast2-mail                    | paquete  | 3.1.4-1.4      | noarch       | openSUSE Current oss   
i | yast2-metapackage-handler     | paquete  | 3.1.3-2.1.4    | noarch       | openSUSE Current oss   
i | yast2-mouse                   | paquete  | 2.21.0-7.1.2   | x86_64       | (Paquetes del sistema) 
i | yast2-network                 | paquete  | 3.0.9-10.2     | x86_64       | (Paquetes del sistema) 
i | yast2-nfs-client              | paquete  | 3.1.9-1.9      | noarch       | openSUSE Current oss   
i | yast2-nfs-common              | paquete  | 3.1.7-2.1.10   | noarch       | openSUSE Current oss   
i | yast2-nis-client              | paquete  | 3.0.1-2.4.3    | x86_64       | (Paquetes del sistema) 
i | yast2-ntp-client              | paquete  | 3.0.1-7.1      | noarch       | (Paquetes del sistema) 
i | yast2-online-update           | paquete  | 3.0.0-2.1.4    | noarch       | (Paquetes del sistema) 
i | yast2-online-update-frontend  | paquete  | 3.1.7-1.7      | noarch       | openSUSE Current oss   
i | yast2-packager                | paquete  | 3.0.8-1.1      | x86_64       | (Paquetes del sistema) 
i | yast2-pam                     | paquete  | 3.1.1-2.1.10   | noarch       | openSUSE Current oss   
i | yast2-perl-bindings           | paquete  | 3.0.1-3.1      | x86_64       | (Paquetes del sistema) 
i | yast2-pkg-bindings            | paquete  | 3.0.3-8.1      | x86_64       | (Paquetes del sistema) 
i | yast2-printer                 | paquete  | 3.1.1.1-2.4.1  | x86_64       | openSUSE Current update
i | yast2-proxy                   | paquete  | 3.1.2-1.1      | noarch       | openSUSE Current oss   
i | yast2-qt-branding-openSUSE    | paquete  | 13.2-3.6.1     | noarch       | openSUSE Current oss   
i | yast2-restore                 | paquete  | 3.0.0-2.1.4    | noarch       | (Paquetes del sistema) 
i | yast2-ruby-bindings           | paquete  | 3.1.24-1.1     | x86_64       | openSUSE Current oss   
i | yast2-runlevel                | paquete  | 3.0.1-1.1      | noarch       | (Paquetes del sistema) 
i | yast2-samba-client            | paquete  | 3.0.1-3.1      | noarch       | (Paquetes del sistema) 
i | yast2-samba-server            | paquete  | 3.0.2-2.1.4    | noarch       | (Paquetes del sistema) 
i | yast2-scanner                 | paquete  | 3.1.1.1-2.4.1  | x86_64       | openSUSE Current update
i | yast2-security                | paquete  | 3.1.4-2.1.8    | noarch       | openSUSE Current oss   
i | yast2-services-manager        | paquete  | 0.0.11-3.4.1   | noarch       | (Paquetes del sistema) 
i | yast2-slp                     | paquete  | 3.0.2-1.1      | x86_64       | (Paquetes del sistema) 
i | yast2-sound                   | paquete  | 3.0.3-1.1      | x86_64       | (Paquetes del sistema) 
i | yast2-storage                 | paquete  | 3.0.9-4.2      | x86_64       | (Paquetes del sistema) 
i | yast2-sudo                    | paquete  | 3.1.1-2.1.9    | noarch       | openSUSE Current oss   
i | yast2-sysconfig               | paquete  | 3.1.1-2.1.10   | noarch       | openSUSE Current oss   
i | yast2-trans-es                | paquete  | 3.1.0-9.1      | noarch       | openSUSE Current update
i | yast2-trans-stats             | paquete  | 2.19.0-16.1.3  | noarch       | openSUSE Current oss   
i | yast2-transfer                | paquete  | 3.0.1-2.1.3    | x86_64       | (Paquetes del sistema) 
i | yast2-tune                    | paquete  | 3.1.5-2.1.10   | x86_64       | openSUSE Current oss   
i | yast2-tv                      | paquete  | 2.21.4-7.1.2   | noarch       | (Paquetes del sistema) 
i | yast2-update                  | paquete  | 3.0.4-2.1.4    | x86_64       | (Paquetes del sistema) 
i | yast2-users                   | paquete  | 3.0.1-2.1.4    | x86_64       | (Paquetes del sistema) 
i | yast2-vm                      | paquete  | 3.1.18-2.1.9   | x86_64       | openSUSE Current oss   
i | yast2-x11                     | paquete  | 3.1.3-2.1.2    | x86_64       | openSUSE Current oss   
i | yast2-xml                     | paquete  | 3.0.0-2.1.2    | x86_64       | (Paquetes del sistema) 
i | yast2-ycp-ui-bindings         | paquete  | 3.1.7-2.1.3    | x86_64       | openSUSE Current oss   
dynamic:/home/kdesuse # zypper lr -p
#  | Alias                           | Nombre                             | Habilitado | Actualizar | Prioridad
---+---------------------------------+------------------------------------+------------+------------+----------
 1 |                                 | Tumbleweed                         | Si         | Si         |   99     
 2 | All Packman                     | All Packman                        | Si         | Si         |   99     
 3 | KDE Extra Tumbleweed            | KDE Extra Tumbleweed               | Si         | Si         |   99     
 4 | LibreOffice Tumbleweed          | LibreOffice Tumbleweed             | No         | No         |   99     
 5 | openSUSE Current non-oss        | openSUSE Current non-oss           | Si         | Si         |   99     
 6 | openSUSE Current oss            | openSUSE Current oss               | Si         | Si         |   99     
 7 | openSUSE Current update         | openSUSE Current update            | Si         | Si         |   99     
 8 | openSUSE Current update non-oss | openSUSE Current update non-oss    | Si         | Si         |   99     
 9 | openSUSE-12.3-1.7               | openSUSE-12.3-1.7                  | No         | No         |   99     
10 | openSUSE:12.3                   | openSUSE:12.3                      | No         | No         |   99     
11 | opensuse-games-i586             | opensuse-games-i586                | No         | Si         |   99     
12 | opensuse-guide.org-repo         | libdvdcss repository               | Si         | Si         |   99     
13 | repo-debug                      | openSUSE-12.3-Debug                | No         | No         |   99     
14 | repo-debug-update               | openSUSE-12.3-Update-Debug         | No         | No         |   99     
15 | repo-debug-update-non-oss       | openSUSE-12.3-Update-Debug-Non-Oss | No         | No         |   99     
16 | repo-non-oss                    | openSUSE-12.3-Non-Oss              | No         | No         |   99     
17 | repo-source                     | openSUSE-12.3-Source               | No         | No         |   99     
18 | repo-update                     | openSUSE-12.3-Update               | No         | No         |   99     
19 | repo-update-non-oss             | openSUSE-12.3-Update-Non-Oss       | No         | No         |   99     
dynamic:/home/kdesuse #
yo tambien he pensado hacer un zypper dup, de hecho lo seleccione pero al ver que modificaba bastante lo desestime hasta saber si realmente es necesario.
edito para ampliar datos:
Código:
i | yast2                                      | paquete  | 3.0.14-17.1                  | x86_64       | (Paquetes del sistema)         
i | yast2-add-on                               | paquete  | 3.0.3-4.1                    | noarch       | (Paquetes del sistema)         
i | yast2-apparmor                             | paquete  | 3.0.1-2.1.4                  | noarch       | (Paquetes del sistema)         
i | yast2-backup                               | paquete  | 3.0.0-2.1.4                  | noarch       | (Paquetes del sistema)         
i | yast2-bootloader                           | paquete  | 3.0.3-2.1.3                  | x86_64       | (Paquetes del sistema)         
i | yast2-branding-openSUSE                    | paquete  | 3.1.31-2.1                   | noarch       | openSUSE Current oss           
i | yast2-control-center                       | paquete  | 3.1.3-2.1.4                  | x86_64       | openSUSE Current oss           
i | yast2-control-center-qt                    | paquete  | 3.1.3-2.1.4                  | x86_64       | openSUSE Current oss           
i | yast2-core                                 | paquete  | 3.0.3-1.1                    | x86_64       | (Paquetes del sistema)         
i | yast2-country                              | paquete  | 3.0.2-1.1                    | x86_64       | (Paquetes del sistema)         
i | yast2-country-data                         | paquete  | 3.1.13.1-4.1                 | x86_64       | openSUSE Current update        
i | yast2-firewall                             | paquete  | 3.1.1-3.1.10                 | noarch       | openSUSE Current oss           
i | yast2-hardware-detection                   | paquete  | 3.0.1-2.1.3                  | x86_64       | (Paquetes del sistema)         
i | yast2-inetd                                | paquete  | 3.1.9-1.2                    | noarch       | openSUSE Current oss           
i | yast2-inetd-doc                            | paquete  | 3.1.9-1.2                    | noarch       | openSUSE Current oss           
i | yast2-installation                         | paquete  | 3.0.8-1.1                    | noarch       | (Paquetes del sistema)         
i | yast2-irda                                 | paquete  | 2.23.0-2.1.2                 | noarch       | (Paquetes del sistema)         
i | yast2-iscsi-client                         | paquete  | 3.1.17-1.4                   | noarch       | openSUSE Current oss           
i | yast2-kerberos-client                      | paquete  | 3.0.0-2.1.4                  | noarch       | (Paquetes del sistema)         
i | yast2-ldap                                 | paquete  | 3.0.1-2.1.3                  | x86_64       | (Paquetes del sistema)         
i | yast2-ldap-client                          | paquete  | 3.0.2-2.4.1                  | noarch       | (Paquetes del sistema)         
i | yast2-mail                                 | paquete  | 3.1.4-1.4                    | noarch       | openSUSE Current oss           
i | yast2-metapackage-handler                  | paquete  | 3.1.3-2.1.4                  | noarch       | openSUSE Current oss           
i | yast2-mouse                                | paquete  | 2.21.0-7.1.2                 | x86_64       | (Paquetes del sistema)         
i | yast2-network                              | paquete  | 3.0.9-10.2                   | x86_64       | (Paquetes del sistema)         
i | yast2-nfs-client                           | paquete  | 3.1.9-1.9                    | noarch       | openSUSE Current oss           
i | yast2-nfs-common                           | paquete  | 3.1.7-2.1.10                 | noarch       | openSUSE Current oss           
i | yast2-nis-client                           | paquete  | 3.0.1-2.4.3                  | x86_64       | (Paquetes del sistema)         
i | yast2-ntp-client                           | paquete  | 3.0.1-7.1                    | noarch       | (Paquetes del sistema)         
i | yast2-online-update                        | paquete  | 3.0.0-2.1.4                  | noarch       | (Paquetes del sistema)         
i | yast2-online-update-frontend               | paquete  | 3.1.7-1.7                    | noarch       | openSUSE Current oss           
i | yast2-packager                             | paquete  | 3.0.8-1.1                    | x86_64       | (Paquetes del sistema)         
i | yast2-pam                                  | paquete  | 3.1.1-2.1.10                 | noarch       | openSUSE Current oss           
i | yast2-perl-bindings                        | paquete  | 3.0.1-3.1                    | x86_64       | (Paquetes del sistema)         
i | yast2-pkg-bindings                         | paquete  | 3.0.3-8.1                    | x86_64       | (Paquetes del sistema)         
i | yast2-printer                              | paquete  | 3.1.1.1-2.4.1                | x86_64       | openSUSE Current update        
i | yast2-proxy                                | paquete  | 3.1.2-1.1                    | noarch       | openSUSE Current oss           
i | yast2-qt-branding-openSUSE                 | paquete  | 13.2-3.6.1                   | noarch       | openSUSE Current oss           
i | yast2-restore                              | paquete  | 3.0.0-2.1.4                  | noarch       | (Paquetes del sistema)         
i | yast2-ruby-bindings                        | paquete  | 3.1.24-1.1                   | x86_64       | openSUSE Current oss           
i | yast2-runlevel                             | paquete  | 3.0.1-1.1                    | noarch       | (Paquetes del sistema)         
i | yast2-samba-client                         | paquete  | 3.0.1-3.1                    | noarch       | (Paquetes del sistema)         
i | yast2-samba-server                         | paquete  | 3.0.2-2.1.4                  | noarch       | (Paquetes del sistema)         
i | yast2-scanner                              | paquete  | 3.1.1.1-2.4.1                | x86_64       | openSUSE Current update        
i | yast2-security                             | paquete  | 3.1.4-2.1.8                  | noarch       | openSUSE Current oss           
i | yast2-services-manager                     | paquete  | 0.0.11-3.4.1                 | noarch       | (Paquetes del sistema)         
i | yast2-slp                                  | paquete  | 3.0.2-1.1                    | x86_64       | (Paquetes del sistema)         
i | yast2-sound                                | paquete  | 3.0.3-1.1                    | x86_64       | (Paquetes del sistema)         
i | yast2-storage                              | paquete  | 3.0.9-4.2                    | x86_64       | (Paquetes del sistema)         
i | yast2-sudo                                 | paquete  | 3.1.1-2.1.9                  | noarch       | openSUSE Current oss           
i | yast2-sysconfig                            | paquete  | 3.1.1-2.1.10                 | noarch       | openSUSE Current oss           
i | yast2-trans-es                             | paquete  | 3.1.0-9.1                    | noarch       | openSUSE Current update        
i | yast2-trans-stats                          | paquete  | 2.19.0-16.1.3                | noarch       | openSUSE Current oss           
i | yast2-transfer                             | paquete  | 3.0.1-2.1.3                  | x86_64       | (Paquetes del sistema)         
i | yast2-tune                                 | paquete  | 3.1.5-2.1.10                 | x86_64       | openSUSE Current oss           
i | yast2-tv                                   | paquete  | 2.21.4-7.1.2                 | noarch       | (Paquetes del sistema)         
i | yast2-update                               | paquete  | 3.0.4-2.1.4                  | x86_64       | (Paquetes del sistema)         
i | yast2-users                                | paquete  | 3.0.1-2.1.4                  | x86_64       | (Paquetes del sistema)         
i | yast2-vm                                   | paquete  | 3.1.18-2.1.9                 | x86_64       | openSUSE Current oss           
i | yast2-x11                                  | paquete  | 3.1.3-2.1.2                  | x86_64       | openSUSE Current oss           
i | yast2-xml                                  | paquete  | 3.0.0-2.1.2                  | x86_64       | (Paquetes del sistema)         
i | yast2-ycp-ui-bindings                      | paquete  | 3.1.7-2.1.3                  | x86_64       | openSUSE Current oss
Código:
dynamic:/home/kdesuse #  zypper lr -u -p
#  | Alias                           | Nombre                             | Habilitado | Actualizar | Prioridad | URI                                                                               
---+---------------------------------+------------------------------------+------------+------------+-----------+-----------------------------------------------------------------------------------
 1 |                                 | Tumbleweed                         | Si         | Si         |   99      | http://download.opensuse.org/repositories/openSUSE:/Tumbleweed/standard/          
 2 | All Packman                     | All Packman                        | Si         | Si         |   99      | http://packman.inode.at/suse/openSUSE_Tumbleweed                                  
 3 | KDE Extra Tumbleweed            | KDE Extra Tumbleweed               | Si         | Si         |   99      | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_Tumbleweed/         
 4 | LibreOffice Tumbleweed          | LibreOffice Tumbleweed             | No         | No         |   99      | http://download.opensuse.org/repositories/LibreOffice:/Stable/openSUSE_Tumbleweed/
 5 | openSUSE Current non-oss        | openSUSE Current non-oss           | Si         | Si         |   99      | http://download.opensuse.org/distribution/openSUSE-current/repo/non-oss/          
 6 | openSUSE Current oss            | openSUSE Current oss               | Si         | Si         |   99      | http://download.opensuse.org/distribution/openSUSE-current/repo/oss/              
 7 | openSUSE Current update         | openSUSE Current update            | Si         | Si         |   99      | http://download.opensuse.org/update/openSUSE-current/                             
 8 | openSUSE Current update non-oss | openSUSE Current update non-oss    | Si         | Si         |   99      | http://download.opensuse.org/update/openSUSE-non-oss-current/                     
 9 | openSUSE-12.3-1.7               | openSUSE-12.3-1.7                  | No         | No         |   99      | http://download.opensuse.org/distribution/12.3/repo/oss/                          
10 | openSUSE:12.3                   | openSUSE:12.3                      | No         | No         |   99      | http://download.opensuse.org/distribution/12.3/repo/oss/                          
11 | opensuse-games-i586             | opensuse-games-i586                | No         | Si         |   99      | http://download.opensuse.org/repositories/games/openSUSE_12.3/                    
12 | opensuse-guide.org-repo         | libdvdcss repository               | Si         | Si         |   99      | http://opensuse-guide.org/repo/12.3/                                              
13 | repo-debug                      | openSUSE-12.3-Debug                | No         | No         |   99      | http://download.opensuse.org/debug/distribution/12.3/repo/oss/                    
14 | repo-debug-update               | openSUSE-12.3-Update-Debug         | No         | No         |   99      | http://download.opensuse.org/debug/update/12.3/                                   
15 | repo-debug-update-non-oss       | openSUSE-12.3-Update-Debug-Non-Oss | No         | No         |   99      | http://download.opensuse.org/debug/update/12.3-non-oss/                           
16 | repo-non-oss                    | openSUSE-12.3-Non-Oss              | No         | No         |   99      | http://download.opensuse.org/distribution/12.3/repo/non-oss/                      
17 | repo-source                     | openSUSE-12.3-Source               | No         | No         |   99      | http://download.opensuse.org/source/distribution/12.3/repo/oss/                   
18 | repo-update                     | openSUSE-12.3-Update               | No         | No         |   99      | http://download.opensuse.org/update/12.3/                                         
19 | repo-update-non-oss             | openSUSE-12.3-Update-Non-Oss       | No         | No         |   99      | http://download.opensuse.org/update/12.3-non-oss/
salu2
__________________

Última edición por enae; 23-feb-2015 a las 01:37 Razón: ampliar datos
Responder Citando
  #9  
Antiguo 23-feb-2015, 05:47
Avatar de mikrios
mikrios mikrios esta en línea ahora
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.526
Agradecimientos: 1.909
Agradecido 1.400 Veces en 1.175 Mensajes
Poder de Credibilidad: 9
mikrios llegará a ser famoso muy pronto
Hola:

Tienes conflicto como para hacer un dup, y según mi punto de vista creo que puede ser desastroso.

Tienes varios archivos de yast con distintas versiones .

Y después estas mezclando repositorios, de distintas versiones de openSUSE .

No se que versión de openSUSE tienes , aunque dice en tu perfil tumbleweed .

No se que opinaran los expertos pero tal como tienes los repositorios, es muy fácil , que puedas tener conflicto y esa sea la causa del problema que tienes.

A pesar que tienes no habilitado los repos de la 12.3, los otros oss y non-oss, no apuntan a una versión de tumbleweed ( y si pones el enlace de ellos en el navegador, verás que son ficheros del año pasado, mas o menos de la fechas de octubre del 2014 ,aunque algunos están a la 2015), eso sin contar que ya algunos no tienen enlace a pagina web(por ejemplo el de juegos, y porque elegiste i586, si tu arquitectura es de 64bit (x86_64) .

Cuando has actualizado me supongo de la 12.3, deberías haber eliminado esos repositorios y poner los correctos (ademas la 12.3 no tiene ya soporte) .

No se si lo mejor pudiera ser hacer una instalación nueva, intentando conservar tu home; pero me supongo que podría haber aplicaciones que dejaran de funcionar.

Y por curiosidad no te ha dado problemas de dependencias (zypper ve y zypper ve -D) .

Que te muestra si ejecutas en consola un cat /etc/issue , o si dispones del comando inxi un inxi -S , ejemplos:

Código:
X79-PRO:~ # cat /etc/issue
Welcome to openSUSE 20150218 "Tumbleweed" - Kernel \r (\l).


X79-PRO:~ # inxi -S
System:    Host: X79-PRO Kernel: 3.19.0-2.g1133f88-desktop x86_64 (64 bit) Desktop: N/A
           Distro: openSUSE 20150218 (Tumbleweed)
Creo que una actualización no te vaya a funcionar y quizás si lo haga una instalación nueva ,conservando el home, pero tendría que ser el mismo usuario y password, usar los mismos sistemas de ficheros que tengas en esa distribución (si es ext4, pues que sea en ext4), no dar formato al home.

O sea que durante la instalación nueva, edites la particiones y pongas el tipo que tenias anteriormente ,idem para el home (que tendrá que llevar el mismo nombre de usuario y password, por supuesto que monte home, pero sin formatear ) .

A pesar de ser instalación nueva, lo que hace es que conserva tu home, pero la raíz te la cambia por completo por una instalación a la nueva versión (se pierde los comandos y aplicaciones del sistema que pudieras tener de la anterior , o sea que tendría que instalarlas de nuevo y algunas de tu home, pueden que ya no funcionen , por lo que creo que habría que reinstalarlas y perderías las configuraciones de ellas) .

Si eliges el actualizar, podrías conservar aquellos repositorios que sean de tumbleweed y que sean correctos y los demás borrarlos o no activarlos durante la actualización (en mi caso he intentado actualizar de esa forma y la mayoría de las veces los resultados fueron negativos, siempre me arrojaban algún error o la actualización al final no funcionaba, por lo que seguía el método anterior y como las versiones eran mas o menos las mismas, las perdidas no eran muy importantes , las instalaba de nuevo y seguía conservando las configuraciones del home, por lo cual no perdía nada ).

Mira haber que comentan los demás (haber si tienen otras soluciones) , por que tal como tienes, no se que podría pasar .

Saludos cordiales

Edito:
El primer repositorio de tumbleweed, que tiene en la lista, el enlace apunta a carpetas vacías del 4 de nov-2014 (vamos que no hay archivos en ellas) .
La verdad no entiendo como te esta actualizando el sistema, eso si es que lo hace .
Packman y kde está correcto.
Seria factible borrar todos los repositorios defectuoso, y poner los que correspondan y actualizar ?, ya ahí no se lo que podría pasar .
Me he dado una vuelta por la wiki https://es.opensuse.org/SDB:Migraci%...leweed_rolling , ahí tienes la lista de repositorios que lleva (también me fije en la fecha que es el 4 de mayo, fecha limite para los que tienen los repositorios de factory , pensaba que era para finales de marzo o abril , o sea que hay 2 meses por delante) .
Date una vuelta por la wiki y mira la documentación de tumbleweed, por si vas a mantener esa versión en tu pc.

https://es.opensuse.org/Portal:Tumbleweed

https://es.opensuse.org/openSUSE:Ins..._de_Tumbleweed

Saludos

Última edición por mikrios; 23-feb-2015 a las 06:10 Razón: añadir
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a mikrios Por Este Mensaje:
enae (23-feb-2015)
  #10  
Antiguo 23-feb-2015, 09:07
Avatar de enae
enae enae esta en línea ahora
Habitual
 
Fecha de Ingreso: 06-agosto-2013
Ubicación: / Home
Versión: Tumbleweed
Mensajes: 111
Agradecimientos: 85
Agradecido 24 Veces en 22 Mensajes
Poder de Credibilidad: 5
enae está en el buen camino
Hola, pues la salida de los comandos no es alentadora,

Código:
dynamic:/home/kdesuse # cat /etc/issue
Welcome to openSUSE 13.1 "Bottle" - Kernel \r (\l).


dynamic:/home/kdesuse # inxi -S
Resuming in non X mode: glxinfo not found. For package install advice run: inxi --recommends
System:    Host: dynamic Kernel: 3.17.1-53.gd944251-desktop x86_64 (64 bit) 
           Desktop KDE 4.14.4 Distro: /etc/SuSE-release corrupted, use -% to override
intentaré un dup por si recupero yast y recompongo todo.

edito: despues del dup, y reiniciar yast funciona, ahora a corregir cosas, muchas gracias por tu ayuda e interes.

salu2 a todos
__________________

Última edición por enae; 23-feb-2015 a las 09:21 Razón: solucionado
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Activado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Mi tarjeta inalámbrica funciona, pero no puedo conectarme jasv Internet, Redes y Wireless 3 21-ene-2010 19:26
Propuesta de solución a la lentitud del YAST keops General OpenSUSE 27 11-oct-2007 19:58
YaST se abre al desarrollo en la comunidad Mikage Noticias 4 02-may-2007 02:06
yast con server 10 no funciona bamos mal suse server General OpenSUSE 1 30-ago-2006 08:14
No reproduce sonido, pero la placa funciona clator Multimedia 0 26-ago-2006 17:01



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 03:52.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba