Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > Software


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Problemas con el yast
  #1  
Antiguo 02-mar-2014, 17:12
Susefan1 Susefan1 está desconectado
Aforado
 
Fecha de Ingreso: 01-marzo-2014
Ubicación: Albardon San Juan Argentina
Versión: 13.2
Mensajes: 25
Agradecimientos: 11
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 0
Susefan1 está en el buen camino
Question Problemas con el yast

Hola amigos del foro he estado intentando instalar un programa con el yast y al abrir éste no se abre ni el actualizador ni el gestor de software ni ninguna de las otras opciones del yast. Al intentar ejecutar yast desde la consola me aparece el siguiente error:

<main>: [BUG] Segmentation fault at 0x00000000000050
ruby 2.1.0p0 (2013-12-25 revision 44422) [x86_64-linux-gnu]

-- Control frame information -----------------------------------------------
c:0001 p:0000 s:0002 E:002648 TOP [FINISH]


-- C level backtrace information -------------------------------------------
/usr/lib64/libruby.so.2.1(+0x18a1d7) [0x7ff8331a91d7]
/usr/lib64/libruby.so.2.1(+0x18a2a3) [0x7ff8331a92a3]
/usr/lib64/libruby.so.2.1(+0x6e9d3) [0x7ff83308d9d3]
/usr/lib64/libruby.so.2.1(rb_bug+0xb3) [0x7ff83308e043]
/usr/lib64/libruby.so.2.1(+0x121f5e) [0x7ff833140f5e]
/lib64/libpthread.so.0(+0xfa00) [0x7ff834a4aa00]
/lib64/libc.so.6(__longjmp_chk+0x10) [0x7ff833d65020]
/usr/lib64/libruby.so.2.1(+0x735db) [0x7ff8330925db]
/usr/lib64/libruby.so.2.1(+0x73ac4) [0x7ff833092ac4]
/usr/lib64/libruby.so.2.1(+0x6f7ca) [0x7ff83308e7ca]
/usr/lib64/libruby.so.2.1(+0x710ae) [0x7ff8330900ae]
/usr/lib64/libruby.so.2.1(+0x77d5e) [0x7ff833096d5e]
/usr/lib64/YaST2/plugin/libpy2lang_ruby.so(_ZN5YRubyC1Ev+0xfe) [0x7ff8334a9fbe]
/usr/lib64/YaST2/plugin/libpy2lang_ruby.so(_ZN5YRuby5yRubyEv+0x41) [0x7ff8334aa1d1]
/usr/lib64/YaST2/plugin/libpy2lang_ruby.so(_ZN8Y2CCRubyC2Ev+0x2b) [0x7ff8334a495b]
/usr/lib64/YaST2/plugin/libpy2lang_ruby.so(+0xbad6) [0x7ff8334a3ad6]
/lib64/ld-linux-x86-64.so.2(+0xe92a) [0x7ff8362f492a]
/lib64/ld-linux-x86-64.so.2(+0xea13) [0x7ff8362f4a13]
/lib64/ld-linux-x86-64.so.2(+0x12b68) [0x7ff8362f8b68]
/lib64/ld-linux-x86-64.so.2(+0xe7e4) [0x7ff8362f47e4]
/lib64/ld-linux-x86-64.so.2(+0x1235b) [0x7ff8362f835b]
/lib64/libdl.so.2(+0x102b) [0x7ff834c5a02b]
/lib64/ld-linux-x86-64.so.2(+0xe7e4) [0x7ff8362f47e4]
/lib64/libdl.so.2(+0x15dd) [0x7ff834c5a5dd]
/lib64/libdl.so.2(dlopen+0x31) [0x7ff834c5a0c1]
/usr/lib64/liby2.so.4(_ZN16Y2LanguageLoaderC1Ev+0x38f) [0x7ff83594e76f]
/usr/lib64/liby2.so.4(+0xdde6) [0x7ff835948de6]
/lib64/ld-linux-x86-64.so.2(+0xe92a) [0x7ff8362f492a]
/lib64/ld-linux-x86-64.so.2(+0xea13) [0x7ff8362f4a13]
/lib64/ld-linux-x86-64.so.2(+0x11ca) [0x7ff8362e71ca]

-- Other runtime information -----------------------------------------------

/sbin/yast: línea 429: 2764 Violación de segmento $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS
Alguien tiene idea de que pasa Gracias
Responder Citando
forzar la instalación de un paquete
  #2  
Antiguo 02-mar-2014, 17:50
Avatar de mikrios
mikrios mikrios está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.551
Agradecimientos: 1.916
Agradecido 1.417 Veces en 1.187 Mensajes
Poder de Credibilidad: 9
mikrios llegará a ser famoso muy pronto
forzar la instalación de un paquete

Puede que tengas las librerías corruptas , intenta reisntalar yast2 (que es el paquete principal ) desde consola con el comando zypper , ejemplo : zypper in yast* (o zypper in yast2* )

Ver mas en :

https://es.opensuse.org/Zypper

Saludos

Edito :

Si tienes problemas con zypper in yast*
Puedes probar con zypper in -f yast*

Creo que el parámetro -f fuerza la reinstalación del paquete de yast .

Saludos

Última edición por mikrios; 03-mar-2014 a las 09:05 Razón: añadir
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a mikrios Por Este Mensaje:
Susefan1 (03-mar-2014)
  #3  
Antiguo 03-mar-2014, 16:41
Susefan1 Susefan1 está desconectado
Aforado
 
Fecha de Ingreso: 01-marzo-2014
Ubicación: Albardon San Juan Argentina
Versión: 13.2
Mensajes: 25
Agradecimientos: 11
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 0
Susefan1 está en el buen camino
Bien me dice con el comando zypper in yast que no o encuentra en los repositorios y con el comando zypper in -f yast* me dice que algunas de las aplicaciones que instalaría yast entran en conflicto con las ya existentes. Que me sugieren hacer
Responder Citando
  #4  
Antiguo 03-mar-2014, 23:36
Avatar de jesusx
jesusx jesusx está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 06-enero-2008
Ubicación: Castellón
Versión: Tumbleweed+Kde
Mensajes: 3.391
Agradecimientos: 328
Agradecido 486 Veces en 402 Mensajes
Poder de Credibilidad: 13
jesusx está en el buen camino
Puedes mirar a ver si te falta alguna dependencia con el comando: sudo zypper verify
Salu2
__________________

Si tienes el vibrato de BB King, el tapping de Van Halen, la velocidad de Malmsteen y la guitarra de Vai... enhorabuena eres un gran imitador.
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a jesusx Por Este Mensaje:
Susefan1 (04-mar-2014)
  #5  
Antiguo 04-mar-2014, 00:36
Susefan1 Susefan1 está desconectado
Aforado
 
Fecha de Ingreso: 01-marzo-2014
Ubicación: Albardon San Juan Argentina
Versión: 13.2
Mensajes: 25
Agradecimientos: 11
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 0
Susefan1 está en el buen camino
Cool

Cita:
Iniciado por jesusx Ver Mensaje
Puedes mirar a ver si te falta alguna dependencia con el comando: sudo zypper verify
Salu2
Lo hice pero no falta ninguna dependencia
Responder Citando
  #6  
Antiguo 04-mar-2014, 23:32
Avatar de jesusx
jesusx jesusx está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 06-enero-2008
Ubicación: Castellón
Versión: Tumbleweed+Kde
Mensajes: 3.391
Agradecimientos: 328
Agradecido 486 Veces en 402 Mensajes
Poder de Credibilidad: 13
jesusx está en el buen camino
Y si pruebas a reconstituir la base de datos?
Cita:
sudo rpm --rebuilddb && sudo zypper clean -a && sudo zypper ref
Salu2
__________________

Si tienes el vibrato de BB King, el tapping de Van Halen, la velocidad de Malmsteen y la guitarra de Vai... enhorabuena eres un gran imitador.
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a jesusx Por Este Mensaje:
Susefan1 (05-mar-2014)
  #7  
Antiguo 05-mar-2014, 01:23
Avatar de mikrios
mikrios mikrios está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.551
Agradecimientos: 1.916
Agradecido 1.417 Veces en 1.187 Mensajes
Poder de Credibilidad: 9
mikrios llegará a ser famoso muy pronto
La verdad que es extraño ver un problema en Yast , me supongo que no habrá mezclado algún repositorio , de todas formas no estaría de mas que lo comprobara con zypper se -si yast2 .

Si tiene los repositorios normales no debería tener problemas de dependencias ( eso creo )

Tampoco digo la solución del zypper dup , por que la considero un poco tabú (y mas desconociendo si añadió repositorios o no ajusto bien las prioridades ,mas que arreglar el problema , podría dejarlo patas arriba y estropearle la instalación ; así que por ahora es mejor que se abstenga de usarlo ).

¿ Nos podría dar la salida del comando zypper lr -p ( la l es la L en minúscula ) ?

Saludos
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a mikrios Por Este Mensaje:
Susefan1 (05-mar-2014)
  #8  
Antiguo 05-mar-2014, 15:30
Susefan1 Susefan1 está desconectado
Aforado
 
Fecha de Ingreso: 01-marzo-2014
Ubicación: Albardon San Juan Argentina
Versión: 13.2
Mensajes: 25
Agradecimientos: 11
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 0
Susefan1 está en el buen camino
Wink

Gracias a todos los que me ayudaron pero en los últimos días me surgieron otros problemas con la computadora que me llevaron a reinstalar todo el sistema. Muchas gracias a todos
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Opinion de OpenSuse 11.1 mukenio Encuestas 48 22-oct-2009 13:59
Multiples cuestiones sobre opensuse por un usuario de ubuntu dudoso100 General OpenSUSE 18 27-ene-2009 22:16
Problemas con yast y updater antitigre Software 0 27-dic-2008 03:15
Propuesta de solución a la lentitud del YAST keops General OpenSUSE 27 11-oct-2007 20:58
problemas con yast decks Software 15 15-ago-2007 01:36



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 18:52.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba