Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > Software


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

VLC en Tumbleweed [RESUELTO]
  #1  
Antiguo 13-sep-2013, 16:43
feroSUSEANDO feroSUSEANDO está desconectado
Aforado
 
Fecha de Ingreso: 18-mayo-2013
Versión: Tumbleweed [x64]
Mensajes: 90
Agradecimientos: 38
Agradecido 6 Veces en 5 Mensajes
Poder de Credibilidad: 5
feroSUSEANDO está en el buen camino
VLC en Tumbleweed [RESUELTO]

Hola!

Tras una semana después de pasar desde OpenSUSE 12.3 kde a Tumblewed siguiendo esta guía http://blog.desdelinux.net/instalar-...d-en-opensuse/ parece que el sistema se va asentando y personalizando.

Algunos datos:
Linux 3.11.0-27.g0a1c41f-desktop
openSUSE 12.3 (Dartmouth) (x86_64)
kde 4.11.1
Controlador gráfico de Intel

Solamente VLC no logro que arranque, aunque la instalación no devuelve ningún error (probé varias veces cambiando dependencias según los repositorios, pero sin errores).

Una duda sería si al ser esta, mi primera experiencia en Tumbleweed, es común que un programa quede sin funcionar durante una semana hasta que es arreglado, o si es que estoy haciendo algo errado.

El kernel es la versión 11 y quizá esto pueda ser la causa. En fin, se trata de descartar que solo sea mi impaciencia porque a otros le esta pasando lo mismo y solo hay que esperar o si merece que busque una solución porque es algo que estoy confundiendo.

Cual sería el repositorio y/o repositorios más adecuado para VLC y sus dependencias. Alguna sugerencia?

Saludos de antemano!

Última edición por feroSUSEANDO; 09-oct-2013 a las 01:16
Responder Citando
  #2  
Antiguo 13-sep-2013, 16:45
feroSUSEANDO feroSUSEANDO está desconectado
Aforado
 
Fecha de Ingreso: 18-mayo-2013
Versión: Tumbleweed [x64]
Mensajes: 90
Agradecimientos: 38
Agradecido 6 Veces en 5 Mensajes
Poder de Credibilidad: 5
feroSUSEANDO está en el buen camino
Olvide la notificación. Disculpas!
Responder Citando
  #3  
Antiguo 13-sep-2013, 17:09
feroSUSEANDO feroSUSEANDO está desconectado
Aforado
 
Fecha de Ingreso: 18-mayo-2013
Versión: Tumbleweed [x64]
Mensajes: 90
Agradecimientos: 38
Agradecido 6 Veces en 5 Mensajes
Poder de Credibilidad: 5
feroSUSEANDO está en el buen camino
Vaya!

Videolan tiene 3 repositorios Tumbleweed (tengo activo el primero), cual será adecuado?

http://download.videolan.org/pub/vid...SE/Tumbleweed/
http://download.videolan.org/pub/SuSE/Tumbleweed/
http://download.videolan.org/pub/vlc/SuSE/Tumbleweed/

Responder Citando
  #4  
Antiguo 13-sep-2013, 17:16
feroSUSEANDO feroSUSEANDO está desconectado
Aforado
 
Fecha de Ingreso: 18-mayo-2013
Versión: Tumbleweed [x64]
Mensajes: 90
Agradecimientos: 38
Agradecido 6 Veces en 5 Mensajes
Poder de Credibilidad: 5
feroSUSEANDO está en el buen camino
Estos son los repositorios que tengo en este momento. Envío adjunto.

Cuantos me sobrarían? o me faltan? o se repiten?

Gracias de nuevo!
Archivos Adjuntos
Tipo de Archivo: zip instantánea2.jpg.zip (217,0 KB (Kilobytes), 9 visitas)
Responder Citando
  #5  
Antiguo 13-sep-2013, 17:28
feroSUSEANDO feroSUSEANDO está desconectado
Aforado
 
Fecha de Ingreso: 18-mayo-2013
Versión: Tumbleweed [x64]
Mensajes: 90
Agradecimientos: 38
Agradecido 6 Veces en 5 Mensajes
Poder de Credibilidad: 5
feroSUSEANDO está en el buen camino
Uf! Esto se esta complicando!

Mirando la página http://es.opensuse.org/Portal:Tumbleweed leo que recomiendan:

"A pesar de no estar soportados, si decides tener otros repositorios activados, este comando es más seguro: zypper dup --from Tumbleweed"

Cuando intento dicho comando me devuelve esto:

zypper dup --from Tumbleweed
Obteniendo los datos del repositorio...
Leyendo los paquetes instalados...
Calculando actualización...
5 Problemas:
Problema: se ha producido un problema con el paquete instalado kernel-desktop-3.11.0-26.1.g16dd1ca.x86_64
Problema: se ha producido un problema con el paquete instalado microcode_ctl-1.17-142.5.1.x86_64
Problema: python-kde4-4.11.1-3.2.x86_64 requiere python-sip(api) = 10.0, pero este requisito no puede cumplirse
Problema: avahi-autoipd-0.6.31-2.27.x86_64 está en conflicto con avahi <= 0.6.31-9.2 proporcionado por avahi-0.6.31-2.27.x86_64
Problema: python-kde4-4.11.1-3.2.x86_64 requiere python-sip(api) = 10.0, pero este requisito no puede cumplirse

Problema: se ha producido un problema con el paquete instalado kernel-desktop-3.11.0-26.1.g16dd1ca.x86_64
Solución 1: mantener el antiguo kernel-desktop-3.7.10-1.16.1.x86_64

Elija la solución usando '1'u omitir, reintentar o cancelar [1/o/r/c] (c):

Leí en varias ocasiones que la opción recomendable suele ser la "1" pero parece que esto me llevaría al kernel anterior. Quizá sea esta la única forma, por el momento, para poder usar VLC o no tiene nada que ver?

Saludos!
Responder Citando
  #6  
Antiguo 13-sep-2013, 19:09
Avatar de jiu
jiu jiu está desconectado
Habitual
 
Fecha de Ingreso: 03-abril-2013
Versión: 13.1 KDE
Mensajes: 176
Agradecimientos: 27
Agradecido 35 Veces en 30 Mensajes
Poder de Credibilidad: 5
jiu está en el buen camino
Hola, el error:

Problema: Problema: avahi-autoipd-0.6.31-2.27.x86_64 está en conflicto con avahi <= 0.6.31-9.2 proporcionado por avahi-0.6.31-2.27.x86_64

me ha dado a mi también, cancela de momento, y vuelve a probar en unos días, al menos lo he hecho yo así, y más después de ver que avahi-autoipd tiene que ver con la conexión v4 de red, mejor no desinstalar, ni tocar, ya lo arreglaran los chicos de tumbleweed.

de los kernel no te puedo ayudar, que yo también tengo un fregao considerable ahí:

http://www.forosuse.org/forosuse/showthread.php?t=30455

VLC sin embargo, si me abre, mi versión es: Reproductor multimedia VLC 2.0.8 Twoflower

Repos de VLC, yo no tengo, puedes ver mis repos en el hilo que te he puesto de lo de los kernel.

Yo esperaría unos días, y probaría a actualizar, a ver si se te soluciona.

saludos

Última edición por jiu; 13-sep-2013 a las 19:12 Razón: corregir enlace
Responder Citando
  #7  
Antiguo 13-sep-2013, 21:12
XisEme XisEme está desconectado
Miembro Senior
 
Fecha de Ingreso: 08-septiembre-2005
Ubicación: ±43º21'N8º22'W
Versión: Tumbleweed[x64]
Mensajes: 1.232
Agradecimientos: 22
Agradecido 301 Veces en 258 Mensajes
Poder de Credibilidad: 14
XisEme está en el buen camino
Como he dicho en otras ocasiones, tengo a Tumbleweed como mi sistema estable desde ...

Sobre VLC; está en packman no son necesarios los de videolan (antes incluso se desaconsejaban no sé como es ahora)

Sobre los repositorios:
- asumo que todos son TW.
- El primero que veo es "trunk" que suena a inestable. peligro-peligro.
- Teniendo All-packman sobran el resto de packmans → elimínalos adiós, bye, bye.
- Salvo que necesites específicamente el VLC de Videolan, elimina ese repositorio tambien.
- Deshabilita (como el trunk) todos los no esenciales. Deja habilitados Current's, standard, packman, libdvdcss, y tal vez KDEExtra? filesystems?.
- Haz # zypper -dup (pon la salida aquí si quieres) con esto deberías conseguir un sistema TW.

No pasa nada por "downgradear" (toma palabro) el kernel luego ya se modernizará.

Para los repos mejor la salida de "zypper lr -pu" que una imagen (están muy sobrevalodas ;D)

Una vez conseguido TW, re-habilita los repos necesarios y olvídate de zypper -dup para siempre usa zypper up o el Yast
__________________
Todo es mejorable, estamos dispuestos a mejorar. ¿Yo? ... poco a poco.
Nunca hay acritud en mis comentarios, si lo pareciera, seguro que me he expresado mal.

Última edición por XisEme; 13-sep-2013 a las 21:15
Responder Citando
  #8  
Antiguo 13-sep-2013, 21:46
Avatar de mikrios
mikrios mikrios está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.551
Agradecimientos: 1.916
Agradecido 1.417 Veces en 1.187 Mensajes
Poder de Credibilidad: 9
mikrios llegará a ser famoso muy pronto
Tengo añadido el repositorio de kernel estable y a mi ese no me aparece :

mikrios-x79:~ # uname -r
3.11.0-2.g0a1c41f-desktop

http://www.forosuse.org/forosuse/sho...187#post168187

Y vlc va como una moto funciona de maravilla .

Saludos
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a mikrios Por Este Mensaje:
feroSUSEANDO (09-oct-2013)
  #9  
Antiguo 20-sep-2013, 02:59
feroSUSEANDO feroSUSEANDO está desconectado
Aforado
 
Fecha de Ingreso: 18-mayo-2013
Versión: Tumbleweed [x64]
Mensajes: 90
Agradecimientos: 38
Agradecido 6 Veces en 5 Mensajes
Poder de Credibilidad: 5
feroSUSEANDO está en el buen camino
Hola!

Muchas gracias por las respuestas

Finalmente haciendo experimentos deje el sistema bastante perjudicado, así que decidí reinstalar. Ahora mismo esta practicamente a punto la versión 12.3kde, incluyendo VLC

El siguiente paso pasarlo a Tumbleweed:

1. Entiendo que son 4 los repositorios principales que añadir (como mencionan esta guía http://blog.desdelinux.net/instalar-...d-en-opensuse/ y esta http://es.opensuse.org/Portal:Tumbleweed), aunque esto me confunde
Código:
- Agrega los repositorios de instalación de Tumbleweed a YaST o zypper y activa actualización automática:

sudo zypper ar --refresh \
http://download.opensuse.org/repositories/openSUSE:/Tumbleweed/standard/ \ 
Tumbleweed

- Agrega los repositorios "current" de openSUSE y activa actualización automática:

sudo zypper ar --refresh \
http://download.opensuse.org/distribution/openSUSE-current/repo/oss/ \
'openSUSE Current oss'

sudo zypper ar --refresh \
http://download.opensuse.org/distribution/openSUSE-current/repo/non-oss/ \
'openSUSE Current non-oss'

sudo zypper ar --refresh \
http://download.opensuse.org/update/openSUSE-current/ \
'openSUSE Current update'

sudo zypper ar --refresh \
http://download.opensuse.org/update/openSUSE-non-oss-current/ \
'openSUSE Current update non-oss'
porque entonces serian 5 repos en vez 4. Esto es muy importante?

Tambien se menciona aquí:
Código:
El único método admitido para el uso de repositorios para Tumbleweed es tener solamente los repositorios principales (OSS, Non-OSS, y Update) y el repositorios de Tumbleweed activos. Para ello un simple

zypper dup
2. También me confunde lo siguiente:
Código:
Opcional, pueden quitar los repos de la versión actual que usen de openSUSE.
En este caso entran a Yast y desactivan los repos de openSUSE xx.x
No habrá problema alguno, openSUSE Tumbleweed, puede convivir con la versión actual de openSUSE.
Entonces dejamos solamete los 4 o 5 repos para tumbleweed o también los oficiales de la versión actual?

3. Y si todo va bien y despues del zypper dup el sistema sigue estable, conviene instalar más repositorios? En que afectaria y/o mejoraria el sistema?:
Código:
Repositorios openSUSE Tumbleweed.

KDE Extra Tumbleweed

http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_Tumbleweed/

zypper ar -f  http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_Tumbleweed/  'KDE Extra Tumbleweed'

 Fonts Tumbleweed

http://download.opensuse.org/repositories/M17N:/fonts/openSUSE_Tumbleweed

zypper ar -f  http://download.opensuse.org/repositories/M17N:/fonts/openSUSE_Tumbleweed/  'Fonts Tumbleweed'

Tumbleweed

http://download.opensuse.org/repositories/openSUSE:/Tumbleweed/standard/

zypper ar -f  http://download.opensuse.org/repositories/openSUSE:/Tumbleweed/standard/  'Tumbleweed'

openSUSE Current updates

http://download.opensuse.org/update/openSUSE-current/

zypper ar -f  http://download.opensuse.org/update/openSUSE-current/  'openSUSE Current updates'

openSUSE Current non-OSS

http://download.opensuse.org/distribution/openSUSE-current/repo/non-oss/

zypper ar -f  http://download.opensuse.org/distribution/openSUSE-current/repo/non-oss/  'openSUSE Current non-OSS'

openSUSE Current OSS

http://download.opensuse.org/distribution/openSUSE-current/repo/oss/

zypper ar -f  http://download.opensuse.org/distribution/openSUSE-current/repo/oss/  'openSUSE Current OSS'

Packman Tumbleweed

http://packman.inode.at/suse/openSUSE_Tumbleweed/Essentials

zypper ar -f  http://packman.inode.at/suse/openSUSE_Tumbleweed/Essentials  'Packman Tumbleweed'

Ati Tumbleweed

http://geeko.ioda.net/mirror/amd-fglrx/openSUSE_Tumbleweed/

zypper ar -f  http://geeko.ioda.net/mirror/amd-fglrx/openSUSE_Tumbleweed/  'Ati Tumbleweed'

All Packman

http://packman.inode.at/suse/openSUSE_Tumbleweed

zypper ar -f  http://packman.inode.at/suse/openSUSE_Tumbleweed  'All Packman'

VLC Tumbleweed
zypper ar -f  http://download.videolan.org/pub/vlc/SuSE/Tumbleweed/  'VLC Tumbleweed'

Multimedia Tumbleweed
zypper ar -f  http://packman.inode.at/suse/openSUSE_Tumbleweed/Multimedia/  'Multimedia Tumbleweed'

Extra Tumbleweed
zypper ar -f  http://packman.inode.at/suse/openSUSE_Tumbleweed/Extra/  'Extra Tumbleweed'

Apache Tumbleweed
zypper ar -f  http://download.opensuse.org/repositories/Apache/openSUSE_Tumbleweed/  'Apache Tumbleweed'

Apache Modules Tumbleweed
zypper ar -f  http://download.opensuse.org/repositories/Apache:/Modules/Apache_openSUSE_Tumbleweed/  'Apache Modules Tumbleweed'

LibreOffice Tumbleweed
zypper ar -f  http://download.opensuse.org/repositories/LibreOffice:/Stable/openSUSE_Tumbleweed/  'LibreOffice Tumbleweed'

Puedes encontrar mas repositorios en la pagina oficial de openSUSE.
4. En general estoy viendo que la opción Tumbleweed requiere una observación mayor sobre repositorios y paquetes?

5. Que sucede cuando hay una aplicacion en repositorios no oficiales. Podemos temporalmente usarlos para instalar supervisando dependencias (todo con los paquetes estables) y luego desactivarlos dejando los principales?

Uf, me extendí, gracias de nuevo
Responder Citando
  #10  
Antiguo 20-sep-2013, 05:57
XisEme XisEme está desconectado
Miembro Senior
 
Fecha de Ingreso: 08-septiembre-2005
Ubicación: ±43º21'N8º22'W
Versión: Tumbleweed[x64]
Mensajes: 1.232
Agradecimientos: 22
Agradecido 301 Veces en 258 Mensajes
Poder de Credibilidad: 14
XisEme está en el buen camino
1 y 2.- Los current apuntan a la versión actual. Antiguamente update-oss y update-non-oss eran uso solo: 4 current + 1 standard (el que tiene las versiones más modernas)
3.- Puedes añadir más repositorios, cuida que sean Tumbleweed (TW). Añádelos una vez hecho el dup. No te olvides del all-packman

Código:
#  | Alias                     | Nombre                    | Habilitado | Actualizar | URI                                                                                            
---+---------------------------+---------------------------+------------+------------+------------------------------------------------------------------------------------------------
 4 | 123_sigil                 | 123_sigil                 | Si         | Si         | http://download.opensuse.org/repositories/home:/dstoecker/openSUSE_12.3/                       
 8 | AOOLibO_local             | AOOLibO_repo              | Si         | Si         | dir:///AOO_LibO_repo                                           
10 | T_Ati-fglrx-legacy        | T_Ati-fglrx-legacy        | Si         | Si         | http://geeko.ioda.net/mirror/amd-fglrx-legacy/openSUSE_Tumbleweed                              
11 | T_KDE_Extra               | T_KDEExtra                | Si         | Si         | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_Tumbleweed/                      
13 | T_LibreOffice_Unstable    | T_LibreOffice_Unstable    | Si         | Si         | http://download.opensuse.org/repositories/LibreOffice:/Unstable/openSUSE_Tumbleweed/           
14 | T_OCR                     | T_OCR                     | Si         | Si         | http://download.opensuse.org/repositories/home:/malcolmlewis:/Miscellanous/openSUSE_Tumbleweed/
15 | T_Packman                 | T_Packman                 | Si         | Si         | http://packman.inode.at/suse/openSUSE_Tumbleweed                                               
17 | T_Recordmydesktop         | T_Recormydesktop_Calibre  | Si         | Si         | http://download.opensuse.org/repositories/home:/ecsos/openSUSE_Tumbleweed/                     
20 | T_current_Standard        | T_Standard                | Si         | Si         | http://download.opensuse.org/repositories/openSUSE:/Tumbleweed/standard/                       
21 | T_current_non-oss         | T_current_non-ss          | Si         | Si         | http://download.opensuse.org/distribution/openSUSE-current/repo/non-oss/                       
22 | T_current_oss             | T_current_oss             | Si         | Si         | http://download.opensuse.org/distribution/openSUSE-current/repo/oss/                           
23 | T_current_update_oss      | T_current_update-oss      | Si         | Si         | http://download.opensuse.org/update/openSUSE-current/                                          
24 | T_current_updates-non-oss | T_current_updates-non-oss | Si         | Si         | http://download.opensuse.org/update/openSUSE-non-oss-current/                                  
25 | T_utilities_BleachBit     | T_utilites_BleachBit      | Si         | Si         | http://download.opensuse.org/repositories/utilities/openSUSE_Tumbleweed/                       
27 | VirtualBox_Oracle         | VirtualBox_Oracle         | Si         | Si         | http://download.virtualbox.org/virtualbox/rpm/opensuse/11.4/  
28 | libdvdcss                 | libdvdcss                 | No         | Si         | http://opensuse-guide.org/repo/12.3/
4.- Eso debiera ser siempre. Naturalmente al igual que no es aconsejable mezclar repos 12.1 con 12.2 tampoco entre 12.3 y TW, pueden funcionar, pero no se garantiza.
5.- Sí, puedes puntualmente. Es mi caso fijate en el 4-123_sigil es de la 12.3
__________________
Todo es mejorable, estamos dispuestos a mejorar. ¿Yo? ... poco a poco.
Nunca hay acritud en mis comentarios, si lo pareciera, seguro que me he expresado mal.

Última edición por XisEme; 20-sep-2013 a las 06:00
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a XisEme Por Este Mensaje:
feroSUSEANDO (09-oct-2013)
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
(Consulta) Conocer sobre opensuse tumbleweed + current Kik1n Instalación y Actualizaciones 38 30-jul-2014 11:49
vlc-codecs chris Software 11 21-dic-2013 04:27
Actualizando tumbleweed con zypper up jiu Instalación y Actualizaciones 10 01-ago-2013 07:16
Tumbleweed reiniciado jcsl Noticias 32 01-dic-2011 17:03
Duda repositorio Tumbleweed Takpe Instalación y Actualizaciones 5 18-nov-2011 16:54



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 14:04.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba