Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > General OpenSUSE


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Pruebas Uefi secure boot OpenSUSE 12.3
  #1  
Antiguo 07-ago-2013, 21:18
Avatar de mikrios
mikrios mikrios está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.551
Agradecimientos: 1.916
Agradecido 1.417 Veces en 1.187 Mensajes
Poder de Credibilidad: 9
mikrios llegará a ser famoso muy pronto
Pruebas Uefi secure boot OpenSUSE 12.3

Hola :
He realizado una instalación de OpenSuse 12.3 en modo Uefi Secure Boot. a modo de prueba en un disco ssd intel ( arranca OpenSuse aproximadamente 5 segundos ).

Por lo pronto comentar que la tabla de particiones es gpt híbrida (tiene una partición de arranque Vfat 16 y arranca con la identificación de EF00 , en vez del arraque de bios boot partición con código EF02 ) .

Desde la bios se selecciona arrancar el dvd en modo UEFI , se activa el arranque seguro y se intenta buscar las claves PK,KeK,DB y DBX , este me direcciona a un directorio con el nombre de EFI ,pero este esta vacío , mire en el siguiente directorio (desde la misma bios ) y me encuentro con otro que se llama opensuse ( /boot/efi/opensuse ) , y ahí me encuentro los siguientes archivos :

Grub.cfg , grub.efi , grubbx.64.efi , MokManager.efi y shim.efi .

Ninguno de estos es valido para cargar en la bios , por lo que efectuó la instalación sin cargar los archivos del dvd , si elijo cargar los predeterminados no me deja hacer la instalación .

Por lo cual efectuó la misma con secure boot activado , pero sin cargar las claves .
Al llegar a la sección del particionador de yast activo el marco que pone secure boot y continuo con esta , hasta que termine .

Se reinicia el pc y en la bios muestra nuevos dispositivos uefi estos son :
UEFI opensuse-secure boot ( P1 : intel ssdsc2ct120a3 )
UEFI opensuse ( P1 : intel ssdsc2ct120a3 )

Al ver esto (me supongo que debio hacerlo durante la instalación ) el pc arranca ,pero sin las claves , reinicio y voy a la bios y en la zona de secure boot , le doy a cargar las predeterminadas ,una vez hecho esto le digo que las guarde ( el las guarda en el disco , hasta ahí no se donde las mete ) .

Intento arrancar el pc , pero no se inicia ,por lo que vuelvo a la bios y las borro y las intento cargar de archivo este me selecciona a /boot/efi donde me encuentro los sigientes :
PK ---> 886 Bytes , KEK ----> 3,5 Kb , DB -----> 6,1 Kb y DBX ----> 76 Bytes

Cargo esas claves de nuevo en la bios , pero sigue sin arrancar , solamente arranca sin la PK cargada y las otras (KEK,DB y DBX) cargadas .

Ahí todo funciona correcto (el sistema arranca como una bala apenas llega a los 5 segundos y ya el escritorio esta completo y la música cantando ) .

La extructura de los directorios son /boot/efi/opensuse ; después de la instalación se mantienen los archivos y los que se han añadido en efi (las claves de administración del secure boot ) .

He querido mirar como quedan las particiones por lo que ejecuto gdisk -l , aquí os dejo una muestra :
linux:~ # gdisk -l /dev/sda
GPT fdisk (gdisk) version 0.8.5

Partition table scan:
MBR: protective
BSD: not present
APM: not present
GPT: present

Found valid GPT with protective MBR; using GPT.
Disk /dev/sda: 234441648 sectors, 111.8 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): A5B2E423-671C-4D66-AEDB-E0F9A28E6098
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 234441614
Partitions will be aligned on 2048-sector boundaries
Total free space is 2925 sectors (1.4 MiB)

Number Start (sector) End (sector) Size Code Name
1 2048 321535 156.0 MiB EF00 primary
2 321536 4530175 2.0 GiB 0700 primary
3 4530176 46475263 20.0 GiB 0700 primary
4 46475264 234440703 89.6 GiB 0700 primary

Según vemos arriba tiene MBR: protective y ademas GPT: present .

También podemos ver :

Found valid GPT with protective MBR; using GPT.

El alineamiento se hizo a 2048 sectores , vemos tambien la partición de arranque con código EF00 (grub-efi o efi system , partición hecha en FAT 16 , lo curioso es que los demas códigos están a 0700 (que es el sistema de ficheros de windows ) ,por lo que posiblemente sea un error de gdisk .
Para salir de dudas ejecuto Gparted y hago una captura que os dejo aquí para que la vean (ya que es muy raro eso de los 0700 en vez de 8300 o 0x83 del sistema de fichero de linux , ni que esto fuera una broma del fututo win 9 ) .

Bueno muchas gracias a todos ,al menos a mi me ha sacado de algunas dudas ,disfrute con ese arranque de 5 segundos y ya me gustaría ver alguna configuración mixta de particiones ya sea con win 8 o con un arranque de bios boot (EF02) .

Saludos cordiales
Edito como ven en gparted aparece ext4 y nada de los 0700 je je ....
Imágenes Adjuntas
Tipo de Archivo: jpg gparted.jpg (10,6 KB (Kilobytes), 27 visitas)

Última edición por mikrios; 07-ago-2013 a las 21:24 Razón: añadir
Responder Citando
  #2  
Antiguo 07-ago-2013, 23:25
Avatar de karlggest
karlggest karlggest está desconectado
Moderador
 
Fecha de Ingreso: 07-febrero-2007
Ubicación: Ourense
Versión: Leap 42.3
Mensajes: 8.211
Agradecimientos: 42
Agradecido 1.261 Veces en 929 Mensajes
Poder de Credibilidad: 19
karlggest está en el buen camino
Hola.

No es lo mismo el tipo de la partición el el sistema de archivos utilizado en ella. Pueden coincidir, o pueden no hacerlo. Por ejemplo, si tú aplicas un sistema de ficheros ext4 en una partición que antes era NTFS, seguramente el tipo no varíe.

También dicen que 0700 es el indicativo para particiones Windows o Linux, así que podrás encontrarte una de ellas en ambos sistemas.

Salud!!
__________________
http://sementedotempo.blogspot.com/

-Si lo creen unos pocos, es un delirio; si son muchos los creyentes, es una religión
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a karlggest Por Este Mensaje:
mikrios (08-ago-2013)
  #3  
Antiguo 08-ago-2013, 18:45
Avatar de mikrios
mikrios mikrios está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.551
Agradecimientos: 1.916
Agradecido 1.417 Veces en 1.187 Mensajes
Poder de Credibilidad: 9
mikrios llegará a ser famoso muy pronto
Puede , esto para mi es algo nuevo , la verdad me extraña fue hecha con el dvd de OpenSUSE ,no se uso otro particionador si no el de yast .
He visto ejemplos por la web y muestran 0x83 ( 8300 ,sistema de archivos de linux ) .
De todas formas he estado buscando en los repositorios alguna otra alternativa y curiosamente di con esto :
(se encuentra buscando por gpt en los repositorios ) .

gptfdisk - GPT partitioning and MBR repair software (el nombre del rpm es : gptfdisk-fixparts )

A program that corrects errors that can creep into MBR-partitioned disks. Removes stray GPT data, fixes mis-sized extended partitions, and enables changing primary vs. logical partition status. Also provides a few additional partition manipulation features.

Este es el que tengo instalado gptfdisk y eso parece ser que corrige errores del mismo .
Cuando vuelva hacer la prueba lo instalo haber que pasa ( la versión es la 0.8.5-2.1.1 ,en ambas ) ,pueda que ese comando tenga algún error y esa es la corrección del mismo .

En este tema tu tienes mayor perspectiva , yo solo conozco lo básico y quizás menos , por eso hago estas pruebas ,e intento confirmar lo que leo por la web de la experiencia de otros que lo han realizado,Tu ayuda en esto ha sido estimable ,idem con tu manual .

También me pidieron en el foro que pusiera los resultados , aún no he probado bcache-tools ,pero en esta prueba el resultado de arranque del ssd intel serie 330 de 120Gb es el siguiente :

Arranca el logo de la bios , después entra el temporizador que da a elegir en entrar en defaul o a modo prueba de fallos y una vez acabado esto tarda 4 a 5 segundos en cargar el sistema .

La instalación no es valida , por que se incluyo ,swap en ella , ademas hay que editar fastb y cambiar parámetros , pasar temporales a ram o cambiarlo a disco hdd , por ejemplo var y tmp se podría poner en disco hdd .

También lo que pone la guía de optimización de discos ssd , se le pueden añadir más parámetros y completarla ; ejemplo no solo añadir en fstab el noatime , si no nodiratime , elegir entre poner trim o usar discard (me pase a noche editando etc/fastb , pero no lo he conseguido , algún fallo de sintaxis o poca experiencia en esto ).

Espero que con todas estas experiencias pueda completar la guía de ssd y aportar mas datos que sirvan de ayuda a otros .
Saludos

Última edición por mikrios; 08-ago-2013 a las 18:49 Razón: añadir
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Activado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Multimedia Pack portable para openSUSE 12.3 64 bit easgs Multimedia 2 13-oct-2014 13:23
Como puedo instalar opensuse 12.3 en modo UEFI ? pablo portillo Instalación y Actualizaciones 5 04-jun-2013 03:09
Opensuse 12.3 video ati chris Hardware 8 18-mar-2013 23:04
Intalando agente NRPE en suseserver 10 64bits prubilar Seguridad y Servidores 4 27-abr-2012 19:40
Después de instalar suse 11.2 no funciona red local amungar Internet, Redes y Wireless 15 21-nov-2009 09:52



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 12:29.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba